]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
bring back strict version dep on base package to -clients
[packages/openssh.git] / openssh.spec
1 # TODO:
2 # - add trigger to enable this:
3 #  * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4 #   new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5 #
6 # Conditional build:
7 %bcond_without  audit           # sshd audit support
8 %bcond_with     gnome           # gnome-askpass (GNOME 1.x) utility
9 %bcond_without  gtk             # gnome-askpass (GTK+ 2.x) utility
10 %bcond_without  ldap            # LDAP support
11 %bcond_with     ldns            # DNSSEC support via libldns
12 %bcond_without  libedit         # libedit (editline/history support in sftp client)
13 %bcond_without  kerberos5       # Kerberos5 support
14 %bcond_without  selinux         # SELinux support
15 %bcond_without  libseccomp      # use libseccomp for seccomp privsep (requires 3.5 kernel)
16 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
17 %bcond_without  tests           # test suite
18 %bcond_with     tests_conch     # run conch interoperability tests
19
20 # gtk2-based gnome-askpass means no gnome1-based
21 %{?with_gtk:%undefine with_gnome}
22
23 %if "%{pld_release}" == "ac"
24 %define         pam_ver 0.79.0
25 %else
26 %define         pam_ver 1:1.1.8-5
27 %endif
28 Summary:        OpenSSH free Secure Shell (SSH) implementation
29 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
30 Summary(es.UTF-8):      Implementación libre de SSH
31 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
32 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
33 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
34 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
35 Summary(pt_BR.UTF-8):   Implementação livre do SSH
36 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
37 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
38 Name:           openssh
39 Version:        9.3p2
40 Release:        2
41 Epoch:          2
42 License:        BSD
43 Group:          Applications/Networking
44 Source0:        https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
45 # Source0-md5:  e21180e7c902e596b047b5520842c2e1
46 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
47 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
48 Source2:        %{name}d.init
49 Source3:        %{name}d.pamd
50 Source4:        %{name}.sysconfig
51 Source5:        ssh-agent.sh
52 Source6:        ssh-agent.conf
53 Source7:        %{name}-lpk.schema
54 Source9:        sshd.service
55 Source10:       sshd-keygen
56 Source11:       sshd.socket
57 Source12:       sshd@.service
58 Patch100:       %{name}-git.patch
59 # Patch100-md5: eb723cc4f21efc32752161d539c9c5e9
60 Patch0:         %{name}-no-pty-tests.patch
61 Patch1:         %{name}-tests-reuseport.patch
62 Patch2:         %{name}-pam_misc.patch
63 Patch3:         %{name}-sigpipe.patch
64 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
65 Patch4:         %{name}-ldap.patch
66 Patch5:         %{name}-ldap-fixes.patch
67 Patch6:         ldap.conf.patch
68 Patch7:         %{name}-config.patch
69 Patch8:         ldap-helper-sigpipe.patch
70 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
71 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
72 Patch9:         %{name}-5.2p1-hpn13v6.diff
73
74 Patch11:        %{name}-chroot.patch
75
76 Patch13:        %{name}-skip-interop-tests.patch
77 Patch14:        %{name}-bind.patch
78 Patch15:        %{name}-disable_ldap.patch
79 Patch16:        openssl3.0.patch
80 URL:            http://www.openssh.com/portable.html
81 BuildRequires:  %{__perl}
82 %{?with_audit:BuildRequires:    audit-libs-devel}
83 BuildRequires:  autoconf >= 2.50
84 BuildRequires:  automake
85 %{?with_gnome:BuildRequires:    gnome-libs-devel}
86 %{?with_gtk:BuildRequires:      gtk+2-devel}
87 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
88 %{?with_ldns:BuildRequires:     ldns-devel}
89 %{?with_libedit:BuildRequires:  libedit-devel}
90 BuildRequires:  libfido2-devel >= 1.5.0
91 %{?with_libseccomp:BuildRequires:       libseccomp-devel}
92 %{?with_selinux:BuildRequires:  libselinux-devel}
93 %{?with_ldap:BuildRequires:     openldap-devel}
94 BuildRequires:  openssl-devel >= 1.1.0g
95 BuildRequires:  pam-devel
96 %{?with_gtk:BuildRequires:      pkgconfig}
97 %if %{with tests} && %{with tests_conch}
98 BuildRequires:  python-TwistedConch
99 %endif
100 BuildRequires:  rpm >= 4.4.9-56
101 BuildRequires:  rpm-build >= 4.6
102 BuildRequires:  rpmbuild(macros) >= 1.752
103 BuildRequires:  sed >= 4.0
104 BuildRequires:  zlib-devel >= 1.2.3
105 %if %{with tests} && 0%(id -u sshd >/dev/null 2>&1; echo $?)
106 BuildRequires:  %{name}-server
107 %endif
108 %if %{with tests} && %{with libseccomp}
109 # libseccomp based sandbox requires NO_NEW_PRIVS prctl flag
110 BuildRequires:  uname(release) >= 3.5
111 %endif
112 Requires:       zlib >= 1.2.3
113 Obsoletes:      ssh
114 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
116 %define         _sysconfdir     /etc/ssh
117 %define         _libexecdir     %{_libdir}/%{name}
118 %define         _privsepdir     /usr/share/empty
119 %define         schemadir       /usr/share/openldap/schema
120
121 %description
122 Ssh (Secure Shell) a program for logging into a remote machine and for
123 executing commands in a remote machine. It is intended to replace
124 rlogin and rsh, and provide secure encrypted communications between
125 two untrusted hosts over an insecure network. X11 connections and
126 arbitrary TCP/IP ports can also be forwarded over the secure channel.
127
128 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
129 it up to date in terms of security and features, as well as removing
130 all patented algorithms to seperate libraries (OpenSSL).
131
132 This package includes the core files necessary for both the OpenSSH
133 client and server. To make this package useful, you should also
134 install openssh-clients, openssh-server, or both.
135
136 %if %{with hpn}
137 This release includes High Performance SSH/SCP patches from
138 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
139 increase throughput on fast connections with high RTT (20-150 msec).
140 See the website for '-w' values for your connection and /proc/sys TCP
141 values. BTW. in a LAN you have got generally RTT < 1 msec.
142 %endif
143
144 %description -l de.UTF-8
145 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
146 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
147 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
148 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
149 andere TCP/IP Ports können ebenso über den sicheren Channel
150 weitergeleitet werden.
151
152 %description -l es.UTF-8
153 SSH es un programa para accesar y ejecutar órdenes en computadores
154 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
155 seguro entre dos servidores en una red insegura. Conexiones X11 y
156 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
157 seguro.
158
159 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
160 continuar la última versión gratuita de SSH, actualizándolo en
161 términos de seguridad y recursos,así también eliminando todos los
162 algoritmos patentados y colocándolos en bibliotecas separadas
163 (OpenSSL).
164
165 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
166 también el paquete openssh-clients u openssh-server o ambos.
167
168 %description -l fr.UTF-8
169 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
170 remplace telnet, rlogin, rexec et rsh, tout en assurant des
171 communications cryptées securisées entre deux hôtes non fiabilisés sur
172 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
173 arbitraires peuvent également être transmis sur le canal sécurisé.
174
175 %description -l it.UTF-8
176 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
177 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
178 sicure e crittate tra due host non fidati su una rete non sicura. Le
179 connessioni X11 ad una porta TCP/IP arbitraria possono essere
180 inoltrate attraverso un canale sicuro.
181
182 %description -l pl.UTF-8
183 Ssh (Secure Shell) to program służący do logowania się na zdalną
184 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
185 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
186 pomiędzy dwoma hostami.
187
188 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
189 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
190 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
191
192 %if %{with hpn}
193 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
194 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
195 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
196 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
197 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
198 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
199 %endif
200
201 %description -l pt.UTF-8
202 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
203 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
204 cifradas entre duas máquinas sem confiança mútua sobre uma rede
205 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
206 reenviados pelo canal seguro.
207
208 %description -l pt_BR.UTF-8
209 SSH é um programa para acessar e executar comandos em máquinas
210 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
211 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
212 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
213
214 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
215 última versão gratuita do SSH, atualizando-o em termos de segurança e
216 recursos, assim como removendo todos os algoritmos patenteados e
217 colocando-os em bibliotecas separadas (OpenSSL).
218
219 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
220 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
221
222 %description -l ru.UTF-8
223 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
224 машину и для выполнения команд на удаленной машине. Она предназначена
225 для замены rlogin и rsh и обеспечивает безопасную шифрованную
226 коммуникацию между двумя хостами в сети, являющейся небезопасной.
227 Соединения X11 и любые порты TCP/IP могут также быть проведены через
228 безопасный канал.
229
230 OpenSSH - это переделка командой разработчиков OpenBSD последней
231 свободной версии SSH, доведенная до современного состояния в терминах
232 уровня безопасности и поддерживаемых возможностей. Все патентованные
233 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
234
235 Этот пакет содержит файлы, необходимые как для клиента, так и для
236 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
237 openssh-server, или оба пакета.
238
239 %description -l uk.UTF-8
240 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
241 машини та для виконання команд на віддаленій машині. Вона призначена
242 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
243 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
244 довільні порти TCP/IP можуть також бути проведені через безпечний
245 канал.
246
247 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
248 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
249 підтримуваних можливостей. Всі патентовані алгоритми винесені до
250 окремих бібліотек (OpenSSL).
251
252 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
253 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
254 openssh-server, чи обидва пакети.
255
256 %package clients
257 Summary:        OpenSSH Secure Shell protocol clients
258 Summary(es.UTF-8):      Clientes de OpenSSH
259 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
260 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
261 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
262 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
263 Group:          Applications/Networking
264 Requires:       %{name} = %{epoch}:%{version}-%{release}
265 Suggests:       %{name}-clients-helper-fido = %{epoch}:%{version}-%{release}
266 Provides:       ssh-clients
267 Obsoletes:      ssh-clients
268 %requires_eq_to openssl%{?_isa} openssl-devel
269
270 %description clients
271 Ssh (Secure Shell) a program for logging into a remote machine and for
272 executing commands in a remote machine. It is intended to replace
273 rlogin and rsh, and provide secure encrypted communications between
274 two untrusted hosts over an insecure network. X11 connections and
275 arbitrary TCP/IP ports can also be forwarded over the secure channel.
276
277 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
278 it up to date in terms of security and features, as well as removing
279 all patented algorithms to seperate libraries (OpenSSL).
280
281 This package includes the clients necessary to make encrypted
282 connections to SSH servers.
283
284 %description clients -l es.UTF-8
285 Este paquete incluye los clientes que se necesitan para hacer
286 conexiones codificadas con servidores SSH.
287
288 %description clients -l pl.UTF-8
289 Ssh (Secure Shell) to program służący do logowania się na zdalną
290 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
291 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
292 pomiędzy dwoma hostami.
293
294 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
295
296 %description clients -l pt_BR.UTF-8
297 Esse pacote inclui os clientes necessários para fazer conexões
298 encriptadas com servidores SSH.
299
300 %description clients -l ru.UTF-8
301 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
302 машину и для выполнения команд на удаленной машине.
303
304 Этот пакет содержит программы-клиенты, необходимые для установления
305 зашифрованных соединений с серверами SSH.
306
307 %description clients -l uk.UTF-8
308 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
309 машини та для виконання команд на віддаленій машині.
310
311 Цей пакет містить програми-клієнти, необхідні для встановлення
312 зашифрованих з'єднань з серверами SSH.
313
314 %package clients-agent-profile_d
315 Summary:        OpenSSH Secure Shell agent init script
316 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
317 Group:          Applications/Networking
318 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
319
320 %description clients-agent-profile_d
321 profile.d scripts for starting SSH agent.
322
323 %description clients-agent-profile_d -l pl.UTF-8
324 Skrypty profile.d do uruchamiania agenta SSH.
325
326 %package clients-agent-xinitrc
327 Summary:        OpenSSH Secure Shell agent init script
328 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
329 Group:          Applications/Networking
330 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
331 Requires:       xinitrc
332
333 %description clients-agent-xinitrc
334 xinitrc scripts for starting SSH agent.
335
336 %description clients-agent-xinitrc -l pl.UTF-8
337 Skrypty xinitrc do uruchamiania agenta SSH.
338
339 %package clients-helper-fido
340 Summary:        OpenSSH helper for FIDO authenticator
341 Summary(pl.UTF-8):      OpenSSH helper obsługujący klucz autoryzujący FIDO
342 Group:          Applications/Networking
343 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
344 Requires:       libfido2 >= 1.5.0
345
346 %description clients-helper-fido
347 OpenSSH helper for FIDO authenticator.
348
349 %description clients-helper-fido -l pl.UTF-8
350 OpenSSH helper obsługujący klucz autoryzujący FIDO.
351
352 %package server
353 Summary:        OpenSSH Secure Shell protocol server (sshd)
354 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
355 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
356 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
357 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
358 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
359 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
360 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
361 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
362 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
363 Group:          Networking/Daemons
364 Requires(post): /sbin/chkconfig
365 Requires(post): grep
366 Requires(post,preun):   /sbin/chkconfig
367 Requires(postun):       /usr/sbin/userdel
368 Requires(pre):  /bin/id
369 Requires(pre):  /usr/sbin/useradd
370 Requires(post,preun,postun):    systemd-units >= 38
371 Requires:       %{name} = %{epoch}:%{version}-%{release}
372 %if "%{pld_release}" == "ac"
373 Requires:       filesystem >= 2.0-1
374 Requires:       pam >= 0.79.0
375 %else
376 Requires:       filesystem >= 3.0-11
377 Requires:       pam >= %{pam_ver}
378 Suggests:       xorg-app-xauth
379 %endif
380 Requires:       rc-scripts >= 0.4.3.0
381 Requires:       systemd-units >= 38
382 %{?with_libseccomp:Requires:    uname(release) >= 3.5}
383 Requires:       util-linux
384 %{?with_ldap:Suggests:  %{name}-server-ldap}
385 Suggests:       /bin/login
386 Suggests:       xorg-app-xauth
387 Provides:       ssh-server
388 Provides:       user(sshd)
389 %requires_eq_to openssl%{?_isa} openssl-devel
390
391 %description server
392 Ssh (Secure Shell) a program for logging into a remote machine and for
393 executing commands in a remote machine. It is intended to replace
394 rlogin and rsh, and provide secure encrypted communications between
395 two untrusted hosts over an insecure network. X11 connections and
396 arbitrary TCP/IP ports can also be forwarded over the secure channel.
397
398 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
399 it up to date in terms of security and features, as well as removing
400 all patented algorithms to seperate libraries (OpenSSL).
401
402 This package contains the secure shell daemon. The sshd is the server
403 part of the secure shell protocol and allows ssh clients to connect to
404 your host.
405
406 %description server -l de.UTF-8
407 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
408
409 %description server -l es.UTF-8
410 Este paquete contiene el servidor SSH. sshd es la parte servidor del
411 protocolo secure shell y permite que clientes ssh se conecten a su
412 servidor.
413
414 %description server -l fr.UTF-8
415 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
416
417 %description server -l it.UTF-8
418 Questo pacchetto installa sshd, il server di OpenSSH.
419
420 %description server -l pl.UTF-8
421 Ssh (Secure Shell) to program służący do logowania się na zdalną
422 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
423 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
424 pomiędzy dwoma hostami.
425
426 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
427 ssh).
428
429 %description server -l pt.UTF-8
430 Este pacote intala o sshd, o servidor do OpenSSH.
431
432 %description server -l pt_BR.UTF-8
433 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
434 protocolo secure shell e permite que clientes ssh se conectem ao seu
435 host.
436
437 %description server -l ru.UTF-8
438 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
439 машину и для выполнения команд на удаленной машине.
440
441 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
442 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
443 вашим хостом.
444
445 %description server -l uk.UTF-8
446 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
447 машини та для виконання команд на віддаленій машині.
448
449 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
450 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
451 з вашим хостом.
452
453 %package server-ldap
454 Summary:        A LDAP support for open source SSH server daemon
455 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
456 Group:          Daemons
457 Requires:       %{name} = %{epoch}:%{version}-%{release}
458 Requires:       openldap-nss-config
459
460 %description server-ldap
461 OpenSSH LDAP backend is a way how to distribute the authorized tokens
462 among the servers in the network.
463
464 %description server-ldap -l pl.UTF-8
465 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
466 tokenów między serwerami w sieci.
467
468 %package gnome-askpass
469 Summary:        OpenSSH GNOME passphrase dialog
470 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
471 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
472 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
473 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
474 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
475 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
476 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
477 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
478 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
479 Group:          Applications/Networking
480 Requires:       %{name} = %{epoch}:%{version}-%{release}
481 Obsoletes:      openssh-askpass
482 Obsoletes:      ssh-askpass
483 Obsoletes:      ssh-extras
484
485 %description gnome-askpass
486 Ssh (Secure Shell) a program for logging into a remote machine and for
487 executing commands in a remote machine. It is intended to replace
488 rlogin and rsh, and provide secure encrypted communications between
489 two untrusted hosts over an insecure network. X11 connections and
490 arbitrary TCP/IP ports can also be forwarded over the secure channel.
491
492 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
493 it up to date in terms of security and features, as well as removing
494 all patented algorithms to seperate libraries (OpenSSL).
495
496 This package contains the GNOME passphrase dialog.
497
498 %description gnome-askpass -l es.UTF-8
499 Este paquete contiene un programa que abre una caja de diálogo para
500 entrada de passphrase en GNOME.
501
502 %description gnome-askpass -l pl.UTF-8
503 Ssh (Secure Shell) to program służący do logowania się na zdalną
504 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
505 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
506 pomiędzy dwoma hostami.
507
508 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
509
510 %description gnome-askpass -l pt_BR.UTF-8
511 Esse pacote contém um programa que abre uma caixa de diálogo para
512 entrada de passphrase no GNOME.
513
514 %description gnome-askpass -l ru.UTF-8
515 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
516 машину и для выполнения команд на удаленной машине.
517
518 Этот пакет содержит диалог ввода ключевой фразы для использования под
519 GNOME.
520
521 %description gnome-askpass -l uk.UTF-8
522 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
523 машини та для виконання команд на віддаленій машині.
524
525 Цей пакет містить діалог вводу ключової фрази для використання під
526 GNOME.
527
528 %package -n openldap-schema-openssh-lpk
529 Summary:        OpenSSH LDAP Public Key schema
530 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
531 Group:          Networking/Daemons
532 Requires(post,postun):  sed >= 4.0
533 Requires:       openldap-servers
534 BuildArch:      noarch
535
536 %description -n openldap-schema-openssh-lpk
537 This package contains OpenSSH LDAP Public Key schema for openldap.
538
539 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
540 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
541 openldap-a.
542
543 %prep
544 %setup -q
545 #%%patch100 -p1
546
547 %patch0 -p1
548 %patch1 -p1
549 %patch2 -p1
550 %patch3 -p1
551 %patch4 -p1
552 %patch5 -p1
553 %patch6 -p1
554 %patch7 -p1
555 %patch8 -p1
556
557 %{?with_hpn:%patch9 -p1}
558
559 %patch11 -p1
560
561 %patch13 -p1
562
563 %patch14 -p1
564 %{!?with_ldap:%patch15 -p1}
565 %patch16 -p1
566
567 %if "%{pld_release}" == "ac"
568 # fix for missing x11.pc
569 %{__sed} -i -e 's/\(`$(PKG_CONFIG) --libs gtk+-2.0\) x11`/\1` -lX11/' contrib/Makefile
570 %endif
571
572 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
573 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh -lopenbsd-compat#g' Makefile*
574
575 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
576 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
577
578 # prevent being ovewritten by aclocal calls
579 %{__mv} aclocal.m4 acinclude.m4
580
581 %build
582 %{__aclocal}
583 %{__autoconf}
584 %{__autoheader}
585 CPPFLAGS="%{rpmcppflags} -DCHROOT -std=gnu99"
586 %configure \
587         PERL=%{__perl} \
588         --disable-strip \
589         --enable-utmpx \
590         --enable-wtmpx \
591         --with-4in6 \
592         %{?with_audit:--with-audit=linux} \
593         --with-ipaddr-display \
594         %{?with_kerberos5:--with-kerberos5=/usr} \
595         --with-ldap%{!?with_ldap:=no} \
596         %{?with_ldns:--with-ldns} \
597         %{?with_libedit:--with-libedit} \
598         --with-mantype=doc \
599         --with-md5-passwords \
600         --with-pam \
601         --with-pid-dir=%{_localstatedir}/run \
602         --with-privsep-path=%{_privsepdir} \
603         --with-privsep-user=sshd \
604         --with-security-key-builtin \
605         %{?with_selinux:--with-selinux} \
606 %if "%{pld_release}" == "ac"
607         --with-xauth=/usr/X11R6/bin/xauth
608 %else
609 %if %{with libseccomp}
610         --with-sandbox=seccomp_filter \
611 %else
612         --with-sandbox=rlimit \
613 %endif
614         --with-xauth=%{_bindir}/xauth
615 %endif
616
617 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
618
619 %{__make}
620
621 %if %{with tests}
622 %{__make} -j1 tests \
623         TEST_SSH_PORT=$((4242 + ${RANDOM:-$$} % 1000)) \
624         TEST_SSH_TRACE="yes" \
625 %if %{without tests_conch}
626         SKIP_LTESTS="conch-ciphers"
627 %endif
628 %endif
629
630 cd contrib
631 %if %{with gnome}
632 %{__make} gnome-ssh-askpass1 \
633         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
634 %endif
635 %if %{with gtk}
636 %{__make} gnome-ssh-askpass2 \
637         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
638 %endif
639
640 %install
641 rm -rf $RPM_BUILD_ROOT
642 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
643         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
644 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
645
646 %{__make} install \
647         DESTDIR=$RPM_BUILD_ROOT
648
649 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
650
651 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
652 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
653 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
654 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
655 ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
656 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
657 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
658
659 cp -p %{SOURCE9} %{SOURCE11} %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
660 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
661
662 %{__sed} -i -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' \
663         $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd \
664         $RPM_BUILD_ROOT%{systemdunitdir}/sshd.service \
665         $RPM_BUILD_ROOT%{systemdunitdir}/sshd@.service \
666         $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
667
668 %if %{with gnome}
669 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
670 %endif
671 %if %{with gtk}
672 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
673 %endif
674 %if %{with gnome} || %{with gtk}
675 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
676 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
677 EOF
678 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
679 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
680 EOF
681 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
682 %endif
683
684 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
685 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
686
687 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
688
689 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
690 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
691 EOF
692
693 %if "%{pld_release}" == "ac"
694 # not present in ac, no point searching it
695 %{__sed} -i -e '/pam_keyinit.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
696 # openssl on ac does not have OPENSSL_HAS_ECC
697 %{__sed} -i -e '/ecdsa/d' $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
698 %endif
699
700 %if %{without audit}
701 # remove recording user's login uid to the process attribute
702 %{__sed} -i -e '/pam_loginuid.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
703 %endif
704
705 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
706 %{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
707
708 %clean
709 rm -rf $RPM_BUILD_ROOT
710
711 %post clients
712 %env_update
713
714 %postun clients
715 %env_update
716
717 %post gnome-askpass
718 %env_update
719
720 %postun gnome-askpass
721 %env_update
722
723 %pre server
724 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
725
726 %post server
727 /sbin/chkconfig --add sshd
728 %service sshd reload "OpenSSH Daemon"
729 NORESTART=1
730 %systemd_post sshd.service
731
732 %preun server
733 if [ "$1" = "0" ]; then
734         %service sshd stop
735         /sbin/chkconfig --del sshd
736 fi
737 %systemd_preun sshd.service
738
739 %postun server
740 if [ "$1" = "0" ]; then
741         %userremove sshd
742 fi
743 %systemd_reload
744
745 %triggerpostun server -- %{name}-server < 2:7.0p1-2
746 %banner %{name}-server -e << EOF
747 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!
748 ! Starting from openssh 7.0 DSA keys are disabled !
749 ! on server and client side. You will NOT be able !
750 ! to use DSA keys for authentication. Please read !
751 ! about PubkeyAcceptedKeyTypes in man ssh_config. !
752 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
753 EOF
754
755 %triggerpostun server -- %{name}-server < 6.2p1-1
756 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
757 sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
758
759 %triggerpostun server -- %{name}-server < 2:5.9p1-8
760 # lpk.patch to ldap.patch
761 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
762         echo >&2 "Migrating LPK patch to LDAP patch"
763         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
764         %{__sed} -i -e '
765                 # disable old configs
766                 # just UseLPK/LkpLdapConf supported for now
767                 s/^\s*UseLPK/## Obsolete &/
768                 s/^\s*Lpk/## Obsolete &/
769                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
770                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
771         ' %{_sysconfdir}/sshd_config
772         if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
773                 /bin/systemctl try-restart sshd.service || :
774         else
775                 %service -q sshd reload
776         fi
777 fi
778 %systemd_trigger sshd.service
779 if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
780 %banner %{name}-server -e << EOF
781 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
782 ! Native systemd support for sshd has been installed.   !
783 ! Restarting sshd.service with systemctl WILL kill all  !
784 ! active ssh sessions (daemon as such will be started). !
785 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
786 EOF
787 fi
788
789 %post -n openldap-schema-openssh-lpk
790 %openldap_schema_register %{schemadir}/openssh-lpk.schema
791 %service -q ldap restart
792
793 %postun -n openldap-schema-openssh-lpk
794 if [ "$1" = "0" ]; then
795         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
796         %service -q ldap restart
797 fi
798
799 %files
800 %defattr(644,root,root,755)
801 %doc TODO README OVERVIEW CREDITS Change*
802 %attr(755,root,root) %{_bindir}/ssh-key*
803 #%attr(755,root,root) %{_bindir}/ssh-vulnkey*
804 %{_mandir}/man1/ssh-key*.1*
805 #%{_mandir}/man1/ssh-vulnkey*.1*
806 %dir %{_sysconfdir}
807 %dir %{_libexecdir}
808
809 %files clients
810 %defattr(644,root,root,755)
811 %attr(755,root,root) %{_bindir}/ssh
812 %attr(755,root,root) %{_bindir}/sftp
813 %attr(755,root,root) %{_bindir}/ssh-agent
814 %attr(755,root,root) %{_bindir}/ssh-add
815 %attr(755,root,root) %{_bindir}/ssh-copy-id
816 %attr(755,root,root) %{_bindir}/scp
817 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
818 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
819 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
820 %{_mandir}/man1/scp.1*
821 %{_mandir}/man1/ssh.1*
822 %{_mandir}/man1/sftp.1*
823 %{_mandir}/man1/ssh-agent.1*
824 %{_mandir}/man1/ssh-add.1*
825 %{_mandir}/man1/ssh-copy-id.1*
826 %{_mandir}/man5/ssh_config.5*
827 %{_mandir}/man8/ssh-pkcs11-helper.8*
828 %lang(it) %{_mandir}/it/man1/ssh.1*
829 %lang(it) %{_mandir}/it/man5/ssh_config.5*
830 %lang(pl) %{_mandir}/pl/man1/scp.1*
831 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
832
833 # for host-based auth (suid required for accessing private host key)
834 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
835 #%{_mandir}/man8/ssh-keysign.8*
836
837 %files clients-agent-profile_d
838 %defattr(644,root,root,755)
839 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
840 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
841
842 %files clients-agent-xinitrc
843 %defattr(644,root,root,755)
844 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
845
846 %files clients-helper-fido
847 %defattr(644,root,root,755)
848 %attr(755,root,root) %{_libexecdir}/ssh-sk-helper
849 %{_mandir}/man8/ssh-sk-helper.8*
850
851 %files server
852 %defattr(644,root,root,755)
853 %attr(755,root,root) %{_sbindir}/sshd
854 %attr(755,root,root) %{_libexecdir}/sftp-server
855 %attr(755,root,root) %{_libexecdir}/ssh-keysign
856 %attr(755,root,root) %{_libexecdir}/sshd-keygen
857 %{_mandir}/man8/sshd.8*
858 %{_mandir}/man8/sftp-server.8*
859 %{_mandir}/man8/ssh-keysign.8*
860 %{_mandir}/man5/sshd_config.5*
861 %{_mandir}/man5/moduli.5*
862 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
863 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
864 %{_sysconfdir}/moduli
865 %attr(754,root,root) /etc/rc.d/init.d/sshd
866 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
867 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
868 %{systemdunitdir}/sshd.service
869 %{systemdunitdir}/sshd.socket
870 %{systemdunitdir}/sshd@.service
871
872 %if %{with ldap}
873 %files server-ldap
874 %defattr(644,root,root,755)
875 %doc HOWTO.ldap-keys ldap.conf
876 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
877 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
878 %{_mandir}/man5/ssh-ldap.conf.5*
879 %{_mandir}/man8/ssh-ldap-helper.8*
880 %endif
881
882 %if %{with gnome} || %{with gtk}
883 %files gnome-askpass
884 %defattr(644,root,root,755)
885 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
886 %dir %{_libexecdir}/ssh
887 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
888 %attr(755,root,root) %{_libexecdir}/ssh-askpass
889 %endif
890
891 %if %{with ldap}
892 %files -n openldap-schema-openssh-lpk
893 %defattr(644,root,root,755)
894 %{schemadir}/openssh-lpk.schema
895 %endif
This page took 0.132141 seconds and 4 git commands to generate.