]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- rel 2; oom avoidance support
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
4 %bcond_without  gtk             # without GTK+ (2.x)
5 %bcond_with     ldap            # with ldap support
6 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
7 %bcond_without  kerberos5       # without kerberos5 support
8 %bcond_without  selinux         # build without SELinux support
9 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
10
11 # gtk2-based gnome-askpass means no gnome1-based
12 %{?with_gtk:%undefine with_gnome}
13 #
14 Summary:        OpenSSH free Secure Shell (SSH) implementation
15 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
16 Summary(es.UTF-8):      Implementación libre de SSH
17 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
18 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
19 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
20 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
21 Summary(pt_BR.UTF-8):   Implementação livre do SSH
22 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
23 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
24 Name:           openssh
25 Version:        5.1p1
26 Release:        2
27 Epoch:          2
28 License:        BSD
29 Group:          Applications/Networking
30 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
31 # Source0-md5:  03f2d0c1b5ec60d4ac9997a146d2faec
32 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
33 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
34 Source2:        %{name}d.init
35 Source3:        %{name}d.pamd
36 Source4:        %{name}.sysconfig
37 Source5:        ssh-agent.sh
38 Source6:        ssh-agent.conf
39 Patch0:         %{name}-no_libnsl.patch
40 Patch2:         %{name}-pam_misc.patch
41 Patch3:         %{name}-sigpipe.patch
42 # http://www.opendarwin.org/projects/openssh-lpk/
43 Patch4:         %{name}-lpk-4.3p1-0.3.7.patch
44 Patch5:         %{name}-config.patch
45 Patch7:         %{name}-selinux.patch
46 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
47 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.9p1-hpn13v2.diff.gz
48 Patch9:         %{name}-5.0p1-hpn13v4.diff
49 Patch10:        %{name}-include.patch
50 Patch11:        %{name}-chroot.patch
51 Patch12:        http://people.debian.org/~cjwatson/%{name}-blacklist.diff
52 URL:            http://www.openssh.com/
53 BuildRequires:  %{__perl}
54 BuildRequires:  autoconf
55 BuildRequires:  automake
56 %{?with_gnome:BuildRequires:    gnome-libs-devel}
57 %{?with_gtk:BuildRequires:      gtk+2-devel}
58 %{?with_kerberos5:BuildRequires:        krb5-devel}
59 %{?with_libedit:BuildRequires:  libedit-devel}
60 %{?with_selinux:BuildRequires:  libselinux-devel}
61 BuildRequires:  libwrap-devel
62 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
63 BuildRequires:  openssl-devel >= 0.9.7d
64 BuildRequires:  pam-devel
65 %{?with_gtk:BuildRequires:      pkgconfig}
66 BuildRequires:  rpmbuild(macros) >= 1.318
67 BuildRequires:  zlib-devel
68 Requires:       filesystem >= 3.0-11
69 Requires:       pam >= 0.99.7.1
70 Suggests:       openssh-blacklist
71 Suggests:       xorg-app-xauth
72 Obsoletes:      ssh
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _sysconfdir     /etc/ssh
76 %define         _libexecdir     %{_libdir}/%{name}
77 %define         _privsepdir     /usr/share/empty
78
79 %description
80 Ssh (Secure Shell) a program for logging into a remote machine and for
81 executing commands in a remote machine. It is intended to replace
82 rlogin and rsh, and provide secure encrypted communications between
83 two untrusted hosts over an insecure network. X11 connections and
84 arbitrary TCP/IP ports can also be forwarded over the secure channel.
85
86 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
87 it up to date in terms of security and features, as well as removing
88 all patented algorithms to seperate libraries (OpenSSL).
89
90 This package includes the core files necessary for both the OpenSSH
91 client and server. To make this package useful, you should also
92 install openssh-clients, openssh-server, or both.
93 %if %{with hpn} || %{with hpn_none}
94 This release includes High Performance SSH/SCP patches from
95 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
96 to increase throughput on fast connections with high RTT (20-150 msec).
97 See the website for '-w' values for your connection and /proc/sys TCP
98 values. BTW. in a LAN you have got generally RTT < 1 msec.
99 %endif
100 %if %{with hpn_none}
101 It also includes an undocumented '-z' option which switches
102 the cipher to none after authentication is completed. Data is
103 still secured from tampering and corruption in transit through
104 the use of the Message Authentication Code (MAC).
105 This option will significantly reduce the number of cpu cycles used
106 by the SSH/SCP process. This may allow some users to see significant
107 improvement in (sniffable) data tranfer rates.
108 %endif
109
110 %description -l de.UTF-8
111 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
112 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
113 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
114 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
115 andere TCP/IP Ports können ebenso über den sicheren Channel
116 weitergeleitet werden.
117
118 %description -l es.UTF-8
119 SSH es un programa para accesar y ejecutar órdenes en computadores
120 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
121 seguro entre dos servidores en una red insegura. Conexiones X11 y
122 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
123 seguro.
124
125 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
126 continuar la última versión gratuita de SSH, actualizándolo en
127 términos de seguridad y recursos,así también eliminando todos los
128 algoritmos patentados y colocándolos en bibliotecas separadas
129 (OpenSSL).
130
131 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
132 también el paquete openssh-clients u openssh-server o ambos.
133
134 %description -l fr.UTF-8
135 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
136 remplace telnet, rlogin, rexec et rsh, tout en assurant des
137 communications cryptées securisées entre deux hôtes non fiabilisés sur
138 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
139 arbitraires peuvent également être transmis sur le canal sécurisé.
140
141 %description -l it.UTF-8
142 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
143 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
144 sicure e crittate tra due host non fidati su una rete non sicura. Le
145 connessioni X11 ad una porta TCP/IP arbitraria possono essere
146 inoltrate attraverso un canale sicuro.
147
148 %description -l pl.UTF-8
149 Ssh (Secure Shell) to program służący do logowania się na zdalną
150 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
151 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
152 pomiędzy dwoma hostami.
153
154 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
155 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
156 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
157 %if %{with hpn} || %{with hpn_none}
158 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
159 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
160 zwiększenie przepustowości transmisji dla szybkich połączeń
161 z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
162 odpowednie dla danego połączenia wartości parametru '-w' oraz
163 opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
164 %endif
165 %if %{with hpn_none}
166 Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
167 za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
168 Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
169 stosowanie Message Authentication Code (MAC).
170 Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
171 procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
172 na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
173 %endif
174
175 %description -l pt.UTF-8
176 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
177 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
178 cifradas entre duas máquinas sem confiança mútua sobre uma rede
179 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
180 reenviados pelo canal seguro.
181
182 %description -l pt_BR.UTF-8
183 SSH é um programa para acessar e executar comandos em máquinas
184 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
185 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
186 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
187
188 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
189 última versão gratuita do SSH, atualizando-o em termos de segurança e
190 recursos, assim como removendo todos os algoritmos patenteados e
191 colocando-os em bibliotecas separadas (OpenSSL).
192
193 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
194 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
195
196 %description -l ru.UTF-8
197 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
198 машину и для выполнения команд на удаленной машине. Она предназначена
199 для замены rlogin и rsh и обеспечивает безопасную шифрованную
200 коммуникацию между двумя хостами в сети, являющейся небезопасной.
201 Соединения X11 и любые порты TCP/IP могут также быть проведены через
202 безопасный канал.
203
204 OpenSSH - это переделка командой разработчиков OpenBSD последней
205 свободной версии SSH, доведенная до современного состояния в терминах
206 уровня безопасности и поддерживаемых возможностей. Все патентованные
207 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
208
209 Этот пакет содержит файлы, необходимые как для клиента, так и для
210 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
211 openssh-server, или оба пакета.
212
213 %description -l uk.UTF-8
214 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
215 машини та для виконання команд на віддаленій машині. Вона призначена
216 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
217 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
218 довільні порти TCP/IP можуть також бути проведені через безпечний
219 канал.
220
221 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
222 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
223 підтримуваних можливостей. Всі патентовані алгоритми винесені до
224 окремих бібліотек (OpenSSL).
225
226 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
227 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
228 openssh-server, чи обидва пакети.
229
230 %package clients
231 Summary:        OpenSSH Secure Shell protocol clients
232 Summary(es.UTF-8):      Clientes de OpenSSH
233 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
234 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
235 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
236 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
237 Group:          Applications/Networking
238 Requires:       %{name} = %{epoch}:%{version}-%{release}
239 Provides:       ssh-clients
240 Obsoletes:      ssh-clients
241
242 %description clients
243 Ssh (Secure Shell) a program for logging into a remote machine and for
244 executing commands in a remote machine. It is intended to replace
245 rlogin and rsh, and provide secure encrypted communications between
246 two untrusted hosts over an insecure network. X11 connections and
247 arbitrary TCP/IP ports can also be forwarded over the secure channel.
248
249 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
250 it up to date in terms of security and features, as well as removing
251 all patented algorithms to seperate libraries (OpenSSL).
252
253 This package includes the clients necessary to make encrypted
254 connections to SSH servers.
255
256 %description clients -l es.UTF-8
257 Este paquete incluye los clientes que se necesitan para hacer
258 conexiones codificadas con servidores SSH.
259
260 %description clients -l pl.UTF-8
261 Ssh (Secure Shell) to program służący do logowania się na zdalną
262 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
263 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
264 pomiędzy dwoma hostami.
265
266 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
267
268 %description clients -l pt_BR.UTF-8
269 Esse pacote inclui os clientes necessários para fazer conexões
270 encriptadas com servidores SSH.
271
272 %description clients -l ru.UTF-8
273 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
274 машину и для выполнения команд на удаленной машине.
275
276 Этот пакет содержит программы-клиенты, необходимые для установления
277 зашифрованных соединений с серверами SSH.
278
279 %description clients -l uk.UTF-8
280 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
281 машини та для виконання команд на віддаленій машині.
282
283 Цей пакет містить програми-клієнти, необхідні для встановлення
284 зашифрованих з'єднань з серверами SSH.
285
286 %package clients-agent-profile_d
287 Summary:        OpenSSH Secure Shell agent init script
288 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
289 Group:          Applications/Networking
290 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
291
292 %description clients-agent-profile_d
293 profile.d scripts for starting SSH agent.
294
295 %description clients-agent-profile_d -l pl.UTF-8
296 Skrypty profile.d do uruchamiania agenta SSH.
297
298 %package clients-agent-xinitrc
299 Summary:        OpenSSH Secure Shell agent init script
300 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
301 Group:          Applications/Networking
302 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
303 Requires:       xinitrc
304
305 %description clients-agent-xinitrc
306 xinitrc scripts for starting SSH agent.
307
308 %description clients-agent-xinitrc -l pl.UTF-8
309 Skrypty xinitrc do uruchamiania agenta SSH.
310
311 %package server
312 Summary:        OpenSSH Secure Shell protocol server (sshd)
313 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
314 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
315 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
316 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
317 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
318 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
319 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
320 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
321 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
322 Group:          Networking/Daemons
323 Requires(post): chkconfig >= 0.9
324 Requires(post): grep
325 Requires(post,preun):   /sbin/chkconfig
326 Requires(postun):       /usr/sbin/userdel
327 Requires(pre):  /bin/id
328 Requires(pre):  /usr/sbin/useradd
329 Requires:       %{name} = %{epoch}:%{version}-%{release}
330 Requires:       /bin/login
331 Requires:       pam >= 0.99.7.1
332 Requires:       rc-scripts >= 0.4.1.23
333 Requires:       util-linux
334 Provides:       ssh-server
335 Provides:       user(sshd)
336
337 %description server
338 Ssh (Secure Shell) a program for logging into a remote machine and for
339 executing commands in a remote machine. It is intended to replace
340 rlogin and rsh, and provide secure encrypted communications between
341 two untrusted hosts over an insecure network. X11 connections and
342 arbitrary TCP/IP ports can also be forwarded over the secure channel.
343
344 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
345 it up to date in terms of security and features, as well as removing
346 all patented algorithms to seperate libraries (OpenSSL).
347
348 This package contains the secure shell daemon. The sshd is the server
349 part of the secure shell protocol and allows ssh clients to connect to
350 your host.
351
352 %description server -l de.UTF-8
353 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
354
355 %description server -l es.UTF-8
356 Este paquete contiene el servidor SSH. sshd es la parte servidor del
357 protocolo secure shell y permite que clientes ssh se conecten a su
358 servidor.
359
360 %description server -l fr.UTF-8
361 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
362
363 %description server -l it.UTF-8
364 Questo pacchetto installa sshd, il server di OpenSSH.
365
366 %description server -l pl.UTF-8
367 Ssh (Secure Shell) to program służący do logowania się na zdalną
368 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
369 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
370 pomiędzy dwoma hostami.
371
372 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
373 ssh).
374
375 %description server -l pt.UTF-8
376 Este pacote intala o sshd, o servidor do OpenSSH.
377
378 %description server -l pt_BR.UTF-8
379 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
380 protocolo secure shell e permite que clientes ssh se conectem ao seu
381 host.
382
383 %description server -l ru.UTF-8
384 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
385 машину и для выполнения команд на удаленной машине.
386
387 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
388 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
389 вашим хостом.
390
391 %description server -l uk.UTF-8
392 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
393 машини та для виконання команд на віддаленій машині.
394
395 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
396 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
397 з вашим хостом.
398
399 %package gnome-askpass
400 Summary:        OpenSSH GNOME passphrase dialog
401 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
402 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
403 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
404 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
405 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
406 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
407 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
408 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
409 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
410 Group:          Applications/Networking
411 Requires:       %{name} = %{epoch}:%{version}-%{release}
412 Obsoletes:      openssh-askpass
413 Obsoletes:      ssh-askpass
414 Obsoletes:      ssh-extras
415
416 %description gnome-askpass
417 Ssh (Secure Shell) a program for logging into a remote machine and for
418 executing commands in a remote machine. It is intended to replace
419 rlogin and rsh, and provide secure encrypted communications between
420 two untrusted hosts over an insecure network. X11 connections and
421 arbitrary TCP/IP ports can also be forwarded over the secure channel.
422
423 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
424 it up to date in terms of security and features, as well as removing
425 all patented algorithms to seperate libraries (OpenSSL).
426
427 This package contains the GNOME passphrase dialog.
428
429 %description gnome-askpass -l es.UTF-8
430 Este paquete contiene un programa que abre una caja de diálogo para
431 entrada de passphrase en GNOME.
432
433 %description gnome-askpass -l pl.UTF-8
434 Ssh (Secure Shell) to program służący do logowania się na zdalną
435 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
436 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
437 pomiędzy dwoma hostami.
438
439 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
440
441 %description gnome-askpass -l pt_BR.UTF-8
442 Esse pacote contém um programa que abre uma caixa de diálogo para
443 entrada de passphrase no GNOME.
444
445 %description gnome-askpass -l ru.UTF-8
446 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
447 машину и для выполнения команд на удаленной машине.
448
449 Этот пакет содержит диалог ввода ключевой фразы для использования под
450 GNOME.
451
452 %description gnome-askpass -l uk.UTF-8
453 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
454 машини та для виконання команд на віддаленій машині.
455
456 Цей пакет містить діалог вводу ключової фрази для використання під
457 GNOME.
458
459 %prep
460 %setup -q
461 %patch0 -p1
462 %patch2 -p1
463 %patch3 -p1
464 %{?with_ldap:%patch4 -p1}
465 %patch5 -p1
466 %patch7 -p1
467 %{?with_hpn:%patch9 -p1}
468 %patch10 -p1
469 %patch11 -p1
470 %patch12 -p1
471
472 %build
473 cp /usr/share/automake/config.sub .
474 %{__aclocal}
475 %{__autoconf}
476 CPPFLAGS="-DCHROOT"
477 %configure \
478         PERL=%{__perl} \
479         --with-dns \
480         --with-pam \
481         --with-mantype=man \
482         --with-md5-passwords \
483         --with-ipaddr-display \
484         %{?with_libedit:--with-libedit} \
485         --with-4in6 \
486         --disable-suid-ssh \
487         --with-tcp-wrappers \
488         %{?with_ldap:--with-libs="-lldap -llber"} \
489         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
490         %{?with_kerberos5:--with-kerberos5=/usr} \
491         --with-privsep-path=%{_privsepdir} \
492         --with-pid-dir=%{_localstatedir}/run \
493         --with-xauth=/usr/bin/xauth \
494         --enable-utmpx \
495         --enable-wtmpx
496
497 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
498
499 %{__make}
500
501 cd contrib
502 %if %{with gnome}
503 %{__make} gnome-ssh-askpass1 \
504         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
505 %endif
506 %if %{with gtk}
507 %{__make} gnome-ssh-askpass2 \
508         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
509 %endif
510
511 %install
512 rm -rf $RPM_BUILD_ROOT
513 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
514         $RPM_BUILD_ROOT%{_libexecdir}/ssh
515 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
516
517 %{__make} install \
518         DESTDIR=$RPM_BUILD_ROOT
519
520 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
521
522 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
523 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
524 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
525 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
526 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
527 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
528
529 %if %{with gnome}
530 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
531 %endif
532 %if %{with gtk}
533 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
534 %endif
535 %if %{with gnome} || %{with gtk}
536 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
537 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
538 EOF
539 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
540 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
541 EOF
542 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
543 %endif
544
545 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
546 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
547
548 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
549
550 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
551 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
552 EOF
553
554 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
555 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
556
557 %clean
558 rm -rf $RPM_BUILD_ROOT
559
560 %post clients
561 %env_update
562
563 %postun clients
564 %env_update
565
566 %post gnome-askpass
567 %env_update
568
569 %postun gnome-askpass
570 %env_update
571
572 %pre server
573 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
574
575 %post server
576 /sbin/chkconfig --add sshd
577 %service sshd reload "openssh daemon"
578 if ! grep -qs ssh /etc/security/passwd.conf ; then
579         umask 022
580         echo "ssh" >> /etc/security/passwd.conf
581 fi
582
583 %preun server
584 if [ "$1" = "0" ]; then
585         %service sshd stop
586         /sbin/chkconfig --del sshd
587 fi
588
589 %postun server
590 if [ "$1" = "0" ]; then
591         %userremove sshd
592 fi
593
594 %files
595 %defattr(644,root,root,755)
596 %doc *.RNG TODO README OVERVIEW CREDITS Change*
597 %attr(755,root,root) %{_bindir}/ssh-key*
598 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
599 %{_mandir}/man1/ssh-key*.1*
600 %{_mandir}/man1/ssh-vulnkey*.1*
601 %dir %{_sysconfdir}
602 %dir %{_libexecdir}
603
604 %files clients
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_bindir}/ssh
607 %attr(755,root,root) %{_bindir}/slogin
608 %attr(755,root,root) %{_bindir}/sftp
609 %attr(755,root,root) %{_bindir}/ssh-agent
610 %attr(755,root,root) %{_bindir}/ssh-add
611 %attr(755,root,root) %{_bindir}/scp
612 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
613 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
614 %{_mandir}/man1/scp.1*
615 %{_mandir}/man1/ssh.1*
616 %{_mandir}/man1/slogin.1*
617 %{_mandir}/man1/sftp.1*
618 %{_mandir}/man1/ssh-agent.1*
619 %{_mandir}/man1/ssh-add.1*
620 %{_mandir}/man5/ssh_config.5*
621 %lang(it) %{_mandir}/it/man1/ssh.1*
622 %lang(it) %{_mandir}/it/man5/ssh_config.5*
623 %lang(pl) %{_mandir}/pl/man1/scp.1*
624 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
625
626 # for host-based auth (suid required for accessing private host key)
627 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
628 #%{_mandir}/man8/ssh-keysign.8*
629
630 %files clients-agent-profile_d
631 %defattr(644,root,root,755)
632 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
633 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
634
635 %files clients-agent-xinitrc
636 %defattr(644,root,root,755)
637 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
638
639 %files server
640 %defattr(644,root,root,755)
641 %attr(755,root,root) %{_sbindir}/sshd
642 %attr(755,root,root) %{_libexecdir}/sftp-server
643 %attr(755,root,root) %{_libexecdir}/ssh-keysign
644 %{_mandir}/man8/sshd.8*
645 %{_mandir}/man8/sftp-server.8*
646 %{_mandir}/man8/ssh-keysign.8*
647 %{_mandir}/man5/sshd_config.5*
648 %{_mandir}/man5/moduli.5*
649 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
650 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
651 %attr(640,root,root) %{_sysconfdir}/moduli
652 %attr(754,root,root) /etc/rc.d/init.d/sshd
653 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
654 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
655
656 %if %{with gnome} || %{with gtk}
657 %files gnome-askpass
658 %defattr(644,root,root,755)
659 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
660 %dir %{_libexecdir}/ssh
661 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
662 %attr(755,root,root) %{_libexecdir}/ssh-askpass
663 %endif
This page took 0.074854 seconds and 3 git commands to generate.