]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- up to 5.3p1
[packages/openssh.git] / openssh.spec
1 # Conditional build:
2 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
3 %bcond_without  gtk             # without GTK+ (2.x)
4 %bcond_without  ldap            # with ldap support
5 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
6 %bcond_without  kerberos5       # without kerberos5 support
7 %bcond_without  selinux         # build without SELinux support
8 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
9
10 # gtk2-based gnome-askpass means no gnome1-based
11 %{?with_gtk:%undefine with_gnome}
12 #
13 Summary:        OpenSSH free Secure Shell (SSH) implementation
14 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
15 Summary(es.UTF-8):      Implementación libre de SSH
16 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
17 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
18 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
19 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
20 Summary(pt_BR.UTF-8):   Implementação livre do SSH
21 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
22 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
23 Name:           openssh
24 Version:        5.3p1
25 Release:        1
26 Epoch:          2
27 License:        BSD
28 Group:          Applications/Networking
29 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
30 # Source0-md5:  13563dbf61f36ca9a1e4254260131041
31 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
32 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
33 Source2:        %{name}d.init
34 Source3:        %{name}d.pamd
35 Source4:        %{name}.sysconfig
36 Source5:        ssh-agent.sh
37 Source6:        ssh-agent.conf
38 Source7:        %{name}-lpk.schema
39 Patch0:         %{name}-no_libnsl.patch
40 Patch2:         %{name}-pam_misc.patch
41 Patch3:         %{name}-sigpipe.patch
42 # http://code.google.com/p/openssh-lpk/
43 Patch4:         %{name}-lpk.patch
44 Patch5:         %{name}-config.patch
45 Patch7:         %{name}-selinux.patch
46 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
47 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
48 Patch9:         %{name}-5.2p1-hpn13v6.diff
49 Patch10:        %{name}-include.patch
50 Patch11:        %{name}-chroot.patch
51 Patch12:        http://people.debian.org/~cjwatson/%{name}-blacklist.diff
52 URL:            http://www.openssh.com/
53 BuildRequires:  %{__perl}
54 BuildRequires:  autoconf
55 BuildRequires:  automake
56 %{?with_gnome:BuildRequires:    gnome-libs-devel}
57 %{?with_gtk:BuildRequires:      gtk+2-devel}
58 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
59 %{?with_libedit:BuildRequires:  libedit-devel}
60 %{?with_selinux:BuildRequires:  libselinux-devel}
61 BuildRequires:  libwrap-devel
62 %{?with_ldap:BuildRequires:     openldap-devel}
63 BuildRequires:  openssl-devel >= 0.9.7d
64 BuildRequires:  pam-devel
65 %{?with_gtk:BuildRequires:      pkgconfig}
66 BuildRequires:  rpmbuild(macros) >= 1.318
67 BuildRequires:  zlib-devel
68 Requires:       filesystem >= 3.0-11
69 Requires:       pam >= 0.99.7.1
70 Suggests:       openssh-blacklist
71 Suggests:       xorg-app-xauth
72 Obsoletes:      ssh
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _sysconfdir     /etc/ssh
76 %define         _libexecdir     %{_libdir}/%{name}
77 %define         _privsepdir     /usr/share/empty
78 %define         schemadir       /usr/share/openldap/schema
79
80 %description
81 Ssh (Secure Shell) a program for logging into a remote machine and for
82 executing commands in a remote machine. It is intended to replace
83 rlogin and rsh, and provide secure encrypted communications between
84 two untrusted hosts over an insecure network. X11 connections and
85 arbitrary TCP/IP ports can also be forwarded over the secure channel.
86
87 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
88 it up to date in terms of security and features, as well as removing
89 all patented algorithms to seperate libraries (OpenSSL).
90
91 This package includes the core files necessary for both the OpenSSH
92 client and server. To make this package useful, you should also
93 install openssh-clients, openssh-server, or both.
94 %if %{with hpn}
95 This release includes High Performance SSH/SCP patches from
96 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
97 to increase throughput on fast connections with high RTT (20-150 msec).
98 See the website for '-w' values for your connection and /proc/sys TCP
99 values. BTW. in a LAN you have got generally RTT < 1 msec.
100 %endif
101
102 %description -l de.UTF-8
103 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
104 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
105 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
106 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
107 andere TCP/IP Ports können ebenso über den sicheren Channel
108 weitergeleitet werden.
109
110 %description -l es.UTF-8
111 SSH es un programa para accesar y ejecutar órdenes en computadores
112 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
113 seguro entre dos servidores en una red insegura. Conexiones X11 y
114 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
115 seguro.
116
117 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
118 continuar la última versión gratuita de SSH, actualizándolo en
119 términos de seguridad y recursos,así también eliminando todos los
120 algoritmos patentados y colocándolos en bibliotecas separadas
121 (OpenSSL).
122
123 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
124 también el paquete openssh-clients u openssh-server o ambos.
125
126 %description -l fr.UTF-8
127 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
128 remplace telnet, rlogin, rexec et rsh, tout en assurant des
129 communications cryptées securisées entre deux hôtes non fiabilisés sur
130 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
131 arbitraires peuvent également être transmis sur le canal sécurisé.
132
133 %description -l it.UTF-8
134 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
135 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
136 sicure e crittate tra due host non fidati su una rete non sicura. Le
137 connessioni X11 ad una porta TCP/IP arbitraria possono essere
138 inoltrate attraverso un canale sicuro.
139
140 %description -l pl.UTF-8
141 Ssh (Secure Shell) to program służący do logowania się na zdalną
142 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
143 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
144 pomiędzy dwoma hostami.
145
146 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
147 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
148 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
149 %if %{with hpn}
150 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
151 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
152 zwiększenie przepustowości transmisji dla szybkich połączeń
153 z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
154 odpowednie dla danego połączenia wartości parametru '-w' oraz
155 opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
156 %endif
157
158 %description -l pt.UTF-8
159 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
160 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
161 cifradas entre duas máquinas sem confiança mútua sobre uma rede
162 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
163 reenviados pelo canal seguro.
164
165 %description -l pt_BR.UTF-8
166 SSH é um programa para acessar e executar comandos em máquinas
167 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
168 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
169 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
170
171 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
172 última versão gratuita do SSH, atualizando-o em termos de segurança e
173 recursos, assim como removendo todos os algoritmos patenteados e
174 colocando-os em bibliotecas separadas (OpenSSL).
175
176 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
177 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
178
179 %description -l ru.UTF-8
180 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
181 машину и для выполнения команд на удаленной машине. Она предназначена
182 для замены rlogin и rsh и обеспечивает безопасную шифрованную
183 коммуникацию между двумя хостами в сети, являющейся небезопасной.
184 Соединения X11 и любые порты TCP/IP могут также быть проведены через
185 безопасный канал.
186
187 OpenSSH - это переделка командой разработчиков OpenBSD последней
188 свободной версии SSH, доведенная до современного состояния в терминах
189 уровня безопасности и поддерживаемых возможностей. Все патентованные
190 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
191
192 Этот пакет содержит файлы, необходимые как для клиента, так и для
193 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
194 openssh-server, или оба пакета.
195
196 %description -l uk.UTF-8
197 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
198 машини та для виконання команд на віддаленій машині. Вона призначена
199 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
200 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
201 довільні порти TCP/IP можуть також бути проведені через безпечний
202 канал.
203
204 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
205 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
206 підтримуваних можливостей. Всі патентовані алгоритми винесені до
207 окремих бібліотек (OpenSSL).
208
209 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
210 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
211 openssh-server, чи обидва пакети.
212
213 %package clients
214 Summary:        OpenSSH Secure Shell protocol clients
215 Summary(es.UTF-8):      Clientes de OpenSSH
216 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
217 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
218 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
219 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
220 Group:          Applications/Networking
221 Requires:       %{name}
222 Provides:       ssh-clients
223 Obsoletes:      ssh-clients
224
225 %description clients
226 Ssh (Secure Shell) a program for logging into a remote machine and for
227 executing commands in a remote machine. It is intended to replace
228 rlogin and rsh, and provide secure encrypted communications between
229 two untrusted hosts over an insecure network. X11 connections and
230 arbitrary TCP/IP ports can also be forwarded over the secure channel.
231
232 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
233 it up to date in terms of security and features, as well as removing
234 all patented algorithms to seperate libraries (OpenSSL).
235
236 This package includes the clients necessary to make encrypted
237 connections to SSH servers.
238
239 %description clients -l es.UTF-8
240 Este paquete incluye los clientes que se necesitan para hacer
241 conexiones codificadas con servidores SSH.
242
243 %description clients -l pl.UTF-8
244 Ssh (Secure Shell) to program służący do logowania się na zdalną
245 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
246 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
247 pomiędzy dwoma hostami.
248
249 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
250
251 %description clients -l pt_BR.UTF-8
252 Esse pacote inclui os clientes necessários para fazer conexões
253 encriptadas com servidores SSH.
254
255 %description clients -l ru.UTF-8
256 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
257 машину и для выполнения команд на удаленной машине.
258
259 Этот пакет содержит программы-клиенты, необходимые для установления
260 зашифрованных соединений с серверами SSH.
261
262 %description clients -l uk.UTF-8
263 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
264 машини та для виконання команд на віддаленій машині.
265
266 Цей пакет містить програми-клієнти, необхідні для встановлення
267 зашифрованих з'єднань з серверами SSH.
268
269 %package clients-agent-profile_d
270 Summary:        OpenSSH Secure Shell agent init script
271 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
272 Group:          Applications/Networking
273 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
274
275 %description clients-agent-profile_d
276 profile.d scripts for starting SSH agent.
277
278 %description clients-agent-profile_d -l pl.UTF-8
279 Skrypty profile.d do uruchamiania agenta SSH.
280
281 %package clients-agent-xinitrc
282 Summary:        OpenSSH Secure Shell agent init script
283 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
284 Group:          Applications/Networking
285 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
286 Requires:       xinitrc
287
288 %description clients-agent-xinitrc
289 xinitrc scripts for starting SSH agent.
290
291 %description clients-agent-xinitrc -l pl.UTF-8
292 Skrypty xinitrc do uruchamiania agenta SSH.
293
294 %package server
295 Summary:        OpenSSH Secure Shell protocol server (sshd)
296 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
297 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
298 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
299 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
300 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
301 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
302 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
303 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
304 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
305 Group:          Networking/Daemons
306 Requires(post): chkconfig >= 0.9
307 Requires(post): grep
308 Requires(post,preun):   /sbin/chkconfig
309 Requires(postun):       /usr/sbin/userdel
310 Requires(pre):  /bin/id
311 Requires(pre):  /usr/sbin/useradd
312 Requires:       %{name} = %{epoch}:%{version}-%{release}
313 Requires:       pam >= 0.99.7.1
314 Requires:       rc-scripts >= 0.4.1.23
315 Requires:       util-linux
316 Suggests:       /bin/login
317 Provides:       ssh-server
318 Provides:       user(sshd)
319
320 %description server
321 Ssh (Secure Shell) a program for logging into a remote machine and for
322 executing commands in a remote machine. It is intended to replace
323 rlogin and rsh, and provide secure encrypted communications between
324 two untrusted hosts over an insecure network. X11 connections and
325 arbitrary TCP/IP ports can also be forwarded over the secure channel.
326
327 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
328 it up to date in terms of security and features, as well as removing
329 all patented algorithms to seperate libraries (OpenSSL).
330
331 This package contains the secure shell daemon. The sshd is the server
332 part of the secure shell protocol and allows ssh clients to connect to
333 your host.
334
335 %description server -l de.UTF-8
336 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
337
338 %description server -l es.UTF-8
339 Este paquete contiene el servidor SSH. sshd es la parte servidor del
340 protocolo secure shell y permite que clientes ssh se conecten a su
341 servidor.
342
343 %description server -l fr.UTF-8
344 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
345
346 %description server -l it.UTF-8
347 Questo pacchetto installa sshd, il server di OpenSSH.
348
349 %description server -l pl.UTF-8
350 Ssh (Secure Shell) to program służący do logowania się na zdalną
351 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
352 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
353 pomiędzy dwoma hostami.
354
355 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
356 ssh).
357
358 %description server -l pt.UTF-8
359 Este pacote intala o sshd, o servidor do OpenSSH.
360
361 %description server -l pt_BR.UTF-8
362 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
363 protocolo secure shell e permite que clientes ssh se conectem ao seu
364 host.
365
366 %description server -l ru.UTF-8
367 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
368 машину и для выполнения команд на удаленной машине.
369
370 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
371 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
372 вашим хостом.
373
374 %description server -l uk.UTF-8
375 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
376 машини та для виконання команд на віддаленій машині.
377
378 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
379 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
380 з вашим хостом.
381
382 %package gnome-askpass
383 Summary:        OpenSSH GNOME passphrase dialog
384 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
385 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
386 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
387 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
388 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
389 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
390 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
391 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
392 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
393 Group:          Applications/Networking
394 Requires:       %{name} = %{epoch}:%{version}-%{release}
395 Obsoletes:      openssh-askpass
396 Obsoletes:      ssh-askpass
397 Obsoletes:      ssh-extras
398
399 %description gnome-askpass
400 Ssh (Secure Shell) a program for logging into a remote machine and for
401 executing commands in a remote machine. It is intended to replace
402 rlogin and rsh, and provide secure encrypted communications between
403 two untrusted hosts over an insecure network. X11 connections and
404 arbitrary TCP/IP ports can also be forwarded over the secure channel.
405
406 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
407 it up to date in terms of security and features, as well as removing
408 all patented algorithms to seperate libraries (OpenSSL).
409
410 This package contains the GNOME passphrase dialog.
411
412 %description gnome-askpass -l es.UTF-8
413 Este paquete contiene un programa que abre una caja de diálogo para
414 entrada de passphrase en GNOME.
415
416 %description gnome-askpass -l pl.UTF-8
417 Ssh (Secure Shell) to program służący do logowania się na zdalną
418 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
419 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
420 pomiędzy dwoma hostami.
421
422 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
423
424 %description gnome-askpass -l pt_BR.UTF-8
425 Esse pacote contém um programa que abre uma caixa de diálogo para
426 entrada de passphrase no GNOME.
427
428 %description gnome-askpass -l ru.UTF-8
429 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
430 машину и для выполнения команд на удаленной машине.
431
432 Этот пакет содержит диалог ввода ключевой фразы для использования под
433 GNOME.
434
435 %description gnome-askpass -l uk.UTF-8
436 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
437 машини та для виконання команд на віддаленій машині.
438
439 Цей пакет містить діалог вводу ключової фрази для використання під
440 GNOME.
441
442 %package -n openldap-schema-openssh-lpk
443 Summary:        OpenSSH LDAP Public Key schema
444 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
445 Group:          Networking/Daemons
446 Requires(post,postun):  sed >= 4.0
447 Requires:       openldap-servers
448
449 %description -n openldap-schema-openssh-lpk
450 This package contains OpenSSH LDAP Public Key schema for openldap.
451
452 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
453 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
454 openldap-a.
455
456 %prep
457 %setup -q
458 %patch0 -p1
459 %patch2 -p1
460 %patch3 -p1
461 %{?with_ldap:%patch4 -p1}
462 %patch5 -p1
463 %patch7 -p1
464 %{?with_hpn:%patch9 -p1}
465 %patch10 -p1
466 %patch11 -p1
467 %patch12 -p1
468
469 %build
470 cp /usr/share/automake/config.sub .
471 %{__aclocal}
472 %{__autoconf}
473 CPPFLAGS="-DCHROOT"
474 %configure \
475         PERL=%{__perl} \
476         --with-dns \
477         --with-pam \
478         --with-mantype=man \
479         --with-md5-passwords \
480         --with-ipaddr-display \
481         %{?with_libedit:--with-libedit} \
482         --with-4in6 \
483         --disable-suid-ssh \
484         --with-tcp-wrappers \
485         %{?with_ldap:--with-libs="-lldap -llber"} \
486         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
487         %{?with_kerberos5:--with-kerberos5=/usr} \
488         --with-privsep-path=%{_privsepdir} \
489         --with-pid-dir=%{_localstatedir}/run \
490         --with-xauth=/usr/bin/xauth \
491         --enable-utmpx \
492         --enable-wtmpx
493
494 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
495
496 %{__make}
497
498 cd contrib
499 %if %{with gnome}
500 %{__make} gnome-ssh-askpass1 \
501         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
502 %endif
503 %if %{with gtk}
504 %{__make} gnome-ssh-askpass2 \
505         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
506 %endif
507
508 %install
509 rm -rf $RPM_BUILD_ROOT
510 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
511         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
512 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
513
514 %{__make} install \
515         DESTDIR=$RPM_BUILD_ROOT
516
517 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
518
519 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
520 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
521 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
522 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
523 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
524 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
525 install %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
526
527 %if %{with gnome}
528 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
529 %endif
530 %if %{with gtk}
531 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
532 %endif
533 %if %{with gnome} || %{with gtk}
534 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
535 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
536 EOF
537 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
538 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
539 EOF
540 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
541 %endif
542
543 install contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
544 install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
545
546 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
547 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
548
549 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
550
551 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
552 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
553 EOF
554
555 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
556 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
557
558 %clean
559 rm -rf $RPM_BUILD_ROOT
560
561 %post clients
562 %env_update
563
564 %postun clients
565 %env_update
566
567 %post gnome-askpass
568 %env_update
569
570 %postun gnome-askpass
571 %env_update
572
573 %pre server
574 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
575
576 %post server
577 /sbin/chkconfig --add sshd
578 %service sshd reload "openssh daemon"
579 if ! grep -qs ssh /etc/security/passwd.conf ; then
580         umask 022
581         echo "ssh" >> /etc/security/passwd.conf
582 fi
583
584 %preun server
585 if [ "$1" = "0" ]; then
586         %service sshd stop
587         /sbin/chkconfig --del sshd
588 fi
589
590 %postun server
591 if [ "$1" = "0" ]; then
592         %userremove sshd
593 fi
594
595 %post -n openldap-schema-openssh-lpk
596 %openldap_schema_register %{schemadir}/openssh-lpk.schema
597 %service -q ldap restart
598
599 %postun -n openldap-schema-openssh-lpk
600 if [ "$1" = "0" ]; then
601         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
602         %service -q ldap restart
603 fi
604
605 %files
606 %defattr(644,root,root,755)
607 %doc *.RNG TODO README OVERVIEW CREDITS Change*
608 %attr(755,root,root) %{_bindir}/ssh-key*
609 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
610 %{_mandir}/man1/ssh-key*.1*
611 %{_mandir}/man1/ssh-vulnkey*.1*
612 %dir %{_sysconfdir}
613 %dir %{_libexecdir}
614
615 %files clients
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_bindir}/ssh
618 %attr(755,root,root) %{_bindir}/slogin
619 %attr(755,root,root) %{_bindir}/sftp
620 %attr(755,root,root) %{_bindir}/ssh-agent
621 %attr(755,root,root) %{_bindir}/ssh-add
622 %attr(755,root,root) %{_bindir}/ssh-copy-id
623 %attr(755,root,root) %{_bindir}/scp
624 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
625 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
626 %{_mandir}/man1/scp.1*
627 %{_mandir}/man1/ssh.1*
628 %{_mandir}/man1/slogin.1*
629 %{_mandir}/man1/sftp.1*
630 %{_mandir}/man1/ssh-agent.1*
631 %{_mandir}/man1/ssh-add.1*
632 %{_mandir}/man1/ssh-copy-id.1*
633 %{_mandir}/man5/ssh_config.5*
634 %lang(it) %{_mandir}/it/man1/ssh.1*
635 %lang(it) %{_mandir}/it/man5/ssh_config.5*
636 %lang(pl) %{_mandir}/pl/man1/scp.1*
637 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
638
639 # for host-based auth (suid required for accessing private host key)
640 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
641 #%{_mandir}/man8/ssh-keysign.8*
642
643 %files clients-agent-profile_d
644 %defattr(644,root,root,755)
645 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
646 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
647
648 %files clients-agent-xinitrc
649 %defattr(644,root,root,755)
650 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
651
652 %files server
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_sbindir}/sshd
655 %attr(755,root,root) %{_libexecdir}/sftp-server
656 %attr(755,root,root) %{_libexecdir}/ssh-keysign
657 %{_mandir}/man8/sshd.8*
658 %{_mandir}/man8/sftp-server.8*
659 %{_mandir}/man8/ssh-keysign.8*
660 %{_mandir}/man5/sshd_config.5*
661 %{_mandir}/man5/moduli.5*
662 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
663 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
664 %attr(640,root,root) %{_sysconfdir}/moduli
665 %attr(754,root,root) /etc/rc.d/init.d/sshd
666 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
667 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
668
669 %if %{with gnome} || %{with gtk}
670 %files gnome-askpass
671 %defattr(644,root,root,755)
672 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
673 %dir %{_libexecdir}/ssh
674 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
675 %attr(755,root,root) %{_libexecdir}/ssh-askpass
676 %endif
677
678 %if %{with ldap}
679 %files -n openldap-schema-openssh-lpk
680 %defattr(644,root,root,755)
681 %{schemadir}/openssh-lpk.schema
682 %endif
This page took 0.081972 seconds and 3 git commands to generate.