]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- 5.0p1-hpn13v4 test
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
4 %bcond_without  gtk             # without GTK+ (2.x)
5 %bcond_with     ldap            # with ldap support
6 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
7 %bcond_without  kerberos5       # without kerberos5 support
8 %bcond_without  selinux         # build without SELinux support
9 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
10
11 # gtk2-based gnome-askpass means no gnome1-based
12 %{?with_gtk:%undefine with_gnome}
13 #
14 Summary:        OpenSSH free Secure Shell (SSH) implementation
15 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
16 Summary(es.UTF-8):      Implementación libre de SSH
17 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
18 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
19 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
20 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
21 Summary(pt_BR.UTF-8):   Implementação livre do SSH
22 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
23 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
24 Name:           openssh
25 Version:        5.0p1
26 Release:        4
27 Epoch:          2
28 License:        BSD
29 Group:          Applications/Networking
30 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
31 # Source0-md5:  1f1dfaa775f33dd3328169de9bdc292a
32 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
33 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
34 Source2:        %{name}d.init
35 Source3:        %{name}d.pamd
36 Source4:        %{name}.sysconfig
37 Source5:        ssh-agent.sh
38 Source6:        ssh-agent.conf
39 Patch0:         %{name}-no_libnsl.patch
40 Patch1:         %{name}-linux-ipv6.patch
41 Patch2:         %{name}-pam_misc.patch
42 Patch3:         %{name}-sigpipe.patch
43 # http://www.opendarwin.org/projects/openssh-lpk/
44 Patch4:         %{name}-lpk-4.3p1-0.3.7.patch
45 Patch5:         %{name}-config.patch
46 Patch7:         %{name}-selinux.patch
47 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
48 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.9p1-hpn13v2.diff.gz
49 Patch9:         %{name}-5.0p1-hpn13v4.diff
50 Patch10:        %{name}-include.patch
51 Patch11:        %{name}-chroot.patch
52 URL:            http://www.openssh.com/
53 BuildRequires:  %{__perl}
54 BuildRequires:  autoconf
55 BuildRequires:  automake
56 %{?with_gnome:BuildRequires:    gnome-libs-devel}
57 %{?with_gtk:BuildRequires:      gtk+2-devel}
58 %{?with_kerberos5:BuildRequires:        krb5-devel}
59 %{?with_libedit:BuildRequires:  libedit-devel}
60 %{?with_selinux:BuildRequires:  libselinux-devel}
61 BuildRequires:  libwrap-devel
62 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
63 BuildRequires:  openssl-devel >= 0.9.7d
64 BuildRequires:  pam-devel
65 %{?with_gtk:BuildRequires:      pkgconfig}
66 BuildRequires:  rpmbuild(macros) >= 1.318
67 BuildRequires:  zlib-devel
68 Requires:       filesystem >= 3.0-11
69 Requires:       pam >= 0.99.7.1
70 Obsoletes:      ssh
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %define         _sysconfdir     /etc/ssh
74 %define         _libexecdir     %{_libdir}/%{name}
75 %define         _privsepdir     /usr/share/empty
76
77 %description
78 Ssh (Secure Shell) a program for logging into a remote machine and for
79 executing commands in a remote machine. It is intended to replace
80 rlogin and rsh, and provide secure encrypted communications between
81 two untrusted hosts over an insecure network. X11 connections and
82 arbitrary TCP/IP ports can also be forwarded over the secure channel.
83
84 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
85 it up to date in terms of security and features, as well as removing
86 all patented algorithms to seperate libraries (OpenSSL).
87
88 This package includes the core files necessary for both the OpenSSH
89 client and server. To make this package useful, you should also
90 install openssh-clients, openssh-server, or both.
91 %if %{with hpn} || %{with hpn_none}
92 This release includes High Performance SSH/SCP patches from
93 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
94 to increase throughput on fast connections with high RTT (20-150 msec).
95 See the website for '-w' values for your connection and /proc/sys TCP
96 values. BTW. in a LAN you have got generally RTT < 1 msec.
97 %endif
98 %if %{with hpn_none}
99 It also includes an undocumented '-z' option which switches
100 the cipher to none after authentication is completed. Data is
101 still secured from tampering and corruption in transit through
102 the use of the Message Authentication Code (MAC).
103 This option will significantly reduce the number of cpu cycles used
104 by the SSH/SCP process. This may allow some users to see significant
105 improvement in (sniffable) data tranfer rates.
106 %endif
107
108 %description -l de.UTF-8
109 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
110 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
111 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
112 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
113 andere TCP/IP Ports können ebenso über den sicheren Channel
114 weitergeleitet werden.
115
116 %description -l es.UTF-8
117 SSH es un programa para accesar y ejecutar órdenes en computadores
118 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
119 seguro entre dos servidores en una red insegura. Conexiones X11 y
120 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
121 seguro.
122
123 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
124 continuar la última versión gratuita de SSH, actualizándolo en
125 términos de seguridad y recursos,así también eliminando todos los
126 algoritmos patentados y colocándolos en bibliotecas separadas
127 (OpenSSL).
128
129 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
130 también el paquete openssh-clients u openssh-server o ambos.
131
132 %description -l fr.UTF-8
133 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
134 remplace telnet, rlogin, rexec et rsh, tout en assurant des
135 communications cryptées securisées entre deux hôtes non fiabilisés sur
136 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
137 arbitraires peuvent également être transmis sur le canal sécurisé.
138
139 %description -l it.UTF-8
140 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
141 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
142 sicure e crittate tra due host non fidati su una rete non sicura. Le
143 connessioni X11 ad una porta TCP/IP arbitraria possono essere
144 inoltrate attraverso un canale sicuro.
145
146 %description -l pl.UTF-8
147 Ssh (Secure Shell) to program służący do logowania się na zdalną
148 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
149 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
150 pomiędzy dwoma hostami.
151
152 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
153 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
154 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
155 %if %{with hpn} || %{with hpn_none}
156 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
157 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
158 zwiększenie przepustowości transmisji dla szybkich połączeń
159 z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
160 odpowednie dla danego połączenia wartości parametru '-w' oraz
161 opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
162 %endif
163 %if %{with hpn_none}
164 Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
165 za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
166 Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
167 stosowanie Message Authentication Code (MAC).
168 Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
169 procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
170 na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
171 %endif
172
173 %description -l pt.UTF-8
174 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
175 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
176 cifradas entre duas máquinas sem confiança mútua sobre uma rede
177 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
178 reenviados pelo canal seguro.
179
180 %description -l pt_BR.UTF-8
181 SSH é um programa para acessar e executar comandos em máquinas
182 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
183 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
184 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
185
186 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
187 última versão gratuita do SSH, atualizando-o em termos de segurança e
188 recursos, assim como removendo todos os algoritmos patenteados e
189 colocando-os em bibliotecas separadas (OpenSSL).
190
191 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
192 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
193
194 %description -l ru.UTF-8
195 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
196 машину и для выполнения команд на удаленной машине. Она предназначена
197 для замены rlogin и rsh и обеспечивает безопасную шифрованную
198 коммуникацию между двумя хостами в сети, являющейся небезопасной.
199 Соединения X11 и любые порты TCP/IP могут также быть проведены через
200 безопасный канал.
201
202 OpenSSH - это переделка командой разработчиков OpenBSD последней
203 свободной версии SSH, доведенная до современного состояния в терминах
204 уровня безопасности и поддерживаемых возможностей. Все патентованные
205 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
206
207 Этот пакет содержит файлы, необходимые как для клиента, так и для
208 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
209 openssh-server, или оба пакета.
210
211 %description -l uk.UTF-8
212 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
213 машини та для виконання команд на віддаленій машині. Вона призначена
214 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
215 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
216 довільні порти TCP/IP можуть також бути проведені через безпечний
217 канал.
218
219 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
220 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
221 підтримуваних можливостей. Всі патентовані алгоритми винесені до
222 окремих бібліотек (OpenSSL).
223
224 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
225 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
226 openssh-server, чи обидва пакети.
227
228 %package clients
229 Summary:        OpenSSH Secure Shell protocol clients
230 Summary(es.UTF-8):      Clientes de OpenSSH
231 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
232 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
233 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
234 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
235 Group:          Applications/Networking
236 Requires:       %{name} = %{epoch}:%{version}-%{release}
237 Provides:       ssh-clients
238 Obsoletes:      ssh-clients
239
240 %description clients
241 Ssh (Secure Shell) a program for logging into a remote machine and for
242 executing commands in a remote machine. It is intended to replace
243 rlogin and rsh, and provide secure encrypted communications between
244 two untrusted hosts over an insecure network. X11 connections and
245 arbitrary TCP/IP ports can also be forwarded over the secure channel.
246
247 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
248 it up to date in terms of security and features, as well as removing
249 all patented algorithms to seperate libraries (OpenSSL).
250
251 This package includes the clients necessary to make encrypted
252 connections to SSH servers.
253
254 %description clients -l es.UTF-8
255 Este paquete incluye los clientes que se necesitan para hacer
256 conexiones codificadas con servidores SSH.
257
258 %description clients -l pl.UTF-8
259 Ssh (Secure Shell) to program służący do logowania się na zdalną
260 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
261 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
262 pomiędzy dwoma hostami.
263
264 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
265
266 %description clients -l pt_BR.UTF-8
267 Esse pacote inclui os clientes necessários para fazer conexões
268 encriptadas com servidores SSH.
269
270 %description clients -l ru.UTF-8
271 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
272 машину и для выполнения команд на удаленной машине.
273
274 Этот пакет содержит программы-клиенты, необходимые для установления
275 зашифрованных соединений с серверами SSH.
276
277 %description clients -l uk.UTF-8
278 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
279 машини та для виконання команд на віддаленій машині.
280
281 Цей пакет містить програми-клієнти, необхідні для встановлення
282 зашифрованих з'єднань з серверами SSH.
283
284 %package clients-agent-profile_d
285 Summary:        OpenSSH Secure Shell agent init script
286 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
287 Group:          Applications/Networking
288 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
289
290 %description clients-agent-profile_d
291 profile.d scripts for starting SSH agent.
292
293 %description clients-agent-profile_d -l pl.UTF-8
294 Skrypty profile.d do uruchamiania agenta SSH.
295
296 %package clients-agent-xinitrc
297 Summary:        OpenSSH Secure Shell agent init script
298 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
299 Group:          Applications/Networking
300 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
301 Requires:       xinitrc
302
303 %description clients-agent-xinitrc
304 xinitrc scripts for starting SSH agent.
305
306 %description clients-agent-xinitrc -l pl.UTF-8
307 Skrypty xinitrc do uruchamiania agenta SSH.
308
309 %package server
310 Summary:        OpenSSH Secure Shell protocol server (sshd)
311 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
312 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
313 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
314 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
315 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
316 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
317 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
318 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
319 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
320 Group:          Networking/Daemons
321 Requires(post): chkconfig >= 0.9
322 Requires(post): grep
323 Requires(post,preun):   /sbin/chkconfig
324 Requires(postun):       /usr/sbin/userdel
325 Requires(pre):  /bin/id
326 Requires(pre):  /usr/sbin/useradd
327 Requires:       %{name} = %{epoch}:%{version}-%{release}
328 Requires:       /bin/login
329 Requires:       pam >= 0.99.7.1
330 Requires:       rc-scripts >= 0.4.0.18
331 Requires:       util-linux
332 Provides:       ssh-server
333 Provides:       user(sshd)
334
335 %description server
336 Ssh (Secure Shell) a program for logging into a remote machine and for
337 executing commands in a remote machine. It is intended to replace
338 rlogin and rsh, and provide secure encrypted communications between
339 two untrusted hosts over an insecure network. X11 connections and
340 arbitrary TCP/IP ports can also be forwarded over the secure channel.
341
342 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
343 it up to date in terms of security and features, as well as removing
344 all patented algorithms to seperate libraries (OpenSSL).
345
346 This package contains the secure shell daemon. The sshd is the server
347 part of the secure shell protocol and allows ssh clients to connect to
348 your host.
349
350 %description server -l de.UTF-8
351 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
352
353 %description server -l es.UTF-8
354 Este paquete contiene el servidor SSH. sshd es la parte servidor del
355 protocolo secure shell y permite que clientes ssh se conecten a su
356 servidor.
357
358 %description server -l fr.UTF-8
359 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
360
361 %description server -l it.UTF-8
362 Questo pacchetto installa sshd, il server di OpenSSH.
363
364 %description server -l pl.UTF-8
365 Ssh (Secure Shell) to program służący do logowania się na zdalną
366 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
367 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
368 pomiędzy dwoma hostami.
369
370 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
371 ssh).
372
373 %description server -l pt.UTF-8
374 Este pacote intala o sshd, o servidor do OpenSSH.
375
376 %description server -l pt_BR.UTF-8
377 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
378 protocolo secure shell e permite que clientes ssh se conectem ao seu
379 host.
380
381 %description server -l ru.UTF-8
382 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
383 машину и для выполнения команд на удаленной машине.
384
385 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
386 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
387 вашим хостом.
388
389 %description server -l uk.UTF-8
390 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
391 машини та для виконання команд на віддаленій машині.
392
393 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
394 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
395 з вашим хостом.
396
397 %package gnome-askpass
398 Summary:        OpenSSH GNOME passphrase dialog
399 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
400 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
401 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
402 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
403 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
404 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
405 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
406 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
407 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
408 Group:          Applications/Networking
409 Requires:       %{name} = %{epoch}:%{version}-%{release}
410 Obsoletes:      openssh-askpass
411 Obsoletes:      ssh-askpass
412 Obsoletes:      ssh-extras
413
414 %description gnome-askpass
415 Ssh (Secure Shell) a program for logging into a remote machine and for
416 executing commands in a remote machine. It is intended to replace
417 rlogin and rsh, and provide secure encrypted communications between
418 two untrusted hosts over an insecure network. X11 connections and
419 arbitrary TCP/IP ports can also be forwarded over the secure channel.
420
421 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
422 it up to date in terms of security and features, as well as removing
423 all patented algorithms to seperate libraries (OpenSSL).
424
425 This package contains the GNOME passphrase dialog.
426
427 %description gnome-askpass -l es.UTF-8
428 Este paquete contiene un programa que abre una caja de diálogo para
429 entrada de passphrase en GNOME.
430
431 %description gnome-askpass -l pl.UTF-8
432 Ssh (Secure Shell) to program służący do logowania się na zdalną
433 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
434 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
435 pomiędzy dwoma hostami.
436
437 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
438
439 %description gnome-askpass -l pt_BR.UTF-8
440 Esse pacote contém um programa que abre uma caixa de diálogo para
441 entrada de passphrase no GNOME.
442
443 %description gnome-askpass -l ru.UTF-8
444 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
445 машину и для выполнения команд на удаленной машине.
446
447 Этот пакет содержит диалог ввода ключевой фразы для использования под
448 GNOME.
449
450 %description gnome-askpass -l uk.UTF-8
451 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
452 машини та для виконання команд на віддаленій машині.
453
454 Цей пакет містить діалог вводу ключової фрази для використання під
455 GNOME.
456
457 %prep
458 %setup -q
459 %patch0 -p1
460 %patch1 -p1
461 %patch2 -p1
462 %patch3 -p1
463 %{?with_ldap:%patch4 -p1}
464 %patch5 -p1
465 %patch7 -p1
466 %{?with_hpn:%patch9 -p1}
467 %patch10 -p1
468 %patch11 -p1
469
470 %build
471 cp /usr/share/automake/config.sub .
472 %{__aclocal}
473 %{__autoconf}
474 CPPFLAGS="-DCHROOT"
475 %configure \
476         PERL=%{__perl} \
477         --with-dns \
478         --with-pam \
479         --with-mantype=man \
480         --with-md5-passwords \
481         --with-ipaddr-display \
482         %{?with_libedit:--with-libedit} \
483         --with-4in6 \
484         --disable-suid-ssh \
485         --with-tcp-wrappers \
486         %{?with_ldap:--with-libs="-lldap -llber"} \
487         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
488         %{?with_kerberos5:--with-kerberos5=/usr} \
489         --with-privsep-path=%{_privsepdir} \
490         --with-pid-dir=%{_localstatedir}/run \
491         --with-xauth=/usr/bin/xauth \
492         --enable-utmpx \
493         --enable-wtmpx
494
495 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
496
497 %{__make}
498
499 cd contrib
500 %if %{with gnome}
501 %{__make} gnome-ssh-askpass1 \
502         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
503 %endif
504 %if %{with gtk}
505 %{__make} gnome-ssh-askpass2 \
506         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
507 %endif
508
509 %install
510 rm -rf $RPM_BUILD_ROOT
511 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
512         $RPM_BUILD_ROOT%{_libexecdir}/ssh
513 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
514
515 %{__make} install \
516         DESTDIR=$RPM_BUILD_ROOT
517
518 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
519
520 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
521 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
522 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
523 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
524 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
525 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
526
527 %if %{with gnome}
528 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
529 %endif
530 %if %{with gtk}
531 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
532 %endif
533 %if %{with gnome} || %{with gtk}
534 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
535 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
536 EOF
537 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
538 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
539 EOF
540 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
541 %endif
542
543 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
544 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
545
546 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
547
548 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
549 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
550 EOF
551
552 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
553 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
554
555 %clean
556 rm -rf $RPM_BUILD_ROOT
557
558 %post clients
559 %env_update
560
561 %postun clients
562 %env_update
563
564 %post gnome-askpass
565 %env_update
566
567 %postun gnome-askpass
568 %env_update
569
570 %pre server
571 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
572
573 %post server
574 /sbin/chkconfig --add sshd
575 %service sshd reload "openssh daemon"
576 if ! grep -qs ssh /etc/security/passwd.conf ; then
577         umask 022
578         echo "ssh" >> /etc/security/passwd.conf
579 fi
580
581 %preun server
582 if [ "$1" = "0" ]; then
583         %service sshd stop
584         /sbin/chkconfig --del sshd
585 fi
586
587 %postun server
588 if [ "$1" = "0" ]; then
589         %userremove sshd
590 fi
591
592 %files
593 %defattr(644,root,root,755)
594 %doc *.RNG TODO README OVERVIEW CREDITS Change*
595 %attr(755,root,root) %{_bindir}/ssh-key*
596 %{_mandir}/man1/ssh-key*.1*
597 %dir %{_sysconfdir}
598 %dir %{_libexecdir}
599
600 %files clients
601 %defattr(644,root,root,755)
602 %attr(755,root,root) %{_bindir}/ssh
603 %attr(755,root,root) %{_bindir}/slogin
604 %attr(755,root,root) %{_bindir}/sftp
605 %attr(755,root,root) %{_bindir}/ssh-agent
606 %attr(755,root,root) %{_bindir}/ssh-add
607 %attr(755,root,root) %{_bindir}/scp
608 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
609 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
610 %{_mandir}/man1/scp.1*
611 %{_mandir}/man1/ssh.1*
612 %{_mandir}/man1/slogin.1*
613 %{_mandir}/man1/sftp.1*
614 %{_mandir}/man1/ssh-agent.1*
615 %{_mandir}/man1/ssh-add.1*
616 %{_mandir}/man5/ssh_config.5*
617 %lang(it) %{_mandir}/it/man1/ssh.1*
618 %lang(it) %{_mandir}/it/man5/ssh_config.5*
619 %lang(pl) %{_mandir}/pl/man1/scp.1*
620 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
621
622 # for host-based auth (suid required for accessing private host key)
623 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
624 #%{_mandir}/man8/ssh-keysign.8*
625
626 %files clients-agent-profile_d
627 %defattr(644,root,root,755)
628 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
629 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
630
631 %files clients-agent-xinitrc
632 %defattr(644,root,root,755)
633 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
634
635 %files server
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_sbindir}/sshd
638 %attr(755,root,root) %{_libexecdir}/sftp-server
639 %attr(755,root,root) %{_libexecdir}/ssh-keysign
640 %{_mandir}/man8/sshd.8*
641 %{_mandir}/man8/sftp-server.8*
642 %{_mandir}/man8/ssh-keysign.8*
643 %{_mandir}/man5/sshd_config.5*
644 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
645 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
646 %attr(640,root,root) %{_sysconfdir}/moduli
647 %attr(754,root,root) /etc/rc.d/init.d/sshd
648 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
649 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
650
651 %if %{with gnome} || %{with gtk}
652 %files gnome-askpass
653 %defattr(644,root,root,755)
654 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
655 %dir %{_libexecdir}/ssh
656 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
657 %attr(755,root,root) %{_libexecdir}/ssh-askpass
658 %endif
This page took 0.075766 seconds and 3 git commands to generate.