]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- ac fix, needed for new autoconf (result without it is strange anyway,
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  chroot          # without chrooted user environment support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_with     ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     sshagentsh      # with system-wide script for starting ssh-agent
11 %bcond_with     hpn             # with High Performance SSH/SCP - HPN-SSH (see patch comment)
12 %bcond_with     hpn_none        # with hpn (above) and '-z' none cipher option
13 #
14 %if %{with hpn_none}
15 %undefine       with_hpn
16 %endif
17 # gtk2-based gnome-askpass means no gnome1-based
18 %{?with_gtk:%undefine with_gnome}
19 Summary:        OpenSSH free Secure Shell (SSH) implementation
20 Summary(de):    OpenSSH - freie Implementation der Secure Shell (SSH)
21 Summary(es):    Implementación libre de SSH
22 Summary(fr):    Implémentation libre du shell sécurisé OpenSSH (SSH)
23 Summary(it):    Implementazione gratuita OpenSSH della Secure Shell
24 Summary(pl):    Publicznie dostêpna implementacja bezpiecznego shella (SSH)
25 Summary(pt):    Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
26 Summary(pt_BR): Implementação livre do SSH
27 Summary(ru):    OpenSSH - Ó×ÏÂÏÄÎÁÑ ÒÅÁÌÉÚÁÃÉÑ ÐÒÏÔÏËÏÌÁ Secure Shell (SSH)
28 Summary(uk):    OpenSSH - ×¦ÌØÎÁ ÒÅÁ̦ÚÁæѠÐÒÏÔÏËÏÌÕ Secure Shell (SSH)
29 Name:           openssh
30 Version:        4.3p2
31 Release:        1%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
32 Epoch:          2
33 License:        BSD
34 Group:          Applications/Networking
35 Source0:        ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
36 # Source0-md5:  7e9880ac20a9b9db0d3fea30a9ff3d46
37 Source1:        %{name}d.conf
38 Source2:        %{name}.conf
39 Source3:        %{name}d.init
40 Source4:        %{name}d.pamd
41 Source5:        %{name}.sysconfig
42 Source6:        passwd.pamd
43 Source7:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
44 # Source7-md5:  66943d481cc422512b537bcc2c7400d1
45 Source9:        http://www.taiyo.co.jp/~gotoh/ssh/connect.c
46 # Source9-md5:  b856937f1cdfca7a3ccfb2fac36ef726
47 Source10:       http://www.taiyo.co.jp/~gotoh/ssh/connect.html
48 # Source10-md5: bb972b3a9d435c62023b355960d78f78
49 Source11:       ssh-agent.sh
50 Source12:       ssh-agent.conf
51 Patch0:         %{name}-no_libnsl.patch
52 Patch2:         %{name}-linux-ipv6.patch
53 Patch3:         %{name}-pam_misc.patch
54 Patch4:         %{name}-sigpipe.patch
55 # http://www.opendarwin.org/projects/openssh-lpk/
56 Patch5:         %{name}-lpk-4.3p1-0.3.7.patch
57 Patch6:         %{name}-heimdal.patch
58 Patch7:         %{name}-pam-conv.patch
59 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
60 Patch8:         %{name}-chroot.patch
61 Patch9:         %{name}-selinux.patch
62 Patch10:        %{name}-selinux-pld.patch
63 # HPN patches rediffed due sigpipe patch.
64 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
65 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
66 Patch11:        %{name}-4.3p1-hpn11.patch
67 # Adds HPN (see p11) and an undocumented -z none cipher flag
68 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
69 Patch12:        %{name}-4.3p1-hpn11-none.patch
70 Patch13:        %{name}-include.patch
71 URL:            http://www.openssh.com/
72 BuildRequires:  %{__perl}
73 BuildRequires:  autoconf
74 BuildRequires:  automake
75 %{?with_gnome:BuildRequires:    gnome-libs-devel}
76 %{?with_gtk:BuildRequires:      gtk+2-devel}
77 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
78 %{?with_libedit:BuildRequires:  libedit-devel}
79 %{?with_selinux:BuildRequires:  libselinux-devel}
80 BuildRequires:  libwrap-devel
81 %{?with_ldap:BuildRequires:     openldap-devel}
82 BuildRequires:  openssl-devel >= 0.9.7d
83 BuildRequires:  pam-devel
84 %{?with_gtk:BuildRequires:      pkgconfig}
85 BuildRequires:  rpmbuild(macros) >= 1.268
86 BuildRequires:  zlib-devel
87 Requires:       FHS >= 2.1-24
88 Requires:       pam >= 0.79.0
89 Obsoletes:      ssh
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         _sysconfdir     /etc/ssh
93 %define         _libexecdir     %{_libdir}/%{name}
94 %define         _privsepdir     /usr/share/empty
95
96 %description
97 Ssh (Secure Shell) a program for logging into a remote machine and for
98 executing commands in a remote machine. It is intended to replace
99 rlogin and rsh, and provide secure encrypted communications between
100 two untrusted hosts over an insecure network. X11 connections and
101 arbitrary TCP/IP ports can also be forwarded over the secure channel.
102
103 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
104 it up to date in terms of security and features, as well as removing
105 all patented algorithms to seperate libraries (OpenSSL).
106
107 This package includes the core files necessary for both the OpenSSH
108 client and server. To make this package useful, you should also
109 install openssh-clients, openssh-server, or both.
110 %if %{with hpn} || %{with hpn_none}
111 This release includes High Performance SSH/SCP patches from
112 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
113 to increase throughput on fast connections with high RTT (20-150 msec).
114 See the website for '-w' values for your connection and /proc/sys TCP
115 values. BTW. in a LAN you have got generally RTT < 1 msec.
116 %endif
117 %if %{with hpn_none}
118 It also includes an undocumented '-z' option which switches
119 the cipher to none after authentication is completed. Data is
120 still secured from tampering and corruption in transit through
121 the use of the Message Authentication Code (MAC).
122 This option will significantly reduce the number of cpu cycles used
123 by the SSH/SCP process. This may allow some users to see significant
124 improvement in (sniffable) data tranfer rates.
125 %endif
126
127 %description -l de
128 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
129 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
130 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
131 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
132 andere TCP/IP Ports können ebenso über den sicheren Channel
133 weitergeleitet werden.
134
135 %description -l es
136 SSH es un programa para accesar y ejecutar órdenes en computadores
137 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
138 seguro entre dos servidores en una red insegura. Conexiones X11 y
139 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
140 seguro.
141
142 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
143 continuar la última versión gratuita de SSH, actualizándolo en
144 términos de seguridad y recursos,así también eliminando todos los
145 algoritmos patentados y colocándolos en bibliotecas separadas
146 (OpenSSL).
147
148 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
149 también el paquete openssh-clients u openssh-server o ambos.
150
151 %description -l fr
152 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
153 remplace telnet, rlogin, rexec et rsh, tout en assurant des
154 communications cryptées securisées entre deux hôtes non fiabilisés sur
155 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
156 arbitraires peuvent également être transmis sur le canal sécurisé.
157
158 %description -l it
159 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
160 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
161 sicure e crittate tra due host non fidati su una rete non sicura. Le
162 connessioni X11 ad una porta TCP/IP arbitraria possono essere
163 inoltrate attraverso un canale sicuro.
164
165 %description -l pl
166 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
167 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
168 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
169 pomiêdzy dwoma hostami.
170
171 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
172 klienta jak i serwera OpenSSH. Aby by³ u¿yteczny, trzeba zainstalowaæ
173 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
174 %if %{with hpn} || %{with hpn_none}
175 Ta wersja zawiera ³aty z projektu High Performance SSH/SCP
176 http://www.psc.edu/networking/projects/hpn-ssh/, które maj± na celu
177 zwiêkszenie przepustowo¶ci transmisji dla szybkich po³±czeñ
178 z du¿ym RTT (20-150 msec). Na stronie projektu znale¼æ mo¿na
179 odpowednie dla danego po³±czenia warto¶ci parametru '-w' oraz
180 opcje /proc/sys dla TCP. Nawiasem mówi±c w sieciach LAN RTT < 1 msec.
181 %endif
182 %if %{with hpn_none}
183 Obs³ugiwana jest równie¿ nieudokumentowana opcja '-z' odpowiedzialna
184 za wy³±czenie szyfrowania danych po zakoñczeniu procesu uwierzytelniania.
185 Dane s± zabezpieczone przed modyfikacj± lub uszkodzeniem przez
186 stosowanie Message Authentication Code (MAC).
187 Opcja ta znacznie redukuje liczbê cykli procesora zu¿ywanych przez
188 procesy SSH/SCP. W wybranych zastosowaniach mo¿e ona wp³yn±æ
189 na wyra¼ne przyspieszenie (pods³uchiwalnej) transmisji danych.
190 %endif
191
192 %description -l pt
193 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
194 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
195 cifradas entre duas máquinas sem confiança mútua sobre uma rede
196 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
197 reenviados pelo canal seguro.
198
199 %description -l pt_BR
200 SSH é um programa para acessar e executar comandos em máquinas
201 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
202 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
203 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
204
205 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
206 última versão gratuita do SSH, atualizando-o em termos de segurança e
207 recursos, assim como removendo todos os algoritmos patenteados e
208 colocando-os em bibliotecas separadas (OpenSSL).
209
210 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
211 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
212
213 %description -l ru
214 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
215 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ. ïÎÁ ÐÒÅÄÎÁÚÎÁÞÅÎÁ
216 ÄÌÑ ÚÁÍÅÎÙ rlogin É rsh É ÏÂÅÓÐÅÞÉ×ÁÅÔ ÂÅÚÏÐÁÓÎÕÀ ÛÉÆÒÏ×ÁÎÎÕÀ
217 ËÏÍÍÕÎÉËÁÃÉÀ ÍÅÖÄÕ Ä×ÕÍÑ ÈÏÓÔÁÍÉ × ÓÅÔÉ, Ñ×ÌÑÀÝÅÊÓÑ ÎÅÂÅÚÏÐÁÓÎÏÊ.
218 óÏÅÄÉÎÅÎÉÑ X11 É ÌÀÂÙÅ ÐÏÒÔÙ TCP/IP ÍÏÇÕÔ ÔÁËÖÅ ÂÙÔØ ÐÒÏ×ÅÄÅÎÙ ÞÅÒÅÚ
219 ÂÅÚÏÐÁÓÎÙÊ ËÁÎÁÌ.
220
221 OpenSSH - ÜÔÏ ÐÅÒÅÄÅÌËÁ ËÏÍÁÎÄÏÊ ÒÁÚÒÁÂÏÔÞÉËÏ× OpenBSD ÐÏÓÌÅÄÎÅÊ
222 Ó×ÏÂÏÄÎÏÊ ×ÅÒÓÉÉ SSH, ÄÏ×ÅÄÅÎÎÁÑ ÄÏ ÓÏ×ÒÅÍÅÎÎÏÇÏ ÓÏÓÔÏÑÎÉÑ × ÔÅÒÍÉÎÁÈ
223 ÕÒÏ×ÎÑ ÂÅÚÏÐÁÓÎÏÓÔÉ É ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ. ÷ÓÅ ÐÁÔÅÎÔÏ×ÁÎÎÙÅ
224 ÁÌÇÏÒÉÔÍÙ ×ÙÎÅÓÅÎÙ × ÏÔÄÅÌØÎÙÅ ÂÉÂÌÉÏÔÅËÉ (OpenSSL).
225
226 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ËÁË ÄÌÑ ËÌÉÅÎÔÁ, ÔÁË É ÄÌÑ
227 ÓÅÒ×ÅÒÁ OpenSSH. ÷ÁÍ ÎÕÖÎÏ ÂÕÄÅÔ ÕÓÔÁÎÏ×ÉÔØ ÅÝÅ openssh-clients,
228 openssh-server, ÉÌÉ ÏÂÁ ÐÁËÅÔÁ.
229
230 %description -l uk
231 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
232 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ. ÷ÏÎÁ ÐÒÉÚÎÁÞÅÎÁ
233 ÄÌÑ ÚÁͦÎÉ rlogin ÔÁ rsh ¦ ÚÁÂÅÚÐÅÞÕ¤ ÂÅÚÐÅÞÎÕ ÛÉÆÒÏ×ÁÎÕ ËÏÍÕΦËÁæÀ
234 ͦ֠Ä×ÏÍÁ ÈÏÓÔÁÍÉ × ÍÅÒÅÖ¦, ÑËÁ ÎÅ ¤ ÂÅÚÐÅÞÎÏÀ. ú'¤ÄÎÁÎÎÑ X11 ÔÁ
235 ÄÏצÌØΦ ÐÏÒÔÉ TCP/IP ÍÏÖÕÔØ ÔÁËÏÖ ÂÕÔÉ ÐÒÏ×ÅÄÅΦ ÞÅÒÅÚ ÂÅÚÐÅÞÎÉÊ
236 ËÁÎÁÌ.
237
238 OpenSSH - ÃÅ ÐÅÒÅÒÏÂËÁ ËÏÍÁÎÄÏÀ ÒÏÚÒÏÂÎÉ˦נOpenBSD ÏÓÔÁÎÎØϧ ×¦ÌØÎϧ
239 ×ÅÒÓ¦§ SSH, ÄÏ×ÅÄÅÎÁ ÄÏ ÓÕÞÁÓÎÏÇÏ ÓÔÁÎÕ × ÔÅÒͦÎÁÈ Ò¦×ÎÑ ÂÅÚÐÅËÉ ÔÁ
240 ЦÄÔÒÉÍÕ×ÁÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ. ÷Ó¦ ÐÁÔÅÎÔÏ×ÁΦ ÁÌÇÏÒÉÔÍÉ ×ÉÎÅÓÅΦ ÄÏ
241 ÏËÒÅÍÉȠ¦Â̦ÏÔÅË (OpenSSL).
242
243 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÑË ÄÌÑ Ë̦¤ÎÔÁ, ÔÁË ¦ ÄÌÑ ÓÅÒ×ÅÒÁ
244 OpenSSH. ÷ÁÍ ÐÏÔÒ¦ÂÎÏ ÂÕÄÅ ÝÅ ×ÓÔÁÎÏ×ÉÔÉ openssh-clients,
245 openssh-server, ÞÉ ÏÂÉÄ×Á ÐÁËÅÔÉ.
246
247 %package clients
248 Summary:        OpenSSH Secure Shell protocol clients
249 Summary(es):    Clientes de OpenSSH
250 Summary(pl):    Klienci protoko³u Secure Shell
251 Summary(pt_BR): Clientes do OpenSSH
252 Summary(ru):    OpenSSH - ËÌÉÅÎÔÙ ÐÒÏÔÏËÏÌÁ Secure Shell
253 Summary(uk):    OpenSSH - Ë̦¤ÎÔÉ ÐÒÏÔÏËÏÌÕ Secure Shell
254 Group:          Applications/Networking
255 Requires:       %{name} = %{epoch}:%{version}-%{release}
256 %{?with_sshagentsh:Requires:    xinitrc}
257 Provides:       ssh-clients
258 Obsoletes:      ssh-clients
259
260 %description clients
261 Ssh (Secure Shell) a program for logging into a remote machine and for
262 executing commands in a remote machine. It is intended to replace
263 rlogin and rsh, and provide secure encrypted communications between
264 two untrusted hosts over an insecure network. X11 connections and
265 arbitrary TCP/IP ports can also be forwarded over the secure channel.
266
267 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
268 it up to date in terms of security and features, as well as removing
269 all patented algorithms to seperate libraries (OpenSSL).
270
271 This package includes the clients necessary to make encrypted
272 connections to SSH servers.
273
274 %description clients -l es
275 Este paquete incluye los clientes que se necesitan para hacer
276 conexiones codificadas con servidores SSH.
277
278 %description clients -l pl
279 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
280 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
281 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
282 pomiêdzy dwoma hostami.
283
284 Ten pakiet zawiera klientów s³u¿±cych do ³±czenia siê z serwerami SSH.
285
286 %description clients -l pt_BR
287 Esse pacote inclui os clientes necessários para fazer conexões
288 encriptadas com servidores SSH.
289
290 %description clients -l ru
291 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
292 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
293
294 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÐÒÏÇÒÁÍÍÙ-ËÌÉÅÎÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÕÓÔÁÎÏ×ÌÅÎÉÑ
295 ÚÁÛÉÆÒÏ×ÁÎÎÙÈ ÓÏÅÄÉÎÅÎÉÊ Ó ÓÅÒ×ÅÒÁÍÉ SSH.
296
297 %description clients -l uk
298 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
299 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
300
301 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÐÒÏÇÒÁÍÉ-Ë̦¤ÎÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ×ÓÔÁÎÏ×ÌÅÎÎÑ
302 ÚÁÛÉÆÒÏ×ÁÎÉÈ Ú'¤ÄÎÁÎØ Ú ÓÅÒ×ÅÒÁÍÉ SSH.
303
304 %package server
305 Summary:        OpenSSH Secure Shell protocol server (sshd)
306 Summary(de):    OpenSSH Secure Shell Protocol-Server (sshd)
307 Summary(es):    Servidor OpenSSH para comunicaciones codificadas
308 Summary(fr):    Serveur de protocole du shell sécurisé OpenSSH (sshd)
309 Summary(it):    Server OpenSSH per il protocollo Secure Shell (sshd)
310 Summary(pl):    Serwer protoko³u Secure Shell (sshd)
311 Summary(pt):    Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
312 Summary(pt_BR): Servidor OpenSSH para comunicações encriptadas
313 Summary(ru):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÁ Secure Shell (sshd)
314 Summary(uk):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÕ Secure Shell (sshd)
315 Group:          Networking/Daemons
316 Requires(post): chkconfig >= 0.9
317 Requires(post): grep
318 Requires(post,preun):   /sbin/chkconfig
319 Requires(postun):       /usr/sbin/userdel
320 Requires(pre):  /bin/id
321 Requires(pre):  /usr/sbin/useradd
322 Requires:       %{name} = %{epoch}:%{version}-%{release}
323 Requires:       /bin/login
324 Requires:       pam >= 0.77.3
325 Requires:       rc-scripts >= 0.4.0.18
326 Requires:       util-linux
327 Provides:       ssh-server
328 Provides:       user(sshd)
329
330 %description server
331 Ssh (Secure Shell) a program for logging into a remote machine and for
332 executing commands in a remote machine. It is intended to replace
333 rlogin and rsh, and provide secure encrypted communications between
334 two untrusted hosts over an insecure network. X11 connections and
335 arbitrary TCP/IP ports can also be forwarded over the secure channel.
336
337 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
338 it up to date in terms of security and features, as well as removing
339 all patented algorithms to seperate libraries (OpenSSL).
340
341 This package contains the secure shell daemon. The sshd is the server
342 part of the secure shell protocol and allows ssh clients to connect to
343 your host.
344
345 %description server -l de
346 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
347
348 %description server -l es
349 Este paquete contiene el servidor SSH. sshd es la parte servidor del
350 protocolo secure shell y permite que clientes ssh se conecten a su
351 servidor.
352
353 %description server -l fr
354 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
355
356 %description server -l it
357 Questo pacchetto installa sshd, il server di OpenSSH.
358
359 %description server -l pl
360 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
361 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
362 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
363 pomiêdzy dwoma hostami.
364
365 Ten pakiet zawiera serwer sshd (do którego mog± ³±czyæ siê klienci
366 ssh).
367
368 %description server -l pt
369 Este pacote intala o sshd, o servidor do OpenSSH.
370
371 %description server -l pt_BR
372 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
373 protocolo secure shell e permite que clientes ssh se conectem ao seu
374 host.
375
376 %description server -l ru
377 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
378 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
379
380 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÜÔÏ ÓÅÒ×ÅÒÎÁÑ
381 ÞÁÓÔØ ÐÒÏÔÏËÏÌÁ Secure Shell, ÐÏÚ×ÏÌÑÀÝÁÑ ËÌÉÅÎÔÁÍ ssh ÓÏÅÄÉÎÑÔØÓÑ Ó
382 ×ÁÛÉÍ ÈÏÓÔÏÍ.
383
384 %description server -l uk
385 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
386 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
387
388 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÃÅ ÓÅÒ×ÅÒÎÁ
389 ÞÁÓÔÉÎÁ ÐÒÏÔÏËÏÌÕ Secure Shell, ÑËÁ ÄÏÚ×ÏÌѤ Ë̦¤ÎÔÁÍ ssh Ú×'ÑÚÕ×ÁÔÉÓØ
390 Ú ×ÁÛÉÍ ÈÏÓÔÏÍ.
391
392 %package gnome-askpass
393 Summary:        OpenSSH GNOME passphrase dialog
394 Summary(de):    OpenSSH GNOME Passwort-Dialog
395 Summary(es):    Diálogo para introducción de passphrase para GNOME
396 Summary(fr):    Dialogue pass-phrase GNOME d'OpenSSH
397 Summary(it):    Finestra di dialogo GNOME per la frase segreta di OpenSSH
398 Summary(pl):    Odpytywacz has³a OpenSSH dla GNOME
399 Summary(pt):    Diálogo de pedido de senha para GNOME do OpenSSH
400 Summary(pt_BR): Diálogo para entrada de passphrase para GNOME
401 Summary(ru):    OpenSSH - ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ (passphrase) ÄÌÑ GNOME
402 Summary(uk):    OpenSSH - Ä¦ÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ (passphrase) ÄÌÑ GNOME
403 Group:          Applications/Networking
404 Requires:       %{name} = %{epoch}:%{version}-%{release}
405 Obsoletes:      openssh-askpass
406 Obsoletes:      ssh-askpass
407 Obsoletes:      ssh-extras
408
409 %description gnome-askpass
410 Ssh (Secure Shell) a program for logging into a remote machine and for
411 executing commands in a remote machine. It is intended to replace
412 rlogin and rsh, and provide secure encrypted communications between
413 two untrusted hosts over an insecure network. X11 connections and
414 arbitrary TCP/IP ports can also be forwarded over the secure channel.
415
416 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
417 it up to date in terms of security and features, as well as removing
418 all patented algorithms to seperate libraries (OpenSSL).
419
420 This package contains the GNOME passphrase dialog.
421
422 %description gnome-askpass -l es
423 Este paquete contiene un programa que abre una caja de diálogo para
424 entrada de passphrase en GNOME.
425
426 %description gnome-askpass -l pl
427 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
428 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
429 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
430 pomiêdzy dwoma hostami.
431
432 Ten pakiet zawiera ,,odpytywacz has³a'' dla GNOME.
433
434 %description gnome-askpass -l pt_BR
435 Esse pacote contém um programa que abre uma caixa de diálogo para
436 entrada de passphrase no GNOME.
437
438 %description gnome-askpass -l ru
439 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
440 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
441
442 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ÐÏÄ
443 GNOME.
444
445 %description gnome-askpass -l uk
446 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
447 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
448
449 ãÅÊ ÐÁËÅԠͦÓÔÉÔؠĦÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎѠЦÄ
450 GNOME.
451
452 %prep
453 %setup -q
454 %patch0 -p1
455 %patch2 -p1
456 %patch3 -p1
457 %patch4 -p1
458 %{?with_ldap:%patch5 -p1}
459 %{?with_kerberos5:%patch6 -p1}
460 #%patch7 -p1
461 %patch8 -p1
462 %{?with_selinux:%patch9 -p1}
463 %{?with_selinux:%patch10 -p1}
464 %{?with_hpn:%patch11 -p1}
465 %{?with_hpn_none:%patch12 -p1}
466 %patch13 -p1
467
468 %build
469 cp %{_datadir}/automake/config.sub .
470 %{__aclocal}
471 %{__autoconf}
472 %{?with_chroot:CPPFLAGS="-DCHROOT"}
473 %configure \
474         PERL=%{__perl} \
475         --with-dns \
476         --with-pam \
477         --with-mantype=man \
478         --with-md5-passwords \
479         --with-ipaddr-display \
480         %{?with_libedit:--with-libedit} \
481         --with-4in6 \
482         --disable-suid-ssh \
483         --with-tcp-wrappers \
484         %{?with_ldap:--with-libs="-lldap -llber"} \
485         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
486         %{?with_kerberos5:--with-kerberos5} \
487         --with-privsep-path=%{_privsepdir} \
488         --with-pid-dir=%{_localstatedir}/run \
489         --with-xauth=/usr/bin/xauth \
490         --enable-utmpx \
491         --enable-wtmpx
492
493 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
494
495 %{__make}
496
497 cp -f %{SOURCE9} .
498 cp -f %{SOURCE10} .
499 %{__cc} %{rpmcflags} %{rpmldflags} connect.c -o connect
500
501 cd contrib
502 %if %{with gnome}
503 %{__make} gnome-ssh-askpass1 \
504         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
505 %endif
506 %if %{with gtk}
507 %{__make} gnome-ssh-askpass2 \
508         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
509 %endif
510
511 %install
512 rm -rf $RPM_BUILD_ROOT
513 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
514         $RPM_BUILD_ROOT%{_libexecdir}/ssh
515 %{?with_sshagentsh:install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}}
516
517 %{__make} install \
518         DESTDIR=$RPM_BUILD_ROOT
519
520 install connect    $RPM_BUILD_ROOT%{_bindir}
521 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
522 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
523 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
524 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
525 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
526 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
527 %if %{with sshagentsh}
528 install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d
529 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
530 install %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}
531 %endif
532
533 bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
534
535 %if %{with gnome}
536 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
537 %endif
538 %if %{with gtk}
539 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
540 %endif
541 %if %{with gnome} || %{with gtk}
542 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
543 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
544 EOF
545 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
546 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
547 EOF
548 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
549 %endif
550
551 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
552 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
553
554 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
555
556 %if "%{_lib}" != "lib"
557 find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 perl -pi -e "s#/usr/lib#/usr/%{_lib}#"
558 %endif
559
560 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
561 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
562 EOF
563
564 %clean
565 rm -rf $RPM_BUILD_ROOT
566
567 %pre server
568 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
569
570 %post server
571 /sbin/chkconfig --add sshd
572 %service sshd reload "openssh daemon"
573 if ! grep -qs ssh /etc/security/passwd.conf ; then
574         umask 022
575         echo "ssh" >> /etc/security/passwd.conf
576 fi
577
578 %preun server
579 if [ "$1" = "0" ]; then
580         %service sshd stop
581         /sbin/chkconfig --del sshd
582 fi
583
584 %postun server
585 if [ "$1" = "0" ]; then
586         %userremove sshd
587 fi
588
589 %files
590 %defattr(644,root,root,755)
591 %doc *.RNG TODO README OVERVIEW CREDITS Change*
592 %attr(755,root,root) %{_bindir}/ssh-key*
593 %{_mandir}/man1/ssh-key*.1*
594 %dir %{_sysconfdir}
595 %dir %{_libexecdir}
596
597 %files clients
598 %defattr(644,root,root,755)
599 %doc connect.html
600 %attr(755,root,root) %{_bindir}/connect
601 %attr(755,root,root) %{_bindir}/ssh
602 %attr(755,root,root) %{_bindir}/slogin
603 %attr(755,root,root) %{_bindir}/sftp
604 %attr(755,root,root) %{_bindir}/ssh-agent
605 %attr(755,root,root) %{_bindir}/ssh-add
606 %attr(755,root,root) %{_bindir}/scp
607 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
608 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
609 %if %{with sshagentsh}
610 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
611 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
612 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
613 %endif
614 %{_mandir}/man1/scp.1*
615 %{_mandir}/man1/ssh.1*
616 %{_mandir}/man1/slogin.1*
617 %{_mandir}/man1/sftp.1*
618 %{_mandir}/man1/ssh-agent.1*
619 %{_mandir}/man1/ssh-add.1*
620 %{_mandir}/man5/ssh_config.5*
621 %lang(it) %{_mandir}/it/man1/ssh.1*
622 %lang(it) %{_mandir}/it/man5/ssh_config.5*
623 %lang(pl) %{_mandir}/pl/man1/scp.1*
624 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
625
626 # for host-based auth (suid required for accessing private host key)
627 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
628 #%{_mandir}/man8/ssh-keysign.8*
629
630 %files server
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_sbindir}/sshd
633 %attr(755,root,root) %{_libexecdir}/sftp-server
634 %attr(755,root,root) %{_libexecdir}/ssh-keysign
635 %{_mandir}/man8/sshd.8*
636 %{_mandir}/man8/sftp-server.8*
637 %{_mandir}/man8/ssh-keysign.8*
638 %{_mandir}/man5/sshd_config.5*
639 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
640 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
641 %attr(640,root,root) %{_sysconfdir}/moduli
642 %attr(754,root,root) /etc/rc.d/init.d/sshd
643 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
644 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
645
646 %if %{with gnome} || %{with gtk}
647 %files gnome-askpass
648 %defattr(644,root,root,755)
649 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
650 %dir %{_libexecdir}/ssh
651 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
652 %attr(755,root,root) %{_libexecdir}/ssh-askpass
653 %endif
This page took 0.559292 seconds and 3 git commands to generate.