]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- rel 6; unbreak keep alive options; from upstream
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
4 %bcond_without  gtk             # without GTK+ (2.x)
5 %bcond_with     ldap            # with ldap support
6 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
7 %bcond_without  kerberos5       # without kerberos5 support
8 %bcond_without  selinux         # build without SELinux support
9 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
10
11 # gtk2-based gnome-askpass means no gnome1-based
12 %{?with_gtk:%undefine with_gnome}
13 #
14 Summary:        OpenSSH free Secure Shell (SSH) implementation
15 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
16 Summary(es.UTF-8):      Implementación libre de SSH
17 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
18 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
19 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
20 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
21 Summary(pt_BR.UTF-8):   Implementação livre do SSH
22 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
23 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
24 Name:           openssh
25 Version:        5.0p1
26 Release:        6
27 Epoch:          2
28 License:        BSD
29 Group:          Applications/Networking
30 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
31 # Source0-md5:  1f1dfaa775f33dd3328169de9bdc292a
32 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
33 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
34 Source2:        %{name}d.init
35 Source3:        %{name}d.pamd
36 Source4:        %{name}.sysconfig
37 Source5:        ssh-agent.sh
38 Source6:        ssh-agent.conf
39 Patch0:         %{name}-no_libnsl.patch
40 Patch1:         %{name}-linux-ipv6.patch
41 Patch2:         %{name}-pam_misc.patch
42 Patch3:         %{name}-sigpipe.patch
43 # http://www.opendarwin.org/projects/openssh-lpk/
44 Patch4:         %{name}-lpk-4.3p1-0.3.7.patch
45 Patch5:         %{name}-config.patch
46 Patch7:         %{name}-selinux.patch
47 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
48 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.9p1-hpn13v2.diff.gz
49 Patch9:         %{name}-5.0p1-hpn13v4.diff
50 Patch10:        %{name}-include.patch
51 Patch11:        %{name}-chroot.patch
52 Patch12:        http://people.debian.org/~cjwatson/%{name}-blacklist.diff
53 Patch13:        %{name}-unbreakalive.patch
54 URL:            http://www.openssh.com/
55 BuildRequires:  %{__perl}
56 BuildRequires:  autoconf
57 BuildRequires:  automake
58 %{?with_gnome:BuildRequires:    gnome-libs-devel}
59 %{?with_gtk:BuildRequires:      gtk+2-devel}
60 %{?with_kerberos5:BuildRequires:        krb5-devel}
61 %{?with_libedit:BuildRequires:  libedit-devel}
62 %{?with_selinux:BuildRequires:  libselinux-devel}
63 BuildRequires:  libwrap-devel
64 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
65 BuildRequires:  openssl-devel >= 0.9.7d
66 BuildRequires:  pam-devel
67 %{?with_gtk:BuildRequires:      pkgconfig}
68 BuildRequires:  rpmbuild(macros) >= 1.318
69 BuildRequires:  zlib-devel
70 Requires:       filesystem >= 3.0-11
71 Requires:       pam >= 0.99.7.1
72 Suggests:       openssh-blacklist
73 Suggests:       xorg-app-xauth
74 Obsoletes:      ssh
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %define         _sysconfdir     /etc/ssh
78 %define         _libexecdir     %{_libdir}/%{name}
79 %define         _privsepdir     /usr/share/empty
80
81 %description
82 Ssh (Secure Shell) a program for logging into a remote machine and for
83 executing commands in a remote machine. It is intended to replace
84 rlogin and rsh, and provide secure encrypted communications between
85 two untrusted hosts over an insecure network. X11 connections and
86 arbitrary TCP/IP ports can also be forwarded over the secure channel.
87
88 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
89 it up to date in terms of security and features, as well as removing
90 all patented algorithms to seperate libraries (OpenSSL).
91
92 This package includes the core files necessary for both the OpenSSH
93 client and server. To make this package useful, you should also
94 install openssh-clients, openssh-server, or both.
95 %if %{with hpn} || %{with hpn_none}
96 This release includes High Performance SSH/SCP patches from
97 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
98 to increase throughput on fast connections with high RTT (20-150 msec).
99 See the website for '-w' values for your connection and /proc/sys TCP
100 values. BTW. in a LAN you have got generally RTT < 1 msec.
101 %endif
102 %if %{with hpn_none}
103 It also includes an undocumented '-z' option which switches
104 the cipher to none after authentication is completed. Data is
105 still secured from tampering and corruption in transit through
106 the use of the Message Authentication Code (MAC).
107 This option will significantly reduce the number of cpu cycles used
108 by the SSH/SCP process. This may allow some users to see significant
109 improvement in (sniffable) data tranfer rates.
110 %endif
111
112 %description -l de.UTF-8
113 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
114 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
115 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
116 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
117 andere TCP/IP Ports können ebenso über den sicheren Channel
118 weitergeleitet werden.
119
120 %description -l es.UTF-8
121 SSH es un programa para accesar y ejecutar órdenes en computadores
122 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
123 seguro entre dos servidores en una red insegura. Conexiones X11 y
124 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
125 seguro.
126
127 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
128 continuar la última versión gratuita de SSH, actualizándolo en
129 términos de seguridad y recursos,así también eliminando todos los
130 algoritmos patentados y colocándolos en bibliotecas separadas
131 (OpenSSL).
132
133 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
134 también el paquete openssh-clients u openssh-server o ambos.
135
136 %description -l fr.UTF-8
137 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
138 remplace telnet, rlogin, rexec et rsh, tout en assurant des
139 communications cryptées securisées entre deux hôtes non fiabilisés sur
140 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
141 arbitraires peuvent également être transmis sur le canal sécurisé.
142
143 %description -l it.UTF-8
144 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
145 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
146 sicure e crittate tra due host non fidati su una rete non sicura. Le
147 connessioni X11 ad una porta TCP/IP arbitraria possono essere
148 inoltrate attraverso un canale sicuro.
149
150 %description -l pl.UTF-8
151 Ssh (Secure Shell) to program służący do logowania się na zdalną
152 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
153 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
154 pomiędzy dwoma hostami.
155
156 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
157 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
158 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
159 %if %{with hpn} || %{with hpn_none}
160 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
161 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
162 zwiększenie przepustowości transmisji dla szybkich połączeń
163 z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
164 odpowednie dla danego połączenia wartości parametru '-w' oraz
165 opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
166 %endif
167 %if %{with hpn_none}
168 Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
169 za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
170 Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
171 stosowanie Message Authentication Code (MAC).
172 Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
173 procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
174 na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
175 %endif
176
177 %description -l pt.UTF-8
178 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
179 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
180 cifradas entre duas máquinas sem confiança mútua sobre uma rede
181 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
182 reenviados pelo canal seguro.
183
184 %description -l pt_BR.UTF-8
185 SSH é um programa para acessar e executar comandos em máquinas
186 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
187 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
188 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
189
190 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
191 última versão gratuita do SSH, atualizando-o em termos de segurança e
192 recursos, assim como removendo todos os algoritmos patenteados e
193 colocando-os em bibliotecas separadas (OpenSSL).
194
195 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
196 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
197
198 %description -l ru.UTF-8
199 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
200 машину и для выполнения команд на удаленной машине. Она предназначена
201 для замены rlogin и rsh и обеспечивает безопасную шифрованную
202 коммуникацию между двумя хостами в сети, являющейся небезопасной.
203 Соединения X11 и любые порты TCP/IP могут также быть проведены через
204 безопасный канал.
205
206 OpenSSH - это переделка командой разработчиков OpenBSD последней
207 свободной версии SSH, доведенная до современного состояния в терминах
208 уровня безопасности и поддерживаемых возможностей. Все патентованные
209 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
210
211 Этот пакет содержит файлы, необходимые как для клиента, так и для
212 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
213 openssh-server, или оба пакета.
214
215 %description -l uk.UTF-8
216 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
217 машини та для виконання команд на віддаленій машині. Вона призначена
218 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
219 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
220 довільні порти TCP/IP можуть також бути проведені через безпечний
221 канал.
222
223 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
224 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
225 підтримуваних можливостей. Всі патентовані алгоритми винесені до
226 окремих бібліотек (OpenSSL).
227
228 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
229 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
230 openssh-server, чи обидва пакети.
231
232 %package clients
233 Summary:        OpenSSH Secure Shell protocol clients
234 Summary(es.UTF-8):      Clientes de OpenSSH
235 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
236 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
237 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
238 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
239 Group:          Applications/Networking
240 Requires:       %{name} = %{epoch}:%{version}-%{release}
241 Provides:       ssh-clients
242 Obsoletes:      ssh-clients
243
244 %description clients
245 Ssh (Secure Shell) a program for logging into a remote machine and for
246 executing commands in a remote machine. It is intended to replace
247 rlogin and rsh, and provide secure encrypted communications between
248 two untrusted hosts over an insecure network. X11 connections and
249 arbitrary TCP/IP ports can also be forwarded over the secure channel.
250
251 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
252 it up to date in terms of security and features, as well as removing
253 all patented algorithms to seperate libraries (OpenSSL).
254
255 This package includes the clients necessary to make encrypted
256 connections to SSH servers.
257
258 %description clients -l es.UTF-8
259 Este paquete incluye los clientes que se necesitan para hacer
260 conexiones codificadas con servidores SSH.
261
262 %description clients -l pl.UTF-8
263 Ssh (Secure Shell) to program służący do logowania się na zdalną
264 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
265 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
266 pomiędzy dwoma hostami.
267
268 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
269
270 %description clients -l pt_BR.UTF-8
271 Esse pacote inclui os clientes necessários para fazer conexões
272 encriptadas com servidores SSH.
273
274 %description clients -l ru.UTF-8
275 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
276 машину и для выполнения команд на удаленной машине.
277
278 Этот пакет содержит программы-клиенты, необходимые для установления
279 зашифрованных соединений с серверами SSH.
280
281 %description clients -l uk.UTF-8
282 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
283 машини та для виконання команд на віддаленій машині.
284
285 Цей пакет містить програми-клієнти, необхідні для встановлення
286 зашифрованих з'єднань з серверами SSH.
287
288 %package clients-agent-profile_d
289 Summary:        OpenSSH Secure Shell agent init script
290 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
291 Group:          Applications/Networking
292 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
293
294 %description clients-agent-profile_d
295 profile.d scripts for starting SSH agent.
296
297 %description clients-agent-profile_d -l pl.UTF-8
298 Skrypty profile.d do uruchamiania agenta SSH.
299
300 %package clients-agent-xinitrc
301 Summary:        OpenSSH Secure Shell agent init script
302 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
303 Group:          Applications/Networking
304 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
305 Requires:       xinitrc
306
307 %description clients-agent-xinitrc
308 xinitrc scripts for starting SSH agent.
309
310 %description clients-agent-xinitrc -l pl.UTF-8
311 Skrypty xinitrc do uruchamiania agenta SSH.
312
313 %package server
314 Summary:        OpenSSH Secure Shell protocol server (sshd)
315 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
316 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
317 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
318 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
319 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
320 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
321 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
322 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
323 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
324 Group:          Networking/Daemons
325 Requires(post): chkconfig >= 0.9
326 Requires(post): grep
327 Requires(post,preun):   /sbin/chkconfig
328 Requires(postun):       /usr/sbin/userdel
329 Requires(pre):  /bin/id
330 Requires(pre):  /usr/sbin/useradd
331 Requires:       %{name} = %{epoch}:%{version}-%{release}
332 Requires:       /bin/login
333 Requires:       pam >= 0.99.7.1
334 Requires:       rc-scripts >= 0.4.1.23
335 Requires:       util-linux
336 Provides:       ssh-server
337 Provides:       user(sshd)
338
339 %description server
340 Ssh (Secure Shell) a program for logging into a remote machine and for
341 executing commands in a remote machine. It is intended to replace
342 rlogin and rsh, and provide secure encrypted communications between
343 two untrusted hosts over an insecure network. X11 connections and
344 arbitrary TCP/IP ports can also be forwarded over the secure channel.
345
346 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
347 it up to date in terms of security and features, as well as removing
348 all patented algorithms to seperate libraries (OpenSSL).
349
350 This package contains the secure shell daemon. The sshd is the server
351 part of the secure shell protocol and allows ssh clients to connect to
352 your host.
353
354 %description server -l de.UTF-8
355 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
356
357 %description server -l es.UTF-8
358 Este paquete contiene el servidor SSH. sshd es la parte servidor del
359 protocolo secure shell y permite que clientes ssh se conecten a su
360 servidor.
361
362 %description server -l fr.UTF-8
363 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
364
365 %description server -l it.UTF-8
366 Questo pacchetto installa sshd, il server di OpenSSH.
367
368 %description server -l pl.UTF-8
369 Ssh (Secure Shell) to program służący do logowania się na zdalną
370 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
371 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
372 pomiędzy dwoma hostami.
373
374 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
375 ssh).
376
377 %description server -l pt.UTF-8
378 Este pacote intala o sshd, o servidor do OpenSSH.
379
380 %description server -l pt_BR.UTF-8
381 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
382 protocolo secure shell e permite que clientes ssh se conectem ao seu
383 host.
384
385 %description server -l ru.UTF-8
386 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
387 машину и для выполнения команд на удаленной машине.
388
389 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
390 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
391 вашим хостом.
392
393 %description server -l uk.UTF-8
394 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
395 машини та для виконання команд на віддаленій машині.
396
397 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
398 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
399 з вашим хостом.
400
401 %package gnome-askpass
402 Summary:        OpenSSH GNOME passphrase dialog
403 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
404 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
405 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
406 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
407 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
408 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
409 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
410 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
411 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
412 Group:          Applications/Networking
413 Requires:       %{name} = %{epoch}:%{version}-%{release}
414 Obsoletes:      openssh-askpass
415 Obsoletes:      ssh-askpass
416 Obsoletes:      ssh-extras
417
418 %description gnome-askpass
419 Ssh (Secure Shell) a program for logging into a remote machine and for
420 executing commands in a remote machine. It is intended to replace
421 rlogin and rsh, and provide secure encrypted communications between
422 two untrusted hosts over an insecure network. X11 connections and
423 arbitrary TCP/IP ports can also be forwarded over the secure channel.
424
425 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
426 it up to date in terms of security and features, as well as removing
427 all patented algorithms to seperate libraries (OpenSSL).
428
429 This package contains the GNOME passphrase dialog.
430
431 %description gnome-askpass -l es.UTF-8
432 Este paquete contiene un programa que abre una caja de diálogo para
433 entrada de passphrase en GNOME.
434
435 %description gnome-askpass -l pl.UTF-8
436 Ssh (Secure Shell) to program służący do logowania się na zdalną
437 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
438 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
439 pomiędzy dwoma hostami.
440
441 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
442
443 %description gnome-askpass -l pt_BR.UTF-8
444 Esse pacote contém um programa que abre uma caixa de diálogo para
445 entrada de passphrase no GNOME.
446
447 %description gnome-askpass -l ru.UTF-8
448 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
449 машину и для выполнения команд на удаленной машине.
450
451 Этот пакет содержит диалог ввода ключевой фразы для использования под
452 GNOME.
453
454 %description gnome-askpass -l uk.UTF-8
455 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
456 машини та для виконання команд на віддаленій машині.
457
458 Цей пакет містить діалог вводу ключової фрази для використання під
459 GNOME.
460
461 %prep
462 %setup -q
463 %patch0 -p1
464 %patch1 -p1
465 %patch2 -p1
466 %patch3 -p1
467 %{?with_ldap:%patch4 -p1}
468 %patch5 -p1
469 %patch7 -p1
470 %{?with_hpn:%patch9 -p1}
471 %patch10 -p1
472 %patch11 -p1
473 %patch12 -p1
474 %patch13 -p0
475
476 %build
477 cp /usr/share/automake/config.sub .
478 %{__aclocal}
479 %{__autoconf}
480 CPPFLAGS="-DCHROOT"
481 %configure \
482         PERL=%{__perl} \
483         --with-dns \
484         --with-pam \
485         --with-mantype=man \
486         --with-md5-passwords \
487         --with-ipaddr-display \
488         %{?with_libedit:--with-libedit} \
489         --with-4in6 \
490         --disable-suid-ssh \
491         --with-tcp-wrappers \
492         %{?with_ldap:--with-libs="-lldap -llber"} \
493         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
494         %{?with_kerberos5:--with-kerberos5=/usr} \
495         --with-privsep-path=%{_privsepdir} \
496         --with-pid-dir=%{_localstatedir}/run \
497         --with-xauth=/usr/bin/xauth \
498         --enable-utmpx \
499         --enable-wtmpx
500
501 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
502
503 %{__make}
504
505 cd contrib
506 %if %{with gnome}
507 %{__make} gnome-ssh-askpass1 \
508         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
509 %endif
510 %if %{with gtk}
511 %{__make} gnome-ssh-askpass2 \
512         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
513 %endif
514
515 %install
516 rm -rf $RPM_BUILD_ROOT
517 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
518         $RPM_BUILD_ROOT%{_libexecdir}/ssh
519 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
520
521 %{__make} install \
522         DESTDIR=$RPM_BUILD_ROOT
523
524 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
525
526 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
527 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
528 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
529 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
530 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
531 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
532
533 %if %{with gnome}
534 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
535 %endif
536 %if %{with gtk}
537 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
538 %endif
539 %if %{with gnome} || %{with gtk}
540 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
541 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
542 EOF
543 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
544 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
545 EOF
546 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
547 %endif
548
549 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
550 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
551
552 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
553
554 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
555 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
556 EOF
557
558 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
559 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
560
561 %clean
562 rm -rf $RPM_BUILD_ROOT
563
564 %post clients
565 %env_update
566
567 %postun clients
568 %env_update
569
570 %post gnome-askpass
571 %env_update
572
573 %postun gnome-askpass
574 %env_update
575
576 %pre server
577 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
578
579 %post server
580 /sbin/chkconfig --add sshd
581 %service sshd reload "openssh daemon"
582 if ! grep -qs ssh /etc/security/passwd.conf ; then
583         umask 022
584         echo "ssh" >> /etc/security/passwd.conf
585 fi
586
587 %preun server
588 if [ "$1" = "0" ]; then
589         %service sshd stop
590         /sbin/chkconfig --del sshd
591 fi
592
593 %postun server
594 if [ "$1" = "0" ]; then
595         %userremove sshd
596 fi
597
598 %files
599 %defattr(644,root,root,755)
600 %doc *.RNG TODO README OVERVIEW CREDITS Change*
601 %attr(755,root,root) %{_bindir}/ssh-key*
602 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
603 %{_mandir}/man1/ssh-key*.1*
604 %{_mandir}/man1/ssh-vulnkey*.1*
605 %dir %{_sysconfdir}
606 %dir %{_libexecdir}
607
608 %files clients
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_bindir}/ssh
611 %attr(755,root,root) %{_bindir}/slogin
612 %attr(755,root,root) %{_bindir}/sftp
613 %attr(755,root,root) %{_bindir}/ssh-agent
614 %attr(755,root,root) %{_bindir}/ssh-add
615 %attr(755,root,root) %{_bindir}/scp
616 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
617 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
618 %{_mandir}/man1/scp.1*
619 %{_mandir}/man1/ssh.1*
620 %{_mandir}/man1/slogin.1*
621 %{_mandir}/man1/sftp.1*
622 %{_mandir}/man1/ssh-agent.1*
623 %{_mandir}/man1/ssh-add.1*
624 %{_mandir}/man5/ssh_config.5*
625 %lang(it) %{_mandir}/it/man1/ssh.1*
626 %lang(it) %{_mandir}/it/man5/ssh_config.5*
627 %lang(pl) %{_mandir}/pl/man1/scp.1*
628 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
629
630 # for host-based auth (suid required for accessing private host key)
631 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
632 #%{_mandir}/man8/ssh-keysign.8*
633
634 %files clients-agent-profile_d
635 %defattr(644,root,root,755)
636 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
637 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
638
639 %files clients-agent-xinitrc
640 %defattr(644,root,root,755)
641 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
642
643 %files server
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_sbindir}/sshd
646 %attr(755,root,root) %{_libexecdir}/sftp-server
647 %attr(755,root,root) %{_libexecdir}/ssh-keysign
648 %{_mandir}/man8/sshd.8*
649 %{_mandir}/man8/sftp-server.8*
650 %{_mandir}/man8/ssh-keysign.8*
651 %{_mandir}/man5/sshd_config.5*
652 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
653 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
654 %attr(640,root,root) %{_sysconfdir}/moduli
655 %attr(754,root,root) /etc/rc.d/init.d/sshd
656 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
657 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
658
659 %if %{with gnome} || %{with gtk}
660 %files gnome-askpass
661 %defattr(644,root,root,755)
662 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
663 %dir %{_libexecdir}/ssh
664 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
665 %attr(755,root,root) %{_libexecdir}/ssh-askpass
666 %endif
This page took 0.15882 seconds and 3 git commands to generate.