]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- up to 5.6p1
[packages/openssh.git] / openssh.spec
1 # TODO
2 # - configure: WARNING: unrecognized options: --with-dns, --disable-suid-ssh
3 #
4 # Conditional build:
5 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
6 %bcond_without  gtk             # without GTK+ (2.x)
7 %bcond_without  ldap            # with ldap support
8 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
9 %bcond_without  kerberos5       # without kerberos5 support
10 %bcond_without  selinux         # build without SELinux support
11 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
12
13 # gtk2-based gnome-askpass means no gnome1-based
14 %{?with_gtk:%undefine with_gnome}
15
16 %if "%{pld_release}" == "ac"
17 %define         pam_ver 0.79.0
18 %else
19 %define         pam_ver 0.99.7.1
20 %endif
21
22 Summary:        OpenSSH free Secure Shell (SSH) implementation
23 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
24 Summary(es.UTF-8):      Implementación libre de SSH
25 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
26 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
27 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
28 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
29 Summary(pt_BR.UTF-8):   Implementação livre do SSH
30 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
31 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
32 Name:           openssh
33 Version:        5.6p1
34 Release:        1
35 Epoch:          2
36 License:        BSD
37 Group:          Applications/Networking
38 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
39 # Source0-md5:  e6ee52e47c768bf0ec42a232b5d18fb0
40 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
41 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
42 Source2:        %{name}d.init
43 Source3:        %{name}d.pamd
44 Source4:        %{name}.sysconfig
45 Source5:        ssh-agent.sh
46 Source6:        ssh-agent.conf
47 Source7:        %{name}-lpk.schema
48 Source8:        %{name}d.upstart
49 Patch100:       %{name}-heimdal.patch
50 Patch0:         %{name}-no_libnsl.patch
51 Patch2:         %{name}-pam_misc.patch
52 Patch3:         %{name}-sigpipe.patch
53 # http://code.google.com/p/openssh-lpk/
54 Patch4:         %{name}-lpk.patch
55 Patch5:         %{name}-config.patch
56 Patch7:         %{name}-selinux.patch
57 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
58 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
59 Patch9:         %{name}-5.2p1-hpn13v6.diff
60 Patch10:        %{name}-include.patch
61 Patch11:        %{name}-chroot.patch
62 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
63 Patch12:        %{name}-blacklist.diff
64 URL:            http://www.openssh.com/
65 BuildRequires:  %{__perl}
66 BuildRequires:  autoconf
67 BuildRequires:  automake
68 %{?with_gnome:BuildRequires:    gnome-libs-devel}
69 %{?with_gtk:BuildRequires:      gtk+2-devel}
70 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
71 %{?with_libedit:BuildRequires:  libedit-devel}
72 %{?with_selinux:BuildRequires:  libselinux-devel}
73 BuildRequires:  libwrap-devel
74 %{?with_ldap:BuildRequires:     openldap-devel}
75 BuildRequires:  openssl-devel >= 0.9.7d
76 BuildRequires:  pam-devel
77 %{?with_gtk:BuildRequires:      pkgconfig}
78 BuildRequires:  rpm >= 4.4.9-56
79 BuildRequires:  rpmbuild(macros) >= 1.318
80 BuildRequires:  sed >= 4.0
81 BuildRequires:  zlib-devel
82 %if "%{pld_release}" == "ac"
83 Requires:       filesystem >= 2.0-1
84 Requires:       pam >= 0.79.0
85 %else
86 Requires:       filesystem >= 3.0-11
87 Requires:       pam >= %{pam_ver}
88 Suggests:       openssh-blacklist
89 Suggests:       xorg-app-xauth
90 %endif
91 Obsoletes:      ssh
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define         _sysconfdir     /etc/ssh
95 %define         _libexecdir     %{_libdir}/%{name}
96 %define         _privsepdir     /usr/share/empty
97 %define         schemadir       /usr/share/openldap/schema
98
99 ## to be moved to rpm-build-macros
100 ## TODO: handle RPM_SKIP_AUTO_RESTART
101
102 # migrate from init script to upstart job
103 %define upstart_post() \
104         if [ -f /var/lock/subsys/"%1" ] ; then \
105                 /sbin/service --no-upstart "%1" stop \
106                 /sbin/service "%1" start \
107         else \
108                 /sbin/service "%1" try-restart \
109         fi
110
111 # restart the job after upgrade or migrate to init script on removal
112 %define upstart_postun() \
113         if [ -x /sbin/initctl ] && /sbin/initctl status "%1" 2>/dev/null | grep -q 'running' ; then \
114                 /sbin/initctl stop "%1" 2>/dev/null \
115                 [ -f "/etc/rc.d/init.d/%1" -o -f "/etc/init/%1.conf" ] && /sbin/service "%1" start \
116         fi
117
118
119 %description
120 Ssh (Secure Shell) a program for logging into a remote machine and for
121 executing commands in a remote machine. It is intended to replace
122 rlogin and rsh, and provide secure encrypted communications between
123 two untrusted hosts over an insecure network. X11 connections and
124 arbitrary TCP/IP ports can also be forwarded over the secure channel.
125
126 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
127 it up to date in terms of security and features, as well as removing
128 all patented algorithms to seperate libraries (OpenSSL).
129
130 This package includes the core files necessary for both the OpenSSH
131 client and server. To make this package useful, you should also
132 install openssh-clients, openssh-server, or both.
133
134 %if %{with hpn}
135 This release includes High Performance SSH/SCP patches from
136 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
137 increase throughput on fast connections with high RTT (20-150 msec).
138 See the website for '-w' values for your connection and /proc/sys TCP
139 values. BTW. in a LAN you have got generally RTT < 1 msec.
140 %endif
141
142 %description -l de.UTF-8
143 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
144 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
145 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
146 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
147 andere TCP/IP Ports können ebenso über den sicheren Channel
148 weitergeleitet werden.
149
150 %description -l es.UTF-8
151 SSH es un programa para accesar y ejecutar órdenes en computadores
152 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
153 seguro entre dos servidores en una red insegura. Conexiones X11 y
154 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
155 seguro.
156
157 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
158 continuar la última versión gratuita de SSH, actualizándolo en
159 términos de seguridad y recursos,así también eliminando todos los
160 algoritmos patentados y colocándolos en bibliotecas separadas
161 (OpenSSL).
162
163 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
164 también el paquete openssh-clients u openssh-server o ambos.
165
166 %description -l fr.UTF-8
167 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
168 remplace telnet, rlogin, rexec et rsh, tout en assurant des
169 communications cryptées securisées entre deux hôtes non fiabilisés sur
170 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
171 arbitraires peuvent également être transmis sur le canal sécurisé.
172
173 %description -l it.UTF-8
174 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
175 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
176 sicure e crittate tra due host non fidati su una rete non sicura. Le
177 connessioni X11 ad una porta TCP/IP arbitraria possono essere
178 inoltrate attraverso un canale sicuro.
179
180 %description -l pl.UTF-8
181 Ssh (Secure Shell) to program służący do logowania się na zdalną
182 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
183 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
184 pomiędzy dwoma hostami.
185
186 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
187 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
188 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
189
190 %if %{with hpn}
191 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
192 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
193 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
194 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
195 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
196 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
197 %endif
198
199 %description -l pt.UTF-8
200 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
201 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
202 cifradas entre duas máquinas sem confiança mútua sobre uma rede
203 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
204 reenviados pelo canal seguro.
205
206 %description -l pt_BR.UTF-8
207 SSH é um programa para acessar e executar comandos em máquinas
208 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
209 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
210 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
211
212 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
213 última versão gratuita do SSH, atualizando-o em termos de segurança e
214 recursos, assim como removendo todos os algoritmos patenteados e
215 colocando-os em bibliotecas separadas (OpenSSL).
216
217 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
218 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
219
220 %description -l ru.UTF-8
221 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
222 машину и для выполнения команд на удаленной машине. Она предназначена
223 для замены rlogin и rsh и обеспечивает безопасную шифрованную
224 коммуникацию между двумя хостами в сети, являющейся небезопасной.
225 Соединения X11 и любые порты TCP/IP могут также быть проведены через
226 безопасный канал.
227
228 OpenSSH - это переделка командой разработчиков OpenBSD последней
229 свободной версии SSH, доведенная до современного состояния в терминах
230 уровня безопасности и поддерживаемых возможностей. Все патентованные
231 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
232
233 Этот пакет содержит файлы, необходимые как для клиента, так и для
234 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
235 openssh-server, или оба пакета.
236
237 %description -l uk.UTF-8
238 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
239 машини та для виконання команд на віддаленій машині. Вона призначена
240 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
241 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
242 довільні порти TCP/IP можуть також бути проведені через безпечний
243 канал.
244
245 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
246 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
247 підтримуваних можливостей. Всі патентовані алгоритми винесені до
248 окремих бібліотек (OpenSSL).
249
250 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
251 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
252 openssh-server, чи обидва пакети.
253
254 %package clients
255 Summary:        OpenSSH Secure Shell protocol clients
256 Summary(es.UTF-8):      Clientes de OpenSSH
257 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
258 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
259 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
260 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
261 Group:          Applications/Networking
262 Requires:       %{name}
263 Provides:       ssh-clients
264 Obsoletes:      ssh-clients
265
266 %description clients
267 Ssh (Secure Shell) a program for logging into a remote machine and for
268 executing commands in a remote machine. It is intended to replace
269 rlogin and rsh, and provide secure encrypted communications between
270 two untrusted hosts over an insecure network. X11 connections and
271 arbitrary TCP/IP ports can also be forwarded over the secure channel.
272
273 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
274 it up to date in terms of security and features, as well as removing
275 all patented algorithms to seperate libraries (OpenSSL).
276
277 This package includes the clients necessary to make encrypted
278 connections to SSH servers.
279
280 %description clients -l es.UTF-8
281 Este paquete incluye los clientes que se necesitan para hacer
282 conexiones codificadas con servidores SSH.
283
284 %description clients -l pl.UTF-8
285 Ssh (Secure Shell) to program służący do logowania się na zdalną
286 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
287 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
288 pomiędzy dwoma hostami.
289
290 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
291
292 %description clients -l pt_BR.UTF-8
293 Esse pacote inclui os clientes necessários para fazer conexões
294 encriptadas com servidores SSH.
295
296 %description clients -l ru.UTF-8
297 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
298 машину и для выполнения команд на удаленной машине.
299
300 Этот пакет содержит программы-клиенты, необходимые для установления
301 зашифрованных соединений с серверами SSH.
302
303 %description clients -l uk.UTF-8
304 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
305 машини та для виконання команд на віддаленій машині.
306
307 Цей пакет містить програми-клієнти, необхідні для встановлення
308 зашифрованих з'єднань з серверами SSH.
309
310 %package clients-agent-profile_d
311 Summary:        OpenSSH Secure Shell agent init script
312 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
313 Group:          Applications/Networking
314 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
315
316 %description clients-agent-profile_d
317 profile.d scripts for starting SSH agent.
318
319 %description clients-agent-profile_d -l pl.UTF-8
320 Skrypty profile.d do uruchamiania agenta SSH.
321
322 %package clients-agent-xinitrc
323 Summary:        OpenSSH Secure Shell agent init script
324 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
325 Group:          Applications/Networking
326 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
327 Requires:       xinitrc
328
329 %description clients-agent-xinitrc
330 xinitrc scripts for starting SSH agent.
331
332 %description clients-agent-xinitrc -l pl.UTF-8
333 Skrypty xinitrc do uruchamiania agenta SSH.
334
335 %package server
336 Summary:        OpenSSH Secure Shell protocol server (sshd)
337 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
338 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
339 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
340 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
341 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
342 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
343 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
344 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
345 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
346 Group:          Networking/Daemons
347 Requires(post): /sbin/chkconfig
348 Requires(post): grep
349 Requires(post,preun):   /sbin/chkconfig
350 Requires(postun):       /usr/sbin/userdel
351 Requires(pre):  /bin/id
352 Requires(pre):  /usr/sbin/useradd
353 Requires:       %{name} = %{epoch}:%{version}-%{release}
354 Requires:       pam >= %{pam_ver}
355 Requires:       rc-scripts >= 0.4.3.0
356 Requires:       util-linux
357 Suggests:       /bin/login
358 Provides:       ssh-server
359 Provides:       user(sshd)
360
361 %description server
362 Ssh (Secure Shell) a program for logging into a remote machine and for
363 executing commands in a remote machine. It is intended to replace
364 rlogin and rsh, and provide secure encrypted communications between
365 two untrusted hosts over an insecure network. X11 connections and
366 arbitrary TCP/IP ports can also be forwarded over the secure channel.
367
368 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
369 it up to date in terms of security and features, as well as removing
370 all patented algorithms to seperate libraries (OpenSSL).
371
372 This package contains the secure shell daemon. The sshd is the server
373 part of the secure shell protocol and allows ssh clients to connect to
374 your host.
375
376 %description server -l de.UTF-8
377 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
378
379 %description server -l es.UTF-8
380 Este paquete contiene el servidor SSH. sshd es la parte servidor del
381 protocolo secure shell y permite que clientes ssh se conecten a su
382 servidor.
383
384 %description server -l fr.UTF-8
385 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
386
387 %description server -l it.UTF-8
388 Questo pacchetto installa sshd, il server di OpenSSH.
389
390 %description server -l pl.UTF-8
391 Ssh (Secure Shell) to program służący do logowania się na zdalną
392 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
393 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
394 pomiędzy dwoma hostami.
395
396 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
397 ssh).
398
399 %description server -l pt.UTF-8
400 Este pacote intala o sshd, o servidor do OpenSSH.
401
402 %description server -l pt_BR.UTF-8
403 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
404 protocolo secure shell e permite que clientes ssh se conectem ao seu
405 host.
406
407 %description server -l ru.UTF-8
408 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
409 машину и для выполнения команд на удаленной машине.
410
411 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
412 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
413 вашим хостом.
414
415 %description server -l uk.UTF-8
416 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
417 машини та для виконання команд на віддаленій машині.
418
419 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
420 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
421 з вашим хостом.
422
423 %package server-upstart
424 Summary:        Upstart job description for OpenSSH server
425 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
426 Group:          Daemons
427 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
428 Requires:       upstart >= 0.6
429
430 %description server-upstart
431 Upstart job description for OpenSSH.
432
433 %description server-upstart -l pl.UTF-8
434 Opis zadania Upstart dla OpenSSH.
435
436 %package gnome-askpass
437 Summary:        OpenSSH GNOME passphrase dialog
438 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
439 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
440 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
441 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
442 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
443 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
444 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
445 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
446 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
447 Group:          Applications/Networking
448 Requires:       %{name} = %{epoch}:%{version}-%{release}
449 Obsoletes:      openssh-askpass
450 Obsoletes:      ssh-askpass
451 Obsoletes:      ssh-extras
452
453 %description gnome-askpass
454 Ssh (Secure Shell) a program for logging into a remote machine and for
455 executing commands in a remote machine. It is intended to replace
456 rlogin and rsh, and provide secure encrypted communications between
457 two untrusted hosts over an insecure network. X11 connections and
458 arbitrary TCP/IP ports can also be forwarded over the secure channel.
459
460 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
461 it up to date in terms of security and features, as well as removing
462 all patented algorithms to seperate libraries (OpenSSL).
463
464 This package contains the GNOME passphrase dialog.
465
466 %description gnome-askpass -l es.UTF-8
467 Este paquete contiene un programa que abre una caja de diálogo para
468 entrada de passphrase en GNOME.
469
470 %description gnome-askpass -l pl.UTF-8
471 Ssh (Secure Shell) to program służący do logowania się na zdalną
472 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
473 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
474 pomiędzy dwoma hostami.
475
476 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
477
478 %description gnome-askpass -l pt_BR.UTF-8
479 Esse pacote contém um programa que abre uma caixa de diálogo para
480 entrada de passphrase no GNOME.
481
482 %description gnome-askpass -l ru.UTF-8
483 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
484 машину и для выполнения команд на удаленной машине.
485
486 Этот пакет содержит диалог ввода ключевой фразы для использования под
487 GNOME.
488
489 %description gnome-askpass -l uk.UTF-8
490 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
491 машини та для виконання команд на віддаленій машині.
492
493 Цей пакет містить діалог вводу ключової фрази для використання під
494 GNOME.
495
496 %package -n openldap-schema-openssh-lpk
497 Summary:        OpenSSH LDAP Public Key schema
498 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
499 Group:          Networking/Daemons
500 Requires(post,postun):  sed >= 4.0
501 Requires:       openldap-servers
502
503 %description -n openldap-schema-openssh-lpk
504 This package contains OpenSSH LDAP Public Key schema for openldap.
505
506 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
507 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
508 openldap-a.
509
510 %prep
511 %setup -q
512 %{?with_kerberos5:%patch100 -p1}
513 %patch0 -p1
514 %patch2 -p1
515 %patch3 -p1
516 %{?with_ldap:%patch4 -p1}
517 %patch5 -p1
518 %patch7 -p1
519 %{?with_hpn:%patch9 -p1}
520 %patch10 -p1
521 %patch11 -p1
522 %patch12 -p1
523
524 %if "%{pld_release}" == "ac"
525 # fix for missing x11.pc
526 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
527 %endif
528
529 %build
530 cp /usr/share/automake/config.sub .
531 %{__aclocal}
532 %{__autoconf}
533 CPPFLAGS="-DCHROOT"
534 %configure \
535         PERL=%{__perl} \
536         --with-dns \
537         --with-pam \
538         --with-mantype=man \
539         --with-md5-passwords \
540         --with-ipaddr-display \
541         %{?with_libedit:--with-libedit} \
542         --with-4in6 \
543         --disable-suid-ssh \
544         --with-tcp-wrappers \
545         %{?with_ldap:--with-libs="-lldap -llber"} \
546         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
547         %{?with_kerberos5:--with-kerberos5=/usr} \
548         --with-privsep-path=%{_privsepdir} \
549         --with-pid-dir=%{_localstatedir}/run \
550 %if "%{pld_release}" == "ac"
551         --with-xauth=/usr/X11R6/bin/xauth \
552 %else
553         --with-xauth=/usr/bin/xauth \
554 %endif
555         --enable-utmpx \
556         --enable-wtmpx
557
558 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
559
560 %{__make}
561
562 cd contrib
563 %if %{with gnome}
564 %{__make} gnome-ssh-askpass1 \
565         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
566 %endif
567 %if %{with gtk}
568 %{__make} gnome-ssh-askpass2 \
569         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
570 %endif
571
572 %install
573 rm -rf $RPM_BUILD_ROOT
574 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
575         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
576 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
577
578 %{__make} install \
579         DESTDIR=$RPM_BUILD_ROOT
580
581 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
582
583 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
584 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
585 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
586 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
587 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
588 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
589 install %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
590
591 install %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
592
593 %if %{with gnome}
594 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
595 %endif
596 %if %{with gtk}
597 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
598 %endif
599 %if %{with gnome} || %{with gtk}
600 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
601 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
602 EOF
603 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
604 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
605 EOF
606 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
607 %endif
608
609 install contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
610 install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
611
612 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
613 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
614
615 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
616
617 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
618 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
619 EOF
620
621 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
622 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
623
624 %clean
625 rm -rf $RPM_BUILD_ROOT
626
627 %post clients
628 %env_update
629
630 %postun clients
631 %env_update
632
633 %post gnome-askpass
634 %env_update
635
636 %postun gnome-askpass
637 %env_update
638
639 %pre server
640 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
641
642 %post server
643 /sbin/chkconfig --add sshd
644 %service sshd reload "openssh daemon"
645 if ! grep -qs ssh /etc/security/passwd.conf ; then
646         umask 022
647         echo "ssh" >> /etc/security/passwd.conf
648 fi
649
650 %preun server
651 if [ "$1" = "0" ]; then
652         %service sshd stop
653         /sbin/chkconfig --del sshd
654 fi
655
656 %postun server
657 if [ "$1" = "0" ]; then
658         %userremove sshd
659 fi
660
661 %post server-upstart
662 %upstart_post sshd
663
664 %postun server-upstart
665 %upstart_postun sshd
666
667 %post -n openldap-schema-openssh-lpk
668 %openldap_schema_register %{schemadir}/openssh-lpk.schema
669 %service -q ldap restart
670
671 %postun -n openldap-schema-openssh-lpk
672 if [ "$1" = "0" ]; then
673         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
674         %service -q ldap restart
675 fi
676
677 %files
678 %defattr(644,root,root,755)
679 %doc *.RNG TODO README OVERVIEW CREDITS Change*
680 %attr(755,root,root) %{_bindir}/ssh-key*
681 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
682 %{_mandir}/man1/ssh-key*.1*
683 %{_mandir}/man1/ssh-vulnkey*.1*
684 %dir %{_sysconfdir}
685 %dir %{_libexecdir}
686
687 %files clients
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_bindir}/ssh
690 %attr(755,root,root) %{_bindir}/slogin
691 %attr(755,root,root) %{_bindir}/sftp
692 %attr(755,root,root) %{_bindir}/ssh-agent
693 %attr(755,root,root) %{_bindir}/ssh-add
694 %attr(755,root,root) %{_bindir}/ssh-copy-id
695 %attr(755,root,root) %{_bindir}/scp
696 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
697 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
698 %{_mandir}/man1/scp.1*
699 %{_mandir}/man1/ssh.1*
700 %{_mandir}/man1/slogin.1*
701 %{_mandir}/man1/sftp.1*
702 %{_mandir}/man1/ssh-agent.1*
703 %{_mandir}/man1/ssh-add.1*
704 %{_mandir}/man1/ssh-copy-id.1*
705 %{_mandir}/man5/ssh_config.5*
706 %lang(it) %{_mandir}/it/man1/ssh.1*
707 %lang(it) %{_mandir}/it/man5/ssh_config.5*
708 %lang(pl) %{_mandir}/pl/man1/scp.1*
709 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
710
711 # for host-based auth (suid required for accessing private host key)
712 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
713 #%{_mandir}/man8/ssh-keysign.8*
714
715 %files clients-agent-profile_d
716 %defattr(644,root,root,755)
717 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
718 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
719
720 %files clients-agent-xinitrc
721 %defattr(644,root,root,755)
722 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
723
724 %files server
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{_sbindir}/sshd
727 %attr(755,root,root) %{_libexecdir}/sftp-server
728 %attr(755,root,root) %{_libexecdir}/ssh-keysign
729 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
730 %{_mandir}/man8/sshd.8*
731 %{_mandir}/man8/sftp-server.8*
732 %{_mandir}/man8/ssh-keysign.8*
733 %{_mandir}/man8/ssh-pkcs11-helper.8*
734 %{_mandir}/man5/sshd_config.5*
735 %{_mandir}/man5/moduli.5*
736 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
737 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
738 %attr(640,root,root) %{_sysconfdir}/moduli
739 %attr(754,root,root) /etc/rc.d/init.d/sshd
740 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
741 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
742
743 %if %{with gnome} || %{with gtk}
744 %files gnome-askpass
745 %defattr(644,root,root,755)
746 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
747 %dir %{_libexecdir}/ssh
748 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
749 %attr(755,root,root) %{_libexecdir}/ssh-askpass
750 %endif
751
752 %if %{with ldap}
753 %files -n openldap-schema-openssh-lpk
754 %defattr(644,root,root,755)
755 %{schemadir}/openssh-lpk.schema
756 %endif
757
758 %if "%{pld_release}" != "ti"
759 %files server-upstart
760 %defattr(644,root,root,755)
761 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
762 %endif
This page took 0.139892 seconds and 3 git commands to generate.