]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
624a2cd3ee44174adf48964c057641ba62f12689
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  audit           # sshd audit support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_without  ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
11
12 # gtk2-based gnome-askpass means no gnome1-based
13 %{?with_gtk:%undefine with_gnome}
14
15 %if "%{pld_release}" == "ac"
16 %define         pam_ver 0.79.0
17 %else
18 %define         pam_ver 0.99.7.1
19 %endif
20
21 Summary:        OpenSSH free Secure Shell (SSH) implementation
22 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
23 Summary(es.UTF-8):      Implementación libre de SSH
24 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
25 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
26 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
27 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
28 Summary(pt_BR.UTF-8):   Implementação livre do SSH
29 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
30 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
31 Name:           openssh
32 Version:        5.9p1
33 Release:        7
34 Epoch:          2
35 License:        BSD
36 Group:          Applications/Networking
37 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
38 # Source0-md5:  b50a499fa02616a47984b1920848b565
39 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
40 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
41 Source2:        %{name}d.init
42 Source3:        %{name}d.pamd
43 Source4:        %{name}.sysconfig
44 Source5:        ssh-agent.sh
45 Source6:        ssh-agent.conf
46 Source7:        %{name}-lpk.schema
47 Source8:        %{name}d.upstart
48 Patch100:       %{name}-heimdal.patch
49 Patch0:         %{name}-no_libnsl.patch
50 Patch2:         %{name}-pam_misc.patch
51 Patch3:         %{name}-sigpipe.patch
52 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
53 Patch4:         %{name}-5.9p1-ldap.patch
54 Patch5:         %{name}-5.9p1-ldap-fixes.patch
55 Patch8:         ldap.conf.patch
56 Patch6:         %{name}-config.patch
57 # https://bugzilla.mindrot.org/show_bug.cgi?id=1663
58 Patch7:         authorized-keys-command.patch
59 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
60 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
61 Patch9:         %{name}-5.2p1-hpn13v6.diff
62 Patch10:        %{name}-include.patch
63 Patch11:        %{name}-chroot.patch
64 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
65 Patch12:        %{name}-blacklist.diff
66 Patch13:        %{name}-kuserok.patch
67 Patch14:        %{name}-bind.patch
68 URL:            http://www.openssh.com/portable.html
69 BuildRequires:  %{__perl}
70 %{?with_audit:BuildRequires:    audit-libs-devel}
71 BuildRequires:  autoconf >= 2.50
72 BuildRequires:  automake
73 %{?with_gnome:BuildRequires:    gnome-libs-devel}
74 %{?with_gtk:BuildRequires:      gtk+2-devel}
75 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
76 %{?with_libedit:BuildRequires:  libedit-devel}
77 %{?with_selinux:BuildRequires:  libselinux-devel}
78 BuildRequires:  libwrap-devel
79 %{?with_ldap:BuildRequires:     openldap-devel}
80 BuildRequires:  openssl-devel >= 0.9.7d
81 BuildRequires:  pam-devel
82 %{?with_gtk:BuildRequires:      pkgconfig}
83 BuildRequires:  rpm >= 4.4.9-56
84 BuildRequires:  rpmbuild(macros) >= 1.318
85 BuildRequires:  sed >= 4.0
86 BuildRequires:  zlib-devel
87 %if "%{pld_release}" == "ac"
88 Requires:       filesystem >= 2.0-1
89 Requires:       pam >= 0.79.0
90 %else
91 Requires:       filesystem >= 3.0-11
92 Requires:       pam >= %{pam_ver}
93 Suggests:       openssh-blacklist
94 Suggests:       xorg-app-xauth
95 %endif
96 Obsoletes:      ssh
97 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
98
99 %define         _sysconfdir     /etc/ssh
100 %define         _libexecdir     %{_libdir}/%{name}
101 %define         _privsepdir     /usr/share/empty
102 %define         schemadir       /usr/share/openldap/schema
103
104 %description
105 Ssh (Secure Shell) a program for logging into a remote machine and for
106 executing commands in a remote machine. It is intended to replace
107 rlogin and rsh, and provide secure encrypted communications between
108 two untrusted hosts over an insecure network. X11 connections and
109 arbitrary TCP/IP ports can also be forwarded over the secure channel.
110
111 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
112 it up to date in terms of security and features, as well as removing
113 all patented algorithms to seperate libraries (OpenSSL).
114
115 This package includes the core files necessary for both the OpenSSH
116 client and server. To make this package useful, you should also
117 install openssh-clients, openssh-server, or both.
118
119 %if %{with hpn}
120 This release includes High Performance SSH/SCP patches from
121 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
122 increase throughput on fast connections with high RTT (20-150 msec).
123 See the website for '-w' values for your connection and /proc/sys TCP
124 values. BTW. in a LAN you have got generally RTT < 1 msec.
125 %endif
126
127 %description -l de.UTF-8
128 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
129 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
130 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
131 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
132 andere TCP/IP Ports können ebenso über den sicheren Channel
133 weitergeleitet werden.
134
135 %description -l es.UTF-8
136 SSH es un programa para accesar y ejecutar órdenes en computadores
137 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
138 seguro entre dos servidores en una red insegura. Conexiones X11 y
139 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
140 seguro.
141
142 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
143 continuar la última versión gratuita de SSH, actualizándolo en
144 términos de seguridad y recursos,así también eliminando todos los
145 algoritmos patentados y colocándolos en bibliotecas separadas
146 (OpenSSL).
147
148 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
149 también el paquete openssh-clients u openssh-server o ambos.
150
151 %description -l fr.UTF-8
152 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
153 remplace telnet, rlogin, rexec et rsh, tout en assurant des
154 communications cryptées securisées entre deux hôtes non fiabilisés sur
155 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
156 arbitraires peuvent également être transmis sur le canal sécurisé.
157
158 %description -l it.UTF-8
159 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
160 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
161 sicure e crittate tra due host non fidati su una rete non sicura. Le
162 connessioni X11 ad una porta TCP/IP arbitraria possono essere
163 inoltrate attraverso un canale sicuro.
164
165 %description -l pl.UTF-8
166 Ssh (Secure Shell) to program służący do logowania się na zdalną
167 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
168 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
169 pomiędzy dwoma hostami.
170
171 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
172 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
173 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
174
175 %if %{with hpn}
176 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
177 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
178 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
179 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
180 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
181 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
182 %endif
183
184 %description -l pt.UTF-8
185 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
186 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
187 cifradas entre duas máquinas sem confiança mútua sobre uma rede
188 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
189 reenviados pelo canal seguro.
190
191 %description -l pt_BR.UTF-8
192 SSH é um programa para acessar e executar comandos em máquinas
193 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
194 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
195 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
196
197 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
198 última versão gratuita do SSH, atualizando-o em termos de segurança e
199 recursos, assim como removendo todos os algoritmos patenteados e
200 colocando-os em bibliotecas separadas (OpenSSL).
201
202 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
203 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
204
205 %description -l ru.UTF-8
206 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
207 машину и для выполнения команд на удаленной машине. Она предназначена
208 для замены rlogin и rsh и обеспечивает безопасную шифрованную
209 коммуникацию между двумя хостами в сети, являющейся небезопасной.
210 Соединения X11 и любые порты TCP/IP могут также быть проведены через
211 безопасный канал.
212
213 OpenSSH - это переделка командой разработчиков OpenBSD последней
214 свободной версии SSH, доведенная до современного состояния в терминах
215 уровня безопасности и поддерживаемых возможностей. Все патентованные
216 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
217
218 Этот пакет содержит файлы, необходимые как для клиента, так и для
219 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
220 openssh-server, или оба пакета.
221
222 %description -l uk.UTF-8
223 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
224 машини та для виконання команд на віддаленій машині. Вона призначена
225 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
226 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
227 довільні порти TCP/IP можуть також бути проведені через безпечний
228 канал.
229
230 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
231 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
232 підтримуваних можливостей. Всі патентовані алгоритми винесені до
233 окремих бібліотек (OpenSSL).
234
235 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
236 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
237 openssh-server, чи обидва пакети.
238
239 %package clients
240 Summary:        OpenSSH Secure Shell protocol clients
241 Summary(es.UTF-8):      Clientes de OpenSSH
242 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
243 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
244 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
245 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
246 Group:          Applications/Networking
247 Requires:       %{name}
248 Provides:       ssh-clients
249 Obsoletes:      ssh-clients
250
251 %description clients
252 Ssh (Secure Shell) a program for logging into a remote machine and for
253 executing commands in a remote machine. It is intended to replace
254 rlogin and rsh, and provide secure encrypted communications between
255 two untrusted hosts over an insecure network. X11 connections and
256 arbitrary TCP/IP ports can also be forwarded over the secure channel.
257
258 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
259 it up to date in terms of security and features, as well as removing
260 all patented algorithms to seperate libraries (OpenSSL).
261
262 This package includes the clients necessary to make encrypted
263 connections to SSH servers.
264
265 %description clients -l es.UTF-8
266 Este paquete incluye los clientes que se necesitan para hacer
267 conexiones codificadas con servidores SSH.
268
269 %description clients -l pl.UTF-8
270 Ssh (Secure Shell) to program służący do logowania się na zdalną
271 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
272 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
273 pomiędzy dwoma hostami.
274
275 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
276
277 %description clients -l pt_BR.UTF-8
278 Esse pacote inclui os clientes necessários para fazer conexões
279 encriptadas com servidores SSH.
280
281 %description clients -l ru.UTF-8
282 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
283 машину и для выполнения команд на удаленной машине.
284
285 Этот пакет содержит программы-клиенты, необходимые для установления
286 зашифрованных соединений с серверами SSH.
287
288 %description clients -l uk.UTF-8
289 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
290 машини та для виконання команд на віддаленій машині.
291
292 Цей пакет містить програми-клієнти, необхідні для встановлення
293 зашифрованих з'єднань з серверами SSH.
294
295 %package clients-agent-profile_d
296 Summary:        OpenSSH Secure Shell agent init script
297 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
298 Group:          Applications/Networking
299 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
300
301 %description clients-agent-profile_d
302 profile.d scripts for starting SSH agent.
303
304 %description clients-agent-profile_d -l pl.UTF-8
305 Skrypty profile.d do uruchamiania agenta SSH.
306
307 %package clients-agent-xinitrc
308 Summary:        OpenSSH Secure Shell agent init script
309 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
310 Group:          Applications/Networking
311 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
312 Requires:       xinitrc
313
314 %description clients-agent-xinitrc
315 xinitrc scripts for starting SSH agent.
316
317 %description clients-agent-xinitrc -l pl.UTF-8
318 Skrypty xinitrc do uruchamiania agenta SSH.
319
320 %package server
321 Summary:        OpenSSH Secure Shell protocol server (sshd)
322 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
323 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
324 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
325 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
326 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
327 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
328 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
329 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
330 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
331 Group:          Networking/Daemons
332 Requires(post): /sbin/chkconfig
333 Requires(post): grep
334 Requires(post,preun):   /sbin/chkconfig
335 Requires(postun):       /usr/sbin/userdel
336 Requires(pre):  /bin/id
337 Requires(pre):  /usr/sbin/useradd
338 Requires:       %{name} = %{epoch}:%{version}-%{release}
339 # remove in 6.0, kept for flawless upgrade
340 Requires:       %{name}-server-ldap = %{epoch}:%{version}-%{release}
341 Requires:       pam >= %{pam_ver}
342 Requires:       rc-scripts >= 0.4.3.0
343 Requires:       util-linux
344 Suggests:       /bin/login
345 Provides:       ssh-server
346 Provides:       user(sshd)
347
348 %description server
349 Ssh (Secure Shell) a program for logging into a remote machine and for
350 executing commands in a remote machine. It is intended to replace
351 rlogin and rsh, and provide secure encrypted communications between
352 two untrusted hosts over an insecure network. X11 connections and
353 arbitrary TCP/IP ports can also be forwarded over the secure channel.
354
355 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
356 it up to date in terms of security and features, as well as removing
357 all patented algorithms to seperate libraries (OpenSSL).
358
359 This package contains the secure shell daemon. The sshd is the server
360 part of the secure shell protocol and allows ssh clients to connect to
361 your host.
362
363 %description server -l de.UTF-8
364 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
365
366 %description server -l es.UTF-8
367 Este paquete contiene el servidor SSH. sshd es la parte servidor del
368 protocolo secure shell y permite que clientes ssh se conecten a su
369 servidor.
370
371 %description server -l fr.UTF-8
372 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
373
374 %description server -l it.UTF-8
375 Questo pacchetto installa sshd, il server di OpenSSH.
376
377 %description server -l pl.UTF-8
378 Ssh (Secure Shell) to program służący do logowania się na zdalną
379 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
380 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
381 pomiędzy dwoma hostami.
382
383 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
384 ssh).
385
386 %description server -l pt.UTF-8
387 Este pacote intala o sshd, o servidor do OpenSSH.
388
389 %description server -l pt_BR.UTF-8
390 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
391 protocolo secure shell e permite que clientes ssh se conectem ao seu
392 host.
393
394 %description server -l ru.UTF-8
395 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
396 машину и для выполнения команд на удаленной машине.
397
398 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
399 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
400 вашим хостом.
401
402 %description server -l uk.UTF-8
403 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
404 машини та для виконання команд на віддаленій машині.
405
406 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
407 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
408 з вашим хостом.
409
410 %package server-ldap
411 Summary:        A LDAP support for open source SSH server daemon
412 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
413 Group:          Daemons
414 Requires:       %{name} = %{epoch}:%{version}-%{release}
415
416 %description server-ldap
417 OpenSSH LDAP backend is a way how to distribute the authorized tokens
418 among the servers in the network.
419
420 %description server-ldap -l pl.UTF-8
421 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
422 tokenów między serwerami w sieci.
423
424 %package server-upstart
425 Summary:        Upstart job description for OpenSSH server
426 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
427 Group:          Daemons
428 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
429 Requires:       upstart >= 0.6
430 Conflicts:      syslog-ng < 3.2.4-1
431
432 %description server-upstart
433 Upstart job description for OpenSSH.
434
435 %description server-upstart -l pl.UTF-8
436 Opis zadania Upstart dla OpenSSH.
437
438 %package gnome-askpass
439 Summary:        OpenSSH GNOME passphrase dialog
440 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
441 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
442 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
443 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
444 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
445 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
446 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
447 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
448 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
449 Group:          Applications/Networking
450 Requires:       %{name} = %{epoch}:%{version}-%{release}
451 Obsoletes:      openssh-askpass
452 Obsoletes:      ssh-askpass
453 Obsoletes:      ssh-extras
454
455 %description gnome-askpass
456 Ssh (Secure Shell) a program for logging into a remote machine and for
457 executing commands in a remote machine. It is intended to replace
458 rlogin and rsh, and provide secure encrypted communications between
459 two untrusted hosts over an insecure network. X11 connections and
460 arbitrary TCP/IP ports can also be forwarded over the secure channel.
461
462 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
463 it up to date in terms of security and features, as well as removing
464 all patented algorithms to seperate libraries (OpenSSL).
465
466 This package contains the GNOME passphrase dialog.
467
468 %description gnome-askpass -l es.UTF-8
469 Este paquete contiene un programa que abre una caja de diálogo para
470 entrada de passphrase en GNOME.
471
472 %description gnome-askpass -l pl.UTF-8
473 Ssh (Secure Shell) to program służący do logowania się na zdalną
474 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
475 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
476 pomiędzy dwoma hostami.
477
478 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
479
480 %description gnome-askpass -l pt_BR.UTF-8
481 Esse pacote contém um programa que abre uma caixa de diálogo para
482 entrada de passphrase no GNOME.
483
484 %description gnome-askpass -l ru.UTF-8
485 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
486 машину и для выполнения команд на удаленной машине.
487
488 Этот пакет содержит диалог ввода ключевой фразы для использования под
489 GNOME.
490
491 %description gnome-askpass -l uk.UTF-8
492 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
493 машини та для виконання команд на віддаленій машині.
494
495 Цей пакет містить діалог вводу ключової фрази для використання під
496 GNOME.
497
498 %package -n openldap-schema-openssh-lpk
499 Summary:        OpenSSH LDAP Public Key schema
500 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
501 Group:          Networking/Daemons
502 Requires(post,postun):  sed >= 4.0
503 Requires:       openldap-servers
504
505 %description -n openldap-schema-openssh-lpk
506 This package contains OpenSSH LDAP Public Key schema for openldap.
507
508 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
509 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
510 openldap-a.
511
512 %prep
513 %setup -q
514 %{?with_kerberos5:%patch100 -p1}
515 %patch0 -p1
516 %patch2 -p1
517 %patch3 -p1
518 %patch4 -p1
519 %patch5 -p1
520 %patch8 -p1
521 %patch6 -p1
522 %patch7 -p1
523 %{?with_hpn:%patch9 -p1}
524 %patch10 -p1
525 %patch11 -p1
526 %patch12 -p1
527 %patch13 -p1
528 %patch14 -p1
529
530 cp -p %{SOURCE3} sshd.pam
531 install -p %{SOURCE2} sshd.init
532
533 %if "%{pld_release}" == "ac"
534 # fix for missing x11.pc
535 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
536 # not present in ac, no point searching it
537 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
538
539 # openssl on ac does not have OPENSSL_HAS_ECC
540 %{__sed} -i -e '/ecdsa/d' sshd.init
541 %endif
542
543 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
544 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
545
546 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
547 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
548
549 %build
550 cp /usr/share/automake/config.sub .
551 %{__aclocal}
552 %{__autoconf}
553 %{__autoheader}
554 CPPFLAGS="-DCHROOT"
555 %configure \
556         PERL=%{__perl} \
557         --disable-strip \
558         --enable-utmpx \
559         --enable-wtmpx \
560         --with-4in6 \
561         %{?with_audit:--with-audit=linux} \
562         --with-ipaddr-display \
563         %{?with_kerberos5:--with-kerberos5=/usr} \
564         --with-ldap%{!?with_ldap:=no} \
565         %{?with_libedit:--with-libedit} \
566         --with-mantype=man \
567         --with-md5-passwords \
568         --with-pam \
569         --with-authorized-keys-command \
570         --with-pid-dir=%{_localstatedir}/run \
571         --with-privsep-path=%{_privsepdir} \
572         %{?with_selinux:--with-selinux} \
573         --with-tcp-wrappers \
574 %if "%{pld_release}" == "ac"
575         --with-xauth=/usr/X11R6/bin/xauth
576 %else
577         --with-xauth=%{_bindir}/xauth
578 %endif
579
580 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
581
582 %{__make}
583
584 cd contrib
585 %if %{with gnome}
586 %{__make} gnome-ssh-askpass1 \
587         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
588 %endif
589 %if %{with gtk}
590 %{__make} gnome-ssh-askpass2 \
591         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
592 %endif
593
594 %install
595 rm -rf $RPM_BUILD_ROOT
596 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
597         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
598 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
599
600 %{__make} install \
601         DESTDIR=$RPM_BUILD_ROOT
602
603 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
604
605 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
606 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
607 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
608 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
609 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
610 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
611 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
612 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
613
614 %if %{with gnome}
615 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
616 %endif
617 %if %{with gtk}
618 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
619 %endif
620 %if %{with gnome} || %{with gtk}
621 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
622 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
623 EOF
624 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
625 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
626 EOF
627 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
628 %endif
629
630 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
631 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
632
633 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
634 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
635
636 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
637
638 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
639 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
640 EOF
641
642 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
643 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf
644
645 %clean
646 rm -rf $RPM_BUILD_ROOT
647
648 %post clients
649 %env_update
650
651 %postun clients
652 %env_update
653
654 %post gnome-askpass
655 %env_update
656
657 %postun gnome-askpass
658 %env_update
659
660 %pre server
661 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
662
663 %post server
664 /sbin/chkconfig --add sshd
665 %service sshd reload "OpenSSH Daemon"
666 if ! grep -qs ssh /etc/security/passwd.conf ; then
667         umask 022
668         echo "ssh" >> /etc/security/passwd.conf
669 fi
670
671 %preun server
672 if [ "$1" = "0" ]; then
673         %service sshd stop
674         /sbin/chkconfig --del sshd
675 fi
676
677 %postun server
678 if [ "$1" = "0" ]; then
679         %userremove sshd
680 fi
681
682 %triggerpostun server -- %{name}-server < 2:5.9p1-1
683 # lpk.patch to ldap.patch
684 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
685         echo >&2 "Migrating LPK patch to LDAP patch"
686         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
687         %{__sed} -i -e '
688                 # disable old configs
689                 # just UseLPK/LkpLdapConf supported for now
690                 s/^UseLPK/## Obsolete &/
691                 s/^Lpk/## Obsolete &/
692                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
693                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
694         ' %{_sysconfdir}/sshd_config
695         %service -q sshd reload
696 fi
697
698 %post server-upstart
699 %upstart_post sshd
700
701 %postun server-upstart
702 %upstart_postun sshd
703
704 %post -n openldap-schema-openssh-lpk
705 %openldap_schema_register %{schemadir}/openssh-lpk.schema
706 %service -q ldap restart
707
708 %postun -n openldap-schema-openssh-lpk
709 if [ "$1" = "0" ]; then
710         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
711         %service -q ldap restart
712 fi
713
714 %files
715 %defattr(644,root,root,755)
716 %doc TODO README OVERVIEW CREDITS Change*
717 %attr(755,root,root) %{_bindir}/ssh-key*
718 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
719 %{_mandir}/man1/ssh-key*.1*
720 %{_mandir}/man1/ssh-vulnkey*.1*
721 %dir %{_sysconfdir}
722 %dir %{_libexecdir}
723
724 %files clients
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{_bindir}/ssh
727 %attr(755,root,root) %{_bindir}/slogin
728 %attr(755,root,root) %{_bindir}/sftp
729 %attr(755,root,root) %{_bindir}/ssh-agent
730 %attr(755,root,root) %{_bindir}/ssh-add
731 %attr(755,root,root) %{_bindir}/ssh-copy-id
732 %attr(755,root,root) %{_bindir}/scp
733 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
734 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
735 %{_mandir}/man1/scp.1*
736 %{_mandir}/man1/ssh.1*
737 %{_mandir}/man1/slogin.1*
738 %{_mandir}/man1/sftp.1*
739 %{_mandir}/man1/ssh-agent.1*
740 %{_mandir}/man1/ssh-add.1*
741 %{_mandir}/man1/ssh-copy-id.1*
742 %{_mandir}/man5/ssh_config.5*
743 %lang(it) %{_mandir}/it/man1/ssh.1*
744 %lang(it) %{_mandir}/it/man5/ssh_config.5*
745 %lang(pl) %{_mandir}/pl/man1/scp.1*
746 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
747
748 # for host-based auth (suid required for accessing private host key)
749 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
750 #%{_mandir}/man8/ssh-keysign.8*
751
752 %files clients-agent-profile_d
753 %defattr(644,root,root,755)
754 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
755 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
756
757 %files clients-agent-xinitrc
758 %defattr(644,root,root,755)
759 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
760
761 %files server
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_sbindir}/sshd
764 %attr(755,root,root) %{_libexecdir}/sftp-server
765 %attr(755,root,root) %{_libexecdir}/ssh-keysign
766 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
767 %{_mandir}/man8/sshd.8*
768 %{_mandir}/man8/sftp-server.8*
769 %{_mandir}/man8/ssh-keysign.8*
770 %{_mandir}/man8/ssh-pkcs11-helper.8*
771 %{_mandir}/man5/sshd_config.5*
772 %{_mandir}/man5/moduli.5*
773 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
774 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
775 %attr(640,root,root) %{_sysconfdir}/moduli
776 %attr(754,root,root) /etc/rc.d/init.d/sshd
777 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
778 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
779
780 %if %{with ldap}
781 %files server-ldap
782 %defattr(644,root,root,755)
783 %doc HOWTO.ldap-keys ldap.conf
784 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
785 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
786 %{_mandir}/man5/ssh-ldap.conf.5*
787 %{_mandir}/man8/ssh-ldap-helper.8*
788 %endif
789
790 %if %{with gnome} || %{with gtk}
791 %files gnome-askpass
792 %defattr(644,root,root,755)
793 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
794 %dir %{_libexecdir}/ssh
795 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
796 %attr(755,root,root) %{_libexecdir}/ssh-askpass
797 %endif
798
799 %if %{with ldap}
800 %files -n openldap-schema-openssh-lpk
801 %defattr(644,root,root,755)
802 %{schemadir}/openssh-lpk.schema
803 %endif
804
805 %if "%{pld_release}" != "ti"
806 %files server-upstart
807 %defattr(644,root,root,755)
808 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
809 %endif
This page took 0.122299 seconds and 3 git commands to generate.