]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- up to 5.5p1
[packages/openssh.git] / openssh.spec
1 # TODO
2 # - configure: WARNING: unrecognized options: --with-dns, --disable-suid-ssh
3 #
4 # Conditional build:
5 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
6 %bcond_without  gtk             # without GTK+ (2.x)
7 %bcond_without  ldap            # with ldap support
8 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
9 %bcond_without  kerberos5       # without kerberos5 support
10 %bcond_without  selinux         # build without SELinux support
11 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
12
13 # gtk2-based gnome-askpass means no gnome1-based
14 %{?with_gtk:%undefine with_gnome}
15
16 %if "%{pld_release}" == "ac"
17 %define         pam_ver 0.79.0
18 %else
19 %define         pam_ver 0.99.7.1
20 %endif
21
22 Summary:        OpenSSH free Secure Shell (SSH) implementation
23 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
24 Summary(es.UTF-8):      Implementación libre de SSH
25 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
26 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
27 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
28 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
29 Summary(pt_BR.UTF-8):   Implementação livre do SSH
30 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
31 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
32 Name:           openssh
33 Version:        5.5p1
34 Release:        1
35 Epoch:          2
36 License:        BSD
37 Group:          Applications/Networking
38 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
39 # Source0-md5:  88633408f4cb1eb11ec7e2ec58b519eb
40 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
41 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
42 Source2:        %{name}d.init
43 Source3:        %{name}d.pamd
44 Source4:        %{name}.sysconfig
45 Source5:        ssh-agent.sh
46 Source6:        ssh-agent.conf
47 Source7:        %{name}-lpk.schema
48 Patch100:       %{name}-heimdal.patch
49 Patch0:         %{name}-no_libnsl.patch
50 Patch2:         %{name}-pam_misc.patch
51 Patch3:         %{name}-sigpipe.patch
52 # http://code.google.com/p/openssh-lpk/
53 Patch4:         %{name}-lpk.patch
54 Patch5:         %{name}-config.patch
55 Patch7:         %{name}-selinux.patch
56 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
57 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
58 Patch9:         %{name}-5.2p1-hpn13v6.diff
59 Patch10:        %{name}-include.patch
60 Patch11:        %{name}-chroot.patch
61 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
62 Patch12:        %{name}-blacklist.diff
63 URL:            http://www.openssh.com/
64 BuildRequires:  %{__perl}
65 BuildRequires:  autoconf
66 BuildRequires:  automake
67 %{?with_gnome:BuildRequires:    gnome-libs-devel}
68 %{?with_gtk:BuildRequires:      gtk+2-devel}
69 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
70 %{?with_libedit:BuildRequires:  libedit-devel}
71 %{?with_selinux:BuildRequires:  libselinux-devel}
72 BuildRequires:  libwrap-devel
73 %{?with_ldap:BuildRequires:     openldap-devel}
74 BuildRequires:  openssl-devel >= 0.9.7d
75 BuildRequires:  pam-devel
76 %{?with_gtk:BuildRequires:      pkgconfig}
77 BuildRequires:  rpm >= 4.4.9-56
78 BuildRequires:  rpmbuild(macros) >= 1.318
79 BuildRequires:  zlib-devel
80 %if "%{pld_release}" == "ac"
81 Requires:       filesystem >= 2.0-1
82 Requires:       pam >= 0.79.0
83 %else
84 Requires:       filesystem >= 3.0-11
85 Requires:       pam >= %{pam_ver}
86 Suggests:       openssh-blacklist
87 Suggests:       xorg-app-xauth
88 %endif
89 Obsoletes:      ssh
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         _sysconfdir     /etc/ssh
93 %define         _libexecdir     %{_libdir}/%{name}
94 %define         _privsepdir     /usr/share/empty
95 %define         schemadir       /usr/share/openldap/schema
96
97 %description
98 Ssh (Secure Shell) a program for logging into a remote machine and for
99 executing commands in a remote machine. It is intended to replace
100 rlogin and rsh, and provide secure encrypted communications between
101 two untrusted hosts over an insecure network. X11 connections and
102 arbitrary TCP/IP ports can also be forwarded over the secure channel.
103
104 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
105 it up to date in terms of security and features, as well as removing
106 all patented algorithms to seperate libraries (OpenSSL).
107
108 This package includes the core files necessary for both the OpenSSH
109 client and server. To make this package useful, you should also
110 install openssh-clients, openssh-server, or both.
111 %if %{with hpn}
112 This release includes High Performance SSH/SCP patches from
113 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
114 to increase throughput on fast connections with high RTT (20-150 msec).
115 See the website for '-w' values for your connection and /proc/sys TCP
116 values. BTW. in a LAN you have got generally RTT < 1 msec.
117 %endif
118
119 %description -l de.UTF-8
120 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
121 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
122 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
123 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
124 andere TCP/IP Ports können ebenso über den sicheren Channel
125 weitergeleitet werden.
126
127 %description -l es.UTF-8
128 SSH es un programa para accesar y ejecutar órdenes en computadores
129 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
130 seguro entre dos servidores en una red insegura. Conexiones X11 y
131 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
132 seguro.
133
134 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
135 continuar la última versión gratuita de SSH, actualizándolo en
136 términos de seguridad y recursos,así también eliminando todos los
137 algoritmos patentados y colocándolos en bibliotecas separadas
138 (OpenSSL).
139
140 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
141 también el paquete openssh-clients u openssh-server o ambos.
142
143 %description -l fr.UTF-8
144 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
145 remplace telnet, rlogin, rexec et rsh, tout en assurant des
146 communications cryptées securisées entre deux hôtes non fiabilisés sur
147 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
148 arbitraires peuvent également être transmis sur le canal sécurisé.
149
150 %description -l it.UTF-8
151 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
152 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
153 sicure e crittate tra due host non fidati su una rete non sicura. Le
154 connessioni X11 ad una porta TCP/IP arbitraria possono essere
155 inoltrate attraverso un canale sicuro.
156
157 %description -l pl.UTF-8
158 Ssh (Secure Shell) to program służący do logowania się na zdalną
159 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
160 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
161 pomiędzy dwoma hostami.
162
163 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
164 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
165 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
166 %if %{with hpn}
167 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
168 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
169 zwiększenie przepustowości transmisji dla szybkich połączeń
170 z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
171 odpowednie dla danego połączenia wartości parametru '-w' oraz
172 opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
173 %endif
174
175 %description -l pt.UTF-8
176 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
177 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
178 cifradas entre duas máquinas sem confiança mútua sobre uma rede
179 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
180 reenviados pelo canal seguro.
181
182 %description -l pt_BR.UTF-8
183 SSH é um programa para acessar e executar comandos em máquinas
184 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
185 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
186 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
187
188 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
189 última versão gratuita do SSH, atualizando-o em termos de segurança e
190 recursos, assim como removendo todos os algoritmos patenteados e
191 colocando-os em bibliotecas separadas (OpenSSL).
192
193 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
194 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
195
196 %description -l ru.UTF-8
197 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
198 машину и для выполнения команд на удаленной машине. Она предназначена
199 для замены rlogin и rsh и обеспечивает безопасную шифрованную
200 коммуникацию между двумя хостами в сети, являющейся небезопасной.
201 Соединения X11 и любые порты TCP/IP могут также быть проведены через
202 безопасный канал.
203
204 OpenSSH - это переделка командой разработчиков OpenBSD последней
205 свободной версии SSH, доведенная до современного состояния в терминах
206 уровня безопасности и поддерживаемых возможностей. Все патентованные
207 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
208
209 Этот пакет содержит файлы, необходимые как для клиента, так и для
210 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
211 openssh-server, или оба пакета.
212
213 %description -l uk.UTF-8
214 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
215 машини та для виконання команд на віддаленій машині. Вона призначена
216 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
217 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
218 довільні порти TCP/IP можуть також бути проведені через безпечний
219 канал.
220
221 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
222 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
223 підтримуваних можливостей. Всі патентовані алгоритми винесені до
224 окремих бібліотек (OpenSSL).
225
226 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
227 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
228 openssh-server, чи обидва пакети.
229
230 %package clients
231 Summary:        OpenSSH Secure Shell protocol clients
232 Summary(es.UTF-8):      Clientes de OpenSSH
233 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
234 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
235 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
236 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
237 Group:          Applications/Networking
238 Requires:       %{name}
239 Provides:       ssh-clients
240 Obsoletes:      ssh-clients
241
242 %description clients
243 Ssh (Secure Shell) a program for logging into a remote machine and for
244 executing commands in a remote machine. It is intended to replace
245 rlogin and rsh, and provide secure encrypted communications between
246 two untrusted hosts over an insecure network. X11 connections and
247 arbitrary TCP/IP ports can also be forwarded over the secure channel.
248
249 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
250 it up to date in terms of security and features, as well as removing
251 all patented algorithms to seperate libraries (OpenSSL).
252
253 This package includes the clients necessary to make encrypted
254 connections to SSH servers.
255
256 %description clients -l es.UTF-8
257 Este paquete incluye los clientes que se necesitan para hacer
258 conexiones codificadas con servidores SSH.
259
260 %description clients -l pl.UTF-8
261 Ssh (Secure Shell) to program służący do logowania się na zdalną
262 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
263 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
264 pomiędzy dwoma hostami.
265
266 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
267
268 %description clients -l pt_BR.UTF-8
269 Esse pacote inclui os clientes necessários para fazer conexões
270 encriptadas com servidores SSH.
271
272 %description clients -l ru.UTF-8
273 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
274 машину и для выполнения команд на удаленной машине.
275
276 Этот пакет содержит программы-клиенты, необходимые для установления
277 зашифрованных соединений с серверами SSH.
278
279 %description clients -l uk.UTF-8
280 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
281 машини та для виконання команд на віддаленій машині.
282
283 Цей пакет містить програми-клієнти, необхідні для встановлення
284 зашифрованих з'єднань з серверами SSH.
285
286 %package clients-agent-profile_d
287 Summary:        OpenSSH Secure Shell agent init script
288 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
289 Group:          Applications/Networking
290 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
291
292 %description clients-agent-profile_d
293 profile.d scripts for starting SSH agent.
294
295 %description clients-agent-profile_d -l pl.UTF-8
296 Skrypty profile.d do uruchamiania agenta SSH.
297
298 %package clients-agent-xinitrc
299 Summary:        OpenSSH Secure Shell agent init script
300 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
301 Group:          Applications/Networking
302 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
303 Requires:       xinitrc
304
305 %description clients-agent-xinitrc
306 xinitrc scripts for starting SSH agent.
307
308 %description clients-agent-xinitrc -l pl.UTF-8
309 Skrypty xinitrc do uruchamiania agenta SSH.
310
311 %package server
312 Summary:        OpenSSH Secure Shell protocol server (sshd)
313 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
314 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
315 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
316 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
317 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
318 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
319 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
320 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
321 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
322 Group:          Networking/Daemons
323 Requires(post): /sbin/chkconfig
324 Requires(post): grep
325 Requires(post,preun):   /sbin/chkconfig
326 Requires(postun):       /usr/sbin/userdel
327 Requires(pre):  /bin/id
328 Requires(pre):  /usr/sbin/useradd
329 Requires:       %{name} = %{epoch}:%{version}-%{release}
330 Requires:       pam >= %{pam_ver}
331 Requires:       rc-scripts >= 0.4.1.23
332 Requires:       util-linux
333 Suggests:       /bin/login
334 Provides:       ssh-server
335 Provides:       user(sshd)
336
337 %description server
338 Ssh (Secure Shell) a program for logging into a remote machine and for
339 executing commands in a remote machine. It is intended to replace
340 rlogin and rsh, and provide secure encrypted communications between
341 two untrusted hosts over an insecure network. X11 connections and
342 arbitrary TCP/IP ports can also be forwarded over the secure channel.
343
344 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
345 it up to date in terms of security and features, as well as removing
346 all patented algorithms to seperate libraries (OpenSSL).
347
348 This package contains the secure shell daemon. The sshd is the server
349 part of the secure shell protocol and allows ssh clients to connect to
350 your host.
351
352 %description server -l de.UTF-8
353 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
354
355 %description server -l es.UTF-8
356 Este paquete contiene el servidor SSH. sshd es la parte servidor del
357 protocolo secure shell y permite que clientes ssh se conecten a su
358 servidor.
359
360 %description server -l fr.UTF-8
361 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
362
363 %description server -l it.UTF-8
364 Questo pacchetto installa sshd, il server di OpenSSH.
365
366 %description server -l pl.UTF-8
367 Ssh (Secure Shell) to program służący do logowania się na zdalną
368 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
369 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
370 pomiędzy dwoma hostami.
371
372 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
373 ssh).
374
375 %description server -l pt.UTF-8
376 Este pacote intala o sshd, o servidor do OpenSSH.
377
378 %description server -l pt_BR.UTF-8
379 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
380 protocolo secure shell e permite que clientes ssh se conectem ao seu
381 host.
382
383 %description server -l ru.UTF-8
384 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
385 машину и для выполнения команд на удаленной машине.
386
387 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
388 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
389 вашим хостом.
390
391 %description server -l uk.UTF-8
392 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
393 машини та для виконання команд на віддаленій машині.
394
395 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
396 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
397 з вашим хостом.
398
399 %package gnome-askpass
400 Summary:        OpenSSH GNOME passphrase dialog
401 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
402 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
403 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
404 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
405 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
406 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
407 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
408 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
409 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
410 Group:          Applications/Networking
411 Requires:       %{name} = %{epoch}:%{version}-%{release}
412 Obsoletes:      openssh-askpass
413 Obsoletes:      ssh-askpass
414 Obsoletes:      ssh-extras
415
416 %description gnome-askpass
417 Ssh (Secure Shell) a program for logging into a remote machine and for
418 executing commands in a remote machine. It is intended to replace
419 rlogin and rsh, and provide secure encrypted communications between
420 two untrusted hosts over an insecure network. X11 connections and
421 arbitrary TCP/IP ports can also be forwarded over the secure channel.
422
423 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
424 it up to date in terms of security and features, as well as removing
425 all patented algorithms to seperate libraries (OpenSSL).
426
427 This package contains the GNOME passphrase dialog.
428
429 %description gnome-askpass -l es.UTF-8
430 Este paquete contiene un programa que abre una caja de diálogo para
431 entrada de passphrase en GNOME.
432
433 %description gnome-askpass -l pl.UTF-8
434 Ssh (Secure Shell) to program służący do logowania się na zdalną
435 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
436 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
437 pomiędzy dwoma hostami.
438
439 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
440
441 %description gnome-askpass -l pt_BR.UTF-8
442 Esse pacote contém um programa que abre uma caixa de diálogo para
443 entrada de passphrase no GNOME.
444
445 %description gnome-askpass -l ru.UTF-8
446 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
447 машину и для выполнения команд на удаленной машине.
448
449 Этот пакет содержит диалог ввода ключевой фразы для использования под
450 GNOME.
451
452 %description gnome-askpass -l uk.UTF-8
453 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
454 машини та для виконання команд на віддаленій машині.
455
456 Цей пакет містить діалог вводу ключової фрази для використання під
457 GNOME.
458
459 %package -n openldap-schema-openssh-lpk
460 Summary:        OpenSSH LDAP Public Key schema
461 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
462 Group:          Networking/Daemons
463 Requires(post,postun):  sed >= 4.0
464 Requires:       openldap-servers
465
466 %description -n openldap-schema-openssh-lpk
467 This package contains OpenSSH LDAP Public Key schema for openldap.
468
469 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
470 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
471 openldap-a.
472
473 %prep
474 %setup -q
475 %{?with_kerberos5:%patch100 -p1}
476 %patch0 -p1
477 %patch2 -p1
478 %patch3 -p1
479 %{?with_ldap:%patch4 -p1}
480 %patch5 -p1
481 %patch7 -p1
482 %{?with_hpn:%patch9 -p1}
483 %patch10 -p1
484 %patch11 -p1
485 %patch12 -p1
486
487 %build
488 cp /usr/share/automake/config.sub .
489 %{__aclocal}
490 %{__autoconf}
491 CPPFLAGS="-DCHROOT"
492 %configure \
493         PERL=%{__perl} \
494         --with-dns \
495         --with-pam \
496         --with-mantype=man \
497         --with-md5-passwords \
498         --with-ipaddr-display \
499         %{?with_libedit:--with-libedit} \
500         --with-4in6 \
501         --disable-suid-ssh \
502         --with-tcp-wrappers \
503         %{?with_ldap:--with-libs="-lldap -llber"} \
504         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
505         %{?with_kerberos5:--with-kerberos5=/usr} \
506         --with-privsep-path=%{_privsepdir} \
507         --with-pid-dir=%{_localstatedir}/run \
508 %if "%{pld_release}" == "ac"
509         --with-xauth=/usr/X11R6/bin/xauth \
510 %else
511         --with-xauth=/usr/bin/xauth \
512 %endif
513         --enable-utmpx \
514         --enable-wtmpx
515
516 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
517
518 %{__make}
519
520 cd contrib
521 %if %{with gnome}
522 %{__make} gnome-ssh-askpass1 \
523         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
524 %endif
525 %if %{with gtk}
526 %{__make} gnome-ssh-askpass2 \
527         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
528 %endif
529
530 %install
531 rm -rf $RPM_BUILD_ROOT
532 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
533         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
534 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
535
536 %{__make} install \
537         DESTDIR=$RPM_BUILD_ROOT
538
539 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
540
541 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
542 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
543 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
544 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
545 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
546 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
547 install %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
548
549 %if %{with gnome}
550 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
551 %endif
552 %if %{with gtk}
553 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
554 %endif
555 %if %{with gnome} || %{with gtk}
556 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
557 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
558 EOF
559 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
560 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
561 EOF
562 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
563 %endif
564
565 install contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
566 install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
567
568 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
569 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
570
571 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
572
573 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
574 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
575 EOF
576
577 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
578 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
579
580 %clean
581 rm -rf $RPM_BUILD_ROOT
582
583 %post clients
584 %env_update
585
586 %postun clients
587 %env_update
588
589 %post gnome-askpass
590 %env_update
591
592 %postun gnome-askpass
593 %env_update
594
595 %pre server
596 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
597
598 %post server
599 /sbin/chkconfig --add sshd
600 %service sshd reload "openssh daemon"
601 if ! grep -qs ssh /etc/security/passwd.conf ; then
602         umask 022
603         echo "ssh" >> /etc/security/passwd.conf
604 fi
605
606 %preun server
607 if [ "$1" = "0" ]; then
608         %service sshd stop
609         /sbin/chkconfig --del sshd
610 fi
611
612 %postun server
613 if [ "$1" = "0" ]; then
614         %userremove sshd
615 fi
616
617 %post -n openldap-schema-openssh-lpk
618 %openldap_schema_register %{schemadir}/openssh-lpk.schema
619 %service -q ldap restart
620
621 %postun -n openldap-schema-openssh-lpk
622 if [ "$1" = "0" ]; then
623         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
624         %service -q ldap restart
625 fi
626
627 %files
628 %defattr(644,root,root,755)
629 %doc *.RNG TODO README OVERVIEW CREDITS Change*
630 %attr(755,root,root) %{_bindir}/ssh-key*
631 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
632 %{_mandir}/man1/ssh-key*.1*
633 %{_mandir}/man1/ssh-vulnkey*.1*
634 %dir %{_sysconfdir}
635 %dir %{_libexecdir}
636
637 %files clients
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{_bindir}/ssh
640 %attr(755,root,root) %{_bindir}/slogin
641 %attr(755,root,root) %{_bindir}/sftp
642 %attr(755,root,root) %{_bindir}/ssh-agent
643 %attr(755,root,root) %{_bindir}/ssh-add
644 %attr(755,root,root) %{_bindir}/ssh-copy-id
645 %attr(755,root,root) %{_bindir}/scp
646 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
647 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
648 %{_mandir}/man1/scp.1*
649 %{_mandir}/man1/ssh.1*
650 %{_mandir}/man1/slogin.1*
651 %{_mandir}/man1/sftp.1*
652 %{_mandir}/man1/ssh-agent.1*
653 %{_mandir}/man1/ssh-add.1*
654 %{_mandir}/man1/ssh-copy-id.1*
655 %{_mandir}/man5/ssh_config.5*
656 %lang(it) %{_mandir}/it/man1/ssh.1*
657 %lang(it) %{_mandir}/it/man5/ssh_config.5*
658 %lang(pl) %{_mandir}/pl/man1/scp.1*
659 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
660
661 # for host-based auth (suid required for accessing private host key)
662 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
663 #%{_mandir}/man8/ssh-keysign.8*
664
665 %files clients-agent-profile_d
666 %defattr(644,root,root,755)
667 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
668 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
669
670 %files clients-agent-xinitrc
671 %defattr(644,root,root,755)
672 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
673
674 %files server
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_sbindir}/sshd
677 %attr(755,root,root) %{_libexecdir}/sftp-server
678 %attr(755,root,root) %{_libexecdir}/ssh-keysign
679 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
680 %{_mandir}/man8/sshd.8*
681 %{_mandir}/man8/sftp-server.8*
682 %{_mandir}/man8/ssh-keysign.8*
683 %{_mandir}/man8/ssh-pkcs11-helper.8*
684 %{_mandir}/man5/sshd_config.5*
685 %{_mandir}/man5/moduli.5*
686 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
687 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
688 %attr(640,root,root) %{_sysconfdir}/moduli
689 %attr(754,root,root) /etc/rc.d/init.d/sshd
690 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
691 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
692
693 %if %{with gnome} || %{with gtk}
694 %files gnome-askpass
695 %defattr(644,root,root,755)
696 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
697 %dir %{_libexecdir}/ssh
698 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
699 %attr(755,root,root) %{_libexecdir}/ssh-askpass
700 %endif
701
702 %if %{with ldap}
703 %files -n openldap-schema-openssh-lpk
704 %defattr(644,root,root,755)
705 %{schemadir}/openssh-lpk.schema
706 %endif
This page took 0.093239 seconds and 3 git commands to generate.