]> git.pld-linux.org Git - packages/opencv.git/commitdiff
- drop references to unused sysctl call/headers
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 9 Mar 2015 12:34:33 +0000 (13:34 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 9 Mar 2015 12:34:33 +0000 (13:34 +0100)
no-sysctl.patch [new file with mode: 0644]
opencv.spec

diff --git a/no-sysctl.patch b/no-sysctl.patch
new file mode 100644 (file)
index 0000000..dd37a32
--- /dev/null
@@ -0,0 +1,44 @@
+Description: get rid of sysctl includes on Linux
+ The 'sysctl' syscall has been strongly deprecated on Linux for ages.
+ Currently, on old architectures it will spam syslog whenever used, and on
+ newer ones it's missing from the headers altogether.  Opencv has migrated
+ away on Linux already, but #include statements were left lingering.
+ .
+ This patch removes such #includes on non-__APPLE__, unbreaking x32.
+Author: Adam Borowski <kilobyte@angband.pl>
+
+--- opencv-2.4.9.1+dfsg.orig/modules/core/src/parallel.cpp
++++ opencv-2.4.9.1+dfsg/modules/core/src/parallel.cpp
+@@ -56,8 +56,8 @@
+     #include <sys/types.h>
+     #if defined ANDROID
+         #include <sys/sysconf.h>
+-    #elif !defined __GNU__
+-        #include <sys/sysctl.h>
++     #elif defined __APPLE__
++         #include <sys/sysctl.h>
+     #endif
+ #endif
+--- opencv-2.4.9.1+dfsg.orig/modules/core/src/system.cpp
++++ opencv-2.4.9.1+dfsg/modules/core/src/system.cpp
+@@ -163,8 +163,6 @@ std::wstring GetTempFileNameWinRT(std::w
+ #include <sys/types.h>
+ #if defined ANDROID
+ #include <sys/sysconf.h>
+-#elif !defined __GNU__
+-#include <sys/sysctl.h>
+ #endif
+ #endif
+--- opencv-2.4.9.1+dfsg.orig/modules/highgui/src/cap_ffmpeg_impl.hpp
++++ opencv-2.4.9.1+dfsg/modules/highgui/src/cap_ffmpeg_impl.hpp
+@@ -145,7 +145,7 @@ extern "C" {
+ #if defined WIN32 || defined _WIN32
+     #include <windows.h>
+-#elif defined __linux__ || defined __APPLE__
++#elif defined __APPLE__
+     #include <unistd.h>
+     #include <stdio.h>
+     #include <sys/types.h>
index b18abeea1cad9c30f1c54207cd9fe13cb4869576..30a3d6891ed9ecdad1378a0fff100a5febc1cce7 100644 (file)
@@ -63,6 +63,7 @@ Patch5:               %{name}-ximea.patch
 Patch6:                %{name}-ocl-fft.patch
 Patch7:                java-ant-sourcelevel.patch
 Patch8:                %{name}-shared.patch
+Patch9:                no-sysctl.patch
 URL:           http://www.opencv.org/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel}
@@ -275,6 +276,7 @@ Wiązania Pythona do OpenCV.
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 
 %build
 install -d build
This page took 0.034294 seconds and 4 git commands to generate.