]> git.pld-linux.org Git - packages/opencv.git/commitdiff
- added cmake patch (fixes undefined list_filterout macro under some conditions) auto/th/opencv-2.4.11-0.1
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 19 May 2015 17:26:51 +0000 (19:26 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 19 May 2015 17:26:51 +0000 (19:26 +0200)
opencv-cmake.patch [new file with mode: 0644]
opencv.spec

diff --git a/opencv-cmake.patch b/opencv-cmake.patch
new file mode 100644 (file)
index 0000000..14de6e2
--- /dev/null
@@ -0,0 +1,34 @@
+--- opencv-2.4.11/samples/gpu/CMakeLists.txt.orig      2015-02-25 13:10:31.000000000 +0100
++++ opencv-2.4.11/samples/gpu/CMakeLists.txt   2015-05-19 18:35:11.803554049 +0200
+@@ -4,6 +4,15 @@
+                                      opencv_superres)
+ ocv_check_dependencies(${OPENCV_GPU_SAMPLES_REQUIRED_DEPS})
++# remove all matching elements from the list
++MACRO(list_filterout lst regex)
++  foreach(item ${${lst}})
++    if(item MATCHES "${regex}")
++      list(REMOVE_ITEM ${lst} "${item}")
++    endif()
++  endforeach()
++ENDMACRO()
++
+ if(BUILD_EXAMPLES AND OCV_DEPENDENCIES_FOUND)
+   set(project "gpu")
+   string(TOUPPER "${project}" project_upper)
+@@ -69,15 +78,6 @@
+     endif()
+   ENDMACRO()
+-  # remove all matching elements from the list
+-  MACRO(list_filterout lst regex)
+-    foreach(item ${${lst}})
+-      if(item MATCHES "${regex}")
+-        list(REMOVE_ITEM ${lst} "${item}")
+-      endif()
+-    endforeach()
+-  ENDMACRO()
+-
+   file(GLOB all_samples RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.cpp)
+   if(NOT HAVE_OPENGL)
index a74feca3ce8a28223086b0b5b4a76d9fbbffe390..a71837bf94028108a2a9157bba7e27bed8bd499d 100644 (file)
@@ -55,6 +55,7 @@ Group:                Libraries
 Source0:       https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: fa06384719cb0be48183b4de972f0b2a
 Patch0:                %{name}-cflags.patch
+Patch1:                %{name}-cmake.patch
 Patch2:                %{name}-unicap-c++.patch
 Patch3:                %{name}-c.patch
 Patch4:                %{name}-gcc.patch
@@ -268,6 +269,7 @@ Wiązania Pythona do OpenCV.
 %undos modules/gpu/CMakeLists.txt
 
 %patch0 -p1
+%patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
This page took 0.058493 seconds and 4 git commands to generate.