]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
- rel 4; BR vtk-tcl
[packages/opencv.git] / opencv.spec
1 # TODO:
2 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
3 # - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
4 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
5 #
6 # Conditional build:
7 # - general options:
8 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
9 %bcond_with     sse             # use SSE instructions
10 %bcond_with     sse2            # use SSE2 instructions
11 %bcond_with     sse3            # use SSE3 instructions
12 %bcond_with     ssse3           # use SSSE3 instructions
13 %bcond_with     sse41           # use SSE4.1 instructions
14 %bcond_with     sse42           # use SSE4.2 instructions
15 %bcond_with     avx             # use AVX instructions
16 %bcond_without  opencl          # OpenCL support
17 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
18 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
19 %bcond_without  opengl          # OpenGL support
20 %bcond_without  gomp            # OpenMP support (available when not using tbb)
21 %bcond_without  examples        # Install examples
22 # - bindings
23 %bcond_without  java            # Java binding
24 # - highgui options:
25 %bcond_without  ffmpeg          # FFMpeg support in highgui
26 %bcond_without  gstreamer       # GStreamer support in highgui
27 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
28 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
29 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
30 %bcond_with     unicap          # Unicap support in highgui (GPL)
31 %bcond_without  v4l             # Video4Linux in highgui
32 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
33 %bcond_with     xine            # XINE support in highgui (GPL)
34 # - other modules
35 %bcond_without  vtk             # VTK library support (opencv_viz module)
36
37 %ifarch pentium3 pentium4 %{x8664}
38 %define         with_sse        1
39 %endif
40 %ifarch pentium4 %{x8664}
41 %define         with_sse2       1
42 %endif
43 Summary:        A library of programming functions mainly aimed at real time computer vision
44 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
45 Name:           opencv
46 Version:        2.4.9
47 Release:        4
48 Epoch:          1
49 %if %{with unicap} || %{with xine}
50 License:        GPL (enforced by used libraries), BSD (opencv itself)
51 %else
52 License:        BSD
53 %endif
54 Group:          Libraries
55 Source0:        https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
56 # Source0-md5:  cc0a8307403ff471f554197401ec0eb9
57 Patch0:         %{name}-cflags.patch
58 Patch1:         %{name}-link.patch
59 Patch2:         %{name}-unicap-c++.patch
60 Patch3:         %{name}-c.patch
61 Patch4:         %{name}-gcc.patch
62 Patch5:         %{name}-ximea.patch
63 Patch6:         %{name}-ocl-fft.patch
64 Patch7:         java-ant-sourcelevel.patch
65 Patch8:         %{name}-shared.patch
66 URL:            http://www.opencv.org/
67 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
68 %{?with_opencl:BuildRequires:   OpenCL-devel}
69 BuildRequires:  OpenEXR-devel
70 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
71 %{?with_opengl:BuildRequires:   OpenGL-devel}
72 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
73 %{?with_openni:BuildRequires:   OpenNI-devel}
74 %{?with_ximea:BuildRequires:    XIMEA-devel >= 4}
75 %{?with_java:BuildRequires:     ant}
76 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
77 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
78 BuildRequires:  cmake >= 2.8
79 BuildRequires:  doxygen
80 BuildRequires:  eigen3 >= 3
81 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
82 %{?with_gomp:BuildRequires:     gcc-c++ >= 6:4.2}
83 %if %{with gstreamer}
84 BuildRequires:  gstreamer-devel >= 0.10
85 BuildRequires:  gstreamer-plugins-base-devel >= 0.10
86 %endif
87 BuildRequires:  jasper-devel
88 %{?with_java:BuildRequires:     jdk}
89 BuildRequires:  libdc1394-devel
90 %{?with_gomp:BuildRequires:     libgomp-devel}
91 BuildRequires:  libjpeg-devel
92 BuildRequires:  libpng-devel
93 BuildRequires:  libraw1394-devel
94 BuildRequires:  libstdc++-devel
95 BuildRequires:  libtiff-devel
96 BuildRequires:  libtool
97 %if %{with unicap}
98 BuildRequires:  libucil-devel
99 BuildRequires:  libunicap-devel
100 %endif
101 BuildRequires:  libv4l-devel
102 BuildRequires:  pkgconfig
103 BuildRequires:  python
104 BuildRequires:  python-devel
105 BuildRequires:  python-numpy-devel
106 BuildRequires:  rpm-pythonprov
107 BuildRequires:  rpmbuild(macros) >= 1.606
108 BuildRequires:  sed >= 4.0
109 BuildRequires:  swig-python
110 %{?with_tbb:BuildRequires:      tbb-devel}
111 %if %{with vtk}
112 BuildRequires:  vtk-devel >= 5.8.0
113 BuildRequires:  vtk-tcl >= 5.8.0
114 %endif
115 %{?with_xine:BuildRequires:     xine-lib-devel}
116 BuildRequires:  zlib-devel
117 %if %{with qt}
118 BuildRequires:  QtCore-devel >= 4
119 BuildRequires:  QtGui-devel >= 4
120 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
121 BuildRequires:  qt4-qmake >= 4
122 %else
123 BuildRequires:  gtk+2-devel >= 2.0
124 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
125 %endif
126 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
127 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
128
129 %define         sover   %(v=%{version}; k=${v#?.?.?}; echo ${v%$k})
130 %define         jver    %(echo %{version} | tr -d .)
131
132 %description
133 OpenCV (Open Source Computer Vision) is a library of programming
134 functions mainly aimed at real time computer vision.
135
136 Example applications of the OpenCV library are:
137 - Human-Computer Interaction (HCI)
138 - Object Identification, Segmentation and Recognition
139 - Face Recognition
140 - Gesture Recognition
141 - Motion Tracking
142 - Ego Motion, Motion Understanding
143 - Structure From Motion (SFM)
144 - Stereo and Multi-Camera Calibration and Depth Computation
145 - Mobile Robotics.
146
147 %description -l pl.UTF-8
148 OpenCV (Open Source Computer Vision) to biblioteka funkcji
149 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
150
151 Przykładowe zastosowania biblioteki OpenCV to
152 - interakcje człowiek-komputer (HCI)
153 - identyfikacja, segmentacja i rozpoznawanie obiektów
154 - rozpoznawanie twarzy
155 - rozpoznawanie gestów
156 - śledzenie ruchu
157 - rozumienie ruchu
158 - SFM (Structure From Motion)
159 - kalibracja dwu- i wielokamerowa, obliczanie głębi
160 - robotyka ruchu.
161
162 %package core
163 Summary:        OpenCV core libraries
164 Summary(pl.UTF-8):      Podstawowe biblioteki OpenCV
165 Group:          Libraries
166 Conflicts:      opencv < 2.4.6.2-1
167
168 %description core
169 This package contains the OpenCV C/C++ core libraries.
170
171 %description core -l pl.UTF-8
172 Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
173
174 %package viz
175 Summary:        OpenCV viz library (VTK support)
176 Summary(pl.UTF-8):      Biblioteka OpenCV viz (obsługa VTK)
177 Group:          Libraries
178 Requires:       %{name} = %{epoch}:%{version}-%{release}
179
180 %description viz
181 OpenCV viz library (VTK support).
182
183 %description viz -l pl.UTF-8
184 Biblioteka OpenCV viz (obsługa VTK).
185
186 %package devel
187 Summary:        Header files for OpenCV library
188 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
189 Group:          Development/Libraries
190 Requires:       %{name} = %{epoch}:%{version}-%{release}
191 %if %{with vtk}
192 Requires:       %{name}-viz = %{epoch}:%{version}-%{release}
193 %endif
194 Obsoletes:      opencv-static
195
196 %description devel
197 Header files for OpenCV library.
198
199 %description devel -l pl.UTF-8
200 Pliki nagłówkowe biblioteki OpenCV.
201
202 %package doc
203 Summary:        Manual for OpenCV
204 Summary(fr.UTF-8):      Documentation pour OpenCV
205 Summary(it.UTF-8):      Documentazione di OpenCV
206 Summary(pl.UTF-8):      Podręcznik dla OpenCV
207 Group:          Documentation
208 # noarch subpackages only when building with rpm5
209 %if "%{_rpmversion}" >= "5"
210 BuildArch:      noarch
211 %endif
212
213 %description doc
214 Documentation for OpenCV.
215
216 %description doc -l fr.UTF-8
217 Documentation pour OpenCV.
218
219 %description doc -l it.UTF-8
220 Documentazione di OpenCV.
221
222 %description doc -l pl.UTF-8
223 Dokumentacja do OpenCV.
224
225 %package examples
226 Summary:        OpenCV code examples
227 Group:          Documentation
228 %if "%{_rpmversion}" >= "5"
229 BuildArch:      noarch
230 %endif
231
232 %description examples
233 OpenCV code examples.
234
235 %package -n java-opencv
236 Summary:        OpenCV Java bindings
237 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
238 Group:          Libraries/Java
239 Requires:       %{name} = %{epoch}:%{version}-%{release}
240 Requires:       jre
241
242 %description -n java-opencv
243 OpenCV Java bindings.
244
245 %description -n java-opencv -l pl.UTF-8
246 Wiązania Javy do OpenCV.
247
248 %package -n python-opencv
249 Summary:        OpenCV Python bindings
250 Summary(pl.UTF-8):      Wiązania Pythona do OpenCV
251 Group:          Libraries/Python
252 Requires:       %{name} = %{epoch}:%{version}-%{release}
253 Requires:       python-libs
254
255 %description -n python-opencv
256 OpenCV Python bindings.
257
258 %description -n python-opencv -l pl.UTF-8
259 Wiązania Pythona do OpenCV.
260
261 %prep
262 %setup -q
263
264 %undos CMakeLists.txt
265 %undos modules/gpu/CMakeLists.txt
266
267 %patch0 -p1
268 %patch1 -p1
269 %patch2 -p1
270 %patch3 -p1
271 %patch4 -p1
272 %patch5 -p1
273 %patch6 -p1
274 %patch7 -p1
275 %patch8 -p1
276
277 %build
278 install -d build
279 cd build
280
281 # handle cmake & ccache
282 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
283 if [[ "%{__cc}" = *ccache* ]]; then
284         cc="%{__cc}"
285         cxx="%{__cxx}"
286         ccache="
287         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
288         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
289         "
290 fi
291
292 %cmake .. \
293         $ccache \
294         -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
295         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
296         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
297         -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
298         -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
299         -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
300         -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
301         -DBUILD_NEW_PYTHON_SUPPORT=ON \
302 %if %{with examples}
303         -DINSTALL_C_EXAMPLES=ON \
304         -DINSTALL_PYTHON_EXAMPLES=ON \
305 %endif
306         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
307         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
308         %{?with_opencl:-DWITH_OPENCL=ON} \
309         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
310         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
311         %{?with_opengl:-DWITH_OPENGL=ON} \
312         %{?with_gomp:-DWITH_OPENMP=ON} \
313         %{?with_openni:-DWITH_OPENNI=ON} \
314         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
315         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
316         %{?with_tbb:-DWITH_TBB=ON} \
317         %{?with_unicap:-DWITH_UNICAP=ON} \
318         %{!?with_v4l:-DWITH_V4L=OFF} \
319         %{?with_vtk:-DWITH_VTK=ON} \
320         %{?with_ximea:-DWITH_XIMEA=ON} \
321         %{?with_xine:-DWITH_XINE=ON}
322
323 %{__make}
324
325 %install
326 rm -rf $RPM_BUILD_ROOT
327 %{__make} -C build install \
328         DESTDIR=$RPM_BUILD_ROOT
329
330 # see -doc package
331 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/OpenCV/doc
332 %if %{with examples}
333 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
334 mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
335 %endif
336
337 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
338 cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
339
340 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
341 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
342 %py_postclean
343
344 %if %{with java}
345 # move to proper directories, create symlink
346 install -d $RPM_BUILD_ROOT%{_javadir}
347 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
348 sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
349         $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
350 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
351 rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
352 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
353 %endif
354
355 %clean
356 rm -rf $RPM_BUILD_ROOT
357
358 %post   -p /sbin/ldconfig
359 %postun -p /sbin/ldconfig
360
361 %post   core -p /sbin/ldconfig
362 %postun core -p /sbin/ldconfig
363
364 %post   viz -p /sbin/ldconfig
365 %postun viz -p /sbin/ldconfig
366
367 %post   -n java-opencv -p /sbin/ldconfig
368 %postun -n java-opencv -p /sbin/ldconfig
369
370 %files
371 %defattr(644,root,root,755)
372 %attr(755,root,root) %{_bindir}/opencv_createsamples
373 %attr(755,root,root) %{_bindir}/opencv_haartraining
374 %attr(755,root,root) %{_bindir}/opencv_performance
375 %attr(755,root,root) %{_bindir}/opencv_traincascade
376 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.%{sover}
377 %attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.2.4
378 %attr(755,root,root) %{_libdir}/libopencv_contrib.so.%{sover}
379 %attr(755,root,root) %ghost %{_libdir}/libopencv_contrib.so.2.4
380 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.%{sover}
381 %attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.2.4
382 %attr(755,root,root) %{_libdir}/libopencv_gpu.so.%{sover}
383 %attr(755,root,root) %ghost %{_libdir}/libopencv_gpu.so.2.4
384 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.%{sover}
385 %attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.2.4
386 %attr(755,root,root) %{_libdir}/libopencv_legacy.so.%{sover}
387 %attr(755,root,root) %ghost %{_libdir}/libopencv_legacy.so.2.4
388 %attr(755,root,root) %{_libdir}/libopencv_nonfree.so.%{sover}
389 %attr(755,root,root) %ghost %{_libdir}/libopencv_nonfree.so.2.4
390 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.%{sover}
391 %attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.2.4
392 %if %{with opencl}
393 %attr(755,root,root) %{_libdir}/libopencv_ocl.so.%{sover}
394 %attr(755,root,root) %ghost %{_libdir}/libopencv_ocl.so.2.4
395 %endif
396 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.%{sover}
397 %attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.2.4
398 %attr(755,root,root) %{_libdir}/libopencv_superres.so.%{sover}
399 %attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.2.4
400 %attr(755,root,root) %{_libdir}/libopencv_ts.so.%{sover}
401 %attr(755,root,root) %ghost %{_libdir}/libopencv_ts.so.2.4
402 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.%{sover}
403 %attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.2.4
404 %dir %{_datadir}/OpenCV
405 %{_datadir}/OpenCV/haarcascades
406 %{_datadir}/OpenCV/lbpcascades
407
408 %files core
409 %defattr(644,root,root,755)
410 %attr(755,root,root) %{_libdir}/libopencv_core.so.%{sover}
411 %attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.2.4
412 %attr(755,root,root) %{_libdir}/libopencv_flann.so.%{sover}
413 %attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.2.4
414 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.%{sover}
415 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.2.4
416 %attr(755,root,root) %{_libdir}/libopencv_ml.so.%{sover}
417 %attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.2.4
418 %attr(755,root,root) %{_libdir}/libopencv_photo.so.%{sover}
419 %attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.2.4
420 %attr(755,root,root) %{_libdir}/libopencv_video.so.%{sover}
421 %attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.2.4
422
423 %if %{with vtk}
424 %files viz
425 %defattr(644,root,root,755)
426 %attr(755,root,root) %{_libdir}/libopencv_viz.so.%{sover}
427 %attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.2.4
428 %endif
429
430 %files devel
431 %defattr(644,root,root,755)
432 # core
433 %attr(755,root,root) %{_libdir}/libopencv_core.so
434 %attr(755,root,root) %{_libdir}/libopencv_flann.so
435 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so
436 %attr(755,root,root) %{_libdir}/libopencv_ml.so
437 %attr(755,root,root) %{_libdir}/libopencv_photo.so
438 %attr(755,root,root) %{_libdir}/libopencv_video.so
439 # GUI/extensions (base package)
440 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so
441 %attr(755,root,root) %{_libdir}/libopencv_contrib.so
442 %attr(755,root,root) %{_libdir}/libopencv_features2d.so
443 %attr(755,root,root) %{_libdir}/libopencv_gpu.so
444 %attr(755,root,root) %{_libdir}/libopencv_highgui.so
445 %attr(755,root,root) %{_libdir}/libopencv_legacy.so
446 %attr(755,root,root) %{_libdir}/libopencv_nonfree.so
447 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so
448 %if %{with opencl}
449 %attr(755,root,root) %{_libdir}/libopencv_ocl.so
450 %endif
451 %attr(755,root,root) %{_libdir}/libopencv_stitching.so
452 %attr(755,root,root) %{_libdir}/libopencv_superres.so
453 %attr(755,root,root) %{_libdir}/libopencv_ts.so
454 %attr(755,root,root) %{_libdir}/libopencv_videostab.so
455 # viz
456 %if %{with vtk}
457 %attr(755,root,root) %{_libdir}/libopencv_viz.so
458 %endif
459 %{_includedir}/opencv
460 %{_includedir}/opencv2
461 %{_datadir}/OpenCV/OpenCV*.cmake
462 %{_pkgconfigdir}/opencv.pc
463
464 %files doc
465 %defattr(644,root,root,755)
466 # TODO: probably could rebuild them and package via make install
467 %doc doc/*
468
469 %if %{with examples}
470 %files examples
471 %defattr(644,root,root,755)
472 %{_examplesdir}/%{name}-%{version}
473 %endif
474
475 %if %{with java}
476 %files -n java-opencv
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
479 %{_javadir}/opencv-%{jver}.jar
480 %{_javadir}/opencv.jar
481 %endif
482
483 %files -n python-opencv
484 %defattr(644,root,root,755)
485 %attr(755,root,root) %{py_sitedir}/cv2.so
486 %{py_sitedir}/cv.py[co]
This page took 0.232599 seconds and 4 git commands to generate.