]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
- BR ogre-devel for ovis contrib module
[packages/opencv.git] / opencv.spec
1 # TODO:
2 # - contrib subpackage(s)
3 # - contrib BRs:
4 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Protobuf)
6 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Glog)
7 #   opencv_contrib-3.1.0/modules/hdf/CMakeLists.txt:find_package(HDF5)
8 #   opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
9 #   opencv_contrib-3.1.0/modules/text/CMakeLists.txt:find_package(Tesseract)
10 # unpackaged (3.4.0)
11 #/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
12 #/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
13 #/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
14 #/usr/share/OpenCV/valgrind.supp
15 #/usr/share/OpenCV/valgrind_3rdparty.supp
16
17 #
18 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
19 # - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
20 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
21 #
22 # Conditional build:
23 # - general options:
24 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
25 %bcond_with     sse             # use SSE instructions
26 %bcond_with     sse2            # use SSE2 instructions
27 %bcond_with     sse3            # use SSE3 instructions
28 %bcond_with     ssse3           # use SSSE3 instructions
29 %bcond_with     sse41           # use SSE4.1 instructions
30 %bcond_with     sse42           # use SSE4.2 instructions
31 %bcond_with     avx             # use AVX instructions
32 %bcond_without  opencl          # OpenCL support
33 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
34 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
35 %bcond_without  opengl          # OpenGL support
36 %bcond_without  openmp          # OpenMP support (available when not using tbb)
37 %bcond_without  examples        # Install examples
38 # - bindings
39 %bcond_without  java            # Java binding
40 # - highgui options:
41 %bcond_without  ffmpeg          # FFMpeg support in highgui
42 %bcond_without  gstreamer       # GStreamer support in highgui
43 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
44 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
45 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
46 %bcond_with     unicap          # Unicap support in highgui (GPL)
47 %bcond_without  v4l             # Video4Linux in highgui
48 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
49 %bcond_with     xine            # XINE support in highgui (GPL)
50 # - other modules
51 %bcond_without  vtk             # VTK library support (opencv_viz module)
52
53 %ifarch pentium3 pentium4 %{x8664} x32
54 %define         with_sse        1
55 %endif
56 %ifarch pentium4 %{x8664} x32
57 %define         with_sse2       1
58 %endif
59 Summary:        A library of programming functions mainly aimed at real time computer vision
60 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
61 Name:           opencv
62 Version:        4.5.1
63 Release:        1
64 Epoch:          1
65 %if %{with unicap} || %{with xine}
66 License:        GPL (enforced by used libraries), BSD (opencv itself)
67 %else
68 License:        BSD
69 %endif
70 Group:          Libraries
71 Source0:        https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
72 # Source0-md5:  2205d3169238ec1f184438a96de68513
73 Source1:        https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
74 # Source1-md5:  19a31bf7271978ab426112dbf5d1b83f
75 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
76 Source10:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
77 # Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
78 Source11:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
79 # Source11-md5: 232c966b13651bd0e46a1497b0852191
80 Source12:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
81 # Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
82 Source13:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
83 # Source13-md5: 202e1b3e9fec871b04da31f7f016679f
84 Source14:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
85 # Source14-md5: 98ea99d399965c03d555cef3ea502a0b
86 Source15:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
87 # Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
88 Source16:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
89 # Source16-md5: 0ae0675534aa318d9668f2a179c2a052
90 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
91 Source20:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
92 # Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
93 Source21:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
94 # Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
95 Source22:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
96 # Source22-md5: 7cd47228edec52b6d82f46511af325c5
97 Source23:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
98 # Source23-md5: 151805e03568c9f490a5e3a872777b75
99 # See opencv_contrib-3.4.1/modules/face/CMakeLists.txt
100 Source30:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
101 # Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
102 # See opencv-4.5.1/modules/gapi/CMakeLists.txt
103 Source40:       https://github.com/opencv/ade/archive/v0.1.1f/v0.1.1f.zip
104 # Source40-md5: b624b995ec9c439cbc2e9e6ee940d3a2
105 Patch0:         %{name}-ximea.patch
106 Patch1:         python-install.patch
107 URL:            http://www.opencv.org/
108 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
109 %{?with_opencl:BuildRequires:   OpenCL-devel}
110 BuildRequires:  OpenEXR-devel
111 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
112 %{?with_opengl:BuildRequires:   OpenGL-devel}
113 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
114 %{?with_openni:BuildRequires:   OpenNI-devel}
115 %{?with_ximea:BuildRequires:    XIMEA-devel >= 4}
116 %{?with_java:BuildRequires:     ant}
117 BuildRequires:  boost-devel
118 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
119 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
120 BuildRequires:  cmake >= 2.8
121 BuildRequires:  doxygen
122 BuildRequires:  eigen3 >= 3
123 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
124 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
125 BuildRequires:  gflags-devel
126 BuildRequires:  gl2ps-devel
127 BuildRequires:  glog-devel
128 %if %{with gstreamer}
129 BuildRequires:  gstreamer-devel >= 1.0
130 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
131 %endif
132 BuildRequires:  jasper-devel
133 %{?with_java:BuildRequires:     jdk}
134 BuildRequires:  libdc1394-devel >= 2
135 %{?with_openmp:BuildRequires:   libgomp-devel}
136 BuildRequires:  libjpeg-devel
137 BuildRequires:  libpng-devel
138 BuildRequires:  libraw1394-devel
139 BuildRequires:  libstdc++-devel
140 BuildRequires:  libtiff-devel
141 BuildRequires:  libtool
142 %if %{with unicap}
143 BuildRequires:  libucil-devel
144 BuildRequires:  libunicap-devel
145 %endif
146 BuildRequires:  libv4l-devel
147 BuildRequires:  ogre-devel
148 BuildRequires:  pkgconfig
149 BuildRequires:  protobuf-devel
150 BuildRequires:  python >= 2.0
151 BuildRequires:  python-devel >= 2.0
152 BuildRequires:  python-numpy-devel
153 BuildRequires:  python3 >= 1:3.2
154 BuildRequires:  python3-devel >= 1:3.2
155 BuildRequires:  python3-numpy-devel
156 BuildRequires:  rpm-pythonprov
157 BuildRequires:  rpmbuild(macros) >= 1.606
158 BuildRequires:  sed >= 4.0
159 BuildRequires:  sphinx-pdg
160 BuildRequires:  swig-python
161 %{?with_tbb:BuildRequires:      tbb-devel}
162 %if %{with vtk}
163 BuildRequires:  vtk-devel >= 5.8.0
164 BuildRequires:  vtk-java >= 5.8.0
165 BuildRequires:  vtk-python3-devel >= 5.8.0
166 %endif
167 %{?with_xine:BuildRequires:     xine-lib-devel}
168 BuildRequires:  xorg-lib-libX11-devel
169 BuildRequires:  zlib-devel
170 %if %{with qt}
171 BuildRequires:  QtCore-devel >= 4
172 BuildRequires:  QtGui-devel >= 4
173 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
174 BuildRequires:  qt4-qmake >= 4
175 %else
176 BuildRequires:  gtk+2-devel >= 2.0
177 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
178 %endif
179 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
180 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
181
182 %define         jver    %(echo %{version} | cut -d. -f1-3 | tr -d .)
183 %define         sover   %(echo %{version} | cut -d. -f1-2)
184
185 %description
186 OpenCV (Open Source Computer Vision) is a library of programming
187 functions mainly aimed at real time computer vision.
188
189 Example applications of the OpenCV library are:
190 - Human-Computer Interaction (HCI)
191 - Object Identification, Segmentation and Recognition
192 - Face Recognition
193 - Gesture Recognition
194 - Motion Tracking
195 - Ego Motion, Motion Understanding
196 - Structure From Motion (SFM)
197 - Stereo and Multi-Camera Calibration and Depth Computation
198 - Mobile Robotics.
199
200 %description -l pl.UTF-8
201 OpenCV (Open Source Computer Vision) to biblioteka funkcji
202 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
203
204 Przykładowe zastosowania biblioteki OpenCV to
205 - interakcje człowiek-komputer (HCI)
206 - identyfikacja, segmentacja i rozpoznawanie obiektów
207 - rozpoznawanie twarzy
208 - rozpoznawanie gestów
209 - śledzenie ruchu
210 - rozumienie ruchu
211 - SFM (Structure From Motion)
212 - kalibracja dwu- i wielokamerowa, obliczanie głębi
213 - robotyka ruchu.
214
215 %package core
216 Summary:        OpenCV core libraries
217 Summary(pl.UTF-8):      Podstawowe biblioteki OpenCV
218 Group:          Libraries
219 Conflicts:      opencv < 2.4.6.2-1
220
221 %description core
222 This package contains the OpenCV C/C++ core libraries.
223
224 %description core -l pl.UTF-8
225 Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
226
227 %package viz
228 Summary:        OpenCV viz library (VTK support)
229 Summary(pl.UTF-8):      Biblioteka OpenCV viz (obsługa VTK)
230 Group:          Libraries
231 Requires:       %{name} = %{epoch}:%{version}-%{release}
232
233 %description viz
234 OpenCV viz library (VTK support).
235
236 %description viz -l pl.UTF-8
237 Biblioteka OpenCV viz (obsługa VTK).
238
239 %package devel
240 Summary:        Header files for OpenCV library
241 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
242 Group:          Development/Libraries
243 Requires:       %{name} = %{epoch}:%{version}-%{release}
244 %if %{with vtk}
245 Requires:       %{name}-viz = %{epoch}:%{version}-%{release}
246 %endif
247 Obsoletes:      opencv-static
248
249 %description devel
250 Header files for OpenCV library.
251
252 %description devel -l pl.UTF-8
253 Pliki nagłówkowe biblioteki OpenCV.
254
255 %package doc
256 Summary:        Manual for OpenCV
257 Summary(fr.UTF-8):      Documentation pour OpenCV
258 Summary(it.UTF-8):      Documentazione di OpenCV
259 Summary(pl.UTF-8):      Podręcznik dla OpenCV
260 Group:          Documentation
261 # noarch subpackages only when building with rpm5
262 BuildArch:      noarch
263
264 %description doc
265 Documentation for OpenCV.
266
267 %description doc -l fr.UTF-8
268 Documentation pour OpenCV.
269
270 %description doc -l it.UTF-8
271 Documentazione di OpenCV.
272
273 %description doc -l pl.UTF-8
274 Dokumentacja do OpenCV.
275
276 %package examples
277 Summary:        OpenCV code examples
278 Group:          Documentation
279 BuildArch:      noarch
280
281 %description examples
282 OpenCV code examples.
283
284 %package -n java-opencv
285 Summary:        OpenCV Java bindings
286 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
287 Group:          Libraries/Java
288 Requires:       %{name} = %{epoch}:%{version}-%{release}
289 Requires:       jre
290
291 %description -n java-opencv
292 OpenCV Java bindings.
293
294 %description -n java-opencv -l pl.UTF-8
295 Wiązania Javy do OpenCV.
296
297 %package -n python-opencv
298 Summary:        OpenCV Python 2 bindings
299 Summary(pl.UTF-8):      Wiązania Pythona 2 do OpenCV
300 Group:          Libraries/Python
301 Requires:       %{name} = %{epoch}:%{version}-%{release}
302 Requires:       python-libs
303
304 %description -n python-opencv
305 OpenCV Python 2 bindings.
306
307 %description -n python-opencv -l pl.UTF-8
308 Wiązania Pythona 2 do OpenCV.
309
310 %package -n python3-opencv
311 Summary:        OpenCV Python 3 bindings
312 Summary(pl.UTF-8):      Wiązania Pythona 3 do OpenCV
313 Group:          Libraries/Python
314 Requires:       %{name} = %{epoch}:%{version}-%{release}
315 Requires:       python3-libs
316
317 %description -n python3-opencv
318 OpenCV Python 3 bindings.
319
320 %description -n python3-opencv -l pl.UTF-8
321 Wiązania Pythona 3 do OpenCV.
322
323 %prep
324 %setup -q -a1
325
326 %undos CMakeLists.txt
327
328 %patch0 -p1
329 %patch1 -p1
330
331 cache_file() {
332         f="$1"
333         d="$2"
334         md5="$(md5sum "$f" | awk '{print $1}')"
335         file="$(basename "$f")"
336         mkdir -p ".cache/$d"
337         install "$f" ".cache/$d/$md5-$file"
338 }
339 for f in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16}; do
340         cache_file $f xfeatures2d/boostdesc
341 done
342 for f in %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23}; do
343         cache_file $f xfeatures2d/vgg
344 done
345 cache_file %{SOURCE30} data
346 cache_file %{SOURCE40} ade
347
348 %build
349 mkdir -p build
350 cd build
351
352 # handle cmake & ccache
353 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
354 if [[ "%{__cc}" = *ccache* ]]; then
355         cc="%{__cc}"
356         cxx="%{__cxx}"
357         ccache="
358         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
359         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
360         "
361 fi
362
363 %cmake .. \
364         $ccache \
365         -DENABLE_PRECOMPILED_HEADERS=OFF \
366         -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
367         -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
368         -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
369         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
370         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
371         -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
372         -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
373         -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
374         -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
375         -DBUILD_NEW_PYTHON_SUPPORT=ON \
376         -DOPENCV_GENERATE_PKGCONFIG:BOOL=ON \
377 %if %{with examples}
378         -DINSTALL_C_EXAMPLES=ON \
379         -DINSTALL_PYTHON_EXAMPLES=ON \
380 %endif
381         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
382         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
383         %{?with_opencl:-DWITH_OPENCL=ON} \
384         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
385         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
386         %{?with_opengl:-DWITH_OPENGL=ON} \
387         %{?with_openmp:-DWITH_OPENMP=ON} \
388         %{?with_openni:-DWITH_OPENNI=ON} \
389         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
390         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
391         %{?with_tbb:-DWITH_TBB=ON} \
392         %{?with_unicap:-DWITH_UNICAP=ON} \
393         %{!?with_v4l:-DWITH_V4L=OFF} \
394         %{?with_vtk:-DWITH_VTK=ON} \
395         %{?with_ximea:-DWITH_XIMEA=ON} \
396         %{?with_xine:-DWITH_XINE=ON} \
397         -DWITH_IPP=OFF
398
399 %{__make}
400
401 %install
402 rm -rf $RPM_BUILD_ROOT
403 %{__make} -C build install \
404         DESTDIR=$RPM_BUILD_ROOT
405
406 %if %{with examples}
407 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
408 mv $RPM_BUILD_ROOT%{_datadir}/opencv4/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
409 %endif
410
411 # disable completeness check incompatible with split packaging
412 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules.cmake
413
414 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
415 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
416 %py_postclean
417
418 %if %{with java}
419 # move to proper directories, create symlink
420 install -d $RPM_BUILD_ROOT%{_javadir}
421 %{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
422 sed -i -e 's#/share/java/opencv4/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
423         $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules-pld.cmake
424 %{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
425 rmdir $RPM_BUILD_ROOT%{_javadir}/opencv4
426 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
427 %endif
428
429 %clean
430 rm -rf $RPM_BUILD_ROOT
431
432 %post   -p /sbin/ldconfig
433 %postun -p /sbin/ldconfig
434
435 %post   core -p /sbin/ldconfig
436 %postun core -p /sbin/ldconfig
437
438 %post   viz -p /sbin/ldconfig
439 %postun viz -p /sbin/ldconfig
440
441 %post   -n java-opencv -p /sbin/ldconfig
442 %postun -n java-opencv -p /sbin/ldconfig
443
444 %files
445 %defattr(644,root,root,755)
446 %attr(755,root,root) %{_bindir}/opencv_annotation
447 #%attr(755,root,root) %{_bindir}/opencv_createsamples
448 %attr(755,root,root) %{_bindir}/opencv_interactive-calibration
449 #%attr(755,root,root) %{_bindir}/opencv_traincascade
450 %attr(755,root,root) %{_bindir}/opencv_version
451 %attr(755,root,root) %{_bindir}/opencv_visualisation
452 %attr(755,root,root) %{_bindir}/setup_vars_opencv4.sh
453 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
454 %attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
455 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
456 %attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
457 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
458 %attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
459 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
460 %attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
461 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
462 %attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
463 %attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
464 %attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
465 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
466 %attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
467 # contrib modules
468 %attr(755,root,root) %{_bindir}/opencv_waldboost_detector
469 %attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
470 %attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
471 %attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
472 %attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
473 %attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
474 %attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
475 %attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
476 %attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
477 %attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
478 %attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
479 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
480 %attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
481 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
482 %attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
483 %attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
484 %attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
485 %attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
486 %attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
487 %attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
488 %attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
489 %attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
490 %attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
491 %attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
492 %attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
493 %attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
494 %attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
495 %attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
496 %attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
497 %attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
498 %attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
499 %attr(755,root,root) %ghost %{_libdir}/libopencv_ovis.so.%{sover}
500 %attr(755,root,root) %{_libdir}/libopencv_ovis.so.*.*.*
501 %attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
502 %attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
503 %attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
504 %attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
505 %attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
506 %attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
507 %attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
508 %attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
509 %attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
510 %attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
511 %attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
512 %attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
513 %attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
514 %attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
515 %attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
516 %attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
517 %attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
518 %attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
519 %attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
520 %attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
521 %attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
522 %attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
523 %attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
524 %attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
525 %attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
526 %attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
527 %attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
528 %attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
529 %attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
530 %attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
531 %attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
532 %attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
533 %attr(755,root,root) %ghost %{_libdir}/libopencv_alphamat.so.%{sover}
534 %attr(755,root,root) %{_libdir}/libopencv_alphamat.so.*.*.*
535 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_superres.so.%{sover}
536 %attr(755,root,root) %{_libdir}/libopencv_dnn_superres.so.*.*.*
537 %attr(755,root,root) %ghost %{_libdir}/libopencv_gapi.so.%{sover}
538 %attr(755,root,root) %{_libdir}/libopencv_gapi.so.*.*.*
539 %attr(755,root,root) %ghost %{_libdir}/libopencv_intensity_transform.so.%{sover}
540 %attr(755,root,root) %{_libdir}/libopencv_intensity_transform.so.*.*.*
541 %attr(755,root,root) %ghost %{_libdir}/libopencv_mcc.so.%{sover}
542 %attr(755,root,root) %{_libdir}/libopencv_mcc.so.*.*.*
543 %attr(755,root,root) %ghost %{_libdir}/libopencv_quality.so.%{sover}
544 %attr(755,root,root) %{_libdir}/libopencv_quality.so.*.*.*
545 %attr(755,root,root) %ghost %{_libdir}/libopencv_rapid.so.%{sover}
546 %attr(755,root,root) %{_libdir}/libopencv_rapid.so.*.*.*
547
548 %dir %{_datadir}/opencv4
549 %{_datadir}/opencv4/haarcascades
550 %{_datadir}/opencv4/lbpcascades
551 %{_datadir}/opencv4/quality
552
553 %files core
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
556 %attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
557 %attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
558 %attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
559 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
560 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
561 %attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
562 %attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
563 %attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
564 %attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
565 %attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
566 %attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
567 %attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
568 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
569 %attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
570 %attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
571 %attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
572 %attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
573
574 %if %{with vtk}
575 %files viz
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
578 %attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
579 %endif
580
581 %files devel
582 %defattr(644,root,root,755)
583 # core
584 %{_libdir}/libopencv_core.so
585 %{_libdir}/libopencv_flann.so
586 %{_libdir}/libopencv_imgproc.so
587 %{_libdir}/libopencv_ml.so
588 %{_libdir}/libopencv_photo.so
589 %{_libdir}/libopencv_video.so
590 # GUI/extensions (base package)
591 %{_libdir}/libopencv_calib3d.so
592 %{_libdir}/libopencv_features2d.so
593 %{_libdir}/libopencv_highgui.so
594 %{_libdir}/libopencv_objdetect.so
595 %{_libdir}/libopencv_stitching.so
596 %{_libdir}/libopencv_superres.so
597 %{_libdir}/libopencv_videostab.so
598 %{_libdir}/libopencv_imgcodecs.so
599 %{_libdir}/libopencv_shape.so
600 %{_libdir}/libopencv_videoio.so
601 # contrib
602 %{_libdir}/libopencv_aruco.so
603 %{_libdir}/libopencv_bgsegm.so
604 %{_libdir}/libopencv_bioinspired.so
605 %{_libdir}/libopencv_ccalib.so
606 %{_libdir}/libopencv_datasets.so
607 %{_libdir}/libopencv_dnn.so
608 %{_libdir}/libopencv_dnn_objdetect.so
609 %{_libdir}/libopencv_dpm.so
610 %{_libdir}/libopencv_face.so
611 %{_libdir}/libopencv_freetype.so
612 %{_libdir}/libopencv_fuzzy.so
613 %{_libdir}/libopencv_hdf.so
614 %{_libdir}/libopencv_hfs.so
615 %{_libdir}/libopencv_img_hash.so
616 %{_libdir}/libopencv_line_descriptor.so
617 %{_libdir}/libopencv_optflow.so
618 %{_libdir}/libopencv_ovis.so
619 %{_libdir}/libopencv_phase_unwrapping.so
620 %{_libdir}/libopencv_plot.so
621 %{_libdir}/libopencv_reg.so
622 %{_libdir}/libopencv_rgbd.so
623 %{_libdir}/libopencv_saliency.so
624 %{_libdir}/libopencv_sfm.so
625 %{_libdir}/libopencv_stereo.so
626 %{_libdir}/libopencv_structured_light.so
627 %{_libdir}/libopencv_surface_matching.so
628 %{_libdir}/libopencv_text.so
629 %{_libdir}/libopencv_tracking.so
630 %{_libdir}/libopencv_xfeatures2d.so
631 %{_libdir}/libopencv_ximgproc.so
632 %{_libdir}/libopencv_xobjdetect.so
633 %{_libdir}/libopencv_xphoto.so
634 %{_libdir}/libopencv_alphamat.so
635 %{_libdir}/libopencv_dnn_superres.so
636 %{_libdir}/libopencv_gapi.so
637 %{_libdir}/libopencv_intensity_transform.so
638 %{_libdir}/libopencv_mcc.so
639 %{_libdir}/libopencv_quality.so
640 %{_libdir}/libopencv_rapid.so
641 # viz
642 %if %{with vtk}
643 %{_libdir}/libopencv_viz.so
644 %endif
645 %{_includedir}/opencv4
646 %{_libdir}/cmake/opencv4/OpenCV*.cmake
647 %{_pkgconfigdir}/opencv4.pc
648
649 %files doc
650 %defattr(644,root,root,755)
651 # TODO: probably could rebuild them and package via make install
652 %doc doc/*
653
654 %if %{with examples}
655 %files examples
656 %defattr(644,root,root,755)
657 %{_examplesdir}/%{name}-%{version}
658 %endif
659
660 %if %{with java}
661 %files -n java-opencv
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
664 %{_javadir}/opencv-%{jver}.jar
665 %{_javadir}/opencv.jar
666 %endif
667
668 %files -n python-opencv
669 %defattr(644,root,root,755)
670 %dir %{py_sitedir}/cv2
671 %dir %{py_sitedir}/cv2/python-*
672 %attr(755,root,root) %{py_sitedir}/cv2/python-*/cv2.so
673 %{py_sitedir}/cv2/*.py[co]
674
675 %files -n python3-opencv
676 %defattr(644,root,root,755)
677 %dir %{py3_sitedir}/cv2
678 %dir %{py3_sitedir}/cv2/python-*
679 %attr(755,root,root) %{py3_sitedir}/cv2/python-*/cv2.cpython-*.so
680 %{py3_sitedir}/cv2/*.py
This page took 0.12231 seconds and 4 git commands to generate.