]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
- try to fix ade caching for gapi
[packages/opencv.git] / opencv.spec
1 # TODO:
2 # - contrib subpackage(s)
3 # - contrib BRs:
4 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5 #   opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
6 # unpackaged (4.5.5)
7 #/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
8 #/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
9 #/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
10 #/usr/share/OpenCV/valgrind.supp
11 #/usr/share/OpenCV/valgrind_3rdparty.supp
12
13 #
14 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
15 # - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
16 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
17 #
18 # Conditional build:
19 # - general options:
20 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
21 %bcond_with     sse             # use SSE instructions
22 %bcond_with     sse2            # use SSE2 instructions
23 %bcond_with     sse3            # use SSE3 instructions
24 %bcond_with     ssse3           # use SSSE3 instructions
25 %bcond_with     sse41           # use SSE4.1 instructions
26 %bcond_with     sse42           # use SSE4.2 instructions
27 %bcond_with     avx             # use AVX instructions
28 %bcond_without  opencl          # OpenCL support
29 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
30 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
31 %bcond_without  opengl          # OpenGL support
32 %bcond_without  openmp          # OpenMP support (available when not using tbb)
33 %bcond_without  examples        # Install examples
34 # - bindings
35 %bcond_without  java            # Java binding
36 # - highgui options:
37 %bcond_without  ffmpeg          # FFMpeg support in highgui
38 %bcond_without  gstreamer       # GStreamer support in highgui
39 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
40 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
41 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
42 %bcond_with     unicap          # Unicap support in highgui (GPL)
43 %bcond_without  v4l             # Video4Linux in highgui
44 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
45 %bcond_with     xine            # XINE support in highgui (GPL)
46 # - other modules
47 %bcond_without  vtk             # VTK library support (opencv_viz module)
48
49 %ifarch pentium3 pentium4 %{x8664} x32
50 %define         with_sse        1
51 %endif
52 %ifarch pentium4 %{x8664} x32
53 %define         with_sse2       1
54 %endif
55 Summary:        A library of programming functions mainly aimed at real time computer vision
56 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
57 Name:           opencv
58 Version:        4.5.5
59 Release:        1
60 Epoch:          1
61 %if %{with unicap} || %{with xine}
62 License:        GPL (enforced by used libraries), BSD (opencv itself)
63 %else
64 License:        BSD
65 %endif
66 Group:          Libraries
67 Source0:        https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
68 # Source0-md5:  a9782f01883fcf51451a183d05bda33d
69 Source1:        https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
70 # Source1-md5:  073793e8085ec2490b3386e04ee20fbc
71 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
72 Source10:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
73 # Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
74 Source11:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
75 # Source11-md5: 232c966b13651bd0e46a1497b0852191
76 Source12:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
77 # Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
78 Source13:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
79 # Source13-md5: 202e1b3e9fec871b04da31f7f016679f
80 Source14:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
81 # Source14-md5: 98ea99d399965c03d555cef3ea502a0b
82 Source15:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
83 # Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
84 Source16:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
85 # Source16-md5: 0ae0675534aa318d9668f2a179c2a052
86 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
87 Source20:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
88 # Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
89 Source21:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
90 # Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
91 Source22:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
92 # Source22-md5: 7cd47228edec52b6d82f46511af325c5
93 Source23:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
94 # Source23-md5: 151805e03568c9f490a5e3a872777b75
95 # See opencv_contrib-3.4.1/modules/face/CMakeLists.txt
96 Source30:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
97 # Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
98 # See opencv-4.5.1/modules/gapi/cmake/DownloadADE.cmake
99 Source40:       https://github.com/opencv/ade/archive/v0.1.2a/ade-0.1.2a.zip
100 # Source40-md5: fa4b3e25167319cb0fa9432ef8281945
101 Patch0:         %{name}-ximea.patch
102 Patch1:         python-install.patch
103 Patch2:         pkgconfig-paths.patch
104 Patch3:         no-cxx-in-c-header.patch
105 Patch4:         gcc11.patch
106 Patch5:         %{name}-ade.patch
107 URL:            http://www.opencv.org/
108 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
109 %{?with_opencl:BuildRequires:   OpenCL-devel}
110 BuildRequires:  OpenEXR-devel
111 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
112 %if %{with opengl}
113 BuildRequires:  OpenGL-devel
114 BuildRequires:  libglvnd-libGL-devel
115 %endif
116 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
117 %{?with_openni:BuildRequires:   OpenNI-devel}
118 %{?with_ximea:BuildRequires:    XIMEA-devel >= 4}
119 %{?with_java:BuildRequires:     ant}
120 BuildRequires:  boost-devel
121 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
122 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
123 BuildRequires:  cmake >= 3.5.1
124 BuildRequires:  doxygen
125 BuildRequires:  eigen3 >= 3
126 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
127 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
128 BuildRequires:  gflags-devel
129 BuildRequires:  gl2ps-devel
130 BuildRequires:  glog-devel
131 %if %{with gstreamer}
132 BuildRequires:  gstreamer-devel >= 1.0
133 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
134 %endif
135 BuildRequires:  jasper-devel
136 %if %{with java}
137 BuildRequires:  jdk
138 BuildRequires:  java-xerces
139 %endif
140 BuildRequires:  khrplatform-devel
141 BuildRequires:  libdc1394-devel >= 2
142 %{?with_openmp:BuildRequires:   libgomp-devel}
143 BuildRequires:  libjpeg-devel
144 BuildRequires:  libpng-devel
145 BuildRequires:  libraw1394-devel
146 BuildRequires:  libstdc++-devel
147 BuildRequires:  libtiff-devel
148 BuildRequires:  libtool
149 %if %{with unicap}
150 BuildRequires:  libucil-devel
151 BuildRequires:  libunicap-devel
152 %endif
153 BuildRequires:  libv4l-devel
154 BuildRequires:  ogre-devel
155 BuildRequires:  pkgconfig
156 BuildRequires:  hdf5-devel
157 BuildRequires:  protobuf-devel
158 BuildRequires:  python >= 1:2.7
159 BuildRequires:  python-devel >= 1:2.7
160 BuildRequires:  python-numpy-devel
161 BuildRequires:  python3 >= 1:3.2
162 BuildRequires:  python3-devel >= 1:3.2
163 BuildRequires:  python3-numpy-devel
164 BuildRequires:  rpm-build >= 4.6
165 BuildRequires:  rpm-pythonprov
166 BuildRequires:  rpmbuild(macros) >= 1.606
167 BuildRequires:  sed >= 4.0
168 BuildRequires:  sphinx-pdg
169 BuildRequires:  swig-python
170 %{?with_tbb:BuildRequires:      tbb-devel}
171 BuildRequires:  tesseract-devel
172 %if %{with vtk}
173 BuildRequires:  vtk-devel >= 5.8.0
174 BuildRequires:  vtk-java >= 5.8.0
175 BuildRequires:  vtk-python3-devel >= 5.8.0
176 %endif
177 %{?with_xine:BuildRequires:     xine-lib-devel}
178 BuildRequires:  xorg-lib-libX11-devel
179 BuildRequires:  zlib-devel >= 1.2.3
180 %if %{with qt}
181 BuildRequires:  QtCore-devel >= 4
182 BuildRequires:  QtGui-devel >= 4
183 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
184 BuildRequires:  qt4-qmake >= 4
185 %else
186 BuildRequires:  gtk+2-devel >= 2.0
187 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
188 %endif
189 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
190 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
191
192 %define         jver    %(echo %{version} | cut -d. -f1-3 | tr -d .)
193 %define         sover   405
194
195 %description
196 OpenCV (Open Source Computer Vision) is a library of programming
197 functions mainly aimed at real time computer vision.
198
199 Example applications of the OpenCV library are:
200 - Human-Computer Interaction (HCI)
201 - Object Identification, Segmentation and Recognition
202 - Face Recognition
203 - Gesture Recognition
204 - Motion Tracking
205 - Ego Motion, Motion Understanding
206 - Structure From Motion (SFM)
207 - Stereo and Multi-Camera Calibration and Depth Computation
208 - Mobile Robotics.
209
210 %description -l pl.UTF-8
211 OpenCV (Open Source Computer Vision) to biblioteka funkcji
212 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
213
214 Przykładowe zastosowania biblioteki OpenCV to
215 - interakcje człowiek-komputer (HCI)
216 - identyfikacja, segmentacja i rozpoznawanie obiektów
217 - rozpoznawanie twarzy
218 - rozpoznawanie gestów
219 - śledzenie ruchu
220 - rozumienie ruchu
221 - SFM (Structure From Motion)
222 - kalibracja dwu- i wielokamerowa, obliczanie głębi
223 - robotyka ruchu.
224
225 %package core
226 Summary:        OpenCV core libraries
227 Summary(pl.UTF-8):      Podstawowe biblioteki OpenCV
228 Group:          Libraries
229 Conflicts:      opencv < 2.4.6.2-1
230
231 %description core
232 This package contains the OpenCV C/C++ core libraries.
233
234 %description core -l pl.UTF-8
235 Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
236
237 %package viz
238 Summary:        OpenCV viz library (VTK support)
239 Summary(pl.UTF-8):      Biblioteka OpenCV viz (obsługa VTK)
240 Group:          Libraries
241 Requires:       %{name} = %{epoch}:%{version}-%{release}
242
243 %description viz
244 OpenCV viz library (VTK support).
245
246 %description viz -l pl.UTF-8
247 Biblioteka OpenCV viz (obsługa VTK).
248
249 %package devel
250 Summary:        Header files for OpenCV library
251 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
252 Group:          Development/Libraries
253 Requires:       %{name} = %{epoch}:%{version}-%{release}
254 %if %{with vtk}
255 Requires:       %{name}-viz = %{epoch}:%{version}-%{release}
256 %endif
257 Obsoletes:      opencv-static < 1:2
258
259 %description devel
260 Header files for OpenCV library.
261
262 %description devel -l pl.UTF-8
263 Pliki nagłówkowe biblioteki OpenCV.
264
265 %package doc
266 Summary:        Manual for OpenCV
267 Summary(fr.UTF-8):      Documentation pour OpenCV
268 Summary(it.UTF-8):      Documentazione di OpenCV
269 Summary(pl.UTF-8):      Podręcznik dla OpenCV
270 Group:          Documentation
271 BuildArch:      noarch
272
273 %description doc
274 Documentation for OpenCV.
275
276 %description doc -l fr.UTF-8
277 Documentation pour OpenCV.
278
279 %description doc -l it.UTF-8
280 Documentazione di OpenCV.
281
282 %description doc -l pl.UTF-8
283 Dokumentacja do OpenCV.
284
285 %package examples
286 Summary:        OpenCV code examples
287 Summary(pl.UTF-8):      Przykłady kodu OpenCV
288 Group:          Documentation
289 BuildArch:      noarch
290
291 %description examples
292 OpenCV code examples.
293
294 %description examples -l pl.UTF-8
295 Przykłady kodu OpenCV.
296
297 %package -n java-opencv
298 Summary:        OpenCV Java bindings
299 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
300 Group:          Libraries/Java
301 Requires:       %{name} = %{epoch}:%{version}-%{release}
302 Requires:       jre
303
304 %description -n java-opencv
305 OpenCV Java bindings.
306
307 %description -n java-opencv -l pl.UTF-8
308 Wiązania Javy do OpenCV.
309
310 %package -n python-opencv
311 Summary:        OpenCV Python 2 bindings
312 Summary(pl.UTF-8):      Wiązania Pythona 2 do OpenCV
313 Group:          Libraries/Python
314 Requires:       %{name} = %{epoch}:%{version}-%{release}
315 Requires:       python-libs >= 1:2.7
316
317 %description -n python-opencv
318 OpenCV Python 2 bindings.
319
320 %description -n python-opencv -l pl.UTF-8
321 Wiązania Pythona 2 do OpenCV.
322
323 %package -n python3-opencv
324 Summary:        OpenCV Python 3 bindings
325 Summary(pl.UTF-8):      Wiązania Pythona 3 do OpenCV
326 Group:          Libraries/Python
327 Requires:       %{name} = %{epoch}:%{version}-%{release}
328 Requires:       python3-libs
329
330 %description -n python3-opencv
331 OpenCV Python 3 bindings.
332
333 %description -n python3-opencv -l pl.UTF-8
334 Wiązania Pythona 3 do OpenCV.
335
336 %prep
337 %setup -q -a1
338
339 %undos CMakeLists.txt
340
341 %patch0 -p1
342 %patch1 -p1
343 %patch2 -p1
344 %patch3 -p1
345 %patch4 -p1
346 %patch5 -p1
347
348 cache_file() {
349         f="$1"
350         d="$2"
351         md5="$(md5sum "$f" | awk '{print $1}')"
352         file="$(basename "$f")"
353         destfile="${md5}-${3:-${file}}"
354         mkdir -p ".cache/$d"
355         ln -s --relative "$f" ".cache/$d/$destfile"
356 }
357 for f in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16}; do
358         cache_file $f xfeatures2d/boostdesc
359 done
360 for f in %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23}; do
361         cache_file $f xfeatures2d/vgg
362 done
363 cache_file %{SOURCE30} data
364 cache_file %{SOURCE40} ade v0.1.2a.zip
365
366 cd opencv_contrib-%{version}
367
368 # both files use Glog_FOUND variable, but set different variables for LIBS; unify them so they won't disturb each other
369 cp -f modules/sfm/cmake/FindGlog.cmake modules/cnn_3dobj/FindGlog.cmake
370 %{__sed} -i -e 's/Glog_LIBS/GLOG_LIBRARIES/' modules/cnn_3dobj/CMakeLists.txt
371
372 %build
373 mkdir -p build
374 cd build
375
376 # handle cmake & ccache
377 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
378 if [[ "%{__cc}" = *ccache* ]]; then
379         cc="%{__cc}"
380         cxx="%{__cxx}"
381         ccache="
382         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
383         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
384         "
385 fi
386
387 # WITH_GTK_2_X=ON: force gtk+2 instead of gtk+3
388 # (as of 4.5.5, OpenGL is not supported with gtk+3, leading to highgui linking errors)
389 %cmake .. \
390         $ccache \
391         -DOpenGL_GL_PREFERENCE=GLVND \
392         -DENABLE_PRECOMPILED_HEADERS=OFF \
393         -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
394         -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
395         -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
396         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
397         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
398         -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
399         -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
400         -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
401         -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
402         -DBUILD_NEW_PYTHON_SUPPORT=ON \
403         -DOPENCV_GENERATE_PKGCONFIG:BOOL=ON \
404 %if %{with examples}
405         -DINSTALL_C_EXAMPLES=ON \
406         -DINSTALL_PYTHON_EXAMPLES=ON \
407 %endif
408         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
409         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
410         -DWITH_GTK_2_X=ON \
411         %{?with_opencl:-DWITH_OPENCL=ON} \
412         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
413         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
414         %{?with_opengl:-DWITH_OPENGL=ON} \
415         %{?with_openmp:-DWITH_OPENMP=ON} \
416         %{?with_openni:-DWITH_OPENNI=ON} \
417         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
418         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
419         %{?with_tbb:-DWITH_TBB=ON} \
420         %{?with_unicap:-DWITH_UNICAP=ON} \
421         %{!?with_v4l:-DWITH_V4L=OFF} \
422         %{?with_vtk:-DWITH_VTK=ON} \
423         %{?with_ximea:-DWITH_XIMEA=ON} \
424         %{?with_xine:-DWITH_XINE=ON} \
425         -DWITH_IPP=OFF
426
427 %{__make}
428
429 %install
430 rm -rf $RPM_BUILD_ROOT
431 %{__make} -C build install \
432         DESTDIR=$RPM_BUILD_ROOT
433
434 %if %{with examples}
435 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
436 mv $RPM_BUILD_ROOT%{_datadir}/opencv4/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
437 %endif
438
439 # disable completeness check incompatible with split packaging
440 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules.cmake
441
442 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
443 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
444 %py_postclean
445
446 %if %{with java}
447 # move to proper directories, create symlink
448 install -d $RPM_BUILD_ROOT%{_javadir}
449 %{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
450 sed -i -e 's#/share/java/opencv4/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
451         $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules-pld.cmake
452 %{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
453 rmdir $RPM_BUILD_ROOT%{_javadir}/opencv4
454 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
455 %endif
456
457 %clean
458 rm -rf $RPM_BUILD_ROOT
459
460 %post   -p /sbin/ldconfig
461 %postun -p /sbin/ldconfig
462
463 %post   core -p /sbin/ldconfig
464 %postun core -p /sbin/ldconfig
465
466 %post   viz -p /sbin/ldconfig
467 %postun viz -p /sbin/ldconfig
468
469 %post   -n java-opencv -p /sbin/ldconfig
470 %postun -n java-opencv -p /sbin/ldconfig
471
472 %files
473 %defattr(644,root,root,755)
474 %attr(755,root,root) %{_bindir}/opencv_annotation
475 %attr(755,root,root) %{_bindir}/opencv_interactive-calibration
476 %attr(755,root,root) %{_bindir}/opencv_model_diagnostics
477 %attr(755,root,root) %{_bindir}/opencv_version
478 %attr(755,root,root) %{_bindir}/opencv_visualisation
479 %attr(755,root,root) %{_bindir}/setup_vars_opencv4.sh
480 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
481 %attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
482 %attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
483 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
484 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
485 %attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
486 %attr(755,root,root) %{_libdir}/libopencv_gapi.so.*.*.*
487 %attr(755,root,root) %ghost %{_libdir}/libopencv_gapi.so.%{sover}
488 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
489 %attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
490 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
491 %attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
492 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
493 %attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
494 %attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
495 %attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
496 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
497 %attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
498 # contrib modules
499 %attr(755,root,root) %{_bindir}/opencv_waldboost_detector
500 %attr(755,root,root) %ghost %{_libdir}/libopencv_alphamat.so.%{sover}
501 %attr(755,root,root) %{_libdir}/libopencv_alphamat.so.*.*.*
502 %attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
503 %attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
504 %attr(755,root,root) %ghost %{_libdir}/libopencv_barcode.so.%{sover}
505 %attr(755,root,root) %{_libdir}/libopencv_barcode.so.*.*.*
506 %attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
507 %attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
508 %attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
509 %attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
510 %attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
511 %attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
512 %attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
513 %attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
514 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
515 %attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
516 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_superres.so.%{sover}
517 %attr(755,root,root) %{_libdir}/libopencv_dnn_superres.so.*.*.*
518 %attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
519 %attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
520 %attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
521 %attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
522 %attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
523 %attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
524 %attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
525 %attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
526 %attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
527 %attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
528 %attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
529 %attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
530 %attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
531 %attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
532 %attr(755,root,root) %ghost %{_libdir}/libopencv_intensity_transform.so.%{sover}
533 %attr(755,root,root) %{_libdir}/libopencv_intensity_transform.so.*.*.*
534 %attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
535 %attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
536 %attr(755,root,root) %ghost %{_libdir}/libopencv_mcc.so.%{sover}
537 %attr(755,root,root) %{_libdir}/libopencv_mcc.so.*.*.*
538 %attr(755,root,root) %ghost %{_libdir}/libopencv_ovis.so.%{sover}
539 %attr(755,root,root) %{_libdir}/libopencv_ovis.so.*.*.*
540 %attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
541 %attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
542 %attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
543 %attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
544 %attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
545 %attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
546 %attr(755,root,root) %ghost %{_libdir}/libopencv_quality.so.%{sover}
547 %attr(755,root,root) %{_libdir}/libopencv_quality.so.*.*.*
548 %attr(755,root,root) %ghost %{_libdir}/libopencv_rapid.so.%{sover}
549 %attr(755,root,root) %{_libdir}/libopencv_rapid.so.*.*.*
550 %attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
551 %attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
552 %attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
553 %attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
554 %attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
555 %attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
556 %attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
557 %attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
558 %attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
559 %attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
560 %attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
561 %attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
562 %attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
563 %attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
564 %attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
565 %attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
566 %attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
567 %attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
568 %attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
569 %attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
570 %attr(755,root,root) %ghost %{_libdir}/libopencv_wechat_qrcode.so.%{sover}
571 %attr(755,root,root) %{_libdir}/libopencv_wechat_qrcode.so.*.*.*
572 %attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
573 %attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
574 %attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
575 %attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
576 %attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
577 %attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
578 %attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
579 %attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
580
581 %dir %{_datadir}/opencv4
582 %{_datadir}/opencv4/haarcascades
583 %{_datadir}/opencv4/lbpcascades
584 %{_datadir}/opencv4/quality
585
586 %files core
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
589 %attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
590 %attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
591 %attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
592 %attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
593 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
594 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
595 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
596 %attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
597 %attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
598 %attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
599 %attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
600 %attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
601 %attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
602 %attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
603 %attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
604
605 %if %{with vtk}
606 %files viz
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
609 %attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
610 %endif
611
612 %files devel
613 %defattr(644,root,root,755)
614 # core
615 %{_libdir}/libopencv_core.so
616 %{_libdir}/libopencv_dnn.so
617 %{_libdir}/libopencv_flann.so
618 %{_libdir}/libopencv_imgcodecs.so
619 %{_libdir}/libopencv_imgproc.so
620 %{_libdir}/libopencv_ml.so
621 %{_libdir}/libopencv_photo.so
622 %{_libdir}/libopencv_video.so
623 %{_libdir}/libopencv_videoio.so
624 # GUI/extensions (base package)
625 %{_libdir}/libopencv_calib3d.so
626 %{_libdir}/libopencv_features2d.so
627 %{_libdir}/libopencv_gapi.so
628 %{_libdir}/libopencv_highgui.so
629 %{_libdir}/libopencv_objdetect.so
630 %{_libdir}/libopencv_stitching.so
631 # contrib
632 %{_libdir}/libopencv_alphamat.so
633 %{_libdir}/libopencv_aruco.so
634 %{_libdir}/libopencv_barcode.so
635 %{_libdir}/libopencv_bgsegm.so
636 %{_libdir}/libopencv_bioinspired.so
637 %{_libdir}/libopencv_ccalib.so
638 %{_libdir}/libopencv_datasets.so
639 %{_libdir}/libopencv_dnn_objdetect.so
640 %{_libdir}/libopencv_dnn_superres.so
641 %{_libdir}/libopencv_dpm.so
642 %{_libdir}/libopencv_face.so
643 %{_libdir}/libopencv_freetype.so
644 %{_libdir}/libopencv_fuzzy.so
645 %{_libdir}/libopencv_hdf.so
646 %{_libdir}/libopencv_hfs.so
647 %{_libdir}/libopencv_img_hash.so
648 %{_libdir}/libopencv_intensity_transform.so
649 %{_libdir}/libopencv_line_descriptor.so
650 %{_libdir}/libopencv_mcc.so
651 %{_libdir}/libopencv_optflow.so
652 %{_libdir}/libopencv_ovis.so
653 %{_libdir}/libopencv_phase_unwrapping.so
654 %{_libdir}/libopencv_plot.so
655 %{_libdir}/libopencv_quality.so
656 %{_libdir}/libopencv_rapid.so
657 %{_libdir}/libopencv_reg.so
658 %{_libdir}/libopencv_rgbd.so
659 %{_libdir}/libopencv_saliency.so
660 %{_libdir}/libopencv_sfm.so
661 %{_libdir}/libopencv_shape.so
662 %{_libdir}/libopencv_stereo.so
663 %{_libdir}/libopencv_superres.so
664 %{_libdir}/libopencv_structured_light.so
665 %{_libdir}/libopencv_surface_matching.so
666 %{_libdir}/libopencv_text.so
667 %{_libdir}/libopencv_tracking.so
668 %{_libdir}/libopencv_videostab.so
669 %{_libdir}/libopencv_wechat_qrcode.so
670 %{_libdir}/libopencv_xfeatures2d.so
671 %{_libdir}/libopencv_ximgproc.so
672 %{_libdir}/libopencv_xobjdetect.so
673 %{_libdir}/libopencv_xphoto.so
674 # viz
675 %if %{with vtk}
676 %{_libdir}/libopencv_viz.so
677 %endif
678 %{_includedir}/opencv4
679 %dir %{_libdir}/cmake/opencv4
680 %{_libdir}/cmake/opencv4/OpenCV*.cmake
681 %{_pkgconfigdir}/opencv4.pc
682
683 %files doc
684 %defattr(644,root,root,755)
685 # TODO: probably could rebuild them and package via make install
686 %doc doc/*
687
688 %if %{with examples}
689 %files examples
690 %defattr(644,root,root,755)
691 %{_examplesdir}/%{name}-%{version}
692 %endif
693
694 %if %{with java}
695 %files -n java-opencv
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
698 %{_javadir}/opencv-%{jver}.jar
699 %{_javadir}/opencv.jar
700 %endif
701
702 %files -n python-opencv
703 %defattr(644,root,root,755)
704 %dir %{py_sitedir}/cv2
705 %dir %{py_sitedir}/cv2/python-*
706 %attr(755,root,root) %{py_sitedir}/cv2/python-*/cv2.so
707 %{py_sitedir}/cv2/*.py[co]
708 %{py_sitedir}/cv2/mat_wrapper
709 %{py_sitedir}/cv2/misc
710 %{py_sitedir}/cv2/utils
711
712 %files -n python3-opencv
713 %defattr(644,root,root,755)
714 %dir %{py3_sitedir}/cv2
715 %dir %{py3_sitedir}/cv2/python-*
716 %attr(755,root,root) %{py3_sitedir}/cv2/python-*/cv2.cpython-*.so
717 %{py3_sitedir}/cv2/*.py
718 %{py3_sitedir}/cv2/gapi
719 %{py3_sitedir}/cv2/mat_wrapper
720 %{py3_sitedir}/cv2/misc
721 %{py3_sitedir}/cv2/utils
This page took 0.179816 seconds and 4 git commands to generate.