]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
- rel 1
[packages/opencv.git] / opencv.spec
1 # TODO:
2 # - contrib subpackage(s)
3 # - contrib BRs:
4 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Protobuf)
6 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Glog)
7 #   opencv_contrib-3.1.0/modules/hdf/CMakeLists.txt:find_package(HDF5)
8 #   opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
9 #   opencv_contrib-3.1.0/modules/text/CMakeLists.txt:find_package(Tesseract)
10 # unpackaged (3.4.0)
11 #/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
12 #/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
13 #/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
14 #/usr/share/OpenCV/valgrind.supp
15 #/usr/share/OpenCV/valgrind_3rdparty.supp
16
17 #
18 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
19 # - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
20 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
21 #
22 # Conditional build:
23 # - general options:
24 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
25 %bcond_with     sse             # use SSE instructions
26 %bcond_with     sse2            # use SSE2 instructions
27 %bcond_with     sse3            # use SSE3 instructions
28 %bcond_with     ssse3           # use SSSE3 instructions
29 %bcond_with     sse41           # use SSE4.1 instructions
30 %bcond_with     sse42           # use SSE4.2 instructions
31 %bcond_with     avx             # use AVX instructions
32 %bcond_without  opencl          # OpenCL support
33 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
34 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
35 %bcond_without  opengl          # OpenGL support
36 %bcond_without  openmp          # OpenMP support (available when not using tbb)
37 %bcond_without  examples        # Install examples
38 # - bindings
39 %bcond_without  java            # Java binding
40 # - highgui options:
41 %bcond_without  ffmpeg          # FFMpeg support in highgui
42 %bcond_without  gstreamer       # GStreamer support in highgui
43 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
44 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
45 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
46 %bcond_with     unicap          # Unicap support in highgui (GPL)
47 %bcond_without  v4l             # Video4Linux in highgui
48 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
49 %bcond_with     xine            # XINE support in highgui (GPL)
50 # - other modules
51 %bcond_without  vtk             # VTK library support (opencv_viz module)
52
53 %ifarch pentium3 pentium4 %{x8664} x32
54 %define         with_sse        1
55 %endif
56 %ifarch pentium4 %{x8664} x32
57 %define         with_sse2       1
58 %endif
59 Summary:        A library of programming functions mainly aimed at real time computer vision
60 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
61 Name:           opencv
62 Version:        4.5.1
63 Release:        13
64 Epoch:          1
65 %if %{with unicap} || %{with xine}
66 License:        GPL (enforced by used libraries), BSD (opencv itself)
67 %else
68 License:        BSD
69 %endif
70 Group:          Libraries
71 Source0:        https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
72 # Source0-md5:  2205d3169238ec1f184438a96de68513
73 Source1:        https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
74 # Source1-md5:  19a31bf7271978ab426112dbf5d1b83f
75 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
76 Source10:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
77 # Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
78 Source11:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
79 # Source11-md5: 232c966b13651bd0e46a1497b0852191
80 Source12:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
81 # Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
82 Source13:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
83 # Source13-md5: 202e1b3e9fec871b04da31f7f016679f
84 Source14:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
85 # Source14-md5: 98ea99d399965c03d555cef3ea502a0b
86 Source15:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
87 # Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
88 Source16:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
89 # Source16-md5: 0ae0675534aa318d9668f2a179c2a052
90 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
91 Source20:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
92 # Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
93 Source21:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
94 # Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
95 Source22:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
96 # Source22-md5: 7cd47228edec52b6d82f46511af325c5
97 Source23:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
98 # Source23-md5: 151805e03568c9f490a5e3a872777b75
99 # See opencv_contrib-3.4.1/modules/face/CMakeLists.txt
100 Source30:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
101 # Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
102 # See opencv-4.5.1/modules/gapi/CMakeLists.txt
103 Source40:       https://github.com/opencv/ade/archive/v0.1.1f/v0.1.1f.zip
104 # Source40-md5: b624b995ec9c439cbc2e9e6ee940d3a2
105 Patch0:         %{name}-ximea.patch
106 Patch1:         python-install.patch
107 Patch2:         pkgconfig-paths.patch
108 Patch3:         no-cxx-in-c-header.patch
109 Patch4:         gcc11.patch
110 Patch5:         ogre2.patch
111 URL:            http://www.opencv.org/
112 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
113 %{?with_opencl:BuildRequires:   OpenCL-devel}
114 BuildRequires:  OpenEXR-devel
115 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
116 %if %{with opengl}
117 BuildRequires:  OpenGL-devel
118 BuildRequires:  libglvnd-libGL-devel
119 %endif
120 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
121 %{?with_openni:BuildRequires:   OpenNI-devel}
122 %{?with_ximea:BuildRequires:    XIMEA-devel >= 4}
123 %{?with_java:BuildRequires:     ant}
124 BuildRequires:  boost-devel
125 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
126 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
127 BuildRequires:  cmake >= 2.8
128 BuildRequires:  doxygen
129 BuildRequires:  eigen3 >= 3
130 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
131 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
132 BuildRequires:  gflags-devel
133 BuildRequires:  gl2ps-devel
134 BuildRequires:  glog-devel
135 %if %{with gstreamer}
136 BuildRequires:  gstreamer-devel >= 1.0
137 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
138 %endif
139 BuildRequires:  jasper-devel
140 %if %{with java}
141 BuildRequires:  jdk
142 BuildRequires:  java-xerces
143 %endif
144 BuildRequires:  khrplatform-devel
145 BuildRequires:  libdc1394-devel >= 2
146 %{?with_openmp:BuildRequires:   libgomp-devel}
147 BuildRequires:  libjpeg-devel
148 BuildRequires:  libpng-devel
149 BuildRequires:  libraw1394-devel
150 BuildRequires:  libstdc++-devel
151 BuildRequires:  libtiff-devel
152 BuildRequires:  libtool
153 %if %{with unicap}
154 BuildRequires:  libucil-devel
155 BuildRequires:  libunicap-devel
156 %endif
157 BuildRequires:  libv4l-devel
158 BuildRequires:  ogre-devel
159 BuildRequires:  pkgconfig
160 BuildRequires:  hdf5-devel
161 BuildRequires:  protobuf-devel
162 BuildRequires:  python >= 2.0
163 BuildRequires:  python-devel >= 2.0
164 BuildRequires:  python-numpy-devel
165 BuildRequires:  python3 >= 1:3.2
166 BuildRequires:  python3-devel >= 1:3.2
167 BuildRequires:  python3-numpy-devel
168 BuildRequires:  rpm-pythonprov
169 BuildRequires:  rpmbuild(macros) >= 1.606
170 BuildRequires:  sed >= 4.0
171 BuildRequires:  sphinx-pdg
172 BuildRequires:  swig-python
173 %{?with_tbb:BuildRequires:      tbb-devel}
174 %if %{with vtk}
175 BuildRequires:  vtk-devel >= 5.8.0
176 BuildRequires:  vtk-java >= 5.8.0
177 BuildRequires:  vtk-python3-devel >= 5.8.0
178 %endif
179 %{?with_xine:BuildRequires:     xine-lib-devel}
180 BuildRequires:  xorg-lib-libX11-devel
181 BuildRequires:  zlib-devel
182 %if %{with qt}
183 BuildRequires:  QtCore-devel >= 4
184 BuildRequires:  QtGui-devel >= 4
185 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
186 BuildRequires:  qt4-qmake >= 4
187 %else
188 BuildRequires:  gtk+2-devel >= 2.0
189 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
190 %endif
191 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
192 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
193
194 %define         jver    %(echo %{version} | cut -d. -f1-3 | tr -d .)
195 %define         sover   %(echo %{version} | cut -d. -f1-2)
196
197 %description
198 OpenCV (Open Source Computer Vision) is a library of programming
199 functions mainly aimed at real time computer vision.
200
201 Example applications of the OpenCV library are:
202 - Human-Computer Interaction (HCI)
203 - Object Identification, Segmentation and Recognition
204 - Face Recognition
205 - Gesture Recognition
206 - Motion Tracking
207 - Ego Motion, Motion Understanding
208 - Structure From Motion (SFM)
209 - Stereo and Multi-Camera Calibration and Depth Computation
210 - Mobile Robotics.
211
212 %description -l pl.UTF-8
213 OpenCV (Open Source Computer Vision) to biblioteka funkcji
214 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
215
216 Przykładowe zastosowania biblioteki OpenCV to
217 - interakcje człowiek-komputer (HCI)
218 - identyfikacja, segmentacja i rozpoznawanie obiektów
219 - rozpoznawanie twarzy
220 - rozpoznawanie gestów
221 - śledzenie ruchu
222 - rozumienie ruchu
223 - SFM (Structure From Motion)
224 - kalibracja dwu- i wielokamerowa, obliczanie głębi
225 - robotyka ruchu.
226
227 %package core
228 Summary:        OpenCV core libraries
229 Summary(pl.UTF-8):      Podstawowe biblioteki OpenCV
230 Group:          Libraries
231 Conflicts:      opencv < 2.4.6.2-1
232
233 %description core
234 This package contains the OpenCV C/C++ core libraries.
235
236 %description core -l pl.UTF-8
237 Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
238
239 %package viz
240 Summary:        OpenCV viz library (VTK support)
241 Summary(pl.UTF-8):      Biblioteka OpenCV viz (obsługa VTK)
242 Group:          Libraries
243 Requires:       %{name} = %{epoch}:%{version}-%{release}
244
245 %description viz
246 OpenCV viz library (VTK support).
247
248 %description viz -l pl.UTF-8
249 Biblioteka OpenCV viz (obsługa VTK).
250
251 %package devel
252 Summary:        Header files for OpenCV library
253 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
254 Group:          Development/Libraries
255 Requires:       %{name} = %{epoch}:%{version}-%{release}
256 %if %{with vtk}
257 Requires:       %{name}-viz = %{epoch}:%{version}-%{release}
258 %endif
259 Obsoletes:      opencv-static
260
261 %description devel
262 Header files for OpenCV library.
263
264 %description devel -l pl.UTF-8
265 Pliki nagłówkowe biblioteki OpenCV.
266
267 %package doc
268 Summary:        Manual for OpenCV
269 Summary(fr.UTF-8):      Documentation pour OpenCV
270 Summary(it.UTF-8):      Documentazione di OpenCV
271 Summary(pl.UTF-8):      Podręcznik dla OpenCV
272 Group:          Documentation
273 # noarch subpackages only when building with rpm5
274 BuildArch:      noarch
275
276 %description doc
277 Documentation for OpenCV.
278
279 %description doc -l fr.UTF-8
280 Documentation pour OpenCV.
281
282 %description doc -l it.UTF-8
283 Documentazione di OpenCV.
284
285 %description doc -l pl.UTF-8
286 Dokumentacja do OpenCV.
287
288 %package examples
289 Summary:        OpenCV code examples
290 Group:          Documentation
291 BuildArch:      noarch
292
293 %description examples
294 OpenCV code examples.
295
296 %package -n java-opencv
297 Summary:        OpenCV Java bindings
298 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
299 Group:          Libraries/Java
300 Requires:       %{name} = %{epoch}:%{version}-%{release}
301 Requires:       jre
302
303 %description -n java-opencv
304 OpenCV Java bindings.
305
306 %description -n java-opencv -l pl.UTF-8
307 Wiązania Javy do OpenCV.
308
309 %package -n python-opencv
310 Summary:        OpenCV Python 2 bindings
311 Summary(pl.UTF-8):      Wiązania Pythona 2 do OpenCV
312 Group:          Libraries/Python
313 Requires:       %{name} = %{epoch}:%{version}-%{release}
314 Requires:       python-libs
315
316 %description -n python-opencv
317 OpenCV Python 2 bindings.
318
319 %description -n python-opencv -l pl.UTF-8
320 Wiązania Pythona 2 do OpenCV.
321
322 %package -n python3-opencv
323 Summary:        OpenCV Python 3 bindings
324 Summary(pl.UTF-8):      Wiązania Pythona 3 do OpenCV
325 Group:          Libraries/Python
326 Requires:       %{name} = %{epoch}:%{version}-%{release}
327 Requires:       python3-libs
328
329 %description -n python3-opencv
330 OpenCV Python 3 bindings.
331
332 %description -n python3-opencv -l pl.UTF-8
333 Wiązania Pythona 3 do OpenCV.
334
335 %prep
336 %setup -q -a1
337
338 %undos CMakeLists.txt
339
340 %patch0 -p1
341 %patch1 -p1
342 %patch2 -p1
343 %patch3 -p1
344 %patch4 -p1
345
346 cache_file() {
347         f="$1"
348         d="$2"
349         md5="$(md5sum "$f" | awk '{print $1}')"
350         file="$(basename "$f")"
351         mkdir -p ".cache/$d"
352         ln -s --relative "$f" ".cache/$d/$md5-$file"
353 }
354 for f in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16}; do
355         cache_file $f xfeatures2d/boostdesc
356 done
357 for f in %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23}; do
358         cache_file $f xfeatures2d/vgg
359 done
360 cache_file %{SOURCE30} data
361 cache_file %{SOURCE40} ade
362
363 cd opencv_contrib-%{version}
364 %patch5 -p1
365
366 # both files use Glog_FOUND variable, but set different variables for LIBS; unify them so they won't disturb each other
367 cp -f modules/sfm/cmake/FindGlog.cmake modules/cnn_3dobj/FindGlog.cmake
368 %{__sed} -i -e 's/Glog_LIBS/GLOG_LIBRARIES/' modules/cnn_3dobj/CMakeLists.txt
369
370 %build
371 mkdir -p build
372 cd build
373
374 # handle cmake & ccache
375 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
376 if [[ "%{__cc}" = *ccache* ]]; then
377         cc="%{__cc}"
378         cxx="%{__cxx}"
379         ccache="
380         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
381         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
382         "
383 fi
384
385 %cmake .. \
386         $ccache \
387         -DOpenGL_GL_PREFERENCE=GLVND \
388         -DENABLE_PRECOMPILED_HEADERS=OFF \
389         -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
390         -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
391         -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
392         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
393         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
394         -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
395         -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
396         -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
397         -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
398         -DBUILD_NEW_PYTHON_SUPPORT=ON \
399         -DOPENCV_GENERATE_PKGCONFIG:BOOL=ON \
400 %if %{with examples}
401         -DINSTALL_C_EXAMPLES=ON \
402         -DINSTALL_PYTHON_EXAMPLES=ON \
403 %endif
404         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
405         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
406         %{?with_opencl:-DWITH_OPENCL=ON} \
407         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
408         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
409         %{?with_opengl:-DWITH_OPENGL=ON} \
410         %{?with_openmp:-DWITH_OPENMP=ON} \
411         %{?with_openni:-DWITH_OPENNI=ON} \
412         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
413         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
414         %{?with_tbb:-DWITH_TBB=ON} \
415         %{?with_unicap:-DWITH_UNICAP=ON} \
416         %{!?with_v4l:-DWITH_V4L=OFF} \
417         %{?with_vtk:-DWITH_VTK=ON} \
418         %{?with_ximea:-DWITH_XIMEA=ON} \
419         %{?with_xine:-DWITH_XINE=ON} \
420         -DWITH_IPP=OFF
421
422 %{__make}
423
424 %install
425 rm -rf $RPM_BUILD_ROOT
426 %{__make} -C build install \
427         DESTDIR=$RPM_BUILD_ROOT
428
429 %if %{with examples}
430 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
431 mv $RPM_BUILD_ROOT%{_datadir}/opencv4/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
432 %endif
433
434 # disable completeness check incompatible with split packaging
435 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules.cmake
436
437 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
438 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
439 %py_postclean
440
441 %if %{with java}
442 # move to proper directories, create symlink
443 install -d $RPM_BUILD_ROOT%{_javadir}
444 %{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
445 sed -i -e 's#/share/java/opencv4/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
446         $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules-pld.cmake
447 %{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
448 rmdir $RPM_BUILD_ROOT%{_javadir}/opencv4
449 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
450 %endif
451
452 %clean
453 rm -rf $RPM_BUILD_ROOT
454
455 %post   -p /sbin/ldconfig
456 %postun -p /sbin/ldconfig
457
458 %post   core -p /sbin/ldconfig
459 %postun core -p /sbin/ldconfig
460
461 %post   viz -p /sbin/ldconfig
462 %postun viz -p /sbin/ldconfig
463
464 %post   -n java-opencv -p /sbin/ldconfig
465 %postun -n java-opencv -p /sbin/ldconfig
466
467 %files
468 %defattr(644,root,root,755)
469 %attr(755,root,root) %{_bindir}/opencv_annotation
470 #%attr(755,root,root) %{_bindir}/opencv_createsamples
471 %attr(755,root,root) %{_bindir}/opencv_interactive-calibration
472 #%attr(755,root,root) %{_bindir}/opencv_traincascade
473 %attr(755,root,root) %{_bindir}/opencv_version
474 %attr(755,root,root) %{_bindir}/opencv_visualisation
475 %attr(755,root,root) %{_bindir}/setup_vars_opencv4.sh
476 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
477 %attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
478 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
479 %attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
480 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
481 %attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
482 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
483 %attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
484 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
485 %attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
486 %attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
487 %attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
488 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
489 %attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
490 # contrib modules
491 %attr(755,root,root) %{_bindir}/opencv_waldboost_detector
492 %attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
493 %attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
494 %attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
495 %attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
496 %attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
497 %attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
498 %attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
499 %attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
500 %attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
501 %attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
502 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
503 %attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
504 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
505 %attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
506 %attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
507 %attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
508 %attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
509 %attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
510 %attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
511 %attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
512 %attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
513 %attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
514 %attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
515 %attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
516 %attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
517 %attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
518 %attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
519 %attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
520 %attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
521 %attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
522 %attr(755,root,root) %ghost %{_libdir}/libopencv_ovis.so.%{sover}
523 %attr(755,root,root) %{_libdir}/libopencv_ovis.so.*.*.*
524 %attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
525 %attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
526 %attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
527 %attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
528 %attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
529 %attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
530 %attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
531 %attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
532 %attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
533 %attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
534 %attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
535 %attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
536 %attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
537 %attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
538 %attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
539 %attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
540 %attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
541 %attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
542 %attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
543 %attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
544 %attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
545 %attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
546 %attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
547 %attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
548 %attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
549 %attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
550 %attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
551 %attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
552 %attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
553 %attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
554 %attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
555 %attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
556 %attr(755,root,root) %ghost %{_libdir}/libopencv_alphamat.so.%{sover}
557 %attr(755,root,root) %{_libdir}/libopencv_alphamat.so.*.*.*
558 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_superres.so.%{sover}
559 %attr(755,root,root) %{_libdir}/libopencv_dnn_superres.so.*.*.*
560 %attr(755,root,root) %ghost %{_libdir}/libopencv_gapi.so.%{sover}
561 %attr(755,root,root) %{_libdir}/libopencv_gapi.so.*.*.*
562 %attr(755,root,root) %ghost %{_libdir}/libopencv_intensity_transform.so.%{sover}
563 %attr(755,root,root) %{_libdir}/libopencv_intensity_transform.so.*.*.*
564 %attr(755,root,root) %ghost %{_libdir}/libopencv_mcc.so.%{sover}
565 %attr(755,root,root) %{_libdir}/libopencv_mcc.so.*.*.*
566 %attr(755,root,root) %ghost %{_libdir}/libopencv_quality.so.%{sover}
567 %attr(755,root,root) %{_libdir}/libopencv_quality.so.*.*.*
568 %attr(755,root,root) %ghost %{_libdir}/libopencv_rapid.so.%{sover}
569 %attr(755,root,root) %{_libdir}/libopencv_rapid.so.*.*.*
570
571 %dir %{_datadir}/opencv4
572 %{_datadir}/opencv4/haarcascades
573 %{_datadir}/opencv4/lbpcascades
574 %{_datadir}/opencv4/quality
575
576 %files core
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
579 %attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
580 %attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
581 %attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
582 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
583 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
584 %attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
585 %attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
586 %attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
587 %attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
588 %attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
589 %attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
590 %attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
591 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
592 %attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
593 %attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
594 %attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
595 %attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
596
597 %if %{with vtk}
598 %files viz
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
601 %attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
602 %endif
603
604 %files devel
605 %defattr(644,root,root,755)
606 # core
607 %{_libdir}/libopencv_core.so
608 %{_libdir}/libopencv_flann.so
609 %{_libdir}/libopencv_imgproc.so
610 %{_libdir}/libopencv_ml.so
611 %{_libdir}/libopencv_photo.so
612 %{_libdir}/libopencv_video.so
613 # GUI/extensions (base package)
614 %{_libdir}/libopencv_calib3d.so
615 %{_libdir}/libopencv_features2d.so
616 %{_libdir}/libopencv_highgui.so
617 %{_libdir}/libopencv_objdetect.so
618 %{_libdir}/libopencv_stitching.so
619 %{_libdir}/libopencv_superres.so
620 %{_libdir}/libopencv_videostab.so
621 %{_libdir}/libopencv_imgcodecs.so
622 %{_libdir}/libopencv_shape.so
623 %{_libdir}/libopencv_videoio.so
624 # contrib
625 %{_libdir}/libopencv_aruco.so
626 %{_libdir}/libopencv_bgsegm.so
627 %{_libdir}/libopencv_bioinspired.so
628 %{_libdir}/libopencv_ccalib.so
629 %{_libdir}/libopencv_datasets.so
630 %{_libdir}/libopencv_dnn.so
631 %{_libdir}/libopencv_dnn_objdetect.so
632 %{_libdir}/libopencv_dpm.so
633 %{_libdir}/libopencv_face.so
634 %{_libdir}/libopencv_freetype.so
635 %{_libdir}/libopencv_fuzzy.so
636 %{_libdir}/libopencv_hdf.so
637 %{_libdir}/libopencv_hfs.so
638 %{_libdir}/libopencv_img_hash.so
639 %{_libdir}/libopencv_line_descriptor.so
640 %{_libdir}/libopencv_optflow.so
641 %{_libdir}/libopencv_ovis.so
642 %{_libdir}/libopencv_phase_unwrapping.so
643 %{_libdir}/libopencv_plot.so
644 %{_libdir}/libopencv_reg.so
645 %{_libdir}/libopencv_rgbd.so
646 %{_libdir}/libopencv_saliency.so
647 %{_libdir}/libopencv_sfm.so
648 %{_libdir}/libopencv_stereo.so
649 %{_libdir}/libopencv_structured_light.so
650 %{_libdir}/libopencv_surface_matching.so
651 %{_libdir}/libopencv_text.so
652 %{_libdir}/libopencv_tracking.so
653 %{_libdir}/libopencv_xfeatures2d.so
654 %{_libdir}/libopencv_ximgproc.so
655 %{_libdir}/libopencv_xobjdetect.so
656 %{_libdir}/libopencv_xphoto.so
657 %{_libdir}/libopencv_alphamat.so
658 %{_libdir}/libopencv_dnn_superres.so
659 %{_libdir}/libopencv_gapi.so
660 %{_libdir}/libopencv_intensity_transform.so
661 %{_libdir}/libopencv_mcc.so
662 %{_libdir}/libopencv_quality.so
663 %{_libdir}/libopencv_rapid.so
664 # viz
665 %if %{with vtk}
666 %{_libdir}/libopencv_viz.so
667 %endif
668 %{_includedir}/opencv4
669 %dir %{_libdir}/cmake/opencv4
670 %{_libdir}/cmake/opencv4/OpenCV*.cmake
671 %{_pkgconfigdir}/opencv4.pc
672
673 %files doc
674 %defattr(644,root,root,755)
675 # TODO: probably could rebuild them and package via make install
676 %doc doc/*
677
678 %if %{with examples}
679 %files examples
680 %defattr(644,root,root,755)
681 %{_examplesdir}/%{name}-%{version}
682 %endif
683
684 %if %{with java}
685 %files -n java-opencv
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
688 %{_javadir}/opencv-%{jver}.jar
689 %{_javadir}/opencv.jar
690 %endif
691
692 %files -n python-opencv
693 %defattr(644,root,root,755)
694 %dir %{py_sitedir}/cv2
695 %dir %{py_sitedir}/cv2/python-*
696 %attr(755,root,root) %{py_sitedir}/cv2/python-*/cv2.so
697 %{py_sitedir}/cv2/*.py[co]
698
699 %files -n python3-opencv
700 %defattr(644,root,root,755)
701 %dir %{py3_sitedir}/cv2
702 %dir %{py3_sitedir}/cv2/python-*
703 %attr(755,root,root) %{py3_sitedir}/cv2/python-*/cv2.cpython-*.so
704 %{py3_sitedir}/cv2/*.py
This page took 0.123731 seconds and 3 git commands to generate.