]> git.pld-linux.org Git - packages/openct.git/blob - openct.spec
- todo already done
[packages/openct.git] / openct.spec
1 Summary:        OpenCT library - library for accessing smart card terminals
2 Summary(pl):    OpenCT - biblioteka dostêpu do terminali kart procesorowych
3 Name:           openct
4 Version:        0.6.2
5 Release:        1
6 License:        BSD-like
7 Group:          Applications
8 Source0:        http://www.opensc.org/files/%{name}-%{version}.tar.gz
9 # Source0-md5:  18d8bca0372515842fec9f366ca461d1
10 Source1:        %{name}.init
11 Patch0:         %{name}-ccid.patch
12 URL:            http://www.opensc.org/
13 BuildRequires:  automake
14 BuildRequires:  libusb-devel
15 BuildRequires:  pcsc-lite-devel
16 BuildRequires:  pkgconfig >= 1:0.9.0
17 Requires(post): /sbin/ldconfig
18 Requires(post,preun):   /sbin/chkconfig
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 OpenCT is a library for accessing smart card terminals. It provides a
23 rich set of functions for driver writers, protocol drivers for T=0 and
24 T=1, serial and USB functionality, including USB hotplugging. 
25
26 %description -l pl
27 OpenCT to biblioteka s³u¿±ca do dostêpu do terminali kart
28 procesorowych (smart card). Dostarcza bogaty zbiór funkcji dla
29 pisz±cych sterowniki, sterowniki protoko³ów dla T=0 i T=1,
30 funkcjonalno¶æ dla portów szeregowych i USB, w³±cznie z pod³±czaniem
31 urz±dzeñ USB w locie (hotplug).
32
33 %package -n pcsc-driver-openct
34 Summary:        OpenCT driver for PC/SC
35 Summary(pl):    Sterownik OpenCT dla PC/SC
36 Group:          Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       pcsc-lite
39
40 %description -n pcsc-driver-openct
41 OpenCT driver for PC/SC.
42
43 %description -n pcsc-driver-openct -l pl
44 Sterownik OpenCT dla PC/SC.
45
46 %package devel
47 Summary:        OpenCT development files
48 Summary(pl):    Pliki dla programistów u¿ywaj±cych OpenCT
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 OpenSC development files.
54
55 %description devel -l pl
56 Pliki dla programistów u¿ywaj±cych OpenCT.
57
58 %package static
59 Summary:        Static OpenCT libraries
60 Summary(pl):    Bibloteki statyczne OpenCT
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static OpenCT libraries.
66
67 %description static -l pl
68 Statyczne biblioteki OpenCT.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73
74 %build
75 cp -f /usr/share/automake/config.* .
76 %configure \
77         --with-bundle-dir=%{_libdir}/pcsc/drivers
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/hotplug/usb,/var/run/openct}
83 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 install etc/openct.conf $RPM_BUILD_ROOT%{_sysconfdir}
89 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/openct
90
91 rm -f $RPM_BUILD_ROOT%{_libdir}/openct-*.{a,la}
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post
97 /sbin/ldconfig
98 /sbin/chkconfig --add openct
99 if [ -f /var/lock/subsys/openct ]; then
100         /etc/rc.d/init.d/openct restart >&2
101 else
102         echo "Run \"/etc/rc.d/init.d/openct start\" to start openct."
103 fi
104
105 %preun
106 if [ "$1" = "0" ]; then
107         if [ -f /var/lock/subsys/openct ]; then
108                 /etc/rc.d/init.d/openct stop >&2
109         fi
110         /sbin/chkconfig --del openct
111 fi
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS ANNOUNCE ChangeLog NEWS TODO doc/openct.{html,css}
117 %attr(755,root,root) %{_bindir}/openct-tool
118 %attr(755,root,root) %{_sbindir}/ifdhandler
119 %attr(755,root,root) %{_sbindir}/ifdproxy
120 %attr(755,root,root) %{_sbindir}/openct-control
121 %attr(755,root,root) %{_libdir}/lib*.so.*.*
122 %attr(755,root,root) %{_libdir}/libopenctapi.so
123 %attr(755,root,root) %{_libdir}/openct-ifd.so
124 %dir /var/run/openct
125 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/openct.conf
126 %attr(755,root,root) %{_sysconfdir}/hotplug/usb/openct
127 %{_sysconfdir}/hotplug/usb/openct.usermap
128 %attr(754,root,root) /etc/rc.d/init.d/openct
129
130 %files -n pcsc-driver-openct
131 %defattr(644,root,root,755)
132 %dir %{_libdir}/pcsc/drivers/openct-ifd.bundle
133 %dir %{_libdir}/pcsc/drivers/openct-ifd.bundle/Contents
134 %dir %{_libdir}/pcsc/drivers/openct-ifd.bundle/Contents/Linux
135 %attr(755,root,root) %dir %{_libdir}/pcsc/drivers/openct-ifd.bundle/Contents/Linux/openct-ifd
136 %{_libdir}/pcsc/drivers/openct-ifd.bundle/Contents/Info.plist
137 %{_libdir}/pcsc/drivers/openct-ifd.bundle/Contents/PkgInfo
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libifd.so
142 %attr(755,root,root) %{_libdir}/libopenct.so
143 %{_libdir}/lib*.la
144 %{_includedir}/openct
145 %{_pkgconfigdir}/*.pc
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/lib*.a
This page took 0.063706 seconds and 4 git commands to generate.