- added nanomsg patch (adjust for .pc file rename in nanomsg 1.0.0+) auto/th/openchange-2.3-51
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 23 May 2020 06:27:51 +0000 (08:27 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 23 May 2020 06:27:51 +0000 (08:27 +0200)
- release 51 (rebuild with samba 4.12.3)

openchange-nanomsg.patch [new file with mode: 0644]
openchange.spec

diff --git a/openchange-nanomsg.patch b/openchange-nanomsg.patch
new file mode 100644 (file)
index 0000000..5b594ea
--- /dev/null
@@ -0,0 +1,11 @@
+--- openchange-openchange-2.3-VULCAN/configure.ac.orig 2020-05-23 08:12:19.965123403 +0200
++++ openchange-openchange-2.3-VULCAN/configure.ac      2020-05-23 08:16:46.680345149 +0200
+@@ -292,7 +292,7 @@
+ dnl ---------------------------------------------------------------------------
+ dnl Check for nanomsg library (server notification)
+ dnl ---------------------------------------------------------------------------
+-PKG_CHECK_MODULES(NANOMSG, libnanomsg, [], [AC_MSG_ERROR(Install nanomsg library >= 0.5)])
++PKG_CHECK_MODULES(NANOMSG, nanomsg, [], [AC_MSG_ERROR(Install nanomsg library >= 0.5)])
+ AC_SUBST(NANOMSG_CFLAGS)
+ AC_SUBST(NANO_LIBS)
index 00804b3c04efcac24b7336e30858f45d12a7c2db..12eb98e2de81d8de14260a09087b1f73ca9bd4c9 100644 (file)
@@ -12,7 +12,7 @@ Summary:      OpenChange - portable implementation of MS Exchange Server and Exchange
 Summary(pl.UTF-8):     OpenChange - przenośna implementacja serwera oraz protokołów MS Exchange
 Name:          openchange
 Version:       2.3
-Release:       50
+Release:       51
 License:       GPL v3+
 Group:         Libraries
 #Source0Download: https://github.com/openchange/openchange/releases
@@ -29,6 +29,7 @@ Patch7:               %{name}-samba-4.10-macros.patch
 Patch8:                %{name}-libical.patch
 Patch9:                samba-4.11.patch
 Patch10:       samba-4.12.patch
+Patch11:       %{name}-nanomsg.patch
 URL:           https://github.com/openchange
 BuildRequires: QtCore-devel >= 4.3.0
 BuildRequires: QtGui-devel >= 4.3.0
@@ -43,7 +44,7 @@ BuildRequires:        libmemcached-devel >= 1.0.18
 BuildRequires: libpcap-devel
 BuildRequires: libstdc++-devel
 BuildRequires: mysql-devel
-BuildRequires: nanomsg-devel >= 0.5
+BuildRequires: nanomsg-devel >= 1.0.0
 BuildRequires: perl-base
 BuildRequires: pkgconfig >= 1:0.20
 BuildRequires: popt-devel
@@ -225,6 +226,7 @@ Wtyczka Nagiosa do sprawdzania usług Exchange/OpenChange.
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
+%patch11 -p1
 
 # no switch for verbose mode, enable manually :/
 %{__sed} -i -e 's/^    @\(\$(\(PIDL\|CC\|CXX\|MOC\)\)/ \1/' Makefile
This page took 0.632432 seconds and 4 git commands to generate.