]> git.pld-linux.org Git - packages/octave.git/commitdiff
- updated to 2.1.48, added gcc33 patch (some problem with templates)
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 17 May 2003 19:28:09 +0000 (19:28 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    octave-gcc33.patch -> 1.1
    octave.spec -> 1.53

octave-gcc33.patch [new file with mode: 0644]
octave.spec

diff --git a/octave-gcc33.patch b/octave-gcc33.patch
new file mode 100644 (file)
index 0000000..068ec52
--- /dev/null
@@ -0,0 +1,26 @@
+--- octave-2.1.48/src/ov-cx-mat.h.orig 2002-11-20 20:03:08.000000000 +0100
++++ octave-2.1.48/src/ov-cx-mat.h      2003-05-17 20:34:16.000000000 +0200
+@@ -78,8 +78,7 @@
+   octave_value *try_narrowing_conversion (void);
+-  void assign (const octave_value_list& idx, const ComplexMatrix& rhs)
+-    { octave_base_matrix<ComplexMatrix>::assign (idx, rhs); }
++  void assign (const octave_value_list& idx, const ComplexMatrix& rhs);
+   void assign (const octave_value_list& idx, const Matrix& rhs);
+--- octave-2.1.48/src/ov-cx-mat.cc.orig        2002-11-20 20:03:08.000000000 +0100
++++ octave-2.1.48/src/ov-cx-mat.cc     2003-05-17 20:35:56.000000000 +0200
+@@ -78,6 +78,11 @@
+ void
+ octave_complex_matrix::assign (const octave_value_list& idx,
++                             const ComplexMatrix& rhs)
++{ octave_base_matrix<ComplexMatrix>::assign (idx, rhs); }
++
++void
++octave_complex_matrix::assign (const octave_value_list& idx,
+                              const Matrix& rhs)
+ {
+   int len = idx.length ();
index d3bb7b5d024d235c64a8aa842a2db9da10b5146e..7be7cbd177adec47396d66eda51c16426cadbb38 100644 (file)
@@ -15,7 +15,7 @@ Summary(ru):  GNU Octave - 
 Summary(sv):   GNU Octave - ett högninvåspråk för numeriska beräkningar
 Summary(zh_CN):        GNU Octave - ÓÃÓÚÊý×Ö¼ÆËãµÄ¸ß¼¶ÓïÑÔ¡£
 Name:          octave
-Version:       2.1.46
+Version:       2.1.48
 Release:       1
 Epoch:         2
 License:       GPL
@@ -24,6 +24,7 @@ Source0:      ftp://ftp.che.wisc.edu/pub/octave/bleeding-edge/%{name}-%{version}.tar.
 Source1:       %{name}.desktop
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-DESTDIR.patch
+Patch2:                %{name}-gcc33.patch
 URL:           http://www.che.wisc.edu/octave/
 BuildRequires: bison
 BuildRequires: blas-devel
@@ -256,6 +257,7 @@ Tryb edycji plik
 %setup -q
 %patch0 -p1
 %patch1 -p0
+%patch2 -p1
 
 %build
 %configure \
This page took 0.055305 seconds and 4 git commands to generate.