]> git.pld-linux.org Git - packages/ocaml-cryptokit.git/commitdiff
- initial; from scratch
authorMichal Moskal <michal@moskal.me>
Mon, 13 May 2002 11:12:50 +0000 (11:12 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ocaml-cryptokit.spec -> 1.1

ocaml-cryptokit.spec [new file with mode: 0644]

diff --git a/ocaml-cryptokit.spec b/ocaml-cryptokit.spec
new file mode 100644 (file)
index 0000000..9913f9a
--- /dev/null
@@ -0,0 +1,121 @@
+Summary:       Cryptographic toolkit for OCaml
+Summary(pl):   Biblioteka kryptograficzna dla OCamla
+Name:          ocaml-cryptokit
+Version:       1.0
+Release:       1
+License:       LGPL w/ linking exception
+Group:         Libraries
+Vendor:                Xavier Leroy <Xavier.Leroy@inria.fr>
+URL:           http://pauillac.inria.fr/~xleroy/software.html
+Source0:       http://caml.inria.fr/distrib/bazar-ocaml/cryptokit-%{version}.tar.gz
+BuildRequires: zlib-devel
+BuildRequires: ocaml >= 3.04-7
+%requires_eq   ocaml-runtime
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+The Cryptokit library for Objective Caml provides a variety of
+cryptographic primitives that can be used to implement cryptographic
+protocols in security-sensitive applications. The primitives provided
+include: symmetric-key cryptography: AES, DES, Triple-DES, ARCfour, in
+ECB, CBC, CFB and OFB modes; public-key cryptography: RSA; hash
+functions and MACs: SHA-1, MD5, and MACs based on AES and DES; random
+number generation; encodings and compression: base 64, hexadecimal,
+Zlib compression.
+
+This package contains files needed to run bytecode executables using
+this library.
+
+%description -l pl
+Biblioteka Cryptokit dostarcza szerok± gamê funkcji kryptograficznych,
+które mog± byæ u¿yte w implementacji protoko³ów kryptograficznych w
+aplikacjach, dla których wa¿ne jest bezpieczeñstwo. Dostarczane
+funkcje to: szyfry symetryczne: AES, DES, 3DES, ARCFour w trybach ECB,
+CBC, CFB oraz OFB; szyfr z kluczem publicznym RSA; kryptograficzne
+funkcje skrótu i MACi: SHA-1, MD5 oraz MACi bazowane na AES oraz DES;
+generacje liczb losowych; kodowania i kompresja: base 64,
+szesntastkowa oraz zlib.
+
+Pakiet ten zawiera binaria potrzebne do uruchamiania programów
+u¿ywaj±cych tej biblioteki.
+
+%package devel
+Summary:       Cryptographic toolkit for OCaml - development part
+Summary(pl):   Biblioteka kryptograficzna dla OCamla - cze¶æ programistyczna
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+%requires_eq   ocaml
+
+%description devel
+The Cryptokit library for Objective Caml provides a variety of
+cryptographic primitives that can be used to implement cryptographic
+protocols in security-sensitive applications. The primitives provided
+include: symmetric-key cryptography: AES, DES, Triple-DES, ARCfour, in
+ECB, CBC, CFB and OFB modes; public-key cryptography: RSA; hash
+functions and MACs: SHA-1, MD5, and MACs based on AES and DES; random
+number generation; encodings and compression: base 64, hexadecimal,
+Zlib compression.
+
+This package contains files needed to develop OCaml programs using
+this library.
+
+%description devel -l pl
+Biblioteka Cryptokit dostarcza szerok± gamê funkcji kryptograficznych,
+które mog± byæ u¿yte w implementacji protoko³ów kryptograficznych w
+aplikacjach, dla których wa¿ne jest bezpieczeñstwo. Dostarczane
+funkcje to: szyfry symetryczne: AES, DES, 3DES, ARCFour w trybach ECB,
+CBC, CFB oraz OFB; szyfr z kluczem publicznym RSA; kryptograficzne
+funkcje skrótu i MACi: SHA-1, MD5 oraz MACi bazowane na AES oraz DES;
+generacje liczb losowych; kodowania i kompresja: base 64,
+szesntastkowa oraz zlib.
+
+Pakiet ten zawiera pliki niezbêdne do tworzenia programów u¿ywaj±cych
+tej biblioteki.
+
+%prep
+%setup -q -n cryptokit-%{version}
+
+%build
+%{__make} CFLAGS="%{rpmcflags} -fPIC" all allopt
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/cryptokit
+%{__make} install INSTALLDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml/cryptokit
+
+install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/cryptokit
+install *.cm[ixa]* *.a dll*.so $RPM_BUILD_ROOT%{_libdir}/ocaml/cryptokit
+(cd $RPM_BUILD_ROOT%{_libdir}/ocaml && ln -s cryptokit/dll*.so .)
+
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+cp -r *test.ml $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
+install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/cryptokit
+cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/cryptokit/META <<EOF
+requires = "unix num"
+version = "%{version}"
+directory = "+cryptokit"
+archive(byte) = "cryptokit.cma"
+archive(native) = "cryptokit.cmxa"
+linkopts = ""
+EOF
+
+gzip -9nf LICENSE README
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%dir %{_libdir}/ocaml/cryptokit
+%attr(755,root,root) %{_libdir}/ocaml/cryptokit/*.so
+%{_libdir}/ocaml/*.so
+
+%files devel
+%defattr(644,root,root,755)
+%doc *.gz doc
+%{_libdir}/ocaml/cryptokit/*.cm[ixa]*
+%{_libdir}/ocaml/cryptokit/*.a
+%{_examplesdir}/%{name}-%{version}
+%{_libdir}/ocaml/site-lib/cryptokit
This page took 0.047185 seconds and 4 git commands to generate.