]> git.pld-linux.org Git - packages/nss.git/blob - nss.spec
- from http://distro.ibiblio.org/pub/linux/distributions/zenwalk/i486/current/source...
[packages/nss.git] / nss.spec
1 Summary:        NSS - Network Security Services
2 Summary(pl):    NSS - Network Security Services
3 Name:           nss
4 Version:        3.11.3
5 %define foover  %(echo %{version} | tr . _)
6 Release:        1
7 Epoch:          1
8 License:        GPL
9 Group:          Libraries
10 # :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot mozilla/dbm -r DBM_1_61_RTM
11 # :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot mozilla/security/dbm -r DBM_1_61_RTM
12 # :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot mozilla/security/coreconf -r NSS_3_9_4_RTM
13 # :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot mozilla/security/nss -r NSS_3_9_4_RTM
14 #Source0:       %{name}-%{version}.tar.bz2
15 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/NSS_%{foover}_RTM/src/%{name}-%{version}.tar.gz
16 # Source0-md5:  196c8d2746bd75d3561d129f64bbf9cf
17 Source1:        %{name}-mozilla-nss.pc
18 Patch0:         %{name}-Makefile.patch
19 URL:            http://www.mozilla.org/projects/security/pki/nss/
20 BuildRequires:  nspr-devel >= 4.6.3
21 BuildRequires:  zlib-devel
22 BuildConflicts: mozilla < 0.9.6-3
23 Requires:       nspr >= 1:4.6.3
24 Obsoletes:      libnss3
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         specflags       -fno-strict-aliasing
28
29 %description
30 NSS supports cross-platform development of security-enabled server
31 applications. Applications built with NSS can support PKCS #5,
32 PKCS #7, PKCS #11, PKCS #12, S/MIME, TLS, SSL v2 and v3, X.509 v3
33 certificates, and other security standards.
34
35 %description -l pl
36 NSS wspomaga pisanie wieloplatformowych bezpiecznych serwerów.
37 Aplikacja u¿ywaj±ca NSS jest w stanie obs³u¿yæ PKCS #5, PKCS #7,
38 PKCS #11, PKCS #12, S/MIME, TLS, SSL v2 oraz v3, certyfikaty X.509 v3,
39 i wiele innych bezpiecznych standardów.
40
41 %package tools
42 Summary:        NSS command line tools and utilities
43 Summary(pl):    Narzêdzia NSS
44 Group:          Applications
45 Requires:       %{name} = %{epoch}:%{version}-%{release}
46
47 %description tools
48 The NSS Toolkit command line tool.
49
50 %description tools -l pl
51 Narzêdzia NSS obs³ugiwane z linii poleceñ.
52
53 %package devel
54 Summary:        NSS - header files
55 Summary(pl):    NSS - pliki nag³ówkowe
56 Group:          Development/Libraries
57 Requires:       %{name} = %{epoch}:%{version}-%{release}
58 Obsoletes:      libnss3-devel
59
60 %description devel
61 Development part of NSS library.
62
63 %description devel -l pl
64 Czê¶æ biblioteki NSS przeznaczona dla programistów.
65
66 %package static
67 Summary:        NSS - static library
68 Summary(pl):    NSS - biblioteka statyczna
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
71
72 %description static
73 Static NSS Toolkit libraries.
74
75 %description static -l pl
76 Statyczne wersje bibliotek z NSS.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81
82 %build
83 cd mozilla/security/nss
84
85 %ifarch %{x8664} ppc64
86 export USE_64=1
87 %endif
88
89 %{__make} build_coreconf \
90         NSDISTMODE=copy \
91         NS_USE_GCC=1 \
92         MOZILLA_CLIENT=1 \
93         NO_MDUPDATE=1 \
94         USE_PTHREADS=1 \
95         BUILD_OPT=1 \
96         OPTIMIZER="%{rpmcflags}"
97
98 %{__make} build_dbm \
99         NSDISTMODE=copy \
100         NS_USE_GCC=1 \
101         MOZILLA_CLIENT=1 \
102         NO_MDUPDATE=1 \
103         USE_PTHREADS=1 \
104         BUILD_OPT=1 \
105         OPTIMIZER="%{rpmcflags}" \
106         PLATFORM="pld"
107
108 %{__make} all \
109         NSDISTMODE=copy \
110         NS_USE_GCC=1 \
111         MOZILLA_CLIENT=1 \
112         NO_MDUPDATE=1 \
113         USE_PTHREADS=1 \
114         BUILD_OPT=1 \
115         USE_SYSTEM_ZLIB=1 \
116         ZLIB_LIBS="-lz" \
117         OPTIMIZER="%{rpmcflags}" \
118         PLATFORM="pld"
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/nss,%{_libdir},%{_pkgconfigdir}}
123
124 install mozilla/dist/private/nss/*      $RPM_BUILD_ROOT%{_includedir}/nss
125 install mozilla/dist/public/dbm/*       $RPM_BUILD_ROOT%{_includedir}/nss
126 install mozilla/dist/public/nss/*       $RPM_BUILD_ROOT%{_includedir}/nss
127 install mozilla/dist/pld/bin/*          $RPM_BUILD_ROOT%{_bindir}
128 install mozilla/dist/pld/lib/*          $RPM_BUILD_ROOT%{_libdir}
129
130 sed \
131         -e 's#libdir=.*#libdir=%{_libdir}#g' \
132         -e 's#includedir=.*#includedir=%{_includedir}#g' \
133         -e 's#VERSION#%{version}#g' \
134         %{SOURCE1} > $RPM_BUILD_ROOT%{_pkgconfigdir}/mozilla-nss.pc
135
136 # resolve conflict with squid
137 mv -f $RPM_BUILD_ROOT%{_bindir}/{,nss-}client
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %files
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/lib*.so
148 %{_libdir}/lib*.chk
149
150 %files devel
151 %defattr(644,root,root,755)
152 %{_includedir}/nss
153 %{_libdir}/libcrmf.a
154 %{_pkgconfigdir}/*.pc
155
156 %files tools
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/*
159
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/lib*.a
163 %exclude %{_libdir}/libcrmf.a
This page took 0.103395 seconds and 4 git commands to generate.