]> git.pld-linux.org Git - packages/nodejs.git/commitdiff
- updated to 16.20.1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 6 Jul 2023 15:38:43 +0000 (17:38 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 6 Jul 2023 15:38:43 +0000 (17:38 +0200)
0002-Install-both-binaries-and-use-libdir.patch [deleted file]
gcc13.patch [deleted file]
nodejs.spec

diff --git a/0002-Install-both-binaries-and-use-libdir.patch b/0002-Install-both-binaries-and-use-libdir.patch
deleted file mode 100644 (file)
index 4ce85c2..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-From cf581096dd350cf7267e5a12ff26159120274c5c Mon Sep 17 00:00:00 2001
-From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
-Date: Tue, 19 Mar 2019 23:22:40 -0400
-Subject: [PATCH 2/3] Install both binaries and use libdir.
-
-This allows us to build with a shared library for other users while
-still providing the normal executable.
-
-Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
----
- configure.py     |  7 +++++++
- tools/install.py | 29 +++++++++++++----------------
- 2 files changed, 20 insertions(+), 16 deletions(-)
-
-diff --git a/configure.py b/configure.py
-index 20cce214dbb113aeef8f1044d7af88d842a11fd7..e2d78a2a51ef81621618cb20fa76f4a1421bf9e0 100755
---- a/configure.py
-+++ b/configure.py
-@@ -559,6 +559,12 @@ parser.add_option('--shared',
-     help='compile shared library for embedding node in another project. ' +
-          '(This mode is not officially supported for regular applications)')
-+parser.add_argument('--libdir',
-+    action='store',
-+    dest='libdir',
-+    default='lib',
-+    help='a directory to install the shared library into')
-+
- parser.add_argument('--without-v8-platform',
-     action='store_true',
-     dest='without_v8_platform',
-@@ -1103,6 +1109,7 @@ def configure_node(o):
-   o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
-   o['variables']['node_shared'] = b(options.shared)
-+  o['variables']['libdir'] = options.libdir
-   node_module_version = getmoduleversion.get_version()
-   if options.dest_os == 'android':
-diff --git a/tools/install.py b/tools/install.py
-index 655802980a6ea94d1d4ca1dc63c8c8e905fbb83a..fe4723bf15012c8aacacb0393dc8294c049b0503 100755
---- a/tools/install.py
-+++ b/tools/install.py
-@@ -121,22 +121,19 @@ def subdir_files(path, dest, action):
- def files(action):
-   is_windows = sys.platform == 'win32'
--  output_file = 'node'
-   output_prefix = 'out/Release/'
-+  output_libprefix = output_prefix
--  if 'false' == variables.get('node_shared'):
--    if is_windows:
--      output_file += '.exe'
-+  if is_windows:
-+    output_bin = 'node.exe'
-+    output_lib = 'node.dll'
-   else:
--    if is_windows:
--      output_file += '.dll'
--    else:
--      output_file = 'lib' + output_file + '.' + variables.get('shlib_suffix')
-+    output_bin = 'node'
-+    output_lib = 'libnode.' + variables.get('shlib_suffix')
--  if 'false' == variables.get('node_shared'):
--    action([output_prefix + output_file], 'bin/' + output_file)
--  else:
--    action([output_prefix + output_file], 'lib/' + output_file)
-+  action([output_prefix + output_bin], 'bin/' + output_bin)
-+  if 'true' == variables.get('node_shared'):
-+    action([output_libprefix + output_lib], variables.get('libdir') + '/' + output_lib)
-   if 'true' == variables.get('node_use_dtrace'):
-     action(['out/Release/node.d'], 'lib/dtrace/node.d')
--- 
-2.23.0
-
diff --git a/gcc13.patch b/gcc13.patch
deleted file mode 100644 (file)
index 2732acc..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-From c2792e58035fcbaa16d0cb70998852fbeb5df4cc Mon Sep 17 00:00:00 2001
-From: WANG Xuerui <git@xen0n.name>
-Date: Fri, 07 Oct 2022 00:23:49 +0800
-Subject: [PATCH] [base] Fix build with gcc-13
-
-See https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes.
-
-Also see Gentoo Linux bug report: https://bugs.gentoo.org/865981
-
-Change-Id: I421f396b02ba37e12ee70048ee33e034f8113566
-Reviewed-on: https://chromium-review.googlesource.com/c/v8/v8/+/3934140
-Reviewed-by: Clemens Backes <clemensb@chromium.org>
-Reviewed-by: Simon Zünd <szuend@chromium.org>
-Commit-Queue: Clemens Backes <clemensb@chromium.org>
-Cr-Commit-Position: refs/heads/main@{#83587}
----
-
-diff --git a/src/base/logging.h b/src/base/logging.h
-index 08db24a..38be165 100644
---- a/src/base/logging.h
-+++ b/src/base/logging.h
-@@ -5,6 +5,7 @@
- #ifndef V8_BASE_LOGGING_H_
- #define V8_BASE_LOGGING_H_
-+#include <cstdint>
- #include <cstring>
- #include <sstream>
- #include <string>
-diff --git a/src/inspector/v8-string-conversions.h b/src/inspector/v8-string-conversions.h
-index c1d69c1..eb33c68 100644
---- a/src/inspector/v8-string-conversions.h
-+++ b/src/inspector/v8-string-conversions.h
-@@ -5,6 +5,7 @@
- #ifndef V8_INSPECTOR_V8_STRING_CONVERSIONS_H_
- #define V8_INSPECTOR_V8_STRING_CONVERSIONS_H_
-+#include <cstdint>
- #include <string>
- // Conversion routines between UT8 and UTF16, used by string-16.{h,cc}. You may
index ecb789d4f091e3c4edc063408c26cceb80ae5421..0ccd551680ce301c4e974d7453301a2de44091f0 100644 (file)
 Summary:       Asynchronous JavaScript Engine
 Summary(pl.UTF-8):     Asynchroniczny silnik JavaScriptu
 Name:          nodejs
-# 14.x LTS - https://github.com/nodejs/Release
-# Active start: 2020-10-27
-# Maintenance start: October 2020
-# Maintenance end: April 2023
-Version:       16.16.0
-Release:       3
+# 16.x LTS - https://github.com/nodejs/Release
+# Active start: 2021-10-26
+# Maintenance start: October 2022
+# Maintenance end: September 2023
+Version:       16.20.1
+Release:       1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
-Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 987d57f2a6be10f61a8cd9907b585050
+Source0:       https://nodejs.org/download/release/latest-v16.x/node-v%{version}.tar.xz
+# Source0-md5: 0eb71fbf3fcf35c9ed479f10c55eedad
 Patch0:                system_cares.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
 Patch3:                %{name}-lib64path.patch
 Patch4:                0001-Disable-running-gyp-on-shared-deps.patch
-Patch5:                0002-Install-both-binaries-and-use-libdir.patch
-Patch6:                gcc13.patch
 URL:           https://nodejs.org/
 BuildRequires: c-ares-devel >= 1.17.2
 BuildRequires: gcc >= 6:6.3
@@ -76,7 +74,7 @@ Requires:     nghttp2-libs >= 1.42.0
 Requires:      zlib >= 1.2.11
 Provides:      nodejs(engine) = %{version}
 Provides:      nodejs(module-version) = %{node_module_version}
-Obsoletes:     nodejs-waf
+Obsoletes:     nodejs-waf < 0.9
 ExclusiveArch: %{ix86} %{x8664} %{arm} aarch64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -162,8 +160,6 @@ Sondy systemtap/dtrace dla Node.js.
 %patch2 -p1
 %endif
 %patch4 -p1
-%patch5 -p1
-%patch6 -p1 -d deps/v8
 
 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python$,#!%{__python3},'
 
This page took 0.199729 seconds and 4 git commands to generate.