]> git.pld-linux.org Git - packages/nginx.git/commitdiff
update rtmp module to 1.1.7
authorElan Ruusamäe <glen@delfi.ee>
Fri, 27 Mar 2015 18:32:56 +0000 (20:32 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Fri, 27 Mar 2015 18:32:56 +0000 (20:32 +0200)
nginx-rtmp-module-build.patch [deleted file]
nginx.spec

diff --git a/nginx-rtmp-module-build.patch b/nginx-rtmp-module-build.patch
deleted file mode 100644 (file)
index ae8ccce..0000000
+++ /dev/null
@@ -1,89 +0,0 @@
-From dd5f2aa117c617e1f0fde26f8fd58903be2d85e8 Mon Sep 17 00:00:00 2001
-From: Roman Arutyunyan <arut@qip.ru>
-Date: Wed, 17 Sep 2014 07:10:38 +0400
-Subject: [PATCH] fixed compilation
-
----
- ngx_rtmp.c             | 4 ++++
- ngx_rtmp.h             | 9 +++++++++
- ngx_rtmp_play_module.c | 8 +++++++-
- 3 files changed, 20 insertions(+), 1 deletion(-)
-
-diff --git a/ngx_rtmp.c b/ngx_rtmp.c
-index c079c90..e525a93 100644
---- a/ngx_rtmp.c
-+++ b/ngx_rtmp.c
-@@ -31,7 +31,11 @@ static char * ngx_rtmp_merge_applications(ngx_conf_t *cf,
-         ngx_uint_t ctx_index);
-+#if (nginx_version >= 1007005)
-+ngx_thread_volatile ngx_queue_t     ngx_rtmp_init_queue;
-+#else
- ngx_thread_volatile ngx_event_t    *ngx_rtmp_init_queue;
-+#endif
- ngx_uint_t  ngx_rtmp_max_module;
-diff --git a/ngx_rtmp.h b/ngx_rtmp.h
-index d3648f7..b87e99e 100644
---- a/ngx_rtmp.h
-+++ b/ngx_rtmp.h
-@@ -12,6 +12,7 @@
- #include <ngx_core.h>
- #include <ngx_event.h>
- #include <ngx_event_connect.h>
-+#include <nginx.h>
- #include "ngx_rtmp_amf.h"
- #include "ngx_rtmp_bandwidth.h"
-@@ -198,7 +199,11 @@ typedef struct {
-     ngx_str_t              *addr_text;
-     int                     connected;
-+#if (nginx_version >= 1007005)
-+    ngx_queue_t             posted_dry_events;
-+#else
-     ngx_event_t            *posted_dry_events;
-+#endif
-     /* client buffer time in msec */
-     uint32_t                buflen;
-@@ -602,7 +607,11 @@ extern ngx_rtmp_bandwidth_t                 ngx_rtmp_bw_in;
- extern ngx_uint_t                           ngx_rtmp_naccepted;
-+#if (nginx_version >= 1007005)
-+extern ngx_thread_volatile ngx_queue_t      ngx_rtmp_init_queue;
-+#else
- extern ngx_thread_volatile ngx_event_t     *ngx_rtmp_init_queue;
-+#endif
- extern ngx_uint_t                           ngx_rtmp_max_module;
- extern ngx_module_t                         ngx_rtmp_core_module;
-diff --git a/ngx_rtmp_play_module.c b/ngx_rtmp_play_module.c
-index acaa46c..f6ea6c3 100644
---- a/ngx_rtmp_play_module.c
-+++ b/ngx_rtmp_play_module.c
-@@ -6,6 +6,7 @@
- #include <ngx_config.h>
- #include <ngx_core.h>
-+#include <nginx.h>
- #include "ngx_rtmp_play_module.h"
- #include "ngx_rtmp_cmd_module.h"
- #include "ngx_rtmp_netcall_module.h"
-@@ -430,7 +431,12 @@ ngx_rtmp_play_do_stop(ngx_rtmp_session_t *s)
-         ngx_del_timer(&ctx->send_evt);
-     }
--    if (ctx->send_evt.prev) {
-+#if (nginx_version >= 1007005)
-+    if (ctx->send_evt.posted)
-+#else
-+    if (ctx->send_evt.prev)
-+#endif
-+    {
-         ngx_delete_posted_event((&ctx->send_evt));
-     }
index 73f100c732f08cd2ee61cbc54b3bc5a49d65fa24..2b0b737f0294ce549886c7a2cca29af3a766b3a7 100644 (file)
@@ -23,7 +23,7 @@
 %bcond_with    rtmp            # rtmp support
 %bcond_without auth_request    # auth_request module
 
-%define                rtmp_version    1.1.5
+%define                rtmp_version    1.1.7
 Summary:       High perfomance HTTP and reverse proxy server
 Summary(pl.UTF-8):     Serwer HTTP i odwrotne proxy o wysokiej wydajności
 # nginx lines:
@@ -58,12 +58,9 @@ Source18:    %{name}-standard.service
 Source19:      %{name}-light.service
 Source20:      %{name}-perl.service
 Source21:      %{name}-mail.service
-# when updating rtmp version, use this url:
-#Source101:    https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/nginx-rtmp-module-%{rtmp_version}.tar.gz
-Source101:     https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}.tar.gz
-# Source101-md5:       a85f8201c01b7c229b01a5e0fc87b374
+Source101:     https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/nginx-rtmp-module-%{rtmp_version}.tar.gz
+# Source101-md5:       8006de2560db3e55bb15d110220076ac
 Patch0:                %{name}-no-Werror.patch
-Patch1:                nginx-rtmp-module-build.patch
 URL:           http://nginx.net/
 BuildRequires: mailcap
 BuildRequires: openssl-devel
@@ -292,9 +289,6 @@ Plik monitrc do monitorowania serwera WWW nginx.
 
 %if %{with rtmp}
 mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
-cd nginx-rtmp-module
-%patch1 -p1
-cd ..
 %endif
 
 # build mime.types.conf
@@ -303,7 +297,7 @@ cd ..
 %build
 # NB: not autoconf generated configure
 cp -f configure auto/
-#
+
 %if %{with perl}
 ./configure \
        --prefix=%{_prefix} \
This page took 0.755853 seconds and 4 git commands to generate.