]> git.pld-linux.org Git - packages/nginx.git/commitdiff
Provide the vhosts.d and webapps.d directories
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Mon, 14 Oct 2013 14:24:22 +0000 (16:24 +0200)
committerJacek Konieczny <jajcus@jajcus.net>
Mon, 14 Oct 2013 14:24:22 +0000 (16:24 +0200)
This can be used like those for our other webservers.

nginx-light.conf
nginx-perl.conf
nginx-standard.conf
nginx.spec

index 6c507e77fd2ceb547ba983af96993db31de795d4..2a4d20fabebf3bb2a408d12b4091926fdb498127 100644 (file)
@@ -40,6 +40,8 @@ http {
                        limit_conn      test-limit      15;
                }
 
+               include webapps.d/*.conf;
+
 
 #              location /nginx_status {
 #                      stub_status     on;
@@ -66,4 +68,5 @@ http {
 
        }
 
+       include vhosts.d/*.conf;
 }
index 88f7c5776e4fb56aa173863b93f0aaef52529269..be689a3c8c120b4006e41d660fe18e5b530577fa 100644 (file)
@@ -78,6 +78,8 @@ http {
                        fastcgi_read_timeout    5m;
                }
 
+               include webapps.d/*.conf;
+
 #              location /nginx_status {
 #                      stub_status     on;
 #                      access_log      off;
@@ -96,4 +98,5 @@ http {
 
        }
 
+       include vhosts.d/*.conf;
 }
index 43da0e73ad1308037b411ae5725ce3e4584416a5..104300ce4ec23b73c3f8eb6d179b7776add0e62b 100644 (file)
@@ -49,6 +49,7 @@ http {
                        limit_conn      test-limit      15;
                }
 
+               include webapps.d/*.conf;
 
 #              location /nginx_status {
 #                      stub_status     on;
@@ -75,4 +76,5 @@ http {
 
        }
 
+       include vhosts.d/*.conf;
 }
index 9a1c2bdf4d0de1d6eae88c5e84512282e23939c0..e7958d63e0dd8270ae0f543f11a5841e96524d50 100644 (file)
@@ -378,7 +378,7 @@ install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
        $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
        $RPM_BUILD_ROOT%{_localstatedir}/cache/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
        $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
-       $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}} \
+       $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{vhosts,webapps}.d} \
        $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
        $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
 
@@ -578,6 +578,8 @@ fi
 %attr(640,root,root) %{_sysconfdir}/koi-utf
 %attr(640,root,root) %{_sysconfdir}/koi-win
 %attr(640,root,root) %{_sysconfdir}/win-utf
+%dir %{_sysconfdir}/webapps.d
+%dir %{_sysconfdir}/vhosts.d
 %attr(750,nginx,logs) %dir /var/log/archive/%{name}
 %attr(750,nginx,logs) /var/log/%{name}
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
This page took 0.04768 seconds and 4 git commands to generate.