]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
- missing fastcgi.params file
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - /etc/sysconfig/nginx file
3 # - missing perl build/install requires
4 # - nginx should have own group (and work with it) or use http group ?
5 #
6 # Conditional build for nginx:
7 %bcond_without  light           # don't build light version
8 %bcond_without  mail            # don't build imap/mail proxy
9 %bcond_without  perl            # don't build with perl module
10 %bcond_without  addition        # adds module
11 %bcond_without  dav             # WebDAV
12 %bcond_without  flv             # FLV stream
13 %bcond_without  sub             # ngx_http_sub_module
14 %bcond_without  poll            # poll
15 %bcond_without  realip          # real ip (behind proxy)
16 %bcond_without  rtsig           # rtsig
17 %bcond_without  select          # select
18 %bcond_without  status          # stats module
19 %bcond_without  ssl             # ssl support
20 %bcond_with     http_browser    # header "User-agent" parser
21 #
22 Summary:        High perfomance HTTP and reverse proxy server
23 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
24 Name:           nginx
25 Version:        0.5.34
26 Release:        0.2
27 License:        BSD-like
28 Group:          Networking/Daemons
29 Source0:        http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
30 # Source0-md5:  8f7d3efcd7caaf1f06e4d95dfaeac238
31 Source1:        http://www.nginx.eu/favicon.ico
32 # Source1-md5:  2aaf2115c752cbdbfb8a2f0b3c3189ab
33 Source2:        http://www.nginx.eu/download/proxy.conf
34 # Source2-md5:  f5263ae01c2edb18f46d5d1df2d3a5cd
35 Source3:        %{name}.logrotate
36 Source4:        %{name}.mime
37 Source5:        %{name}-light.conf
38 Source6:        %{name}-light.monitrc
39 Source7:        %{name}-light.init
40 Source8:        %{name}-mail.conf
41 Source9:        %{name}-mail.monitrc
42 Source10:       %{name}-mail.init
43 Source11:       %{name}-perl.conf
44 Source12:       %{name}-perl.monitrc
45 Source13:       %{name}-perl.init
46 Source14:       %{name}-standard.conf
47 Source15:       %{name}-standard.monitrc
48 Source16:       %{name}-standard.init
49 Source17:       %{name}-mime.types.sh
50 Patch0:         %{name}-config.patch
51 URL:            http://nginx.net/
52 BuildRequires:  mailcap
53 BuildRequires:  openssl-devel
54 BuildRequires:  pcre-devel
55 %{?with_perl:BuildRequires: perl-CGI}
56 %{?with_perl:BuildRequires: perl-devel}
57 %{?with_perl:BuildRequires: rpm-perlprov}
58 BuildRequires:  rpmbuild(macros) >= 1.268
59 BuildRequires:  zlib-devel
60 Requires(post,preun):   /sbin/chkconfig
61 Requires(postun):       /usr/sbin/groupdel
62 Requires(postun):       /usr/sbin/userdel
63 Requires(pre):  /bin/id
64 Requires(pre):  /usr/bin/getgid
65 Requires(pre):  /usr/sbin/groupadd
66 Requires(pre):  /usr/sbin/useradd
67 Requires:       nginx-daemon
68 Requires:       openssl
69 Requires:       pcre
70 Requires:       rc-scripts >= 0.2.0
71 Requires:       zlib
72 Suggests:       nginx-standard
73 Provides:       group(http)
74 Provides:       group(nginx)
75 Provides:       user(nginx)
76 Provides:       webserver
77 Conflicts:      logrotate < 3.7-4
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %define         _sysconfdir     /etc/%{name}
81 %define         _nginxdir       /home/services/%{name}
82
83 %description
84 nginx ("engine x") is a high-performance HTTP server and reverse
85 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
86 Sysoev for Rambler.ru, Russia's second-most visited website, where it
87 has been running in production for over two and a half years. Igor has
88 released the source code under a BSD-like license. Although still in
89 beta, nginx is known for its stability, rich feature set, simple
90 configuration, and low resource consumption.
91
92 Common files for nginx daemon.
93
94 %description -l pl.UTF-8
95 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
96 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva
97 na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
98 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
99 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
100 w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
101 prostej konfiguracji oraz małej "zasobożerności".
102
103 Niezbędne pliki dla nginx.
104
105 %package light
106 Summary:        High perfomance HTTP and reverse proxy server
107 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
108 Group:          Networking/Daemons
109 Requires(post,preun):   /sbin/chkconfig
110 Requires(postun):       /usr/sbin/groupdel
111 Requires(postun):       /usr/sbin/userdel
112 Requires:       %{name} = %{version}-%{release}
113 Requires:       openssl
114 Requires:       pcre
115 Requires:       zlib
116 Provides:       group(http)
117 Provides:       group(nginx)
118 Provides:       nginx-daemon
119 Provides:       user(nginx)
120 Provides:       webserver
121
122 %description light
123 The smallest, but also the fastest nginx edition. No additional
124 modules, no Perl, no DAV, no FLV, no IMAP, POP3, SMTP proxy.
125
126 %description light -l pl.UTF-8
127 Najmniejsza i najszybsza wersja nginx. Bez wsparcia dla Perla, DAV,
128 FLV oraz IMAP, POP3, SMTP proxy.
129
130 %package perl
131 Summary:        High perfomance HTTP and reverse proxy server
132 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
133 Group:          Networking/Daemons
134 Requires(post,preun):   /sbin/chkconfig
135 Requires(postun):       /usr/sbin/groupdel
136 Requires(postun):       /usr/sbin/userdel
137 Requires:       %{name} = %{version}-%{release}
138 Requires:       openssl
139 Provides:       group(http)
140 Provides:       group(nginx)
141 Provides:       nginx-daemon
142 Provides:       user(nginx)
143 Provides:       webserver
144
145 %description perl
146 nginx with Perl support. Mail modules not included.
147
148 %description perl -l pl.UTF-8
149 nginx z obsługą Perla. Bez wsparcia dla modułów poczty.
150
151 %package mail
152 Summary:        High perfomance IMAP, POP3, SMTP proxy server
153 Summary(pl.UTF-8):      IMAP, POP3, SMTP proxy o wysokiej wydajności
154 Group:          Networking/Daemons
155 Requires(post,preun):   /sbin/chkconfig
156 Requires(postun):       /usr/sbin/groupdel
157 Requires(postun):       /usr/sbin/userdel
158 Requires:       %{name} = %{version}-%{release}
159 Requires:       openssl
160 Requires:       pcre
161 Requires:       zlib
162 Provides:       group(http)
163 Provides:       group(nginx)
164 Provides:       nginx-daemon
165 Provides:       user(nginx)
166 Provides:       webserver
167
168 %description mail
169 nginx with mail support. Only mail modules included.
170
171 %description mail -l pl.UTF-8
172 nginx ze wsparciem tylko dla modułów poczty.
173
174 %package standard
175 Summary:        High perfomance HTTP and reverse proxy server
176 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
177 Group:          Networking/Daemons
178 Requires(post,preun):   /sbin/chkconfig
179 Requires(postun):       /usr/sbin/groupdel
180 Requires(postun):       /usr/sbin/userdel
181 Requires:       %{name} = %{version}-%{release}
182 Requires:       openssl
183 Provides:       group(http)
184 Provides:       group(nginx)
185 Provides:       nginx-daemon
186 Conflicts:      logrotate < 3.7-4
187
188 %description standard
189 This is standard nginx version, without Perl support and IMAP, POP3,
190 SMTP proxy. 
191
192 %description standard -l pl.UTF-8
193 To jest standardowa wersja nginx, bez obsługi Perla oraz proxy dla
194 IMAP, POP3, SMTP.
195
196 %package -n monit-rc-nginx
197 Summary:        nginx support for monit
198 Summary(pl.UTF-8):      Wsparcie nginx dla monit
199 Group:          Applications/System
200 URL:            http://nginx.eu/
201 Requires:       %{name} = %{version}-%{release}
202 Requires:       monit
203
204 %description -n monit-rc-nginx
205 monitrc file for monitoring nginx webserver.
206
207 %description -n monit-rc-nginx -l pl.UTF-8
208 Plik monitrc do monitorowania serwera WWW nginx.
209
210 %prep
211 %setup -q
212 %patch0 -p0
213
214 # build mime.types.conf
215 #sh %{SOURCE17} /etc/mime.types
216
217 %build
218 # NB: not autoconf generated configure
219 cp -f configure auto/
220 #
221 %if %{with perl}
222 ./configure \
223         --prefix=%{_prefix} \
224         --sbin-path=%{_sbindir}/%{name}-perl \
225         --conf-path=%{_sysconfdir}/%{name}-perl.conf \
226         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_error.log \
227         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_access.log \
228         --pid-path=%{_localstatedir}/run/%{name}-perl.pid \
229         --lock-path=%{_localstatedir}/lock/subsys/%{name}-perl \
230         --user=nginx \
231         --group=nginx \
232         --with-http_perl_module \
233         --without-mail_pop3_module \
234         --without-mail_imap_module \
235         --without-mail_smtp_module \
236         %{?with_addition:--with-http_addition_module} \
237         %{?with_dav:--with-http_dav_module} \
238         %{?with_flv:--with-http_flv_module} \
239         %{?with_sub:--with-http_sub_module} \
240         %{?with_poll:--with-poll_module} \
241         %{?with_realip:--with-http_realip_module} \
242         %{?with_rtsig:--with-rtsig_module} \
243         %{?with_select:--with-select_module} \
244         %{?with_status:--with-http_stub_status_module} \
245         %{?with_ssl:--with-http_ssl_module} \
246         %{!?with_http_browser:--without-http_browser_module} \
247         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-perl/client_body_temp \
248         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-perl/proxy_temp \
249         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-perl/fastcgi_temp \
250         --with-cc="%{__cc}" \
251         --with-cc-opt="%{rpmcflags}" \
252         --with-ld-opt="%{rpmldflags}"
253 %{__make}
254 mv -f objs/nginx contrib/nginx-perl
255 mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.bs contrib/nginx.bs
256 mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so contrib/nginx.so
257 mv -f objs/src/http/modules/perl/nginx.pm contrib/nginx.pm
258 %endif
259
260 %if %{with mail}
261 ./configure \
262         --prefix=%{_prefix} \
263         --sbin-path=%{_sbindir}/%{name}-mail \
264         --conf-path=%{_sysconfdir}/%{name}-mail.conf \
265         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_error.log \
266         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_access.log \
267         --pid-path=%{_localstatedir}/run/%{name}-mail.pid \
268         --lock-path=%{_localstatedir}/lock/subsys/%{name}-mail \
269         --user=nginx \
270         --group=nginx \
271         --with-imap \
272         --with-mail \
273         --with-mail_ssl_module \
274         --without-http \
275         %{?with_poll:--with-poll_module} \
276         %{?with_rtsig:--with-rtsig_module} \
277         %{?with_select:--with-select_module} \
278         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-mail/client_body_temp \
279         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-mail/proxy_temp \
280         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-mail/fastcgi_temp \
281         --with-cc="%{__cc}" \
282         --with-cc-opt="%{rpmcflags}" \
283         --with-ld-opt="%{rpmldflags}" \
284         %{?debug:--with-debug}
285 %{__make}
286 mv -f objs/nginx contrib/nginx-mail
287 %endif
288
289 %if %{with light}
290 ./configure \
291         --prefix=%{_prefix} \
292         --sbin-path=%{_sbindir}/%{name}-light \
293         --conf-path=%{_sysconfdir}/%{name}-light.conf \
294         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-light_error.log \
295         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-light_access.log \
296         --pid-path=%{_localstatedir}/run/%{name}-light.pid \
297         --lock-path=%{_localstatedir}/lock/subsys/%{name}-light \
298         --user=nginx \
299         --group=nginx \
300         %{?with_poll:--with-poll_module} \
301         %{?with_realip:--with-http_realip_module} \
302         %{?with_rtsig:--with-rtsig_module} \
303         %{?with_select:--with-select_module} \
304         %{?with_status:--with-http_stub_status_module} \
305         %{?with_ssl:--with-http_ssl_module} \
306         --without-http_browser_module \
307         --without-mail_pop3_module \
308         --without-mail_imap_module \
309         --without-mail_smtp_module \
310         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-light/client_body_temp \
311         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-light/proxy_temp \
312         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-light/fastcgi_temp \
313         --with-cc="%{__cc}" \
314         --with-cc-opt="%{rpmcflags}" \
315         --with-ld-opt="%{rpmldflags}" \
316         %{?debug:--with-debug}
317 %{__make}
318 mv -f objs/nginx contrib/nginx-light
319 %endif
320
321 ./configure \
322         --prefix=%{_prefix} \
323         --sbin-path=%{_sbindir}/%{name}-standard \
324         --conf-path=%{_sysconfdir}/%{name}-standard.conf \
325         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_error.log \
326         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_access.log \
327         --pid-path=%{_localstatedir}/run/%{name}-standard.pid \
328         --lock-path=%{_localstatedir}/lock/subsys/%{name}-standard \
329         --user=nginx \
330         --group=nginx \
331         %{?with_addition:--with-http_addition_module} \
332         %{?with_dav:--with-http_dav_module} \
333         %{?with_flv:--with-http_flv_module} \
334         %{?with_sub:--with-http_sub_module} \
335         %{?with_poll:--with-poll_module} \
336         %{?with_realip:--with-http_realip_module} \
337         %{?with_rtsig:--with-rtsig_module} \
338         %{?with_select:--with-select_module} \
339         %{?with_status:--with-http_stub_status_module} \
340         %{?with_ssl:--with-http_ssl_module} \
341         %{!?with_http_browser:--without-http_browser_module} \
342         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-standard/client_body_temp \
343         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-standard/proxy_temp \
344         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-standard/fastcgi_temp \
345         --with-cc="%{__cc}" \
346         --with-cc-opt="%{rpmcflags}" \
347         --with-ld-opt="%{rpmldflags}" \
348         %{?debug:--with-debug}
349 %{__make}
350
351
352 %install
353 rm -rf $RPM_BUILD_ROOT
354 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
355         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
356         $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
357         $RPM_BUILD_ROOT%{_localstatedir}/cache/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
358         $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
359         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}} \
360         $RPM_BUILD_ROOT/etc/{logrotate.d,monit}
361
362 install conf/fastcgi_params $RPM_BUILD_ROOT%{_sysconfdir}/fastcgi.params
363 install conf/koi-utf $RPM_BUILD_ROOT%{_sysconfdir}/koi-utf
364 install conf/koi-win $RPM_BUILD_ROOT%{_sysconfdir}/koi-win
365 install conf/win-utf $RPM_BUILD_ROOT%{_sysconfdir}/win-utf
366 install html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
367 install html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
368 install %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
369 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
370 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
371 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
372 install %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-standard.conf
373 install %{SOURCE15} $RPM_BUILD_ROOT/etc/monit/%{name}-standard.monitrc
374 install %{SOURCE16} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-standard
375 install objs/%{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}-standard
376
377 %if %{with light}
378 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-light.conf
379 install %{SOURCE6} $RPM_BUILD_ROOT/etc/monit/%{name}-light.monitrc
380 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-light
381 install contrib/nginx-light $RPM_BUILD_ROOT%{_sbindir}/%{name}-light
382 %endif
383
384 %if %{with mail}
385 install %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-mail.conf
386 install %{SOURCE9} $RPM_BUILD_ROOT/etc/monit/%{name}-mail.monitrc
387 install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-mail
388 install contrib/nginx-mail $RPM_BUILD_ROOT%{_sbindir}/%{name}-mail
389 %endif
390
391 %if %{with perl}
392 install -d $RPM_BUILD_ROOT{%{perl_vendorarch},%{perl_vendorarch}/auto/%{name}}
393 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-perl.conf
394 install %{SOURCE12} $RPM_BUILD_ROOT/etc/monit/%{name}-perl.monitrc
395 install %{SOURCE13} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-perl
396 install contrib/nginx.pm $RPM_BUILD_ROOT%{perl_vendorarch}/%{name}.pm
397 install contrib/nginx.so $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.so
398 install contrib/nginx.bs $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.bs
399 install contrib/nginx-perl $RPM_BUILD_ROOT%{_sbindir}/%{name}-perl
400 %endif
401
402 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/*.default
403 rm -rf $RPM_BUILD_ROOT%{_prefix}/html
404
405 %clean
406 rm -rf $RPM_BUILD_ROOT
407
408 %pre
409 %groupadd -r -g 213 %{name}
410 %groupadd -g 51 http
411 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
412 %addusertogroup %{name} http
413
414 %post standard
415 for a in access.log error.log; do
416         if [ ! -f /var/log/%{name}/nginx-standard_$a ]; then
417                 umask 022
418                 touch /var/log/%{name}/nginx-standard_$a
419                 chown nginx:nginx /var/log/%{name}/nginx-standard_$a
420                 chmod 644 /var/log/%{name}/nginx-standard_$a
421         fi
422 done
423 /sbin/chkconfig --add %{name}-standard
424 %service %{name}-standard restart
425 echo 'NOTE: daemon is now using "/etc/nginx/nginx-standard.conf" as config.'
426
427 %post light
428 for a in access.log error.log; do
429         if [ ! -f /var/log/%{name}/nginx-light_$a ]; then
430                 umask 022
431                 touch /var/log/%{name}/nginx-light_$a
432                 chown nginx:nginx /var/log/%{name}/nginx-light_$a
433                 chmod 644 /var/log/%{name}/nginx-light_$a
434         fi
435 done
436 /sbin/chkconfig --add %{name}-light
437 %service %{name}-light restart
438 echo 'NOTE: daemon is now using "/etc/nginx/nginx-light.conf" as config'
439
440 %post perl
441 for a in access.log error.log; do
442         if [ ! -f /var/log/%{name}/nginx-perl_$a ]; then
443                 umask 022
444                 touch /var/log/%{name}/nginx-perl_$a
445                 chown nginx:nginx /var/log/%{name}/nginx-perl_$a
446                 chmod 644 /var/log/%{name}/nginx-perl_$a
447         fi
448 done
449 /sbin/chkconfig --add %{name}-perl
450 %service %{name}-perl restart
451 echo 'NOTE: daemon is now using "/etc/nginx/nginx-perl.conf" as config'
452
453 %post mail
454 for a in access.log error.log; do
455         if [ ! -f /var/log/%{name}/nginx-mail_$a ]; then
456                 umask 022
457                 touch /var/log/%{name}/nginx-mail_$a
458                 chown nginx:nginx /var/log/%{name}/nginx-mail_$a
459                 chmod 644 /var/log/%{name}/nginx-mail_$a
460         fi
461 done
462 /sbin/chkconfig --add %{name}-mail
463 %service %{name}-mail restart
464 echo 'NOTE: daemon is now using "/etc/nginx/nginx-mail.conf" as config'
465
466 %preun standard
467 if [ "$1" = "0" ];then
468         %service %{name}-standard stop
469         /sbin/chkconfig --del %{name}-standard
470 fi
471
472 %preun light
473 if [ "$1" = "0" ]; then
474         %service %{name}-light stop
475         /sbin/chkconfig --del %{name}-light
476 fi
477
478 %preun perl
479 if [ "$1" = "0" ]; then
480         %service %{name}-perl stop
481         /sbin/chkconfig --del %{name}-perl
482 fi
483
484 %preun mail
485 if [ "$1" = "0" ]; then
486         %service %{name}-mail stop
487         /sbin/chkconfig --del %{name}-mail
488 fi
489
490 %postun
491 if [ "$1" = "0" ]; then
492         %userremove %{name}
493         %groupremove %{name}
494 fi
495
496 %files
497 %defattr(644,root,root,755)
498 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
499 %doc %lang(ru) CHANGES.ru
500 %dir %attr(754,root,root) %{_sysconfdir}
501 %dir %{_nginxdir}
502 %dir %{_nginxdir}/cgi-bin
503 %dir %{_nginxdir}/html
504 %dir %{_nginxdir}/errors
505 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
506 # XXX: duplicates, don't use such glob here
507 #%attr(640,root,root) %{_sysconfdir}/*[_-]*
508 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
509 attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.params
510 %attr(640,root,root) %{_sysconfdir}/mime.types
511 %attr(640,root,root) %{_sysconfdir}/koi-utf
512 %attr(640,root,root) %{_sysconfdir}/koi-win
513 %attr(640,root,root) %{_sysconfdir}/win-utf
514 %attr(750,root,root) %dir /var/log/archive/%{name}
515 %attr(750,%{name},logs) /var/log/%{name}
516 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
517 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
518
519 %files standard
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{_sbindir}/%{name}-standard
522 %attr(770,root,%{name}) /var/cache/%{name}-standard
523 %attr(754,root,root) /etc/rc.d/init.d/%{name}-standard
524 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-standard.conf
525
526 %if %{with mail}
527 %files mail
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_sbindir}/%{name}-mail
530 %attr(770,root,%{name}) /var/cache/%{name}-mail
531 %attr(754,root,root) /etc/rc.d/init.d/%{name}-mail
532 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-mail.conf
533 %endif
534
535 %if %{with light}
536 %files light
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_sbindir}/%{name}-light
539 %attr(770,root,%{name}) /var/cache/%{name}-light
540 %attr(754,root,root) /etc/rc.d/init.d/%{name}-light
541 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-light.conf
542 %endif
543
544 %if %{with perl}
545 %files perl
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{_sbindir}/%{name}-perl
548 %attr(754,root,root) /etc/rc.d/init.d/%{name}-perl
549 %attr(770,root,%{name}) /var/cache/%{name}-perl
550 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-perl.conf
551 %dir %{perl_vendorarch}/auto/%{name}
552 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
553 %{perl_vendorarch}/auto/%{name}/%{name}.bs
554 %{perl_vendorarch}/%{name}.pm
555 %endif
556
557 %files -n monit-rc-nginx
558 %defattr(644,root,root,755)
559 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-standard.monitrc
560 %if %{with perl}
561 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-perl.monitrc
562 %endif
563 %if %{with light}
564 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-light.monitrc
565 %endif
566 %if %{with mail}
567 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-mail.monitrc
568 %endif
This page took 0.165256 seconds and 4 git commands to generate.