]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
- updated to 0.6.35
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - /etc/sysconfig/nginx file
3 # - missing perl build/install requires
4 # - nginx should have own group (and work with it) or use http group ?
5 #
6 # Conditional build for nginx:
7 %bcond_without  light           # don't build light version
8 %bcond_without  mail            # don't build imap/mail proxy
9 %bcond_without  perl            # don't build with perl module
10 %bcond_without  addition        # adds module
11 %bcond_without  dav             # WebDAV
12 %bcond_without  flv             # FLV stream
13 %bcond_without  sub             # ngx_http_sub_module
14 %bcond_without  poll            # poll
15 %bcond_without  realip          # real ip (behind proxy)
16 %bcond_without  rtsig           # rtsig
17 %bcond_without  select          # select
18 %bcond_without  status          # stats module
19 %bcond_without  ssl             # ssl support
20 %bcond_with     http_browser    # header "User-agent" parser
21 #
22 Summary:        High perfomance HTTP and reverse proxy server
23 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
24 Name:           nginx
25 Version:        0.6.35
26 Release:        1
27 License:        BSD-like
28 Group:          Networking/Daemons/HTTP
29 Source0:        http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
30 # Source0-md5:  45c7a2d3d91f27f5af1b463f0ff46070
31 Source1:        http://www.nginx.eu/favicon.ico
32 # Source1-md5:  2aaf2115c752cbdbfb8a2f0b3c3189ab
33 Source2:        http://www.nginx.eu/download/proxy.conf
34 # Source2-md5:  f5263ae01c2edb18f46d5d1df2d3a5cd
35 Source3:        %{name}.logrotate
36 Source4:        %{name}.mime
37 Source5:        %{name}-light.conf
38 Source6:        %{name}-light.monitrc
39 Source7:        %{name}-light.init
40 Source8:        %{name}-mail.conf
41 Source9:        %{name}-mail.monitrc
42 Source10:       %{name}-mail.init
43 Source11:       %{name}-perl.conf
44 Source12:       %{name}-perl.monitrc
45 Source13:       %{name}-perl.init
46 Source14:       %{name}-standard.conf
47 Source15:       %{name}-standard.monitrc
48 Source16:       %{name}-standard.init
49 Source17:       %{name}-mime.types.sh
50 URL:            http://nginx.net/
51 BuildRequires:  mailcap
52 BuildRequires:  openssl-devel
53 BuildRequires:  pcre-devel
54 %{?with_perl:BuildRequires: perl-CGI}
55 %{?with_perl:BuildRequires: perl-devel}
56 %{?with_perl:BuildRequires: python}
57 %{?with_perl:BuildRequires: rpm-perlprov}
58 BuildRequires:  rpmbuild(macros) >= 1.268
59 BuildRequires:  zlib-devel
60 Requires(post,preun):   /sbin/chkconfig
61 Requires(postun):       /usr/sbin/groupdel
62 Requires(postun):       /usr/sbin/userdel
63 Requires(pre):  /bin/id
64 Requires(pre):  /usr/bin/getgid
65 Requires(pre):  /usr/sbin/groupadd
66 Requires(pre):  /usr/sbin/useradd
67 Requires:       nginx-daemon
68 Requires:       openssl
69 Requires:       pcre
70 Requires:       rc-scripts >= 0.2.0
71 Requires:       zlib
72 Suggests:       nginx-standard
73 Provides:       group(http)
74 Provides:       group(nginx)
75 Provides:       user(nginx)
76 Provides:       webserver
77 Conflicts:      logrotate < 3.7-4
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %define         _sysconfdir     /etc/%{name}
81 %define         _nginxdir       /home/services/%{name}
82
83 %description
84 nginx ("engine x") is a high-performance HTTP server and reverse
85 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
86 Sysoev for Rambler.ru, Russia's second-most visited website, where it
87 has been running in production for over two and a half years. Igor has
88 released the source code under a BSD-like license. Although still in
89 beta, nginx is known for its stability, rich feature set, simple
90 configuration, and low resource consumption.
91
92 Common files for nginx daemon.
93
94 %description -l pl.UTF-8
95 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
96 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva
97 na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
98 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
99 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
100 w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
101 prostej konfiguracji oraz małej "zasobożerności".
102
103 Niezbędne pliki dla nginx.
104
105 %package light
106 Summary:        High perfomance HTTP and reverse proxy server
107 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
108 Group:          Networking/Daemons/HTTP
109 Requires(post,preun):   /sbin/chkconfig
110 Requires(postun):       /usr/sbin/groupdel
111 Requires(postun):       /usr/sbin/userdel
112 Requires:       %{name} = %{version}-%{release}
113 Requires:       openssl
114 Requires:       pcre
115 Requires:       zlib
116 Provides:       group(http)
117 Provides:       group(nginx)
118 Provides:       nginx-daemon
119 Provides:       user(nginx)
120 Provides:       webserver
121
122 %description light
123 The smallest, but also the fastest nginx edition. No additional
124 modules, no Perl, no DAV, no FLV, no IMAP, POP3, SMTP proxy.
125
126 %description light -l pl.UTF-8
127 Najmniejsza i najszybsza wersja nginx. Bez wsparcia dla Perla, DAV,
128 FLV oraz IMAP, POP3, SMTP proxy.
129
130 %package perl
131 Summary:        High perfomance HTTP and reverse proxy server
132 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
133 Group:          Networking/Daemons/HTTP
134 Requires(post,preun):   /sbin/chkconfig
135 Requires(postun):       /usr/sbin/groupdel
136 Requires(postun):       /usr/sbin/userdel
137 Requires:       %{name} = %{version}-%{release}
138 Requires:       openssl
139 Provides:       group(http)
140 Provides:       group(nginx)
141 Provides:       nginx-daemon
142 Provides:       user(nginx)
143 Provides:       webserver
144
145 %description perl
146 nginx with Perl support. Mail modules not included.
147
148 %description perl -l pl.UTF-8
149 nginx z obsługą Perla. Bez wsparcia dla modułów poczty.
150
151 %package mail
152 Summary:        High perfomance IMAP, POP3, SMTP proxy server
153 Summary(pl.UTF-8):      IMAP, POP3, SMTP proxy o wysokiej wydajności
154 Group:          Networking/Daemons/HTTP
155 Requires(post,preun):   /sbin/chkconfig
156 Requires(postun):       /usr/sbin/groupdel
157 Requires(postun):       /usr/sbin/userdel
158 Requires:       %{name} = %{version}-%{release}
159 Requires:       openssl
160 Requires:       pcre
161 Requires:       zlib
162 Provides:       group(http)
163 Provides:       group(nginx)
164 Provides:       nginx-daemon
165 Provides:       user(nginx)
166 Provides:       webserver
167
168 %description mail
169 nginx with mail support. Only mail modules included.
170
171 %description mail -l pl.UTF-8
172 nginx ze wsparciem tylko dla modułów poczty.
173
174 %package standard
175 Summary:        High perfomance HTTP and reverse proxy server
176 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
177 Group:          Networking/Daemons/HTTP
178 Requires(post,preun):   /sbin/chkconfig
179 Requires(postun):       /usr/sbin/groupdel
180 Requires(postun):       /usr/sbin/userdel
181 Requires:       %{name} = %{version}-%{release}
182 Requires:       openssl
183 Provides:       group(http)
184 Provides:       group(nginx)
185 Provides:       nginx-daemon
186 Conflicts:      logrotate < 3.7-4
187
188 %description standard
189 This is standard nginx version, without Perl support and IMAP, POP3,
190 SMTP proxy. 
191
192 %description standard -l pl.UTF-8
193 To jest standardowa wersja nginx, bez obsługi Perla oraz proxy dla
194 IMAP, POP3, SMTP.
195
196 %package -n monit-rc-nginx
197 Summary:        nginx support for monit
198 Summary(pl.UTF-8):      Wsparcie nginx dla monit
199 Group:          Applications/System
200 URL:            http://nginx.eu/
201 Requires:       %{name} = %{version}-%{release}
202 Requires:       monit
203
204 %description -n monit-rc-nginx
205 monitrc file for monitoring nginx webserver.
206
207 %description -n monit-rc-nginx -l pl.UTF-8
208 Plik monitrc do monitorowania serwera WWW nginx.
209
210 %prep
211 %setup -q
212
213 # build mime.types.conf
214 #sh %{SOURCE17} /etc/mime.types
215
216 %build
217 # NB: not autoconf generated configure
218 cp -f configure auto/
219 #
220 %if %{with perl}
221 ./configure \
222         --prefix=%{_prefix} \
223         --sbin-path=%{_sbindir}/%{name}-perl \
224         --conf-path=%{_sysconfdir}/%{name}-perl.conf \
225         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_error.log \
226         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_access.log \
227         --pid-path=%{_localstatedir}/run/%{name}-perl.pid \
228         --lock-path=%{_localstatedir}/lock/subsys/%{name}-perl \
229         --user=nginx \
230         --group=nginx \
231         --with-http_perl_module \
232         --without-mail_pop3_module \
233         --without-mail_imap_module \
234         --without-mail_smtp_module \
235         %{?with_addition:--with-http_addition_module} \
236         %{?with_dav:--with-http_dav_module} \
237         %{?with_flv:--with-http_flv_module} \
238         %{?with_sub:--with-http_sub_module} \
239         %{?with_poll:--with-poll_module} \
240         %{?with_realip:--with-http_realip_module} \
241         %{?with_rtsig:--with-rtsig_module} \
242         %{?with_select:--with-select_module} \
243         %{?with_status:--with-http_stub_status_module} \
244         %{?with_ssl:--with-http_ssl_module} \
245         %{!?with_http_browser:--without-http_browser_module} \
246         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-perl/client_body_temp \
247         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-perl/proxy_temp \
248         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-perl/fastcgi_temp \
249         --with-cc="%{__cc}" \
250         --with-cc-opt="%{rpmcflags}" \
251         --with-ld-opt="%{rpmldflags}"
252 %{__make}
253 mv -f objs/nginx contrib/nginx-perl
254 mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.bs contrib/nginx.bs
255 mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so contrib/nginx.so
256 mv -f objs/src/http/modules/perl/nginx.pm contrib/nginx.pm
257 %endif
258
259 %if %{with mail}
260 ./configure \
261         --prefix=%{_prefix} \
262         --sbin-path=%{_sbindir}/%{name}-mail \
263         --conf-path=%{_sysconfdir}/%{name}-mail.conf \
264         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_error.log \
265         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_access.log \
266         --pid-path=%{_localstatedir}/run/%{name}-mail.pid \
267         --lock-path=%{_localstatedir}/lock/subsys/%{name}-mail \
268         --user=nginx \
269         --group=nginx \
270         --with-imap \
271         --with-mail \
272         --with-mail_ssl_module \
273         --without-http \
274         %{?with_poll:--with-poll_module} \
275         %{?with_rtsig:--with-rtsig_module} \
276         %{?with_select:--with-select_module} \
277         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-mail/client_body_temp \
278         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-mail/proxy_temp \
279         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-mail/fastcgi_temp \
280         --with-cc="%{__cc}" \
281         --with-cc-opt="%{rpmcflags}" \
282         --with-ld-opt="%{rpmldflags}" \
283         %{?debug:--with-debug}
284 %{__make}
285 mv -f objs/nginx contrib/nginx-mail
286 %endif
287
288 %if %{with light}
289 ./configure \
290         --prefix=%{_prefix} \
291         --sbin-path=%{_sbindir}/%{name}-light \
292         --conf-path=%{_sysconfdir}/%{name}-light.conf \
293         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-light_error.log \
294         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-light_access.log \
295         --pid-path=%{_localstatedir}/run/%{name}-light.pid \
296         --lock-path=%{_localstatedir}/lock/subsys/%{name}-light \
297         --user=nginx \
298         --group=nginx \
299         %{?with_poll:--with-poll_module} \
300         %{?with_realip:--with-http_realip_module} \
301         %{?with_rtsig:--with-rtsig_module} \
302         %{?with_select:--with-select_module} \
303         %{?with_status:--with-http_stub_status_module} \
304         %{?with_ssl:--with-http_ssl_module} \
305         --without-http_browser_module \
306         --without-mail_pop3_module \
307         --without-mail_imap_module \
308         --without-mail_smtp_module \
309         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-light/client_body_temp \
310         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-light/proxy_temp \
311         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-light/fastcgi_temp \
312         --with-cc="%{__cc}" \
313         --with-cc-opt="%{rpmcflags}" \
314         --with-ld-opt="%{rpmldflags}" \
315         %{?debug:--with-debug}
316 %{__make}
317 mv -f objs/nginx contrib/nginx-light
318 %endif
319
320 ./configure \
321         --prefix=%{_prefix} \
322         --sbin-path=%{_sbindir}/%{name}-standard \
323         --conf-path=%{_sysconfdir}/%{name}-standard.conf \
324         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_error.log \
325         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_access.log \
326         --pid-path=%{_localstatedir}/run/%{name}-standard.pid \
327         --lock-path=%{_localstatedir}/lock/subsys/%{name}-standard \
328         --user=nginx \
329         --group=nginx \
330         %{?with_addition:--with-http_addition_module} \
331         %{?with_dav:--with-http_dav_module} \
332         %{?with_flv:--with-http_flv_module} \
333         %{?with_sub:--with-http_sub_module} \
334         %{?with_poll:--with-poll_module} \
335         %{?with_realip:--with-http_realip_module} \
336         %{?with_rtsig:--with-rtsig_module} \
337         %{?with_select:--with-select_module} \
338         %{?with_status:--with-http_stub_status_module} \
339         %{?with_ssl:--with-http_ssl_module} \
340         %{!?with_http_browser:--without-http_browser_module} \
341         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-standard/client_body_temp \
342         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-standard/proxy_temp \
343         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-standard/fastcgi_temp \
344         --with-cc="%{__cc}" \
345         --with-cc-opt="%{rpmcflags}" \
346         --with-ld-opt="%{rpmldflags}" \
347         %{?debug:--with-debug}
348 %{__make}
349
350
351 %install
352 rm -rf $RPM_BUILD_ROOT
353 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
354         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
355         $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
356         $RPM_BUILD_ROOT%{_localstatedir}/cache/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
357         $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
358         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}} \
359         $RPM_BUILD_ROOT/etc/{logrotate.d,monit}
360
361 install conf/fastcgi_params $RPM_BUILD_ROOT%{_sysconfdir}/fastcgi.params
362 install conf/koi-utf $RPM_BUILD_ROOT%{_sysconfdir}/koi-utf
363 install conf/koi-win $RPM_BUILD_ROOT%{_sysconfdir}/koi-win
364 install conf/win-utf $RPM_BUILD_ROOT%{_sysconfdir}/win-utf
365 install html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
366 install html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
367 install %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
368 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
369 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
370 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
371 install %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-standard.conf
372 install %{SOURCE15} $RPM_BUILD_ROOT/etc/monit/%{name}-standard.monitrc
373 install %{SOURCE16} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-standard
374 install objs/%{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}-standard
375
376 %if %{with light}
377 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-light.conf
378 install %{SOURCE6} $RPM_BUILD_ROOT/etc/monit/%{name}-light.monitrc
379 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-light
380 install contrib/nginx-light $RPM_BUILD_ROOT%{_sbindir}/%{name}-light
381 %endif
382
383 %if %{with mail}
384 install %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-mail.conf
385 install %{SOURCE9} $RPM_BUILD_ROOT/etc/monit/%{name}-mail.monitrc
386 install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-mail
387 install contrib/nginx-mail $RPM_BUILD_ROOT%{_sbindir}/%{name}-mail
388 %endif
389
390 %if %{with perl}
391 install -d $RPM_BUILD_ROOT{%{perl_vendorarch},%{perl_vendorarch}/auto/%{name}}
392 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-perl.conf
393 install %{SOURCE12} $RPM_BUILD_ROOT/etc/monit/%{name}-perl.monitrc
394 install %{SOURCE13} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-perl
395 install contrib/nginx.pm $RPM_BUILD_ROOT%{perl_vendorarch}/%{name}.pm
396 install contrib/nginx.so $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.so
397 install contrib/nginx.bs $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.bs
398 install contrib/nginx-perl $RPM_BUILD_ROOT%{_sbindir}/%{name}-perl
399 %endif
400
401 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/*.default
402 rm -rf $RPM_BUILD_ROOT%{_prefix}/html
403
404 %clean
405 rm -rf $RPM_BUILD_ROOT
406
407 %pre
408 %groupadd -r -g 213 %{name}
409 %groupadd -g 51 http
410 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
411 %addusertogroup %{name} http
412
413 %post standard
414 for a in access.log error.log; do
415         if [ ! -f /var/log/%{name}/nginx-standard_$a ]; then
416                 umask 022
417                 touch /var/log/%{name}/nginx-standard_$a
418                 chown nginx:nginx /var/log/%{name}/nginx-standard_$a
419                 chmod 644 /var/log/%{name}/nginx-standard_$a
420         fi
421 done
422 /sbin/chkconfig --add %{name}-standard
423 %service %{name}-standard restart
424 echo 'NOTE: daemon is now using "/etc/nginx/nginx-standard.conf" as config.'
425
426 %post light
427 for a in access.log error.log; do
428         if [ ! -f /var/log/%{name}/nginx-light_$a ]; then
429                 umask 022
430                 touch /var/log/%{name}/nginx-light_$a
431                 chown nginx:nginx /var/log/%{name}/nginx-light_$a
432                 chmod 644 /var/log/%{name}/nginx-light_$a
433         fi
434 done
435 /sbin/chkconfig --add %{name}-light
436 %service %{name}-light restart
437 echo 'NOTE: daemon is now using "/etc/nginx/nginx-light.conf" as config'
438
439 %post perl
440 for a in access.log error.log; do
441         if [ ! -f /var/log/%{name}/nginx-perl_$a ]; then
442                 umask 022
443                 touch /var/log/%{name}/nginx-perl_$a
444                 chown nginx:nginx /var/log/%{name}/nginx-perl_$a
445                 chmod 644 /var/log/%{name}/nginx-perl_$a
446         fi
447 done
448 /sbin/chkconfig --add %{name}-perl
449 %service %{name}-perl restart
450 echo 'NOTE: daemon is now using "/etc/nginx/nginx-perl.conf" as config'
451
452 %post mail
453 for a in access.log error.log; do
454         if [ ! -f /var/log/%{name}/nginx-mail_$a ]; then
455                 umask 022
456                 touch /var/log/%{name}/nginx-mail_$a
457                 chown nginx:nginx /var/log/%{name}/nginx-mail_$a
458                 chmod 644 /var/log/%{name}/nginx-mail_$a
459         fi
460 done
461 /sbin/chkconfig --add %{name}-mail
462 %service %{name}-mail restart
463 echo 'NOTE: daemon is now using "/etc/nginx/nginx-mail.conf" as config'
464
465 %preun standard
466 if [ "$1" = "0" ];then
467         %service %{name}-standard stop
468         /sbin/chkconfig --del %{name}-standard
469 fi
470
471 %preun light
472 if [ "$1" = "0" ]; then
473         %service %{name}-light stop
474         /sbin/chkconfig --del %{name}-light
475 fi
476
477 %preun perl
478 if [ "$1" = "0" ]; then
479         %service %{name}-perl stop
480         /sbin/chkconfig --del %{name}-perl
481 fi
482
483 %preun mail
484 if [ "$1" = "0" ]; then
485         %service %{name}-mail stop
486         /sbin/chkconfig --del %{name}-mail
487 fi
488
489 %postun
490 if [ "$1" = "0" ]; then
491         %userremove %{name}
492         %groupremove %{name}
493 fi
494
495 %files
496 %defattr(644,root,root,755)
497 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
498 %doc %lang(ru) CHANGES.ru
499 %dir %attr(754,root,root) %{_sysconfdir}
500 %dir %{_nginxdir}
501 %dir %{_nginxdir}/cgi-bin
502 %dir %{_nginxdir}/html
503 %dir %{_nginxdir}/errors
504 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
505 # XXX: duplicates, don't use such glob here
506 #%attr(640,root,root) %{_sysconfdir}/*[_-]*
507 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
508 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.params
509 %attr(640,root,root) %{_sysconfdir}/mime.types
510 %attr(640,root,root) %{_sysconfdir}/koi-utf
511 %attr(640,root,root) %{_sysconfdir}/koi-win
512 %attr(640,root,root) %{_sysconfdir}/win-utf
513 %attr(750,root,root) %dir /var/log/archive/%{name}
514 %attr(750,%{name},logs) /var/log/%{name}
515 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
516 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
517
518 %files standard
519 %defattr(644,root,root,755)
520 %attr(755,root,root) %{_sbindir}/%{name}-standard
521 %attr(770,root,%{name}) /var/cache/%{name}-standard
522 %attr(754,root,root) /etc/rc.d/init.d/%{name}-standard
523 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-standard.conf
524
525 %if %{with mail}
526 %files mail
527 %defattr(644,root,root,755)
528 %attr(755,root,root) %{_sbindir}/%{name}-mail
529 %attr(770,root,%{name}) /var/cache/%{name}-mail
530 %attr(754,root,root) /etc/rc.d/init.d/%{name}-mail
531 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-mail.conf
532 %endif
533
534 %if %{with light}
535 %files light
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_sbindir}/%{name}-light
538 %attr(770,root,%{name}) /var/cache/%{name}-light
539 %attr(754,root,root) /etc/rc.d/init.d/%{name}-light
540 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-light.conf
541 %endif
542
543 %if %{with perl}
544 %files perl
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_sbindir}/%{name}-perl
547 %attr(754,root,root) /etc/rc.d/init.d/%{name}-perl
548 %attr(770,root,%{name}) /var/cache/%{name}-perl
549 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-perl.conf
550 %dir %{perl_vendorarch}/auto/%{name}
551 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
552 %{perl_vendorarch}/auto/%{name}/%{name}.bs
553 %{perl_vendorarch}/%{name}.pm
554 %endif
555
556 %files -n monit-rc-nginx
557 %defattr(644,root,root,755)
558 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-standard.monitrc
559 %if %{with perl}
560 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-perl.monitrc
561 %endif
562 %if %{with light}
563 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-light.monitrc
564 %endif
565 %if %{with mail}
566 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-mail.monitrc
567 %endif
This page took 0.075559 seconds and 3 git commands to generate.