]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
Up to 1.26.0
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - /etc/sysconfig/nginx file
3 # - missing perl build/install requires
4 # - add njs: https://nginx.org/en/docs/njs/
5 #
6 # Conditional build for nginx:
7 # Features
8 %bcond_with     debug           # enable debug logging: http://nginx.org/en/docs/debugging_log.html
9 %bcond_without  file_aio        # file AIO support
10 %bcond_without  threads         # thread pool support
11 # Modules
12 %bcond_without  addition        # http addition module
13 %bcond_without  auth_request    # auth_request module
14 %bcond_without  dav             # WebDAV
15 %bcond_without  flv             # http FLV module
16 %bcond_without  gd              # without http image filter module
17 %bcond_without  geoip           # without http geoip module and stream geoip module
18 %bcond_without  http2           # HTTP/2 module
19 %bcond_without  http3           # HTTP/3 module
20 %bcond_without  mail            # don't build imap/mail proxy
21 %bcond_without  perl            # don't build with perl module
22 %bcond_without  poll            # poll module
23 %bcond_without  realip          # real ip (behind proxy)
24 %bcond_without  select          # select module
25 %bcond_without  ssl             # ssl support and http ssl module
26 %bcond_without  stream          # TCP/UDP proxy module
27 %bcond_without  stub_status     # http stub status module
28 %bcond_without  sub             # ngx_http_sub_module
29 %bcond_without  xslt            # without http xslt module
30 %bcond_with     http_browser    # http browser module (header "User-agent" parser)
31 %bcond_without  modsecurity     # modsecurity module
32 %bcond_with     rtmp            # rtmp support
33 %bcond_without  vts             # virtual host traffic status module
34 %bcond_without  headers_more    # headers more module
35
36 %ifarch x32
37 %undefine       with_rtsig
38 %endif
39
40 %define         ssl_version     1.0.2
41 %define         rtmp_version    1.2.2
42 %define         vts_version     0.2.2
43 %define         headers_more_version    0.37
44 %define         modsecurity_version     1.0.3
45 %define         http_cache_purge_version        2.5.3
46
47 Summary:        High perfomance HTTP and reverse proxy server
48 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
49 # nginx mainline is recommended by nginx team: https://www.nginx.com/blog/nginx-1-6-1-7-released/
50 # http://nginx.org/en/download.html
51 Name:           nginx
52 Version:        1.25.4
53 Release:        1
54 License:        BSD-like
55 Group:          Networking/Daemons/HTTP
56 Source0:        https://nginx.org/download/%{name}-%{version}.tar.gz
57 # Source0-md5:  527a2e135e8b158ef502239ce4701018
58 Source1:        https://nginx.org/favicon.ico
59 # Source1-md5:  72e228c3809db53da8a884b6676ed36a
60 Source2:        proxy.conf
61 Source3:        %{name}.logrotate
62 Source4:        %{name}.mime
63 Source6:        %{name}.monitrc
64 Source7:        %{name}.init
65 Source14:       %{name}.conf
66 Source17:       %{name}-mime.types.sh
67 Source18:       %{name}.service
68 Source33:       https://github.com/SpiderLabs/ModSecurity-nginx/releases/download/v%{modsecurity_version}/modsecurity-%{name}-v%{modsecurity_version}.tar.gz
69 # Source33-md5: b85e1996f81b51a06a32e73b3be4709d
70 Source101:      https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/%{name}-rtmp-module-%{rtmp_version}.tar.gz
71 # Source101-md5:        9bb7a06aede38d9e36ad13dc1354d8f9
72 Source102:      https://github.com/vozlt/nginx-module-vts/archive/v%{vts_version}.tar.gz
73 # Source102-md5:        aeb08aec8dc89e45fb9411be76850d63
74 Source103:      https://github.com/openresty/headers-more-nginx-module/archive/v%{headers_more_version}.tar.gz
75 # Source103-md5:        21782630f592fd2e046df96de30923ad
76 # https://github.com/nginx-modules/ngx_cache_purge
77 Source104:      https://github.com/nginx-modules/ngx_cache_purge/archive/refs/tags/%{http_cache_purge_version}.tar.gz
78 # Source104-md5:        bf92baae08e4c850825a8543c7d4aaa8
79 Patch0:         %{name}-no-Werror.patch
80 URL:            https://nginx.org/
81 BuildRequires:  mailcap
82 BuildRequires:  pcre2-8-devel
83 BuildRequires:  rpmbuild(macros) >= 1.644
84 BuildRequires:  zlib-devel
85 %if %{with geoip}
86 BuildRequires:  GeoIP-devel
87 %endif
88 %if %{with gd}
89 BuildRequires:  gd-devel
90 %endif
91 %if %{with modsecurity}
92 BuildRequires:  lua-devel
93 BuildRequires:  libmodsecurity-devel
94 %endif
95 %if %{with perl}
96 BuildRequires:  perl-CGI
97 BuildRequires:  perl-devel
98 BuildRequires:  python3
99 BuildRequires:  rpm-perlprov
100 %endif
101 %if %{with ssl}
102 BuildRequires:  openssl-devel >= %{ssl_version}
103 Requires:       openssl >= %{ssl_version}
104 %endif
105 %if %{with xslt}
106 BuildRequires:  libxslt-devel
107 %endif
108 Provides:       group(http)
109 Provides:       group(nginx)
110 Provides:       user(nginx)
111 Provides:       webserver
112 Provides:       webserver(access)
113 Provides:       webserver(alias)
114 Provides:       webserver(auth)
115 Provides:       webserver(expires)
116 Provides:       webserver(headers)
117 Provides:       webserver(indexfile)
118 Provides:       webserver(log)
119 Provides:       webserver(mime)
120 Provides:       webserver(reqtimeout)
121 Provides:       webserver(rewrite)
122 Provides:       webserver(setenv)
123 Conflicts:      logrotate < 3.8.0
124 Requires(post,preun):   /sbin/chkconfig
125 Requires(post,preun,postun):    systemd-units >= 38
126 Requires(postun):       /usr/sbin/groupdel
127 Requires(postun):       /usr/sbin/userdel
128 Requires(pre):  /bin/id
129 Requires(pre):  /usr/bin/getgid
130 Requires(pre):  /usr/sbin/groupadd
131 Requires(pre):  /usr/sbin/useradd
132 Requires:       rc-scripts >= 0.2.0
133 Requires:       systemd-units >= 38
134 Suggests:       vim-syntax-nginx
135 Obsoletes:      nginx-common < 1.13.3
136 Obsoletes:      nginx-light < 1.13.3
137 Obsoletes:      nginx-standard < 1.13.3
138 Conflicts:      rpm < 4.4.2-0.2
139 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
140
141 %define         _sysconfdir     /etc/%{name}
142 %define         _nginxdir       /home/services/%{name}
143
144 # minimizing restarts logics. we restart webserver:
145 #
146 # 1. at the end of transaction. (posttrans, feature from rpm 4.4.2)
147 # 2. first install of module (post: $1 = 1)
148 # 2. uninstall of module (postun: $1 == 0)
149 #
150 # the strict internal deps between modules and
151 # main package are very important for all this to work.
152
153 # restart webserver at the end of transaction
154
155 %define restart_webserver \
156         %systemd_post %{name}.service \
157         %service %{name} force-reload \
158         %{nil}
159
160 # macro called at module post scriptlet
161 %define module_post \
162 if [ "$1" = "1" ]; then \
163         %restart_webserver \
164 fi
165
166 # macro called at module postun scriptlet
167 %define module_postun \
168 if [ "$1" = "0" ]; then \
169         %restart_webserver \
170 fi
171
172 # it's sooo annoying to write them
173 %define module_scripts() \
174 %post %1 \
175 %module_post \
176 \
177 %postun %1 \
178 %module_postun
179
180 %description
181 nginx ("engine x") is a high-performance HTTP server and reverse
182 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
183 Sysoev for Rambler.ru, Russia's second-most visited website, where it
184 has been running in production for over two and a half years. Igor has
185 released the source code under a BSD-like license. Although still in
186 beta, nginx is known for its stability, rich feature set, simple
187 configuration, and low resource consumption.
188
189 %description -l pl.UTF-8
190 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
191 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
192 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
193 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
194 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
195 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
196 prostej konfiguracji oraz małej "zasobożerności".
197
198 %package mod_headers_more
199 Summary:        Nginx HTTP headers more module
200 Group:          Daemons
201 Requires:       %{name} = %{version}-%{release}
202
203 %description mod_headers_more
204 Set and clear input and output headers...more than "add".
205
206 %package mod_http_geoip
207 Summary:        Nginx HTTP geoip module
208 Group:          Daemons
209 Requires:       %{name} = %{version}-%{release}
210 Requires:       GeoIP
211
212 %description mod_http_geoip
213 Nginx HTTP geoip module.
214
215 %package mod_stream_geoip
216 Summary:        Nginx stream geoip module
217 Group:          Daemons
218 Requires:       %{name} = %{version}-%{release}
219 Requires:       %{name}-mod_stream = %{version}-%{release}
220 Requires:       GeoIP
221
222 %description mod_stream_geoip
223 Nginx stream geoip module.
224
225 %package mod_http_image_filter
226 Summary:        Nginx HTTP image filter module
227 Group:          Daemons
228 Requires:       %{name} = %{version}-%{release}
229
230 %description mod_http_image_filter
231 Nginx HTTP image filter module.
232
233 %package mod_http_perl
234 Summary:        Nginx HTTP Perl module
235 Group:          Networking/Daemons/HTTP
236 Requires:       %{name} = %{version}-%{release}
237
238 %description mod_http_perl
239 Nginx HTTP Perl module.
240
241 %package mod_http_xslt_filter
242 Summary:        Nginx XSLT module
243 Group:          Daemons
244 Requires:       %{name} = %{version}-%{release}
245
246 %description mod_http_xslt_filter
247 Nginx XSLT module.
248
249 %package mod_mail
250 Summary:        Nginx mail module
251 Group:          Networking/Daemons/HTTP
252 Requires:       %{name} = %{version}-%{release}
253
254 %description mod_mail
255 Nginx mail module.
256
257 %package mod_vts
258 Summary:        Nginx virtual host traffic status module
259 Group:          Networking/Daemons/HTTP
260 Requires:       %{name} = %{version}-%{release}
261
262 %description mod_vts
263 Nginx virtual host traffic status module.
264
265 %package mod_stream
266 Summary:        Nginx stream modules
267 Group:          Daemons
268 Requires:       %{name} = %{version}-%{release}
269
270 %description mod_stream
271 Nginx stream modules.
272
273 %package mod_http_cache_purge
274 Summary:        Nginx cache purge module
275 Group:          Daemons
276 Requires:       %{name} = %{version}-%{release}
277
278 %description mod_http_cache_purge
279 `ngx_cache_purge` is `nginx` module which adds ability to purge
280 content from `FastCGI`, `proxy`, `SCGI` and `uWSGI` caches.
281
282 %package mod_http_modsecurity
283 Summary:        Nginx modsecurity module
284 Group:          Daemons
285 Requires:       %{name} = %{version}-%{release}
286
287 %description mod_http_modsecurity
288 The ModSecurity-nginx connector takes the form of an nginx module. The
289 module simply serves as a layer of communication between nginx and
290 ModSecurity.
291
292 %package -n monit-rc-nginx
293 Summary:        nginx support for monit
294 Summary(pl.UTF-8):      Wsparcie nginx dla monit
295 Group:          Applications/System
296 Requires:       %{name} = %{version}-%{release}
297 Requires:       monit
298
299 %description -n monit-rc-nginx
300 monitrc file for monitoring nginx webserver.
301
302 %description -n monit-rc-nginx -l pl.UTF-8
303 Plik monitrc do monitorowania serwera WWW nginx.
304
305 %prep
306 %setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a33} %{?with_vts:-a102} %{?with_headers_more:-a103} -a104
307 %patch0 -p0
308
309 %if %{with rtmp}
310 mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
311 %endif
312
313 %if %{with vts}
314 mv nginx-module-vts-%{vts_version} nginx-vts-module
315 %endif
316
317 %if %{with headers_more}
318 mv headers-more-nginx-module-%{headers_more_version} nginx-headers-more-module
319 %endif
320
321 mv ngx_cache_purge-* ngx_cache_purge
322
323 # build mime.types.conf
324 #sh %{SOURCE17} /etc/mime.types
325
326 %build
327 # NB: not autoconf generated configure
328 cp -f configure auto/
329
330 ./configure \
331         --prefix=%{_prefix} \
332         --modules-path=%{_libdir}/%{name}/modules \
333         --sbin-path=%{_sbindir}/%{name} \
334         --conf-path=%{_sysconfdir}/%{name}.conf \
335         --error-log-path=%{_localstatedir}/log/%{name}/error.log \
336         --http-log-path=%{_localstatedir}/log/%{name}/access.log \
337         --pid-path=%{_localstatedir}/run/%{name}.pid \
338         --lock-path=%{_localstatedir}/lock/subsys/%{name} \
339         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
340         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
341         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
342         --http-uwsgi-temp-path=%{_localstatedir}/cache/%{name}/uwsgi_temp \
343         --http-scgi-temp-path=%{_localstatedir}/cache/%{name}/scgi_temp \
344         --user=nginx \
345         --group=nginx \
346         --with-compat \
347         %{?with_select:--with-select_module} \
348         %{?with_poll:--with-poll_module} \
349         %{?with_rtsig:--with-rtsig_module} \
350         %{?with_perl:--with-http_perl_module=dynamic} \
351         %{?with_gd:--with-http_image_filter_module=dynamic} \
352         %{?with_xslt:--with-http_xslt_module=dynamic} \
353         %{?with_geoip:--with-http_geoip_module=dynamic} \
354         %{?with_geoip:--with-stream_geoip_module=dynamic} \
355 %if %{with mail}
356         --with-mail=dynamic \
357         --with-mail_ssl_module \
358 %endif
359 %if %{with stream}
360         --with-stream=dynamic \
361         --with-stream_ssl_module \
362 %endif
363         --with-cc="%{__cc}" \
364         --with-cc-opt="%{rpmcflags}" \
365         --with-ld-opt="%{rpmldflags}" \
366         %{?with_debug:--with-debug} \
367         %{?with_addition:--with-http_addition_module} \
368         %{?with_dav:--with-http_dav_module} \
369         %{?with_flv:--with-http_flv_module} \
370         %{?with_sub:--with-http_sub_module} \
371         %{?with_realip:--with-http_realip_module} \
372         %{?with_stub_status:--with-http_stub_status_module} \
373         %{?with_ssl:--with-http_ssl_module} \
374         %{!?with_http_browser:--without-http_browser_module} \
375         --add-dynamic-module=./ngx_cache_purge \
376         %{?with_headers_more:--add-dynamic-module=./nginx-headers-more-module} \
377         %{?with_rtmp:--add-module=./nginx-rtmp-module} \
378         %{?with_vts:--add-dynamic-module=./nginx-vts-module} \
379         %{?with_auth_request:--with-http_auth_request_module} \
380         %{?with_threads:--with-threads} \
381         %{?with_http2:--with-http_v2_module} \
382         %{?with_http3:--with-http_v3_module} \
383         %{?with_modsecurity:--add-dynamic-module=modsecurity-nginx-v%{modsecurity_version}} \
384         --with-http_secure_link_module \
385         %{?with_file_aio:--with-file-aio} \
386         %{nil}
387
388 %{__make}
389
390 %install
391 rm -rf $RPM_BUILD_ROOT
392 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
393         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
394         $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
395         $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
396         $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
397         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{conf,modules,vhosts,webapps}.d} \
398         $RPM_BUILD_ROOT%{_sysconfdir}/snippets \
399         $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
400         $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
401
402 %{__make} install \
403         INSTALLDIRS=vendor \
404         DESTDIR=$RPM_BUILD_ROOT
405
406 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/*.default
407
408 cp -p %{_sourcedir}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
409 cp -p %{_sourcedir}/%{name}.service $RPM_BUILD_ROOT%{systemdunitdir}
410 cp -p %{_sourcedir}/%{name}.monitrc $RPM_BUILD_ROOT/etc/monit
411 install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
412
413 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
414 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
415 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
416 rm -r $RPM_BUILD_ROOT%{_prefix}/html
417 cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
418 cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
419 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
420
421 load_module() {
422         local module=ngx_${1}_module.so conffile=mod_$1.conf
423         printf 'load_module "%{_libdir}/%{name}/modules/%s";' "$module" \
424                 > $RPM_BUILD_ROOT%{_sysconfdir}/modules.d/$conffile
425 }
426
427 %if %{with perl}
428 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
429 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/nginx/.packlist
430 load_module http_perl
431 %endif
432
433 %if %{with geoip}
434 load_module http_geoip
435 load_module stream_geoip
436 %endif
437 %if %{with gd}
438 load_module http_image_filter
439 %endif
440 %if %{with xslt}
441 load_module http_xslt_filter
442 %endif
443 %if %{with mail}
444 load_module mail
445 %endif
446 %{?with_vts:load_module http_vhost_traffic_status}
447 %{?with_headers_more:load_module http_headers_more_filter}
448 %if %{with stream}
449 load_module stream
450 %endif
451 %if %{with modsecurity}
452 load_module http_modsecurity
453 %endif
454 load_module http_cache_purge
455
456 %clean
457 rm -rf $RPM_BUILD_ROOT
458
459 %pre
460 %groupadd -r -g 213 %{name}
461 %groupadd -g 51 http
462 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
463 %addusertogroup %{name} http
464
465 %post
466 for a in access.log error.log; do
467         if [ ! -f /var/log/%{name}/$a ]; then
468                 umask 022
469                 touch /var/log/%{name}/$a
470                 chown nginx:nginx /var/log/%{name}/$a
471                 chmod 644 /var/log/%{name}/$a
472         fi
473 done
474 /sbin/chkconfig --add %{name}
475
476 %posttrans
477 %restart_webserver
478
479 %preun
480 if [ "$1" = "0" ];then
481         %service %{name} stop
482         /sbin/chkconfig --del %{name}
483 fi
484 %systemd_preun %{name}.service
485
486 %postun
487 if [ "$1" = "0" ]; then
488         %userremove %{name}
489         %groupremove %{name}
490 fi
491 %systemd_reload
492
493 %module_scripts mod_http_geoip
494 %module_scripts mod_http_image_filter
495 %module_scripts mod_http_perl
496 %module_scripts mod_http_xslt_filter
497 %module_scripts mod_mail
498 %module_scripts mod_vts
499 %module_scripts mod_headers_more
500 %module_scripts mod_stream
501 %module_scripts mod_stream_geoip
502 %module_scripts mod_http_cache_purge
503
504 %files
505 %defattr(644,root,root,755)
506 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
507 %doc %lang(ru) CHANGES.ru
508 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
509 %attr(754,root,root) /etc/rc.d/init.d/%{name}
510 %dir %attr(750,root,nginx) %{_sysconfdir}
511 %dir %{_sysconfdir}/conf.d
512 %dir %{_sysconfdir}/modules.d
513 %dir %{_sysconfdir}/snippets
514 %dir %{_sysconfdir}/vhosts.d
515 %dir %{_sysconfdir}/webapps.d
516 %attr(640,root,root) %{_sysconfdir}/mime.types
517 %attr(640,root,root) %{_sysconfdir}/koi-utf
518 %attr(640,root,root) %{_sysconfdir}/koi-win
519 %attr(640,root,root) %{_sysconfdir}/win-utf
520 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.conf
521 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
522 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
523 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
524 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
525 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
526 %attr(755,root,root) %{_sbindir}/%{name}
527 %dir %{_libdir}/%{name}
528 %dir %{_libdir}/%{name}/modules
529 %{systemdunitdir}/%{name}.service
530
531 %attr(750,nginx,logs) %dir /var/log/archive/%{name}
532 %attr(750,nginx,logs) /var/log/%{name}
533 %attr(770,root,nginx) /var/cache/%{name}
534
535 %dir %{_nginxdir}
536 %dir %{_nginxdir}/cgi-bin
537 %dir %{_nginxdir}/html
538 %dir %{_nginxdir}/errors
539 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
540 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
541
542 %if %{with geoip}
543 %files mod_http_geoip
544 %defattr(644,root,root,755)
545 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_geoip.conf
546 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_geoip_module.so
547
548 %files mod_stream_geoip
549 %defattr(644,root,root,755)
550 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream_geoip.conf
551 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_geoip_module.so
552 %endif
553
554 %if %{with gd}
555 %files mod_http_image_filter
556 %defattr(644,root,root,755)
557 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_image_filter.conf
558 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_image_filter_module.so
559 %endif
560
561 %if %{with perl}
562 %files mod_http_perl
563 %defattr(644,root,root,755)
564 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_perl.conf
565 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_perl_module.so
566 %dir %{perl_vendorarch}/auto/%{name}
567 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
568 %{perl_vendorarch}/%{name}.pm
569 %{_mandir}/man3/nginx.3pm*
570 %endif
571
572 %if %{with xslt}
573 %files mod_http_xslt_filter
574 %defattr(644,root,root,755)
575 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_xslt_filter.conf
576 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_xslt_filter_module.so
577 %endif
578
579 %if %{with mail}
580 %files mod_mail
581 %defattr(644,root,root,755)
582 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_mail.conf
583 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
584 %endif
585
586 %if %{with headers_more}
587 %files mod_headers_more
588 %defattr(644,root,root,755)
589 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_headers_more_filter.conf
590 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_headers_more_filter_module.so
591 %endif
592
593 %if %{with vts}
594 %files mod_vts
595 %defattr(644,root,root,755)
596 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_vhost_traffic_status.conf
597 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_vhost_traffic_status_module.so
598 %endif
599
600 %if %{with stream}
601 %files mod_stream
602 %defattr(644,root,root,755)
603 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream.conf
604 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_module.so
605 %endif
606
607 %files mod_http_cache_purge
608 %defattr(644,root,root,755)
609 %doc ngx_cache_purge/{CHANGES,README.md}
610 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_cache_purge.conf
611 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_cache_purge_module.so
612
613 %files mod_http_modsecurity
614 %defattr(644,root,root,755)
615 %doc ngx_cache_purge/{CHANGES,README.md}
616 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_modsecurity.conf
617 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_modsecurity_module.so
618
619 %files -n monit-rc-nginx
620 %defattr(644,root,root,755)
621 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.141707 seconds and 3 git commands to generate.