]> git.pld-linux.org Git - packages/nginx.git/blame - nginx.spec
Up to 1.22.1; fixes CVE-2022-41741, CVE-2022-41742
[packages/nginx.git] / nginx.spec
CommitLineData
f9e65082 1# TODO
ee4f2132 2# - /etc/sysconfig/nginx file
1c438d78 3# - missing perl build/install requires
644ecce3 4# - add njs: https://nginx.org/en/docs/njs/
ee4f2132 5#
362f5ab2 6# Conditional build for nginx:
d2732616
ER
7# Features
8%bcond_with debug # enable debug logging: http://nginx.org/en/docs/debugging_log.html
88c57830 9%bcond_without file_aio # file AIO support
d54a9642 10%bcond_without threads # thread pool support
d2732616
ER
11# Modules
12%bcond_without addition # http addition module
13%bcond_without auth_request # auth_request module
14%bcond_without dav # WebDAV
15%bcond_without flv # http FLV module
278483d6 16%bcond_without gd # without http image filter module
82f38dc6 17%bcond_without geoip # without http geoip module and stream geoip module
d2732616 18%bcond_without http2 # HTTP/2 module
056acc18 19%bcond_without mail # don't build imap/mail proxy
20%bcond_without perl # don't build with perl module
d2732616 21%bcond_without poll # poll module
d0c0492d 22%bcond_without realip # real ip (behind proxy)
d2732616
ER
23%bcond_without select # select module
24%bcond_without ssl # ssl support and http ssl module
25%bcond_without stream # TCP/UDP proxy module
26%bcond_without stub_status # http stub status module
27%bcond_without sub # ngx_http_sub_module
278483d6 28%bcond_without xslt # without http xslt module
d2732616 29%bcond_with http_browser # http browser module (header "User-agent" parser)
ba5570e8 30%bcond_with modsecurity # modsecurity module
d2732616 31%bcond_with rtmp # rtmp support
a7bd1a0f 32%bcond_without vts # virtual host traffic status module
1736adcc 33%bcond_without headers_more # headers more module
fb649fe5 34
8cf64677
WF
35%ifarch x32
36%undefine with_rtsig
37%endif
38
27ce902f 39%define ssl_version 1.0.2
0675db0c 40%define rtmp_version 1.2.2
998b098d
AM
41%define vts_version 0.2.1
42%define headers_more_version 0.34
43%define modsecurity_version 3.0.8
44%define http_cache_purge_version 2.5.2
35d493bf 45
8e1389c7 46Summary: High perfomance HTTP and reverse proxy server
185313bb 47Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
3dfa1ca2
AM
48# nginx lines:
49# - stable: production quality with stable API
50# - mainline: production quality but API can change
436be8d4 51# http://nginx.org/en/download.html
f9e65082 52Name: nginx
998b098d
AM
53Version: 1.22.1
54Release: 1
51ef519b 55License: BSD-like
cbf76340 56Group: Networking/Daemons/HTTP
91620b87 57Source0: https://nginx.org/download/%{name}-%{version}.tar.gz
998b098d 58# Source0-md5: 8296d957561aeed0261d9be4d3decaec
91620b87 59Source1: https://nginx.org/favicon.ico
0675db0c 60# Source1-md5: 72e228c3809db53da8a884b6676ed36a
06e274b9 61Source2: proxy.conf
226bcc40 62Source3: %{name}.logrotate
63Source4: %{name}.mime
7f97359c 64Source6: %{name}.monitrc
2cb3d9b2 65Source7: %{name}.init
5d9f0850 66Source14: %{name}.conf
7d80c773 67Source17: %{name}-mime.types.sh
8d0ed4b0 68Source18: %{name}.service
701bd771 69Source33: https://github.com/SpiderLabs/ModSecurity/releases/download/v%{modsecurity_version}/modsecurity-v%{modsecurity_version}.tar.gz
998b098d 70# Source33-md5: ef62527cbed82c0993a1781414163b01
278483d6 71Source101: https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/%{name}-rtmp-module-%{rtmp_version}.tar.gz
0675db0c 72# Source101-md5: 9bb7a06aede38d9e36ad13dc1354d8f9
a7bd1a0f 73Source102: https://github.com/vozlt/nginx-module-vts/archive/v%{vts_version}.tar.gz
998b098d 74# Source102-md5: 730163ed1eeecf39179f95fd973ac64b
1736adcc 75Source103: https://github.com/openresty/headers-more-nginx-module/archive/v%{headers_more_version}.tar.gz
998b098d 76# Source103-md5: a1c5af547af31b058c3e75c40b6f58b1
35d493bf
AM
77# https://github.com/nginx-modules/ngx_cache_purge
78Source104: https://github.com/nginx-modules/ngx_cache_purge/archive/refs/tags/%{http_cache_purge_version}.tar.gz
998b098d 79# Source104-md5: ea728fb28ed6c7c6326fb1abb8aa66a8
5ca9795d 80Patch0: %{name}-no-Werror.patch
7ce2935c 81Patch1: %{name}-modsecurity-xheaders.patch
91620b87 82URL: https://nginx.org/
dfef7372 83BuildRequires: mailcap
d049d371 84BuildRequires: pcre2-8-devel
d323480a 85BuildRequires: rpmbuild(macros) >= 1.644
f9e65082 86BuildRequires: zlib-devel
278483d6
ER
87%if %{with geoip}
88BuildRequires: GeoIP-devel
89%endif
90%if %{with gd}
91BuildRequires: gd-devel
92%endif
93%if %{with modsecurity}
94BuildRequires: lua-devel
95%endif
96%if %{with perl}
97BuildRequires: perl-CGI
98BuildRequires: perl-devel
99BuildRequires: python
100BuildRequires: rpm-perlprov
101%endif
102%if %{with ssl}
103BuildRequires: openssl-devel >= %{ssl_version}
104Requires: openssl >= %{ssl_version}
105%endif
106%if %{with xslt}
107BuildRequires: libxslt-devel
108%endif
1a973791
JK
109Provides: group(http)
110Provides: group(nginx)
111Provides: user(nginx)
4ac1d45f 112Provides: webserver
9b47506f
AM
113Provides: webserver(access)
114Provides: webserver(alias)
81d5057a
JK
115Provides: webserver(auth)
116Provides: webserver(expires)
117Provides: webserver(headers)
1e42c256 118Provides: webserver(indexfile)
81d5057a
JK
119Provides: webserver(log)
120Provides: webserver(mime)
121Provides: webserver(reqtimeout)
122Provides: webserver(rewrite)
123Provides: webserver(setenv)
1a973791 124Conflicts: logrotate < 3.8.0
85600569 125Requires(post,preun): /sbin/chkconfig
1a973791 126Requires(post,preun,postun): systemd-units >= 38
4ac1d45f
ER
127Requires(postun): /usr/sbin/groupdel
128Requires(postun): /usr/sbin/userdel
129Requires(pre): /bin/id
130Requires(pre): /usr/bin/getgid
131Requires(pre): /usr/sbin/groupadd
132Requires(pre): /usr/sbin/useradd
133Requires: rc-scripts >= 0.2.0
134Requires: systemd-units >= 38
135Suggests: vim-syntax-nginx
7cd50bff
AM
136Obsoletes: nginx-common < 1.13.3
137Obsoletes: nginx-light < 1.13.3
138Obsoletes: nginx-standard < 1.13.3
6d00ffc3 139Conflicts: rpm < 4.4.2-0.2
4ac1d45f 140BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1a973791 141
4ac1d45f
ER
142%define _sysconfdir /etc/%{name}
143%define _nginxdir /home/services/%{name}
1a973791 144
6d00ffc3
ER
145# minimizing restarts logics. we restart webserver:
146#
147# 1. at the end of transaction. (posttrans, feature from rpm 4.4.2)
148# 2. first install of module (post: $1 = 1)
149# 2. uninstall of module (postun: $1 == 0)
150#
151# the strict internal deps between modules and
152# main package are very important for all this to work.
85600569 153
6d00ffc3
ER
154# restart webserver at the end of transaction
155
156%define restart_webserver \
157 %systemd_post %{name}.service \
158 %service %{name} force-reload \
159 %{nil}
160
161# macro called at module post scriptlet
162%define module_post \
163if [ "$1" = "1" ]; then \
164 %restart_webserver \
165fi
166
167# macro called at module postun scriptlet
168%define module_postun \
169if [ "$1" = "0" ]; then \
170 %restart_webserver \
171fi
172
173# it's sooo annoying to write them
174%define module_scripts() \
175%post %1 \
176%module_post \
177\
178%postun %1 \
179%module_postun
2ee780b1 180
4ac1d45f 181%description
1a973791
JK
182nginx ("engine x") is a high-performance HTTP server and reverse
183proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
184Sysoev for Rambler.ru, Russia's second-most visited website, where it
185has been running in production for over two and a half years. Igor has
186released the source code under a BSD-like license. Although still in
187beta, nginx is known for its stability, rich feature set, simple
188configuration, and low resource consumption.
189
4ac1d45f 190%description -l pl.UTF-8
1a973791 191nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
192a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
193potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
1a973791 194odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
195opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
196fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1a973791
JK
197prostej konfiguracji oraz małej "zasobożerności".
198
1736adcc
AM
199%package mod_headers_more
200Summary: Nginx HTTP headers more module
201Group: Daemons
202Requires: %{name} = %{version}-%{release}
1736adcc
AM
203
204%description mod_headers_more
205Set and clear input and output headers...more than "add".
206
278483d6
ER
207%package mod_http_geoip
208Summary: Nginx HTTP geoip module
209Group: Daemons
210Requires: %{name} = %{version}-%{release}
211Requires: GeoIP
2ee780b1 212
278483d6
ER
213%description mod_http_geoip
214Nginx HTTP geoip module.
2ee780b1 215
82f38dc6
ER
216%package mod_stream_geoip
217Summary: Nginx stream geoip module
218Group: Daemons
219Requires: %{name} = %{version}-%{release}
57aa9c0a 220Requires: %{name}-mod_stream = %{version}-%{release}
82f38dc6 221Requires: GeoIP
1a973791 222
82f38dc6
ER
223%description mod_stream_geoip
224Nginx stream geoip module.
2ee780b1 225
278483d6
ER
226%package mod_http_image_filter
227Summary: Nginx HTTP image filter module
228Group: Daemons
229Requires: %{name} = %{version}-%{release}
1a973791 230
278483d6
ER
231%description mod_http_image_filter
232Nginx HTTP image filter module.
2ee780b1 233
f5d76ba0
ER
234%package mod_http_perl
235Summary: Nginx HTTP Perl module
cbf76340 236Group: Networking/Daemons/HTTP
4ac1d45f 237Requires: %{name} = %{version}-%{release}
2ee780b1 238
f5d76ba0
ER
239%description mod_http_perl
240Nginx HTTP Perl module.
1a973791 241
278483d6
ER
242%package mod_http_xslt_filter
243Summary: Nginx XSLT module
244Group: Daemons
245Requires: %{name} = %{version}-%{release}
2ee780b1 246
278483d6
ER
247%description mod_http_xslt_filter
248Nginx XSLT module.
2ee780b1 249
f5d76ba0
ER
250%package mod_mail
251Summary: Nginx mail module
cbf76340 252Group: Networking/Daemons/HTTP
4ac1d45f 253Requires: %{name} = %{version}-%{release}
28a25161 254
f5d76ba0
ER
255%description mod_mail
256Nginx mail module.
1a973791 257
9b4add35
AM
258%package mod_vts
259Summary: Nginx virtual host traffic status module
260Group: Networking/Daemons/HTTP
261Requires: %{name} = %{version}-%{release}
262
263%description mod_vts
264Nginx virtual host traffic status module.
265
278483d6
ER
266%package mod_stream
267Summary: Nginx stream modules
268Group: Daemons
269Requires: %{name} = %{version}-%{release}
fccff804 270
278483d6
ER
271%description mod_stream
272Nginx stream modules.
85600569 273
384caed6
AM
274%package mod_http_cache_purge
275Summary: Nginx cache purge module
276Group: Daemons
277Requires: %{name} = %{version}-%{release}
278
279%description mod_http_cache_purge
280`ngx_cache_purge` is `nginx` module which adds ability to purge
281content from `FastCGI`, `proxy`, `SCGI` and `uWSGI` caches.
282
283
dd7459ac 284%package -n monit-rc-nginx
57f21172 285Summary: nginx support for monit
286Summary(pl.UTF-8): Wsparcie nginx dla monit
60b8f836 287Group: Applications/System
4ac1d45f 288Requires: %{name} = %{version}-%{release}
1cf92547 289Requires: monit
dd7459ac 290
291%description -n monit-rc-nginx
57f21172 292monitrc file for monitoring nginx webserver.
dd7459ac 293
294%description -n monit-rc-nginx -l pl.UTF-8
57f21172 295Plik monitrc do monitorowania serwera WWW nginx.
dd7459ac 296
f9e65082 297%prep
384caed6 298%setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22} %{?with_vts:-a102} %{?with_headers_more:-a103} -a104
717159c4 299%patch0 -p0
7ce2935c 300%{?with_modsecurity:%patch1 -p0}
f9e65082 301
fb649fe5
ER
302%if %{with rtmp}
303mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
304%endif
305
a7bd1a0f
AM
306%if %{with vts}
307mv nginx-module-vts-%{vts_version} nginx-vts-module
308%endif
309
1736adcc
AM
310%if %{with headers_more}
311mv headers-more-nginx-module-%{headers_more_version} nginx-headers-more-module
312%endif
313
35d493bf 314mv ngx_cache_purge-* ngx_cache_purge
384caed6 315
a8eaad11 316# build mime.types.conf
7d80c773 317#sh %{SOURCE17} /etc/mime.types
a8eaad11 318
f9e65082
ER
319%build
320# NB: not autoconf generated configure
056acc18 321cp -f configure auto/
5d0d957d 322
056acc18 323./configure \
324 --prefix=%{_prefix} \
483adace 325 --modules-path=%{_libdir}/%{name}/modules \
efc6207e
ER
326 --sbin-path=%{_sbindir}/%{name} \
327 --conf-path=%{_sysconfdir}/%{name}.conf \
328 --error-log-path=%{_localstatedir}/log/%{name}/error.log \
329 --http-log-path=%{_localstatedir}/log/%{name}/access.log \
330 --pid-path=%{_localstatedir}/run/%{name}.pid \
331 --lock-path=%{_localstatedir}/lock/subsys/%{name} \
332 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
333 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
334 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
0bd5043b 335 --http-uwsgi-temp-path=%{_localstatedir}/cache/%{name}/uwsgi_temp \
bfad744d 336 --http-scgi-temp-path=%{_localstatedir}/cache/%{name}/scgi_temp \
2fb62cf2
ER
337 --user=nginx \
338 --group=nginx \
021e3ce8
ER
339 %{?with_select:--with-select_module} \
340 %{?with_poll:--with-poll_module} \
341 %{?with_rtsig:--with-rtsig_module} \
278483d6 342 %{?with_perl:--with-http_perl_module=dynamic} \
278483d6
ER
343 %{?with_gd:--with-http_image_filter_module=dynamic} \
344 %{?with_xslt:--with-http_xslt_module=dynamic} \
82f38dc6
ER
345 %{?with_geoip:--with-http_geoip_module=dynamic} \
346 %{?with_geoip:--with-stream_geoip_module=dynamic} \
008e09c3
ER
347%if %{with mail}
348 --with-mail=dynamic \
349 --with-mail_ssl_module \
278483d6
ER
350%endif
351%if %{with stream}
352 --with-stream=dynamic \
353 --with-stream_ssl_module \
008e09c3 354%endif
2fb62cf2
ER
355 --with-cc="%{__cc}" \
356 --with-cc-opt="%{rpmcflags}" \
357 --with-ld-opt="%{rpmldflags}" \
0aa7dc69 358 %{?with_debug:--with-debug} \
056acc18 359 %{?with_addition:--with-http_addition_module} \
360 %{?with_dav:--with-http_dav_module} \
361 %{?with_flv:--with-http_flv_module} \
d6fc4b09 362 %{?with_sub:--with-http_sub_module} \
056acc18 363 %{?with_realip:--with-http_realip_module} \
d2732616 364 %{?with_stub_status:--with-http_stub_status_module} \
056acc18 365 %{?with_ssl:--with-http_ssl_module} \
366 %{!?with_http_browser:--without-http_browser_module} \
35d493bf 367 --add-dynamic-module=./ngx_cache_purge \
1736adcc 368 %{?with_headers_more:--add-dynamic-module=./nginx-headers-more-module} \
fb649fe5 369 %{?with_rtmp:--add-module=./nginx-rtmp-module} \
9b4add35 370 %{?with_vts:--add-dynamic-module=./nginx-vts-module} \
e9a11359 371 %{?with_auth_request:--with-http_auth_request_module} \
8cf64677 372 %{?with_threads:--with-threads} \
6f05a009 373 %{?with_http2:--with-http_v2_module} \
ba5570e8 374 %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
ca3f3f03 375 --with-http_secure_link_module \
88c57830 376 %{?with_file_aio:--with-file-aio} \
2fb62cf2
ER
377 %{nil}
378
53215d5e 379%{__make}
f9e65082 380
53215d5e
ER
381%if %{with modsecurity}
382cd modsecurity-%{modsecurity_version}
383./autogen.sh
384%configure \
385 --enable-standalone-module \
386 --disable-mlogc \
387 --enable-alp2 \
388 --with-lua=/usr
389%{__make}
390cd ..
391%endif
056acc18 392
f9e65082
ER
393%install
394rm -rf $RPM_BUILD_ROOT
362f5ab2 395install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
396 $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
4e61eac8 397 $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
c63e9e18
ER
398 $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
399 $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
97ac281a 400 $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{conf,modules,vhosts,webapps}.d} \
924400ca 401 $RPM_BUILD_ROOT%{_sysconfdir}/snippets \
d323480a 402 $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
599f35f0 403 $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
f9e65082 404
483adace
ER
405%{__make} install \
406 INSTALLDIRS=vendor \
407 DESTDIR=$RPM_BUILD_ROOT
408
409%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/*.default
410
7f97359c
ER
411cp -p %{_sourcedir}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
412cp -p %{_sourcedir}/%{name}.service $RPM_BUILD_ROOT%{systemdunitdir}
413cp -p %{_sourcedir}/%{name}.monitrc $RPM_BUILD_ROOT/etc/monit
c63e9e18
ER
414install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
415
483adace
ER
416cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
417cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
3c75ce8a 418cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
483adace 419rm -r $RPM_BUILD_ROOT%{_prefix}/html
5ca9795d
ER
420cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
421cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
422cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
c9aa991c 423
a88a446d
ER
424load_module() {
425 local module=ngx_${1}_module.so conffile=mod_$1.conf
9453c586 426 printf 'load_module "%{_libdir}/%{name}/modules/%s";' "$module" \
97ac281a 427 > $RPM_BUILD_ROOT%{_sysconfdir}/modules.d/$conffile
c9aa991c
ER
428}
429
85600569 430%if %{with perl}
483adace
ER
431%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
432%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/nginx/.packlist
a88a446d 433load_module http_perl
85600569 434%endif
f9e65082 435
a88a446d
ER
436%if %{with geoip}
437load_module http_geoip
763de572 438load_module stream_geoip
a88a446d
ER
439%endif
440%if %{with gd}
441load_module http_image_filter
442%endif
443%if %{with xslt}
444load_module http_xslt_filter
445%endif
c9aa991c 446%if %{with mail}
a88a446d
ER
447load_module mail
448%endif
d925a29b 449%{?with_vts:load_module http_vhost_traffic_status}
1736adcc 450%{?with_headers_more:load_module http_headers_more_filter}
a88a446d
ER
451%if %{with stream}
452load_module stream
c9aa991c 453%endif
384caed6 454load_module http_cache_purge
32c47bd6 455
f9e65082
ER
456%clean
457rm -rf $RPM_BUILD_ROOT
458
c63e9e18 459%pre
a37373c3 460%groupadd -r -g 213 %{name}
362f5ab2 461%groupadd -g 51 http
a37373c3 462%useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
362f5ab2 463%addusertogroup %{name} http
f1fc9780 464
c63e9e18 465%post
738166d2 466for a in access.log error.log; do
c63e9e18 467 if [ ! -f /var/log/%{name}/$a ]; then
98376457 468 umask 022
c63e9e18
ER
469 touch /var/log/%{name}/$a
470 chown nginx:nginx /var/log/%{name}/$a
471 chmod 644 /var/log/%{name}/$a
738166d2 472 fi
473done
c63e9e18 474/sbin/chkconfig --add %{name}
738166d2 475
6d00ffc3
ER
476%posttrans
477%restart_webserver
738166d2 478
c63e9e18 479%preun
7d80c773 480if [ "$1" = "0" ];then
c63e9e18
ER
481 %service %{name} stop
482 /sbin/chkconfig --del %{name}
f9e65082 483fi
c63e9e18 484%systemd_preun %{name}.service
f9e65082 485
c63e9e18 486%postun
f1fc9780 487if [ "$1" = "0" ]; then
7d9b86c7
ER
488 %userremove %{name}
489 %groupremove %{name}
f1fc9780 490fi
d323480a
JK
491%systemd_reload
492
6d00ffc3
ER
493%module_scripts mod_http_geoip
494%module_scripts mod_http_image_filter
495%module_scripts mod_http_perl
496%module_scripts mod_http_xslt_filter
497%module_scripts mod_mail
9b4add35 498%module_scripts mod_vts
1736adcc 499%module_scripts mod_headers_more
6d00ffc3
ER
500%module_scripts mod_stream
501%module_scripts mod_stream_geoip
384caed6 502%module_scripts mod_http_cache_purge
d323480a 503
c63e9e18 504%files
f9e65082 505%defattr(644,root,root,755)
6f8318ed 506%doc CHANGES LICENSE README html/index.html conf/nginx.conf
f9e65082 507%doc %lang(ru) CHANGES.ru
28a25161 508%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
7f6266e4
ER
509%attr(754,root,root) /etc/rc.d/init.d/%{name}
510%dir %attr(750,root,nginx) %{_sysconfdir}
943e8c63 511%dir %{_sysconfdir}/conf.d
97ac281a 512%dir %{_sysconfdir}/modules.d
924400ca 513%dir %{_sysconfdir}/snippets
7f6266e4
ER
514%dir %{_sysconfdir}/vhosts.d
515%dir %{_sysconfdir}/webapps.d
f1fc9780 516%attr(640,root,root) %{_sysconfdir}/mime.types
57f21172 517%attr(640,root,root) %{_sysconfdir}/koi-utf
518%attr(640,root,root) %{_sysconfdir}/koi-win
519%attr(640,root,root) %{_sysconfdir}/win-utf
ba3249a3 520%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.conf
7f6266e4
ER
521%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
522%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
523%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
524%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
525%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
483adace 526%attr(755,root,root) %{_sbindir}/%{name}
278483d6
ER
527%dir %{_libdir}/%{name}
528%dir %{_libdir}/%{name}/modules
c63e9e18 529%{systemdunitdir}/%{name}.service
b0fa7cc6 530
debe6eba
JR
531%attr(750,nginx,logs) %dir /var/log/archive/%{name}
532%attr(750,nginx,logs) /var/log/%{name}
7f6266e4
ER
533%attr(770,root,nginx) /var/cache/%{name}
534
535%dir %{_nginxdir}
536%dir %{_nginxdir}/cgi-bin
537%dir %{_nginxdir}/html
538%dir %{_nginxdir}/errors
475fecd1 539%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
cd728db7 540%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
28a25161 541
278483d6
ER
542%if %{with geoip}
543%files mod_http_geoip
b0fa7cc6 544%defattr(644,root,root,755)
97ac281a 545%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_geoip.conf
278483d6 546%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_geoip_module.so
b0fa7cc6 547
82f38dc6 548%files mod_stream_geoip
85600569 549%defattr(644,root,root,755)
97ac281a 550%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream_geoip.conf
82f38dc6 551%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_geoip_module.so
85600569 552%endif
553
278483d6
ER
554%if %{with gd}
555%files mod_http_image_filter
85600569 556%defattr(644,root,root,755)
97ac281a 557%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_image_filter.conf
278483d6 558%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_image_filter_module.so
85600569 559%endif
560
561%if %{with perl}
f5d76ba0 562%files mod_http_perl
85600569 563%defattr(644,root,root,755)
97ac281a 564%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_perl.conf
008e09c3 565%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_perl_module.so
85600569 566%dir %{perl_vendorarch}/auto/%{name}
567%attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
98376457 568%{perl_vendorarch}/%{name}.pm
483adace 569%{_mandir}/man3/nginx.3pm*
dd7459ac 570%endif
571
278483d6
ER
572%if %{with xslt}
573%files mod_http_xslt_filter
dd7459ac 574%defattr(644,root,root,755)
97ac281a 575%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_xslt_filter.conf
278483d6 576%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_xslt_filter_module.so
dd7459ac 577%endif
278483d6 578
dd7459ac 579%if %{with mail}
278483d6
ER
580%files mod_mail
581%defattr(644,root,root,755)
97ac281a 582%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_mail.conf
278483d6 583%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
dd7459ac 584%endif
278483d6 585
1736adcc
AM
586%if %{with headers_more}
587%files mod_headers_more
588%defattr(644,root,root,755)
589%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_headers_more_filter.conf
590%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_headers_more_filter_module.so
591%endif
592
9b4add35
AM
593%if %{with vts}
594%files mod_vts
595%defattr(644,root,root,755)
d925a29b 596%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_vhost_traffic_status.conf
9b4add35
AM
597%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_vhost_traffic_status_module.so
598%endif
599
278483d6
ER
600%if %{with stream}
601%files mod_stream
602%defattr(644,root,root,755)
97ac281a 603%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream.conf
278483d6
ER
604%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_module.so
605%endif
606
384caed6
AM
607%files mod_http_cache_purge
608%defattr(644,root,root,755)
35d493bf 609%doc ngx_cache_purge/{CHANGES,README.md}
384caed6
AM
610%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_cache_purge.conf
611%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_cache_purge_module.so
612
dd7459ac 613%files -n monit-rc-nginx
614%defattr(644,root,root,755)
c63e9e18 615%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.446531 seconds and 4 git commands to generate.