]> git.pld-linux.org Git - packages/nginx.git/blame - nginx.spec
Up to 1.21.4.
[packages/nginx.git] / nginx.spec
CommitLineData
f9e65082 1# TODO
ee4f2132 2# - /etc/sysconfig/nginx file
1c438d78 3# - missing perl build/install requires
644ecce3 4# - add njs: https://nginx.org/en/docs/njs/
ee4f2132 5#
362f5ab2 6# Conditional build for nginx:
d2732616
ER
7# Features
8%bcond_with debug # enable debug logging: http://nginx.org/en/docs/debugging_log.html
d54a9642 9%bcond_without threads # thread pool support
d2732616
ER
10# Modules
11%bcond_without addition # http addition module
12%bcond_without auth_request # auth_request module
13%bcond_without dav # WebDAV
14%bcond_without flv # http FLV module
278483d6 15%bcond_without gd # without http image filter module
82f38dc6 16%bcond_without geoip # without http geoip module and stream geoip module
d2732616 17%bcond_without http2 # HTTP/2 module
056acc18 18%bcond_without mail # don't build imap/mail proxy
19%bcond_without perl # don't build with perl module
d2732616 20%bcond_without poll # poll module
d0c0492d 21%bcond_without realip # real ip (behind proxy)
d2732616
ER
22%bcond_without select # select module
23%bcond_without ssl # ssl support and http ssl module
24%bcond_without stream # TCP/UDP proxy module
25%bcond_without stub_status # http stub status module
26%bcond_without sub # ngx_http_sub_module
278483d6 27%bcond_without xslt # without http xslt module
d2732616 28%bcond_with http_browser # http browser module (header "User-agent" parser)
ba5570e8 29%bcond_with modsecurity # modsecurity module
d2732616 30%bcond_with rtmp # rtmp support
a7bd1a0f 31%bcond_without vts # virtual host traffic status module
1736adcc 32%bcond_without headers_more # headers more module
fb649fe5 33
8cf64677
WF
34%ifarch x32
35%undefine with_rtsig
36%endif
37
27ce902f 38%define ssl_version 1.0.2
0675db0c 39%define rtmp_version 1.2.2
a7bd1a0f 40%define vts_version 0.1.18
1736adcc 41%define headers_more_version 0.33
0675db0c 42%define modsecurity_version 3.0.5
35d493bf
AM
43%define http_cache_purge_version 2.5.1
44
8e1389c7 45Summary: High perfomance HTTP and reverse proxy server
185313bb 46Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
3dfa1ca2
AM
47# nginx lines:
48# - stable: production quality with stable API
49# - mainline: production quality but API can change
436be8d4 50# http://nginx.org/en/download.html
f9e65082 51Name: nginx
569a3f7c 52Version: 1.21.4
0675db0c 53Release: 1
51ef519b 54License: BSD-like
cbf76340 55Group: Networking/Daemons/HTTP
91620b87 56Source0: https://nginx.org/download/%{name}-%{version}.tar.gz
569a3f7c 57# Source0-md5: 58295ef467a7122987a55df2c644b950
91620b87 58Source1: https://nginx.org/favicon.ico
0675db0c 59# Source1-md5: 72e228c3809db53da8a884b6676ed36a
06e274b9 60Source2: proxy.conf
226bcc40 61Source3: %{name}.logrotate
62Source4: %{name}.mime
7f97359c 63Source6: %{name}.monitrc
2cb3d9b2 64Source7: %{name}.init
5d9f0850 65Source14: %{name}.conf
7d80c773 66Source17: %{name}-mime.types.sh
8d0ed4b0 67Source18: %{name}.service
701bd771 68Source33: https://github.com/SpiderLabs/ModSecurity/releases/download/v%{modsecurity_version}/modsecurity-v%{modsecurity_version}.tar.gz
0675db0c 69# Source33-md5: 8143ac32fbeec6bc9685f11faab6ea79
278483d6 70Source101: https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/%{name}-rtmp-module-%{rtmp_version}.tar.gz
0675db0c 71# Source101-md5: 9bb7a06aede38d9e36ad13dc1354d8f9
a7bd1a0f
AM
72Source102: https://github.com/vozlt/nginx-module-vts/archive/v%{vts_version}.tar.gz
73# Source102-md5: 409a10dbd85e0b807cc77eecec29a3b5
1736adcc
AM
74Source103: https://github.com/openresty/headers-more-nginx-module/archive/v%{headers_more_version}.tar.gz
75# Source103-md5: 95e15a2331c2d4db3691a56268df5f47
35d493bf
AM
76# https://github.com/nginx-modules/ngx_cache_purge
77Source104: https://github.com/nginx-modules/ngx_cache_purge/archive/refs/tags/%{http_cache_purge_version}.tar.gz
78# Source104-md5: d42d996efcd6539d2e955c77d24b1e0f
5ca9795d 79Patch0: %{name}-no-Werror.patch
7ce2935c 80Patch1: %{name}-modsecurity-xheaders.patch
91620b87 81URL: https://nginx.org/
dfef7372 82BuildRequires: mailcap
f1fc9780 83BuildRequires: pcre-devel
d323480a 84BuildRequires: rpmbuild(macros) >= 1.644
f9e65082 85BuildRequires: zlib-devel
278483d6
ER
86%if %{with geoip}
87BuildRequires: GeoIP-devel
88%endif
89%if %{with gd}
90BuildRequires: gd-devel
91%endif
92%if %{with modsecurity}
93BuildRequires: lua-devel
94%endif
95%if %{with perl}
96BuildRequires: perl-CGI
97BuildRequires: perl-devel
98BuildRequires: python
99BuildRequires: rpm-perlprov
100%endif
101%if %{with ssl}
102BuildRequires: openssl-devel >= %{ssl_version}
103Requires: openssl >= %{ssl_version}
104%endif
105%if %{with xslt}
106BuildRequires: libxslt-devel
107%endif
1a973791
JK
108Provides: group(http)
109Provides: group(nginx)
110Provides: user(nginx)
4ac1d45f 111Provides: webserver
9b47506f
AM
112Provides: webserver(access)
113Provides: webserver(alias)
81d5057a
JK
114Provides: webserver(auth)
115Provides: webserver(expires)
116Provides: webserver(headers)
1e42c256 117Provides: webserver(indexfile)
81d5057a
JK
118Provides: webserver(log)
119Provides: webserver(mime)
120Provides: webserver(reqtimeout)
121Provides: webserver(rewrite)
122Provides: webserver(setenv)
1a973791 123Conflicts: logrotate < 3.8.0
85600569 124Requires(post,preun): /sbin/chkconfig
1a973791 125Requires(post,preun,postun): systemd-units >= 38
4ac1d45f
ER
126Requires(postun): /usr/sbin/groupdel
127Requires(postun): /usr/sbin/userdel
128Requires(pre): /bin/id
129Requires(pre): /usr/bin/getgid
130Requires(pre): /usr/sbin/groupadd
131Requires(pre): /usr/sbin/useradd
132Requires: rc-scripts >= 0.2.0
133Requires: systemd-units >= 38
134Suggests: vim-syntax-nginx
7cd50bff
AM
135Obsoletes: nginx-common < 1.13.3
136Obsoletes: nginx-light < 1.13.3
137Obsoletes: nginx-standard < 1.13.3
6d00ffc3 138Conflicts: rpm < 4.4.2-0.2
4ac1d45f 139BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1a973791 140
4ac1d45f
ER
141%define _sysconfdir /etc/%{name}
142%define _nginxdir /home/services/%{name}
1a973791 143
6d00ffc3
ER
144# minimizing restarts logics. we restart webserver:
145#
146# 1. at the end of transaction. (posttrans, feature from rpm 4.4.2)
147# 2. first install of module (post: $1 = 1)
148# 2. uninstall of module (postun: $1 == 0)
149#
150# the strict internal deps between modules and
151# main package are very important for all this to work.
85600569 152
6d00ffc3
ER
153# restart webserver at the end of transaction
154
155%define restart_webserver \
156 %systemd_post %{name}.service \
157 %service %{name} force-reload \
158 %{nil}
159
160# macro called at module post scriptlet
161%define module_post \
162if [ "$1" = "1" ]; then \
163 %restart_webserver \
164fi
165
166# macro called at module postun scriptlet
167%define module_postun \
168if [ "$1" = "0" ]; then \
169 %restart_webserver \
170fi
171
172# it's sooo annoying to write them
173%define module_scripts() \
174%post %1 \
175%module_post \
176\
177%postun %1 \
178%module_postun
2ee780b1 179
4ac1d45f 180%description
1a973791
JK
181nginx ("engine x") is a high-performance HTTP server and reverse
182proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
183Sysoev for Rambler.ru, Russia's second-most visited website, where it
184has been running in production for over two and a half years. Igor has
185released the source code under a BSD-like license. Although still in
186beta, nginx is known for its stability, rich feature set, simple
187configuration, and low resource consumption.
188
4ac1d45f 189%description -l pl.UTF-8
1a973791 190nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
191a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
192potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
1a973791 193odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
194opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
195fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1a973791
JK
196prostej konfiguracji oraz małej "zasobożerności".
197
1736adcc
AM
198%package mod_headers_more
199Summary: Nginx HTTP headers more module
200Group: Daemons
201Requires: %{name} = %{version}-%{release}
1736adcc
AM
202
203%description mod_headers_more
204Set and clear input and output headers...more than "add".
205
278483d6
ER
206%package mod_http_geoip
207Summary: Nginx HTTP geoip module
208Group: Daemons
209Requires: %{name} = %{version}-%{release}
210Requires: GeoIP
2ee780b1 211
278483d6
ER
212%description mod_http_geoip
213Nginx HTTP geoip module.
2ee780b1 214
82f38dc6
ER
215%package mod_stream_geoip
216Summary: Nginx stream geoip module
217Group: Daemons
218Requires: %{name} = %{version}-%{release}
57aa9c0a 219Requires: %{name}-mod_stream = %{version}-%{release}
82f38dc6 220Requires: GeoIP
1a973791 221
82f38dc6
ER
222%description mod_stream_geoip
223Nginx stream geoip module.
2ee780b1 224
278483d6
ER
225%package mod_http_image_filter
226Summary: Nginx HTTP image filter module
227Group: Daemons
228Requires: %{name} = %{version}-%{release}
1a973791 229
278483d6
ER
230%description mod_http_image_filter
231Nginx HTTP image filter module.
2ee780b1 232
f5d76ba0
ER
233%package mod_http_perl
234Summary: Nginx HTTP Perl module
cbf76340 235Group: Networking/Daemons/HTTP
4ac1d45f 236Requires: %{name} = %{version}-%{release}
2ee780b1 237
f5d76ba0
ER
238%description mod_http_perl
239Nginx HTTP Perl module.
1a973791 240
278483d6
ER
241%package mod_http_xslt_filter
242Summary: Nginx XSLT module
243Group: Daemons
244Requires: %{name} = %{version}-%{release}
2ee780b1 245
278483d6
ER
246%description mod_http_xslt_filter
247Nginx XSLT module.
2ee780b1 248
f5d76ba0
ER
249%package mod_mail
250Summary: Nginx mail module
cbf76340 251Group: Networking/Daemons/HTTP
4ac1d45f 252Requires: %{name} = %{version}-%{release}
28a25161 253
f5d76ba0
ER
254%description mod_mail
255Nginx mail module.
1a973791 256
9b4add35
AM
257%package mod_vts
258Summary: Nginx virtual host traffic status module
259Group: Networking/Daemons/HTTP
260Requires: %{name} = %{version}-%{release}
261
262%description mod_vts
263Nginx virtual host traffic status module.
264
278483d6
ER
265%package mod_stream
266Summary: Nginx stream modules
267Group: Daemons
268Requires: %{name} = %{version}-%{release}
fccff804 269
278483d6
ER
270%description mod_stream
271Nginx stream modules.
85600569 272
384caed6
AM
273%package mod_http_cache_purge
274Summary: Nginx cache purge module
275Group: Daemons
276Requires: %{name} = %{version}-%{release}
277
278%description mod_http_cache_purge
279`ngx_cache_purge` is `nginx` module which adds ability to purge
280content from `FastCGI`, `proxy`, `SCGI` and `uWSGI` caches.
281
282
dd7459ac 283%package -n monit-rc-nginx
57f21172 284Summary: nginx support for monit
285Summary(pl.UTF-8): Wsparcie nginx dla monit
60b8f836 286Group: Applications/System
4ac1d45f 287Requires: %{name} = %{version}-%{release}
1cf92547 288Requires: monit
dd7459ac 289
290%description -n monit-rc-nginx
57f21172 291monitrc file for monitoring nginx webserver.
dd7459ac 292
293%description -n monit-rc-nginx -l pl.UTF-8
57f21172 294Plik monitrc do monitorowania serwera WWW nginx.
dd7459ac 295
f9e65082 296%prep
384caed6 297%setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22} %{?with_vts:-a102} %{?with_headers_more:-a103} -a104
717159c4 298%patch0 -p0
7ce2935c 299%{?with_modsecurity:%patch1 -p0}
f9e65082 300
fb649fe5
ER
301%if %{with rtmp}
302mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
303%endif
304
a7bd1a0f
AM
305%if %{with vts}
306mv nginx-module-vts-%{vts_version} nginx-vts-module
307%endif
308
1736adcc
AM
309%if %{with headers_more}
310mv headers-more-nginx-module-%{headers_more_version} nginx-headers-more-module
311%endif
312
35d493bf 313mv ngx_cache_purge-* ngx_cache_purge
384caed6 314
a8eaad11 315# build mime.types.conf
7d80c773 316#sh %{SOURCE17} /etc/mime.types
a8eaad11 317
f9e65082
ER
318%build
319# NB: not autoconf generated configure
056acc18 320cp -f configure auto/
5d0d957d 321
056acc18 322./configure \
323 --prefix=%{_prefix} \
483adace 324 --modules-path=%{_libdir}/%{name}/modules \
efc6207e
ER
325 --sbin-path=%{_sbindir}/%{name} \
326 --conf-path=%{_sysconfdir}/%{name}.conf \
327 --error-log-path=%{_localstatedir}/log/%{name}/error.log \
328 --http-log-path=%{_localstatedir}/log/%{name}/access.log \
329 --pid-path=%{_localstatedir}/run/%{name}.pid \
330 --lock-path=%{_localstatedir}/lock/subsys/%{name} \
331 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
332 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
333 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
0bd5043b 334 --http-uwsgi-temp-path=%{_localstatedir}/cache/%{name}/uwsgi_temp \
bfad744d 335 --http-scgi-temp-path=%{_localstatedir}/cache/%{name}/scgi_temp \
2fb62cf2
ER
336 --user=nginx \
337 --group=nginx \
021e3ce8
ER
338 %{?with_select:--with-select_module} \
339 %{?with_poll:--with-poll_module} \
340 %{?with_rtsig:--with-rtsig_module} \
278483d6 341 %{?with_perl:--with-http_perl_module=dynamic} \
278483d6
ER
342 %{?with_gd:--with-http_image_filter_module=dynamic} \
343 %{?with_xslt:--with-http_xslt_module=dynamic} \
82f38dc6
ER
344 %{?with_geoip:--with-http_geoip_module=dynamic} \
345 %{?with_geoip:--with-stream_geoip_module=dynamic} \
008e09c3
ER
346%if %{with mail}
347 --with-mail=dynamic \
348 --with-mail_ssl_module \
278483d6
ER
349%endif
350%if %{with stream}
351 --with-stream=dynamic \
352 --with-stream_ssl_module \
008e09c3 353%endif
2fb62cf2
ER
354 --with-cc="%{__cc}" \
355 --with-cc-opt="%{rpmcflags}" \
356 --with-ld-opt="%{rpmldflags}" \
0aa7dc69 357 %{?with_debug:--with-debug} \
056acc18 358 %{?with_addition:--with-http_addition_module} \
359 %{?with_dav:--with-http_dav_module} \
360 %{?with_flv:--with-http_flv_module} \
d6fc4b09 361 %{?with_sub:--with-http_sub_module} \
056acc18 362 %{?with_realip:--with-http_realip_module} \
d2732616 363 %{?with_stub_status:--with-http_stub_status_module} \
056acc18 364 %{?with_ssl:--with-http_ssl_module} \
365 %{!?with_http_browser:--without-http_browser_module} \
35d493bf 366 --add-dynamic-module=./ngx_cache_purge \
1736adcc 367 %{?with_headers_more:--add-dynamic-module=./nginx-headers-more-module} \
fb649fe5 368 %{?with_rtmp:--add-module=./nginx-rtmp-module} \
9b4add35 369 %{?with_vts:--add-dynamic-module=./nginx-vts-module} \
e9a11359 370 %{?with_auth_request:--with-http_auth_request_module} \
8cf64677 371 %{?with_threads:--with-threads} \
6f05a009 372 %{?with_http2:--with-http_v2_module} \
ba5570e8 373 %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
ca3f3f03 374 --with-http_secure_link_module \
2fb62cf2
ER
375 %{nil}
376
53215d5e 377%{__make}
f9e65082 378
53215d5e
ER
379%if %{with modsecurity}
380cd modsecurity-%{modsecurity_version}
381./autogen.sh
382%configure \
383 --enable-standalone-module \
384 --disable-mlogc \
385 --enable-alp2 \
386 --with-lua=/usr
387%{__make}
388cd ..
389%endif
056acc18 390
f9e65082
ER
391%install
392rm -rf $RPM_BUILD_ROOT
362f5ab2 393install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
394 $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
4e61eac8 395 $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
c63e9e18
ER
396 $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
397 $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
97ac281a 398 $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{conf,modules,vhosts,webapps}.d} \
924400ca 399 $RPM_BUILD_ROOT%{_sysconfdir}/snippets \
d323480a 400 $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
599f35f0 401 $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
f9e65082 402
483adace
ER
403%{__make} install \
404 INSTALLDIRS=vendor \
405 DESTDIR=$RPM_BUILD_ROOT
406
407%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/*.default
408
7f97359c
ER
409cp -p %{_sourcedir}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
410cp -p %{_sourcedir}/%{name}.service $RPM_BUILD_ROOT%{systemdunitdir}
411cp -p %{_sourcedir}/%{name}.monitrc $RPM_BUILD_ROOT/etc/monit
c63e9e18
ER
412install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
413
483adace
ER
414cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
415cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
3c75ce8a 416cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
483adace 417rm -r $RPM_BUILD_ROOT%{_prefix}/html
5ca9795d
ER
418cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
419cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
420cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
c9aa991c 421
a88a446d
ER
422load_module() {
423 local module=ngx_${1}_module.so conffile=mod_$1.conf
9453c586 424 printf 'load_module "%{_libdir}/%{name}/modules/%s";' "$module" \
97ac281a 425 > $RPM_BUILD_ROOT%{_sysconfdir}/modules.d/$conffile
c9aa991c
ER
426}
427
85600569 428%if %{with perl}
483adace
ER
429%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
430%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/nginx/.packlist
a88a446d 431load_module http_perl
85600569 432%endif
f9e65082 433
a88a446d
ER
434%if %{with geoip}
435load_module http_geoip
763de572 436load_module stream_geoip
a88a446d
ER
437%endif
438%if %{with gd}
439load_module http_image_filter
440%endif
441%if %{with xslt}
442load_module http_xslt_filter
443%endif
c9aa991c 444%if %{with mail}
a88a446d
ER
445load_module mail
446%endif
d925a29b 447%{?with_vts:load_module http_vhost_traffic_status}
1736adcc 448%{?with_headers_more:load_module http_headers_more_filter}
a88a446d
ER
449%if %{with stream}
450load_module stream
c9aa991c 451%endif
384caed6 452load_module http_cache_purge
32c47bd6 453
f9e65082
ER
454%clean
455rm -rf $RPM_BUILD_ROOT
456
c63e9e18 457%pre
a37373c3 458%groupadd -r -g 213 %{name}
362f5ab2 459%groupadd -g 51 http
a37373c3 460%useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
362f5ab2 461%addusertogroup %{name} http
f1fc9780 462
c63e9e18 463%post
738166d2 464for a in access.log error.log; do
c63e9e18 465 if [ ! -f /var/log/%{name}/$a ]; then
98376457 466 umask 022
c63e9e18
ER
467 touch /var/log/%{name}/$a
468 chown nginx:nginx /var/log/%{name}/$a
469 chmod 644 /var/log/%{name}/$a
738166d2 470 fi
471done
c63e9e18 472/sbin/chkconfig --add %{name}
738166d2 473
6d00ffc3
ER
474%posttrans
475%restart_webserver
738166d2 476
c63e9e18 477%preun
7d80c773 478if [ "$1" = "0" ];then
c63e9e18
ER
479 %service %{name} stop
480 /sbin/chkconfig --del %{name}
f9e65082 481fi
c63e9e18 482%systemd_preun %{name}.service
f9e65082 483
c63e9e18 484%postun
f1fc9780 485if [ "$1" = "0" ]; then
7d9b86c7
ER
486 %userremove %{name}
487 %groupremove %{name}
f1fc9780 488fi
d323480a
JK
489%systemd_reload
490
6d00ffc3
ER
491%module_scripts mod_http_geoip
492%module_scripts mod_http_image_filter
493%module_scripts mod_http_perl
494%module_scripts mod_http_xslt_filter
495%module_scripts mod_mail
9b4add35 496%module_scripts mod_vts
1736adcc 497%module_scripts mod_headers_more
6d00ffc3
ER
498%module_scripts mod_stream
499%module_scripts mod_stream_geoip
384caed6 500%module_scripts mod_http_cache_purge
d323480a 501
c63e9e18 502%files
f9e65082 503%defattr(644,root,root,755)
6f8318ed 504%doc CHANGES LICENSE README html/index.html conf/nginx.conf
f9e65082 505%doc %lang(ru) CHANGES.ru
28a25161 506%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
7f6266e4
ER
507%attr(754,root,root) /etc/rc.d/init.d/%{name}
508%dir %attr(750,root,nginx) %{_sysconfdir}
943e8c63 509%dir %{_sysconfdir}/conf.d
97ac281a 510%dir %{_sysconfdir}/modules.d
924400ca 511%dir %{_sysconfdir}/snippets
7f6266e4
ER
512%dir %{_sysconfdir}/vhosts.d
513%dir %{_sysconfdir}/webapps.d
f1fc9780 514%attr(640,root,root) %{_sysconfdir}/mime.types
57f21172 515%attr(640,root,root) %{_sysconfdir}/koi-utf
516%attr(640,root,root) %{_sysconfdir}/koi-win
517%attr(640,root,root) %{_sysconfdir}/win-utf
ba3249a3 518%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.conf
7f6266e4
ER
519%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
520%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
521%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
522%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
523%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
483adace 524%attr(755,root,root) %{_sbindir}/%{name}
278483d6
ER
525%dir %{_libdir}/%{name}
526%dir %{_libdir}/%{name}/modules
c63e9e18 527%{systemdunitdir}/%{name}.service
b0fa7cc6 528
debe6eba
JR
529%attr(750,nginx,logs) %dir /var/log/archive/%{name}
530%attr(750,nginx,logs) /var/log/%{name}
7f6266e4
ER
531%attr(770,root,nginx) /var/cache/%{name}
532
533%dir %{_nginxdir}
534%dir %{_nginxdir}/cgi-bin
535%dir %{_nginxdir}/html
536%dir %{_nginxdir}/errors
475fecd1 537%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
cd728db7 538%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
28a25161 539
278483d6
ER
540%if %{with geoip}
541%files mod_http_geoip
b0fa7cc6 542%defattr(644,root,root,755)
97ac281a 543%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_geoip.conf
278483d6 544%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_geoip_module.so
b0fa7cc6 545
82f38dc6 546%files mod_stream_geoip
85600569 547%defattr(644,root,root,755)
97ac281a 548%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream_geoip.conf
82f38dc6 549%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_geoip_module.so
85600569 550%endif
551
278483d6
ER
552%if %{with gd}
553%files mod_http_image_filter
85600569 554%defattr(644,root,root,755)
97ac281a 555%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_image_filter.conf
278483d6 556%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_image_filter_module.so
85600569 557%endif
558
559%if %{with perl}
f5d76ba0 560%files mod_http_perl
85600569 561%defattr(644,root,root,755)
97ac281a 562%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_perl.conf
008e09c3 563%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_perl_module.so
85600569 564%dir %{perl_vendorarch}/auto/%{name}
565%attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
98376457 566%{perl_vendorarch}/%{name}.pm
483adace 567%{_mandir}/man3/nginx.3pm*
dd7459ac 568%endif
569
278483d6
ER
570%if %{with xslt}
571%files mod_http_xslt_filter
dd7459ac 572%defattr(644,root,root,755)
97ac281a 573%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_xslt_filter.conf
278483d6 574%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_xslt_filter_module.so
dd7459ac 575%endif
278483d6 576
dd7459ac 577%if %{with mail}
278483d6
ER
578%files mod_mail
579%defattr(644,root,root,755)
97ac281a 580%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_mail.conf
278483d6 581%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
dd7459ac 582%endif
278483d6 583
1736adcc
AM
584%if %{with headers_more}
585%files mod_headers_more
586%defattr(644,root,root,755)
587%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_headers_more_filter.conf
588%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_headers_more_filter_module.so
589%endif
590
9b4add35
AM
591%if %{with vts}
592%files mod_vts
593%defattr(644,root,root,755)
d925a29b 594%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_vhost_traffic_status.conf
9b4add35
AM
595%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_vhost_traffic_status_module.so
596%endif
597
278483d6
ER
598%if %{with stream}
599%files mod_stream
600%defattr(644,root,root,755)
97ac281a 601%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream.conf
278483d6
ER
602%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_module.so
603%endif
604
384caed6
AM
605%files mod_http_cache_purge
606%defattr(644,root,root,755)
35d493bf 607%doc ngx_cache_purge/{CHANGES,README.md}
384caed6
AM
608%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_cache_purge.conf
609%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_cache_purge_module.so
610
dd7459ac 611%files -n monit-rc-nginx
612%defattr(644,root,root,755)
c63e9e18 613%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.18148 seconds and 4 git commands to generate.