]> git.pld-linux.org Git - packages/nethack.git/commitdiff
- allow building without qt and x11
authorwolf <wolf@pld-linux.org>
Mon, 3 Mar 2003 00:53:33 +0000 (00:53 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    nethack-config.patch -> 1.2
    nethack-makefile.patch -> 1.6
    nethack-qt.patch -> 1.1
    nethack.spec -> 1.51

nethack-config.patch
nethack-makefile.patch
nethack-qt.patch [new file with mode: 0644]
nethack.spec

index a6d532c8562f03dc96c16372c7ba35425001d604..f814db3ff6cd1a48348a6f544ff8a19134f84ca2 100644 (file)
@@ -1,15 +1,6 @@
 diff -ruN nethack-3.4.0.orig/include/config.h 2/include/config.h
 --- nethack-3.4.0.orig/include/config.h        Mon Mar 25 23:47:30 2002
 +++ 2/include/config.h Tue Mar 26 20:35:52 2002
-@@ -44,7 +44,7 @@
-  */
- #define TTY_GRAPHICS  /* good old tty based graphics */
- /* #define X11_GRAPHICS */    /* X11 interface */
--/* #define QT_GRAPHICS */     /* Qt interface */
-+#define QT_GRAPHICS           /* Qt interface */
- /* #define GNOME_GRAPHICS */  /* Gnome interface */
- /* #define MSWIN_GRAPHICS */  /* Windows NT, CE, Graphics */
 @@ -136,6 +136,7 @@
   *            LOGFILE and NEWS refer to files in the playground.
   */
index bddc3b70b707cecc12eacb177e69cb988ee29593..4d3810a0657a73cd24ca1946e8fd35e3960ef008 100644 (file)
@@ -10,17 +10,6 @@ diff -ruN nethack-3.4.1./sys/unix/Makefile.src nethack-3.4.1/sys/unix/Makefile.s
  CXX=g++
  #LD=g++
  
-@@ -204,8 +204,8 @@
- #
- #
--WINSRC = $(WINTTYSRC)
--WINOBJ = $(WINTTYOBJ)
-+WINSRC = $(WINTTYSRC) $(WINQTSRC)
-+WINOBJ = $(WINTTYOBJ) $(WINQTOBJ)
- # on some systems the termcap library is in -ltermcap or -lcurses
- # on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
 @@ -220,8 +220,8 @@
  # WINTTYLIB = -ltermcap
  # WINTTYLIB = -lcurses
@@ -32,15 +21,6 @@ diff -ruN nethack-3.4.1./sys/unix/Makefile.src nethack-3.4.1/sys/unix/Makefile.s
  #
  # libraries for X11
  # If USE_XPM is defined in config.h, you will also need -lXpm here.
-@@ -245,7 +245,7 @@
- # libraries for BeOS 
- WINBELIB = -lbe
--WINLIB = $(WINTTYLIB)
-+WINLIB = $(WINTTYLIB) $(WINQTLIB)
- # any other strange libraries your system needs (for Sysunix only -- the more
- # specialized targets should already be right)
 @@ -382,7 +382,7 @@
  
  Sysunix:      $(HOBJ) Makefile
diff --git a/nethack-qt.patch b/nethack-qt.patch
new file mode 100644 (file)
index 0000000..4b2e74b
--- /dev/null
@@ -0,0 +1,35 @@
+diff -ruN nethack-3.4.1/include/config.h nethack-3.4.1-qt/include/config.h
+--- nethack-3.4.1/include/config.h     Mon Mar  3 01:16:08 2003
++++ nethack-3.4.1-qt/include/config.h  Mon Mar  3 01:11:30 2003
+@@ -44,7 +44,7 @@
+  */
+ #define TTY_GRAPHICS  /* good old tty based graphics */
+ /* #define X11_GRAPHICS */    /* X11 interface */
+-/* #define QT_GRAPHICS */     /* Qt interface */
++#define QT_GRAPHICS           /* Qt interface */
+ /* #define GNOME_GRAPHICS */  /* Gnome interface */
+ /* #define MSWIN_GRAPHICS */  /* Windows NT, CE, Graphics */
+diff -ruN nethack-3.4.1/sys/unix/Makefile.src nethack-3.4.1-qt/sys/unix/Makefile.src
+--- nethack-3.4.1/sys/unix/Makefile.src        Mon Mar  3 01:16:08 2003
++++ nethack-3.4.1-qt/sys/unix/Makefile.src     Mon Mar  3 01:11:30 2003
+@@ -204,8 +204,8 @@
+ #
+ #
+-WINSRC = $(WINTTYSRC)
+-WINOBJ = $(WINTTYOBJ)
++WINSRC = $(WINTTYSRC) $(WINQTSRC)
++WINOBJ = $(WINTTYOBJ) $(WINQTOBJ)
+ # on some systems the termcap library is in -ltermcap or -lcurses
+ # on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
+@@ -245,7 +245,7 @@
+ # libraries for BeOS 
+ WINBELIB = -lbe
+-WINLIB = $(WINTTYLIB)
++WINLIB = $(WINTTYLIB) $(WINQTLIB)
+ # any other strange libraries your system needs (for Sysunix only -- the more
+ # specialized targets should already be right)
index 9052a42deff0721fc22d95d16fd6e111feafe87b..438a733bc8a176d272b6927c37762b8859c525a9 100644 (file)
@@ -1,6 +1,7 @@
 #
 # Conditional build:
 # --with vanilla - build vanilla NetHack (without patches)
+# --without qt   - no X11 and QT bloat
 #
 # no patches for now, wait for updates
 %define _with_vanilla  1
@@ -30,6 +31,7 @@ Source8:      %{name}-vol3-1.2.2.pdf
 Patch0:                %{name}-config.patch
 Patch1:                %{name}-makefile.patch
 Patch2:                %{name}-gcc3.patch
+Patch3:                %{name}-qt.patch
 # patches below are adapted from ones found at http://avrc.city.ac.uk/nethack/patches.html
 # warning: order is important in most cases
 Patch100:      %{name}-show_born.patch
@@ -53,11 +55,11 @@ Patch117:   %{name}-newt.patch
 # after adding additional features update this patch
 Patch200:      %{name}-makedefs.patch
 URL:           http://www.nethack.org/
-BuildRequires: XFree86-devel
+%{?!_without_qt:BuildRequires: XFree86-devel}
 BuildRequires: bison
 BuildRequires: flex
 BuildRequires: ncurses-devel
-BuildRequires: qt-devel >= 3.0.3
+%{?!_without_qt:BuildRequires: qt-devel >= 3.0.3}
 Requires:      /bin/gzip
 Requires:      applnk >= 1.5.13
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -139,6 +141,7 @@ Nethackowy podr
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%{?!_without_qt:%patch3 -p1}
 
 # patches adding fun
 %{?!_with_vanilla:%patch100 -p1}
@@ -207,8 +210,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %attr(755,root,root) %dir %{_nhdir}
 %{_nhdir}/nhdat
-%{_nhdir}/*.xpm
-%{_nhdir}/x11tiles
+%{?!_without_qt:%{_nhdir}/*.xpm}
+%{?!_without_qt:%{_nhdir}/x11tiles}
 
 %attr(2775,root,games) %dir %{_dyndir}
 %attr(2775,root,games) %dir %{_dyndir}/save
This page took 0.165542 seconds and 4 git commands to generate.