]> git.pld-linux.org Git - packages/netcdf-fortran.git/blob - netcdf-fortran.spec
- updated to 4.4.0 (note: f77+f90 now obligatory, f2003 optional)
[packages/netcdf-fortran.git] / netcdf-fortran.spec
1 #
2 # Conditional build:
3 %bcond_without  f2003           # don't build Fortran 2003 interface (just F77/F90)
4 %bcond_without  tests           # don't perform "make check"
5                                 # (note: tests need endoder-enabled szip)
6 #
7 Summary:        NetCDF Fortran library
8 Summary(pl.UTF-8):      Biblioteka NetCDF dla języka Fortran
9 Name:           netcdf-fortran
10 Version:        4.4.0
11 Release:        1
12 License:        BSD-like
13 Group:          Libraries
14 Source0:        ftp://ftp.unidata.ucar.edu/pub/netcdf/%{name}-%{version}.tar.gz
15 # Source0-md5:  258fac4fe522be5945d84bf4a4b3b837
16 Patch0:         %{name}-f90.patch
17 URL:            http://www.unidata.ucar.edu/packages/netcdf/
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake
20 %if %{with f2003}
21 BuildRequires:  gcc-fortran >= 6:4.4
22 %else
23 BuildRequires:  gcc-fortran >= 5:4.0
24 %endif
25 BuildRequires:  libtool >= 2:2.2
26 BuildRequires:  netcdf-devel >= 4.2
27 BuildRequires:  texinfo
28 Requires:       netcdf >= 4.2
29 Obsoletes:      netcdf-f90
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 NetCDF (network Common Data Form) is an interface for array-oriented
34 data access and a library that provides an implementation of the
35 interface. The netCDF library also defines a machine-independent
36 format for representing scientific data. Together, the interface,
37 library, and format support the creation, access, and sharing of
38 scientific data. The netCDF software was developed at the Unidata
39 Program Center in Boulder, Colorado.
40
41 This package contains Fortran 77%{?with_f90: and 90} library.
42
43 %description -l pl.UTF-8
44 NetCDF (Network Common Data Form) jest interfejsem dostępu do danych
45 zorganizowanych w tablice. Biblioteka netCDF definiuje niezależny od
46 maszyny format reprezentowania danych naukowych. Interfejs oraz
47 biblioteka pozwalają na tworzenie, dostęp i współdzielenie danych.
48 NetCDF powstał w Unidata Program Center w Boulder, Colorado.
49
50 Ten pakiet zawiera bibliotekę dla języka Fortran 77%{?with_f90: i 90}.
51
52 %package devel
53 Summary:        Header files for netCDF Fortran interface
54 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu netCDF dla języka Fortran
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 %if %{with f2003}
58 Requires:       gcc-fortran >= 6:4.4
59 %else
60 Requires:       gcc-fortran >= 5:4.0
61 %endif
62 Requires:       netcdf-devel >= 4.2
63 Obsoletes:      netcdf-f90-devel
64
65 %description devel
66 Header files for netCDF - Fortran interface.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe biblioteki netCDF - interfejs dla języka Fortran.
70
71 %package static
72 Summary:        NetCDF Fortran static library
73 Summary(pl.UTF-8):      Biblioteka statyczna netCDF dla języka Fortran
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76 Obsoletes:      netcdf-f90-static
77
78 %description static
79 Static version of netCDF Fortran library.
80
81 %description static -l pl.UTF-8
82 Statyczna wersja biblioteki netCDF dla języka Fortran.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I m4
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 # specify gFortran, configure detection may fail if FC specifies *-gfortran different `which gfortran`
95 CPPFLAGS="%{rpmcppflags} -DgFortran=1"
96 %configure \
97         FCFLAGS="%{rpmcflags}" \
98         %{!?with_f2003:--disable-f03}
99
100 %{__make}
101
102 %if %{with tests}
103 %{__make} check
104 %endif
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 # obsoleted by pkg-config
113 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libnetcdff.la
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %post   devel -p /sbin/postshell
122 -/usr/sbin/fix-info-dir -c %{_infodir}
123
124 %postun devel -p /sbin/postshell
125 -/usr/sbin/fix-info-dir -c %{_infodir}
126
127 %files
128 %defattr(644,root,root,755)
129 %doc COPYRIGHT README.md RELEASE_NOTES.md
130 %attr(755,root,root) %{_libdir}/libnetcdff.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libnetcdff.so.6
132
133 %files devel
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/nf-config
136 %attr(755,root,root) %{_libdir}/libnetcdff.so
137 %{_includedir}/netcdf.inc
138 %{_includedir}/netcdf*.mod
139 %{_includedir}/typesizes.mod
140 %{_pkgconfigdir}/netcdf-fortran.pc
141 %{_mandir}/man3/netcdf_fortran.3*
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libnetcdff.a
This page took 0.065312 seconds and 3 git commands to generate.