]> git.pld-linux.org Git - packages/net-tools.git/commitdiff
- rediffed master auto/th/net-tools-2.10-2
authorMarcin Krol <hawk@tld-linux.org>
Sat, 2 Dec 2023 22:35:53 +0000 (23:35 +0100)
committerMarcin Krol <hawk@tld-linux.org>
Sat, 2 Dec 2023 22:35:53 +0000 (23:35 +0100)
net-tools-interface.patch
net-tools-netstat-netlink-diag.patch
net-tools.spec

index 4c0e5b74023b1595f7bf3e2b71954d73f7d750ba..c025bb48149c5b7fe876359c7d5441c53dbe9dc1 100644 (file)
@@ -1,8 +1,8 @@
-diff -up net-tools-2.0/man/en_US/netstat.8.interface net-tools-2.0/man/en_US/netstat.8
---- net-tools-2.0/man/en_US/netstat.8.interface        2014-11-24 14:52:45.648623478 +0100
-+++ net-tools-2.0/man/en_US/netstat.8  2014-11-24 14:53:32.294972184 +0100
-@@ -49,9 +49,9 @@ netstat \- Print network connections, ro
- .RB [delay]
+diff -urNp -x '*.orig' net-tools-2.10.org/man/en_US/netstat.8 net-tools-2.10/man/en_US/netstat.8
+--- net-tools-2.10.org/man/en_US/netstat.8     2021-01-07 00:22:35.000000000 +0100
++++ net-tools-2.10/man/en_US/netstat.8 2023-12-02 23:35:08.827986462 +0100
+@@ -47,9 +47,9 @@ netstat \- Print network connections, ro
+ .RB [ \-\-continuous | \-c ]
  .P
  .B netstat
 -.RB { \-\-interfaces | \-i }
@@ -13,7 +13,7 @@ diff -up net-tools-2.0/man/en_US/netstat.8.interface net-tools-2.0/man/en_US/net
  .RB [ \-\-verbose | \-v ]
  .RB [ \-\-program | \-p ]
  .RB [ \-\-numeric | \-n ]
-@@ -134,8 +134,8 @@ and
+@@ -128,8 +128,8 @@ and
  produce the same output.
  .SS "\-\-groups, \-g"
  Display multicast group membership information for IPv4 and IPv6.
@@ -24,10 +24,10 @@ diff -up net-tools-2.0/man/en_US/netstat.8.interface net-tools-2.0/man/en_US/net
  .SS "\-\-masquerade, \-M"
  Display a list of masqueraded connections.
  .SS "\-\-statistics, \-s"
-diff -up net-tools-2.0/netstat.c.interface net-tools-2.0/netstat.c
---- net-tools-2.0/netstat.c.interface  2014-11-24 14:52:45.644623534 +0100
-+++ net-tools-2.0/netstat.c    2014-11-24 14:52:45.652623422 +0100
-@@ -144,6 +144,7 @@ static char *Release = RELEASE, *Signatu
+diff -urNp -x '*.orig' net-tools-2.10.org/netstat.c net-tools-2.10/netstat.c
+--- net-tools-2.10.org/netstat.c       2023-12-02 23:35:08.762985691 +0100
++++ net-tools-2.10/netstat.c   2023-12-02 23:35:08.827986462 +0100
+@@ -149,6 +149,7 @@ static char *Release = RELEASE, *Signatu
  #define E_IOCTL -3
  
  int flag_int = 0;
@@ -35,7 +35,7 @@ diff -up net-tools-2.0/netstat.c.interface net-tools-2.0/netstat.c
  int flag_rou = 0;
  int flag_mas = 0;
  int flag_sta = 0;
-@@ -2083,6 +2083,7 @@ static int rfcomm_info(void)
+@@ -2132,6 +2133,7 @@ static int rfcomm_info(void)
  
  static int iface_info(void)
  {
@@ -43,8 +43,8 @@ diff -up net-tools-2.0/netstat.c.interface net-tools-2.0/netstat.c
      if (skfd < 0) {
        if ((skfd = sockets_open(0)) < 0) {
            perror("socket");
-@@ -1802,7 +1804,11 @@ static int iface_info(void)
-           printf(_("Iface      MTU    RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR TX-DRP TX-OVR Flg\n"));
+@@ -2144,7 +2146,11 @@ static int iface_info(void)
+       printf(_("Iface             MTU    RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR TX-DRP TX-OVR Flg\n"));
      }
  
 -    if (for_all_interfaces(do_if_print, &flag_all) < 0) {
@@ -56,7 +56,7 @@ diff -up net-tools-2.0/netstat.c.interface net-tools-2.0/netstat.c
        perror(_("missing interface information"));
        exit(1);
      }
-@@ -1825,10 +1825,11 @@ static void usage(int rc)
+@@ -2171,10 +2177,11 @@ static void usage(int rc)
      FILE *fp = rc ? stderr : stdout;
      fprintf(fp, _("usage: netstat [-vWeenNcCF] [<Af>] -r         netstat {-V|--version|-h|--help}\n"));
      fprintf(fp, _("       netstat [-vWnNcaeol] [<Socket> ...]\n"));
@@ -69,7 +69,7 @@ diff -up net-tools-2.0/netstat.c.interface net-tools-2.0/netstat.c
      fprintf(fp, _("        -g, --groups             display multicast group memberships\n"));
      fprintf(fp, _("        -s, --statistics         display networking statistics (like SNMP)\n"));
  #if HAVE_FW_MASQUERADE
-@@ -1875,7 +1882,7 @@ int main
+@@ -2217,7 +2224,7 @@ int main
      {
        AFTRANS_OPTS,
        {"version", 0, 0, 'V'},
@@ -78,7 +78,7 @@ diff -up net-tools-2.0/netstat.c.interface net-tools-2.0/netstat.c
        {"help", 0, 0, 'h'},
        {"route", 0, 0, 'r'},
  #if HAVE_FW_MASQUERADE
-@@ -1919,7 +1926,7 @@ int main
+@@ -2261,7 +2268,7 @@ int main
      getroute_init();          /* Set up AF routing support */
  
      afname[0] = '\0';
@@ -87,7 +87,7 @@ diff -up net-tools-2.0/netstat.c.interface net-tools-2.0/netstat.c
        switch (i) {
        case -1:
            break;
-@@ -1960,6 +1967,13 @@ int main
+@@ -2302,6 +2309,13 @@ int main
        case 'p':
            flag_prg++;
            break;
index be737b9a985940e016b5bae2a0766ac6e9e79443..4bcd23bbcede7d2e76af85061d9073da1008d5b2 100644 (file)
@@ -4,12 +4,36 @@ Index: netstat.c
 ===================================================================
 RCS file: /cvsroot/net-tools/net-tools/netstat.c,v
 retrieving revision 1.55
-diff -c -d -u -r1.55 netstat.c
---- netstat.c  1 Dec 2007 19:00:40 -0000       1.55
-+++ netstat.c  20 Feb 2008 23:04:29 -0000
-@@ -96,6 +96,13 @@
- #include "util.h"
- #include "proc.h"
+diff -urNp -x '*.orig' net-tools-2.10.org/config.h net-tools-2.10/config.h
+--- net-tools-2.10.org/config.h        2023-12-02 23:34:04.104218822 +0100
++++ net-tools-2.10/config.h    2023-12-02 23:34:04.168219581 +0100
+@@ -73,3 +73,4 @@
+ #define HAVE_IP_TOOLS 0
+ #define HAVE_MII 1
+ #define HAVE_SELINUX 1
++#define HAVE_NETLINK 1
+diff -urNp -x '*.orig' net-tools-2.10.org/config.in net-tools-2.10/config.in
+--- net-tools-2.10.org/config.in       2021-01-07 00:22:35.000000000 +0100
++++ net-tools-2.10/config.in   2023-12-02 23:34:04.168219581 +0100
+@@ -98,3 +98,4 @@ bool 'Build mii-tool' HAVE_MII y
+ bool 'Build plipconfig' HAVE_PLIP_TOOLS y
+ bool 'Build slattach' HAVE_SERIAL_TOOLS y
+ bool 'SELinux support' HAVE_SELINUX n
++bool 'Use Netlink Diag' HAVE_NETLINK y
+diff -urNp -x '*.orig' net-tools-2.10.org/config.make net-tools-2.10/config.make
+--- net-tools-2.10.org/config.make     2023-12-02 23:34:04.104218822 +0100
++++ net-tools-2.10/config.make 2023-12-02 23:34:04.168219581 +0100
+@@ -36,3 +36,4 @@ HAVE_HWIRDA=1
+ # HAVE_IP_TOOLS=0
+ HAVE_MII=1
+ HAVE_SELINUX=1
++HAVE_NETLINK=1
+diff -urNp -x '*.orig' net-tools-2.10.org/netstat.c net-tools-2.10/netstat.c
+--- net-tools-2.10.org/netstat.c       2021-01-07 00:22:35.000000000 +0100
++++ net-tools-2.10/netstat.c   2023-12-02 23:34:04.168219581 +0100
+@@ -107,6 +107,13 @@
+ #include <bluetooth/bluetooth.h>
+ #endif
  
 +#ifdef HAVE_NETLINK
 +#include <asm/types.h>
@@ -19,10 +43,10 @@ diff -c -d -u -r1.55 netstat.c
 +
 +
  #define PROGNAME_WIDTH 20
+ #define SELINUX_WIDTH 50
  
- #if !defined(s6_addr32) && defined(in6a_words)
-@@ -828,11 +835,194 @@
-     }
+@@ -1216,11 +1223,194 @@ static void tcp_do_one(int lnr, const ch
+       finish_this_one(uid,inode,timers);
  }
  
 +
@@ -216,26 +240,5 @@ diff -c -d -u -r1.55 netstat.c
  }
 + 
  
- static void udp_do_one(int lnr, const char *line,const char *prot)
+ static int notnull(const struct sockaddr_storage *sas)
  {
---- config.in~ 2009-03-10 04:37:40.000000000 +0200
-+++ config.in  2009-03-10 04:38:14.092903210 +0200
-@@ -89,3 +89,4 @@
- bool 'Build iptunnel and ipmaddr' HAVE_IP_TOOLS n
- bool 'Build mii-tool' HAVE_MII n
- bool 'SELinux support' HAVE_SELINUX n
-+bool 'Use Netlink Diag' HAVE_NETLINK y
---- config.h~  2009-03-10 04:49:18.000000000 +0200
-+++ config.h   2009-03-10 04:49:55.762832175 +0200
-@@ -72,3 +72,4 @@
- #define HAVE_IP_TOOLS 0
- #define HAVE_MII 1
- #define HAVE_SELINUX 1
-+#define HAVE_NETLINK 1
---- config.make~       2009-03-10 04:49:18.000000000 +0200
-+++ config.make        2009-03-10 04:50:19.880072014 +0200
-@@ -33,3 +33,4 @@
- # HAVE_IP_TOOLS=0
- HAVE_MII=1
- HAVE_SELINUX=1
-+HAVE_NETLINK=1
index 7e98cf2b757da93ab9968a04f43586df9fb7401f..daf56783b63fdc09ee5306df12e6be3ead14fa36 100644 (file)
@@ -9,7 +9,7 @@ Summary(ru.UTF-8):      Базовые сетевые программы
 Summary(uk.UTF-8):     Базові програми мережі
 Name:          net-tools
 Version:       2.10
-Release:       1
+Release:       2
 License:       GPL v2+
 Group:         Networking/Admin
 Source0:       https://sourceforge.net/projects/net-tools/files/%{name}-%{version}.tar.xz
@@ -120,7 +120,7 @@ maszyny połączonej poprzez PLIP.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p0
+%patch5 -p1
 %patch6 -p1
 
 %build
This page took 0.123755 seconds and 4 git commands to generate.