]> git.pld-linux.org Git - packages/net-snmp.git/commitdiff
- up to 5.7.3 (drop obsolete patches) auto/th/net-snmp-5.7.3-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 30 Mar 2015 08:50:20 +0000 (10:50 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 30 Mar 2015 08:50:20 +0000 (10:50 +0200)
net-snmp-libnl.patch [deleted file]
net-snmp-libpci-init.patch [deleted file]
net-snmp-snmpksm.patch [deleted file]
net-snmp.spec

diff --git a/net-snmp-libnl.patch b/net-snmp-libnl.patch
deleted file mode 100644 (file)
index 2404de3..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
---- net-snmp-5.6.1/agent/mibgroup/mibII/tcpTable.c.org 2011-03-27 22:39:13.428728506 +0200
-+++ net-snmp-5.6.1/agent/mibgroup/mibII/tcpTable.c     2011-03-27 22:39:47.606956561 +0200
-@@ -555,8 +555,9 @@
- static int
- tcpTable_load_netlink(void)
- {
-+      int err;
-       /*  TODO: perhaps use permanent nl handle? */
--      struct nl_handle *nl = nl_handle_alloc();
-+      struct nl_sock *nl = nl_socket_alloc();
-       if (nl == NULL) {
-               DEBUGMSGTL(("mibII/tcpTable", "Failed to allocate netlink handle\n"));
-@@ -564,10 +565,10 @@
-               return -1;
-       }
--      if (nl_connect(nl, NETLINK_INET_DIAG) < 0) {
--              DEBUGMSGTL(("mibII/tcpTable", "Failed to connect to netlink: %s\n", nl_geterror()));
--              snmp_log(LOG_ERR, "snmpd: Couldn't connect to netlink: %s\n", nl_geterror());
--              nl_handle_destroy(nl);
-+      if ((err = nl_connect(nl, NETLINK_INET_DIAG)) < 0) {
-+              DEBUGMSGTL(("mibII/tcpTable", "Failed to connect to netlink: %s\n", nl_geterror(err)));
-+              snmp_log(LOG_ERR, "snmpd: Couldn't connect to netlink: %s\n", nl_geterror(err));
-+              nl_socket_free(nl);
-               return -1;
-       }
-@@ -579,10 +580,10 @@
-       struct nl_msg *nm = nlmsg_alloc_simple(TCPDIAG_GETSOCK, NLM_F_ROOT|NLM_F_MATCH|NLM_F_REQUEST);
-       nlmsg_append(nm, &req, sizeof(struct inet_diag_req), 0);
--      if (nl_send_auto_complete(nl, nm) < 0) {
--              DEBUGMSGTL(("mibII/tcpTable", "nl_send_autocomplete(): %s\n", nl_geterror()));
--              snmp_log(LOG_ERR, "snmpd: nl_send_autocomplete(): %s\n", nl_geterror());
--              nl_handle_destroy(nl);
-+      if ((err = nl_send_auto_complete(nl, nm)) < 0) {
-+              DEBUGMSGTL(("mibII/tcpTable", "nl_send_autocomplete(): %s\n", nl_geterror(err)));
-+              snmp_log(LOG_ERR, "snmpd: nl_send_autocomplete(): %s\n", nl_geterror(err));
-+              nl_socket_free(nl);
-               return -1;
-       }
-       nlmsg_free(nm);
-@@ -593,9 +594,9 @@
-       while (running) {
-               if ((len = nl_recv(nl, &peer, &buf, NULL)) <= 0) {
--                      DEBUGMSGTL(("mibII/tcpTable", "nl_recv(): %s\n", nl_geterror()));
--                      snmp_log(LOG_ERR, "snmpd: nl_recv(): %s\n", nl_geterror());
--                      nl_handle_destroy(nl);
-+                      DEBUGMSGTL(("mibII/tcpTable", "nl_recv(): %s\n", nl_geterror(len)));
-+                      snmp_log(LOG_ERR, "snmpd: nl_recv(): %s\n", nl_geterror(len));
-+                      nl_socket_free(nl);
-                       return -1;
-               }
-@@ -644,7 +645,7 @@
-               free(buf);
-       }
--      nl_handle_destroy(nl);
-+      nl_socket_free(nl);
-       if (tcp_head) {
-               DEBUGMSGTL(("mibII/tcpTable", "Loaded TCP Table using netlink\n"));
---- net-snmp-5.7.1/configure.d/config_os_libs2.orig    2011-09-28 06:53:47.000000000 +0200
-+++ net-snmp-5.7.1/configure.d/config_os_libs2 2011-10-30 12:25:15.940463045 +0100
-@@ -222,10 +222,11 @@
- #
- if test "x$with_nl" != "xno"; then
-+    CPPFLAGS="$CPPFLAGS -I/usr/include/libnl3"
-     case $target_os in
-     linux*) # Check for libnl (linux)
-       NETSNMP_SEARCH_LIBS(
--          nl_connect, nl,
-+          nl_connect, nl-3,
-           [AC_CHECK_HEADERS(netlink/netlink.h)],,, LMIBLIBS)
-     ;;
-     esac
diff --git a/net-snmp-libpci-init.patch b/net-snmp-libpci-init.patch
deleted file mode 100644 (file)
index 4adca98..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
---- net-snmp-5.7/agent/mibgroup/if-mib/data_access/interface_linux.c.orig      2011-07-02 00:35:46.000000000 +0200
-+++ net-snmp-5.7/agent/mibgroup/if-mib/data_access/interface_linux.c   2011-08-07 21:10:45.760672551 +0200
-@@ -19,6 +19,18 @@
- #ifdef HAVE_PCI_LOOKUP_NAME
- #include <pci/pci.h>
- static struct pci_access *pci_access;
-+static int _net_snmp_pci_status = 1;
-+
-+static void _net_snmp_pci_error(char *msg, ...)
-+{
-+  va_list args;
-+
-+  va_start(args, msg);
-+  snmp_log(LOG_ERR, "pcilib: ");
-+  snmp_vlog(LOG_ERR, msg, args);
-+  snmp_log(LOG_ERR, "\n");
-+  _net_snmp_pci_status = 0;
-+}
- #endif
- #ifdef HAVE_LINUX_ETHTOOL_H
-@@ -146,9 +158,15 @@
- #ifdef HAVE_PCI_LOOKUP_NAME
-     pci_access = pci_alloc();
--    if (pci_access)
-+    if (pci_access) {
-+      pci_access->error = _net_snmp_pci_error;
-       pci_init(pci_access);
--    else
-+      if (_net_snmp_pci_status == 0) {
-+          pci_cleanup(pci_access);
-+          pci_access = NULL;
-+          snmp_log(LOG_ERR, "Unable to create pci access method (libpci)\n");
-+      }
-+    } else
-       snmp_log(LOG_ERR, "Unable to create pci access method\n");
- #endif
- }
diff --git a/net-snmp-snmpksm.patch b/net-snmp-snmpksm.patch
deleted file mode 100644 (file)
index f1dc10f..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
---- net-snmp-5.4/snmplib/snmpksm.c.orig        2006-09-16 19:56:11.000000000 +0200
-+++ net-snmp-5.4/snmplib/snmpksm.c     2006-12-02 13:29:52.905425500 +0100
-@@ -63,11 +63,13 @@
- #ifdef NETSNMP_USE_KERBEROS_HEIMDAL
- #define CHECKSUM_TYPE(x)      (x)->cksumtype
- #define CHECKSUM_CONTENTS(x)  ((char *)((x)->checksum.data))
-+#define CHECKSUM_CONTENTS_L(x)        ((x)->checksum.data)
- #define CHECKSUM_LENGTH(x)    (x)->checksum.length
- #define TICKET_CLIENT(x)      (x)->client
- #else                         /* NETSNMP_USE_KERBEROS_HEIMDAL */
- #define CHECKSUM_TYPE(x)      (x)->checksum_type
- #define CHECKSUM_CONTENTS(x)  (x)->contents
-+#define CHECKSUM_CONTENTS_L(x)        (x)->contents
- #define CHECKSUM_LENGTH(x)    (x)->length
- #define TICKET_CLIENT(x)      (x)->enc_part2->client
- #endif                                /* NETSNMP_USE_KERBEROS_HEIMDAL */
-@@ -481,7 +483,7 @@
-     outdata.data = NULL;
-     ivector.length = 0;
-     ivector.data = NULL;
--    CHECKSUM_CONTENTS(&pdu_checksum) = NULL;
-+    CHECKSUM_CONTENTS_L(&pdu_checksum) = NULL;
-     if (!ksm_state) {
-         /*
-@@ -489,7 +491,7 @@
-          * suppress this (temporarily) while we build the credential info.
-          *   XXX - what about "udp:host" style addresses?
-          */
--        colon = strrchr(params->session->peername, ':');
-+        colon = strrchr(parms->session->peername, ':');
-         if (colon != NULL) {
-             *colon='\0';
-         }
-@@ -952,7 +954,7 @@
-       /* we did the bogus checksum--don't need to ask for the size again
-        * or initialize cksumtype; just free the bits */
-       free(CHECKSUM_CONTENTS(&pdu_checksum));
--      CHECKSUM_CONTENTS(&pdu_checksum) = NULL;
-+      CHECKSUM_CONTENTS_L(&pdu_checksum) = NULL;
-     }
-     else {
-       retval = krb5_checksumsize(kcontext, cksumtype,
-@@ -1072,7 +1074,7 @@
-      */
- #ifndef OLD_HEIMDAL /* since heimdal allocs the mem for us */
--    CHECKSUM_CONTENTS(&pdu_checksum) = malloc(CHECKSUM_LENGTH(&pdu_checksum));
-+    CHECKSUM_CONTENTS_L(&pdu_checksum) = malloc(CHECKSUM_LENGTH(&pdu_checksum));
-     if (!CHECKSUM_CONTENTS(&pdu_checksum)) {
-         DEBUGMSGTL(("ksm", "Unable to malloc %d bytes for checksum\n",
-@@ -1228,7 +1230,7 @@
-     DEBUGMSGTL(("ksm", "Processing has begun\n"));
--    CHECKSUM_CONTENTS(&checksum) = NULL;
-+    CHECKSUM_CONTENTS_L(&checksum) = NULL;
-     ap_req.data = NULL;
-     ivector.length = 0;
-     ivector.data = NULL;
-@@ -1347,7 +1349,7 @@
-         goto error;
-     }
--    CHECKSUM_CONTENTS(&checksum) = malloc(cksumlength);
-+    CHECKSUM_CONTENTS_L(&checksum) = malloc(cksumlength);
-     if (!CHECKSUM_CONTENTS(&checksum)) {
-         DEBUGMSGTL(("ksm", "Unable to malloc %d bytes for checksum.\n",
-                     cksumlength));
index eae6406d5404fb5dbc7172a32389f842c809d30b..aa24fdc9270ebb3bf7f5d8ea092ffe382c73eae3 100644 (file)
@@ -25,12 +25,12 @@ Summary(pt_BR.UTF-8):       Agente SNMP da UCD
 Summary(ru.UTF-8):     Набор утилит для протокола SNMP от UC-Davis
 Summary(uk.UTF-8):     Набір утиліт для протоколу SNMP від UC-Davis
 Name:          net-snmp
-Version:       5.7.2.1
-Release:       5
+Version:       5.7.3
+Release:       1
 License:       BSD-like
 Group:         Networking/Daemons
 Source0:       http://downloads.sourceforge.net/net-snmp/%{name}-%{version}.tar.gz
-# Source0-md5: 7db683faba037249837b226f64d566d4
+# Source0-md5: d4a3459e1577d0efa8d96ca70a885e53
 Source1:       %{name}d.init
 Source2:       %{name}d.conf
 Source3:       %{name}d.sysconfig
@@ -48,14 +48,12 @@ Patch4:             %{name}-link.patch
 Patch5:                %{name}-llinterfaces.patch
 Patch6:                %{name}-kernel_headers.patch
 Patch7:                %{name}-rpmpath.patch
-Patch8:                %{name}-snmpksm.patch
+
 Patch9:                %{name}-python.patch
 Patch10:       %{name}-lvalue.patch
 Patch11:       %{name}-defaultconfig.patch
 Patch12:       %{name}-use-rpm-hrmib.patch
 Patch13:       %{name}-TCP_STATS_CACHE_TIMEOUT.patch
-Patch14:       %{name}-libnl.patch
-Patch15:       %{name}-libpci-init.patch
 
 Patch17:       %{name}-logging.patch
 URL:           http://www.net-snmp.org/
@@ -433,14 +431,12 @@ SNMP dla trzech wersji tego protokołu (SNMPv3, SNMPv2c, SNMPv1).
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
-%patch8 -p1
+
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
-%patch14 -p1
-%patch15 -p1
 
 %patch17 -p1
 
This page took 0.048533 seconds and 4 git commands to generate.