]> git.pld-linux.org Git - packages/nagios-plugins.git/commitdiff
- rel 19; understang ping6 output from iputils package
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 17 Sep 2009 07:08:45 +0000 (07:08 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    nagios-plugins-ping.patch -> 1.1
    nagios-plugins.spec -> 1.119

nagios-plugins-ping.patch [new file with mode: 0644]
nagios-plugins.spec

diff --git a/nagios-plugins-ping.patch b/nagios-plugins-ping.patch
new file mode 100644 (file)
index 0000000..232d97f
--- /dev/null
@@ -0,0 +1,33 @@
+--- nagios-plugins-1.4.13/plugins/check_ping.c.org     2009-09-17 08:56:15.043692330 +0200
++++ nagios-plugins-1.4.13/plugins/check_ping.c 2009-09-17 09:04:41.830352692 +0200
+@@ -519,12 +519,13 @@
+ error_scan (char buf[MAX_INPUT_BUFFER], const char *addr)
+ {
+       if (strstr (buf, "Network is unreachable") ||
+-              strstr (buf, "Destination Net Unreachable")
++              strstr (buf, "Destination Net Unreachable") ||
++              strstr (buf, "No route")
+               )
+               die (STATE_CRITICAL, _("CRITICAL - Network Unreachable (%s)"), addr);
+-      else if (strstr (buf, "Destination Host Unreachable"))
++      else if (strstr (buf, "Destination Host Unreachable") || strstr(buf, "Address unreachable"))
+               die (STATE_CRITICAL, _("CRITICAL - Host Unreachable (%s)"), addr);
+-      else if (strstr (buf, "Destination Port Unreachable"))
++      else if (strstr (buf, "Destination Port Unreachable") || strstr(buf, "Port unreachable"))
+               die (STATE_CRITICAL, _("CRITICAL - Bogus ICMP: Port Unreachable (%s)"), addr);
+       else if (strstr (buf, "Destination Protocol Unreachable"))
+               die (STATE_CRITICAL, _("CRITICAL - Bogus ICMP: Protocol Unreachable (%s)"), addr);
+@@ -532,11 +533,11 @@
+               die (STATE_CRITICAL, _("CRITICAL - Network Prohibited (%s)"), addr);
+       else if (strstr (buf, "Destination Host Prohibited"))
+               die (STATE_CRITICAL, _("CRITICAL - Host Prohibited (%s)"), addr);
+-      else if (strstr (buf, "Packet filtered"))
++      else if (strstr (buf, "Packet filtered") || strstr(buf, "Administratively prohibited"))
+               die (STATE_CRITICAL, _("CRITICAL - Packet Filtered (%s)"), addr);
+       else if (strstr (buf, "unknown host" ))
+               die (STATE_CRITICAL, _("CRITICAL - Host not found (%s)"), addr);
+-      else if (strstr (buf, "Time to live exceeded"))
++      else if (strstr (buf, "Time to live exceeded") || strstr(buf, "Time exceeded"))
+               die (STATE_CRITICAL, _("CRITICAL - Time to live exceeded (%s)"), addr);
+       if (strstr (buf, "(DUP!)") || strstr (buf, "DUPLICATES FOUND")) {
index 230c568554728165b442585fa0a0dbac16ee85d5..a235694029de4c905a419fcd08f3ee6ea6c3ff9d 100644 (file)
@@ -9,7 +9,7 @@ Summary:        Host/service/network monitoring program plugins for Nagios
 Summary(pl.UTF-8):     Wtyczki do monitorowania hostów/usług/sieci dla Nagiosa
 Name:          nagios-plugins
 Version:       1.4.13
-Release:       18
+Release:       19
 License:       GPL v2
 Group:         Networking
 Source0:       http://dl.sourceforge.net/nagiosplug/%{name}-%{version}.tar.gz
@@ -41,6 +41,7 @@ Patch23:      %{name}-check_disk_smb-zero-cap.patch
 Patch24:       %{name}-paths.patch
 Patch25:       %{name}-check_snmp_disk_monitor-bulk.patch
 Patch26:       %{name}-check_snmp_disk_monitor-opts.patch
+Patch27:       %{name}-ping.patch
 URL:           http://www.nagiosplugins.org/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -491,6 +492,7 @@ mv nagios-plugins-config-*/* .
 %patch24 -p1
 %patch25 -p0
 %patch26 -p0
+%patch27 -p1
 
 # bring contribs into shape...
 cd contrib
This page took 0.12242 seconds and 4 git commands to generate.