]> git.pld-linux.org Git - packages/mysql.git/commitdiff
- rename is_prefix to mysql_is_prefix in exported syms
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 31 Mar 2011 15:25:21 +0000 (15:25 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    libmysql.version -> 1.4
    mysql-dubious-exports.patch -> 1.2
    mysql.spec -> 1.542

libmysql.version
mysql-dubious-exports.patch
mysql.spec

index 131018fb6c4e2a5834ecd9d9c52d0f6a294ee1cb..f60b8c69d46b041ffdb5440eab431ba9050887f4 100644 (file)
@@ -140,6 +140,5 @@ libmysqlclient_16.1 {
 # PHP's mysqli.so requires this (via the ER() macro)
        mysql_client_errors;
 # perl-DBD-mysql-4.018 for is_prefix
-# TODO: add it to mysql-dubious-exports.patch
-       is_prefix;
+       mysql_is_prefix;
 };
index 3342bf82bb72e5ab4fb374ce195f58929081eeac..ed8bec52d580f944ed763aba6980c5421d981e46 100644 (file)
@@ -58,3 +58,46 @@ diff -Naur mysql-5.5.8.orig/include/mysql_com.h mysql-5.5.8/include/mysql_com.h
  my_bool net_realloc(NET *net, size_t length);
  my_bool       net_flush(NET *net);
  my_bool       my_net_write(NET *net,const unsigned char *packet, size_t len);
+--- mysql-5.5.9/include/m_string.h~    2011-01-20 00:37:08.000000000 +0200
++++ mysql-5.5.9/include/m_string.h     2011-03-31 16:36:35.184588054 +0300
+@@ -118,6 +118,7 @@
+ extern size_t strnlen(const char *s, size_t n);
+ #endif
++#define is_prefix mysql_is_prefix             /* namespace sanity */
+ extern int is_prefix(const char *, const char *);
+ /* Conversion routines */
+--- mysql-5.5.9/sql/ha_ndbcluster.h~   2011-01-20 00:37:09.000000000 +0200
++++ mysql-5.5.9/sql/ha_ndbcluster.h    2011-03-31 16:39:03.528050275 +0300
+@@ -28,7 +28,7 @@
+ #endif
+ /* Blob tables and events are internal to NDB and must never be accessed */
+-#define IS_NDB_BLOB_PREFIX(A) is_prefix(A, "NDB$BLOB")
++#define IS_NDB_BLOB_PREFIX(A) mysql_is_prefix(A, "NDB$BLOB")
+ #include <NdbApi.hpp>
+ #include <ndbapi_limits.h>
+--- mysql-5.5.9/sql/ha_ndbcluster_binlog.h~    2011-01-20 00:37:09.000000000 +0200
++++ mysql-5.5.9/sql/ha_ndbcluster_binlog.h     2011-03-31 16:39:17.212010376 +0300
+@@ -27,7 +27,7 @@
+ typedef NdbDictionary::Dictionary  NDBDICT;
+ typedef NdbDictionary::Event  NDBEVENT;
+-#define IS_TMP_PREFIX(A) (is_prefix(A, tmp_file_prefix))
++#define IS_TMP_PREFIX(A) (mysql_is_prefix(A, tmp_file_prefix))
+ #define INJECTOR_EVENT_LEN 200
+--- mysql-5.5.9/strings/is_prefix.c~   2011-01-20 00:37:10.000000000 +0200
++++ mysql-5.5.9/strings/is_prefix.c    2011-03-31 17:03:18.174663621 +0300
+@@ -24,7 +24,7 @@
+ #include <my_global.h>
+ #include "m_string.h"
+-int is_prefix(register const char *s, register const char *t)
++int mysql_is_prefix(register const char *s, register const char *t)
+ {
+   while (*t)
+     if (*s++ != *t++) return 0;
index c03ce629c90aa8cc2eb959ee13953ae9242ea3eb..a7ccca7cfc35423c187f2d252a8728ca566f5409 100644 (file)
@@ -37,7 +37,7 @@ Summary(uk.UTF-8):    MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
 Version:       5.5.9
-Release:       6.2
+Release:       6.3
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
 # Source0Download: http://dev.mysql.com/downloads/mysql/5.5.html#downloads
This page took 0.168622 seconds and 4 git commands to generate.