]> git.pld-linux.org Git - packages/mysql.git/commitdiff
- add mysql-dubious-exports.patch from fedora, used by libmysql.version
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 31 Mar 2011 12:01:47 +0000 (12:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    mysql-dubious-exports.patch -> 1.1
    mysql.spec -> 1.540

mysql-dubious-exports.patch [new file with mode: 0644]
mysql.spec

diff --git a/mysql-dubious-exports.patch b/mysql-dubious-exports.patch
new file mode 100644 (file)
index 0000000..3342bf8
--- /dev/null
@@ -0,0 +1,60 @@
+Prefix mysql_ to the real names of several symbols that have to be exported
+from libmysqlclient because mysql-connector-odbc and/or PHP depend on them.
+This limits the intrusion on application namespace.
+
+
+diff -Naur mysql-5.5.8.orig/include/errmsg.h mysql-5.5.8/include/errmsg.h
+--- mysql-5.5.8.orig/include/errmsg.h  2010-12-03 12:58:24.000000000 -0500
++++ mysql-5.5.8/include/errmsg.h       2010-12-27 14:29:59.184552374 -0500
+@@ -24,6 +24,7 @@
+ #endif
+ void  init_client_errs(void);
+ void  finish_client_errs(void);
++#define client_errors mysql_client_errors             /* namespace sanity */
+ extern const char *client_errors[];   /* Error messages */
+ #ifdef        __cplusplus
+ }
+diff -Naur mysql-5.5.8.orig/include/my_sys.h mysql-5.5.8/include/my_sys.h
+--- mysql-5.5.8.orig/include/my_sys.h  2010-12-03 12:58:24.000000000 -0500
++++ mysql-5.5.8/include/my_sys.h       2010-12-27 14:27:23.956926896 -0500
+@@ -227,6 +227,7 @@
+ /* charsets */
+ #define MY_ALL_CHARSETS_SIZE 2048
++#define default_charset_info mysql_default_charset_info       /* namespace sanity */
+ extern MYSQL_PLUGIN_IMPORT CHARSET_INFO *default_charset_info;
+ extern MYSQL_PLUGIN_IMPORT CHARSET_INFO *all_charsets[MY_ALL_CHARSETS_SIZE];
+ extern CHARSET_INFO compiled_charsets[];
+@@ -914,6 +915,9 @@
+ extern uint get_collation_number(const char *name);
+ extern const char *get_charset_name(uint cs_number);
++#define get_charset mysql_get_charset         /* namespace sanity */
++#define get_charset_by_csname mysql_get_charset_by_csname
++
+ extern CHARSET_INFO *get_charset(uint cs_number, myf flags);
+ extern CHARSET_INFO *get_charset_by_name(const char *cs_name, myf flags);
+ extern CHARSET_INFO *get_charset_by_csname(const char *cs_name,
+diff -Naur mysql-5.5.8.orig/include/mysql.h.pp mysql-5.5.8/include/mysql.h.pp
+--- mysql-5.5.8.orig/include/mysql.h.pp        2010-12-03 12:58:24.000000000 -0500
++++ mysql-5.5.8/include/mysql.h.pp     2010-12-27 14:27:23.956926896 -0500
+@@ -86,7 +86,7 @@
+ void my_net_local_init(NET *net);
+ void net_end(NET *net);
+   void net_clear(NET *net, my_bool clear_buffer);
+-my_bool net_realloc(NET *net, size_t length);
++my_bool mysql_net_realloc(NET *net, size_t length);
+ my_bool net_flush(NET *net);
+ my_bool my_net_write(NET *net,const unsigned char *packet, size_t len);
+ my_bool net_write_command(NET *net,unsigned char command,
+diff -Naur mysql-5.5.8.orig/include/mysql_com.h mysql-5.5.8/include/mysql_com.h
+--- mysql-5.5.8.orig/include/mysql_com.h       2010-12-03 12:58:24.000000000 -0500
++++ mysql-5.5.8/include/mysql_com.h    2010-12-27 14:27:23.957927198 -0500
+@@ -448,6 +448,7 @@
+ void  my_net_local_init(NET *net);
+ void  net_end(NET *net);
+   void        net_clear(NET *net, my_bool clear_buffer);
++#define net_realloc mysql_net_realloc         /* namespace sanity */
+ my_bool net_realloc(NET *net, size_t length);
+ my_bool       net_flush(NET *net);
+ my_bool       my_net_write(NET *net,const unsigned char *packet, size_t len);
index 3d77d19f20287f1d1579b3f6495c182e5f1cf9cc..0f3ad9066cf37abdac1d740ffc2695efad5ce944 100644 (file)
@@ -37,7 +37,7 @@ Summary(uk.UTF-8):    MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
 Version:       5.5.9
-Release:       6
+Release:       6.1
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
 # Source0Download: http://dev.mysql.com/downloads/mysql/5.5.html#downloads
@@ -75,10 +75,12 @@ Patch12:    %{name}-config.patch
 Patch14:       %{name}-bug-43594.patch
 Patch18:       %{name}-sphinx.patch
 Patch19:       %{name}-chain-certs.patch
+# from fedora
+Patch20:       %{name}-dubious-exports.patch
 # <percona patches, updated with percona.sh>
 Patch100:      microsec_process.patch
 Patch101:      optimizer_fix.patch
-Patch102:      mysql_dump_ignore_ct.patch
+Patch102:      %{name}_dump_ignore_ct.patch
 Patch103:      control_online_alter_index.patch
 Patch104:      show_temp.patch
 Patch105:      innodb_show_status.patch
@@ -111,7 +113,7 @@ Patch131:   slow_extended.patch
 Patch132:      percona_support.patch
 Patch133:      query_cache_enhance.patch
 Patch134:      log_connection_error.patch
-Patch135:      mysql_syslog.patch
+Patch135:      %{name}_syslog.patch
 Patch136:      response_time_distribution.patch
 Patch137:      error_pad.patch
 Patch138:      remove_fcntl_excessive_calls.patch
@@ -120,7 +122,7 @@ Patch140:   show_slave_status_nolock.patch
 Patch141:      log_warnings_suppress.patch
 Patch142:      userstat.patch
 Patch143:      bug580324.patch
-Patch144:      mysql_remove_eol_carret.patch
+Patch144:      %{name}_remove_eol_carret.patch
 # </percona>
 URL:           http://www.mysql.com/products/community/
 BuildRequires: bison
@@ -559,6 +561,7 @@ mv sphinx-*/mysqlse storage/sphinx
 %patch12 -p1
 %patch14 -p0
 %patch19 -p1
+%patch20 -p1
 # <percona %patches>
 %patch100 -p1
 %patch101 -p1
This page took 0.05428 seconds and 4 git commands to generate.