]> git.pld-linux.org Git - packages/mysql.git/commitdiff
- trigger to use old password() function, even after fixing tables.
authorPaweł Gołaszewski <blues@pld-linux.org>
Mon, 4 Apr 2005 18:00:21 +0000 (18:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    mysql.spec -> 1.260

mysql.spec

index 34aa2b21023f6b29a863dd2d660e2b15db644d05..5a0dc60065bf697c9dba966271b31dd0a0e4fe3a 100644 (file)
@@ -24,7 +24,7 @@ Summary(zh_CN):       MySQL
 Name:          mysql
 Group:         Applications/Databases
 Version:       4.1.10a
-Release:       1
+Release:       1.1
 License:       GPL + MySQL FLOSS Exception
 Source0:       http://mysql.mirror.anlx.net/Downloads/MySQL-4.1/%{name}-%{version}.tar.gz
 # Source0-md5: 6a4a6a5b3d0a42a9a271b2b8867bde82
@@ -647,6 +647,22 @@ if [ -f "/etc/sysconfig/mysql" ]; then
        fi
 fi
 
+%triggerpostun -- mysql <= 4.1.1
+# For better compatibility with prevoius versions:
+for config in `grep -v "^#" /etc/mysql/clusters.conf | cut -d"=" -f 1`; do
+       if echo "$config" | grep -q '^/'; then
+               config_file="$config"
+       elif [ -f "/etc/mysql/$config" ]; then
+               config_file=/etc/mysql/$config
+       else
+               config_file="$clusterdir/mysqld.conf"
+       fi
+       echo "Adding option old-passwords to config: $config_file"
+       echo "If you want to use new, better passwords - remove it"
+       echo "# Compatibility options:" >> $config_file
+       echo "old-passwords" >> $config_file
+done
+
 %files
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/mysql
This page took 0.071606 seconds and 4 git commands to generate.