]> git.pld-linux.org Git - packages/mysql.git/commitdiff
- up to 5.6.33; patches updated; build issues as todo
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 15 Oct 2013 16:25:15 +0000 (18:25 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 15 Oct 2013 16:25:15 +0000 (18:25 +0200)
mysql-config.patch
mysql-dubious-exports.patch
mysql-system-users.patch
mysql.spec

index 7a8fc65cc3b8b1af45ae6d8dce0c95bcb0907c46..ac61f8fd8c9148f62440598d397c408a97f5db8f 100644 (file)
@@ -1,18 +1,20 @@
---- mysql-5.1.26-rc/scripts/mysql_config.sh.orig       2008-07-01 00:36:15.000000000 +0200
-+++ mysql-5.1.26-rc/scripts/mysql_config.sh    2008-08-25 19:39:20.111236513 +0200
-@@ -132,21 +132,21 @@
+--- Percona-Server-5.6.13-rel61.0/scripts/mysql_config.sh~     2013-10-07 12:25:25.000000000 +0200
++++ Percona-Server-5.6.13-rel61.0/scripts/mysql_config.sh      2013-10-15 18:17:41.547988430 +0200
+@@ -124,23 +124,23 @@
+ for remove in DDBUG_OFF DSAFE_MUTEX DFORCE_INIT_OF_VARS \
                DEXTRA_DEBUG DHAVE_purify O 'O[0-9]' 'xO[0-9]' 'W[-A-Za-z]*' \
                'mtune=[-A-Za-z0-9]*' 'mcpu=[-A-Za-z0-9]*' 'march=[-A-Za-z0-9]*' \
-               Xa xstrconst "xc99=none" AC99 \
 -              unroll2 ip mp restrict
 +              unroll2 ip mp restrict 'f[-a-z0-9]*' 'g[-a-z0-9]*' 'm[-a-z0-9]*'
  do
    # The first option we might strip will always have a space before it because
    # we set -I$pkgincludedir as the first option
 -  cflags=`echo "$cflags"|sed -e "s/ -$remove  */ /g"` 
-+  cflags=`echo "$cflags"|sed -e "s/ \(-$remove  *\)\{1,\}/ /g"` 
++  cflags=`echo "$cflags"|sed -e "s/ \(-$remove  *\)\{1,\}/ /g"`
+   cxxflags=`echo "$cxxflags"|sed -e "s/ -$remove  */ /g"` 
  done
  cflags=`echo "$cflags"|sed -e 's/ *\$//'` 
+ cxxflags=`echo "$cxxflags"|sed -e 's/ *\$//'` 
  
  # Same for --libs(_r)
 -for remove in lmtmalloc static-libcxa i-static static-intel
@@ -22,9 +24,9 @@
 -  libs=`echo "$libs"|sed -e "s/ -$remove  */ /g"` 
 -  libs_r=`echo "$libs_r"|sed -e "s/ -$remove  */ /g"` 
 -  embedded_libs=`echo "$embedded_libs"|sed -e "s/ -$remove  */ /g"` 
-+  libs=`echo "$libs"|sed -e "s/ \(-$remove  *\)\{1,\}/ /g"` 
-+  libs_r=`echo "$libs_r"|sed -e "s/ \(-$remove  *\)\{1,\}/ /g"` 
-+  embedded_libs=`echo "$embedded_libs"|sed -e "s/ \(-$remove  *\)\{1,\}/ /g"` 
++  libs=`echo "$libs"|sed -e "s/ \(-$remove  *\)\{1,\}/ /g"`
++  libs_r=`echo "$libs_r"|sed -e "s/ \(-$remove  *\)\{1,\}/ /g"`
++  embedded_libs=`echo "$embedded_libs"|sed -e "s/ \(-$remove  *\)\{1,\}/ /g"`
  done
  
  # Strip trailing and ending space if any, and '+' (FIXME why?)
index 8874fce45a6e89b4d421f1e4ab44b121ca4dde0b..4166c52d228cc937cc9a195c22bbb553673f490b 100644 (file)
@@ -27,10 +27,10 @@ diff -Naur mysql-5.5.8.orig/include/my_sys.h mysql-5.5.8/include/my_sys.h
 diff -Naur mysql-5.5.8.orig/include/mysql.h.pp mysql-5.5.8/include/mysql.h.pp
 --- mysql-5.5.8.orig/include/mysql.h.pp        2010-12-03 12:58:24.000000000 -0500
 +++ mysql-5.5.8/include/mysql.h.pp     2010-12-27 14:27:23.956926896 -0500
-@@ -86,7 +86,7 @@
+@@ -90,7 +90,7 @@
  void my_net_local_init(NET *net);
  void net_end(NET *net);
  void net_clear(NET *net, my_bool clear_buffer);
void net_clear(NET *net, my_bool check_buffer);
 -my_bool net_realloc(NET *net, size_t length);
 +my_bool mysql_net_realloc(NET *net, size_t length);
  my_bool net_flush(NET *net);
@@ -39,11 +39,11 @@ diff -Naur mysql-5.5.8.orig/include/mysql.h.pp mysql-5.5.8/include/mysql.h.pp
 diff -Naur mysql-5.5.8.orig/include/mysql_com.h mysql-5.5.8/include/mysql_com.h
 --- mysql-5.5.8.orig/include/mysql_com.h       2010-12-03 12:58:24.000000000 -0500
 +++ mysql-5.5.8/include/mysql_com.h    2010-12-27 14:27:23.957927198 -0500
-@@ -448,6 +448,7 @@
- void  my_net_local_init(NET *net);
- void  net_end(NET *net);
  void        net_clear(NET *net, my_bool clear_buffer);
-+#define net_realloc mysql_net_realloc         /* namespace sanity */
+@@ -497,6 +497,7 @@
+ void my_net_local_init(NET *net);
+ void net_end(NET *net);
void net_clear(NET *net, my_bool check_buffer);
++#define net_realloc mysql_net_realloc          /* namespace sanity */
  my_bool net_realloc(NET *net, size_t length);
  my_bool       net_flush(NET *net);
  my_bool       my_net_write(NET *net,const unsigned char *packet, size_t len);
index 34b360ce2530634f887d3ef89f708f80b464b418..cc7ecc51ab3d0cee78726ab9aa5000fdbedd01f9 100644 (file)
  -- Fill "user" table with default users allowing root access
  -- from local machine if "user" table didn't exist before
  CREATE TEMPORARY TABLE tmp_user LIKE user;
--INSERT INTO tmp_user VALUES ('localhost','root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','');
--REPLACE INTO tmp_user SELECT @current_hostname,'root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','' FROM dual WHERE LOWER( @current_hostname) != 'localhost';
--REPLACE INTO tmp_user VALUES ('127.0.0.1','root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','');
--REPLACE INTO tmp_user VALUES ('::1','root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','');
-+INSERT INTO tmp_user VALUES ('localhost','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','');
-+REPLACE INTO tmp_user SELECT @current_hostname,'mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','' FROM dual WHERE LOWER( @current_hostname) != 'localhost';
-+REPLACE INTO tmp_user VALUES ('127.0.0.1','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','');
-+REPLACE INTO tmp_user VALUES ('::1','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','');
-+INSERT INTO tmp_user VALUES ('localhost','mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','');
-+REPLACE INTO tmp_user SELECT @current_hostname,'mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','' FROM dual WHERE LOWER( @current_hostname) != 'localhost';
-+REPLACE INTO tmp_user VALUES ('127.0.0.1','mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','');
-+REPLACE INTO tmp_user VALUES ('::1','mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','');
+-INSERT INTO tmp_user VALUES ('localhost','root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N');
+-REPLACE INTO tmp_user SELECT @current_hostname,'root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N' FROM dual WHERE LOWER( @current_hostname) != 'localhost';
+-REPLACE INTO tmp_user VALUES ('127.0.0.1','root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N');
+-REPLACE INTO tmp_user VALUES ('::1','root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N');
++INSERT INTO tmp_user VALUES ('localhost','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N');
++REPLACE INTO tmp_user SELECT @current_hostname,'mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N' FROM dual WHERE LOWER( @current_hostname) != 'localhost';
++REPLACE INTO tmp_user VALUES ('127.0.0.1','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N');
++REPLACE INTO tmp_user VALUES ('::1','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N');
++INSERT INTO tmp_user VALUES ('localhost','mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','','N');
++REPLACE INTO tmp_user SELECT @current_hostname,'mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','','N' FROM dual WHERE LOWER( @current_hostname) != 'localhost';
++REPLACE INTO tmp_user VALUES ('127.0.0.1','mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','','N');
++REPLACE INTO tmp_user VALUES ('::1','mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','','N');
  INSERT INTO tmp_user (host,user) VALUES ('localhost','');
  INSERT INTO tmp_user (host,user) SELECT @current_hostname,'' FROM dual WHERE LOWER(@current_hostname ) != 'localhost';
  INSERT INTO user SELECT * FROM tmp_user WHERE @had_user_table=0;
index b7d69e199dd46e34939edcef889094fa3c8f5b99..ce8f5d1e62223a988c7b19ee31e0dcdf74531b8a 100644 (file)
@@ -23,7 +23,7 @@
 %bcond_with    tests           # FIXME: don't run correctly
 %bcond_with    ndb             # NDB is now a separate product, this here is broken, so disable it
 
-%define        percona_rel     31.1
+%define        percona_rel     61.0
 %include       /usr/lib/rpm/macros.perl
 Summary:       MySQL: a very fast and reliable SQL database engine
 Summary(de.UTF-8):     MySQL: ist eine SQL-Datenbank
@@ -34,16 +34,16 @@ Summary(ru.UTF-8):  MySQL - быстрый SQL-сервер
 Summary(uk.UTF-8):     MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
-Version:       5.5.33
-Release:       2
+Version:       5.6.13
+Release:       0.1
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
 # Source0Download: http://dev.mysql.com/downloads/mysql/5.5.html#downloads
 # Source0:     http://vesta.informatik.rwth-aachen.de/mysql/Downloads/MySQL-5.5/%{name}-%{version}.tar.gz
-Source0:       http://www.percona.com/redir/downloads/Percona-Server-5.5/LATEST/source/Percona-Server-%{version}-rel%{percona_rel}.tar.gz
-# Source0-md5: 4a1c053dbdda4bb643f7ab13a9776f34
-Source100:     http://www.sphinxsearch.com/files/sphinx-2.0.8-release.tar.gz
-# Source100-md5:       bcaf0af0ba403a43b9ef3af6f9599cb4
+Source0:       http://www.percona.com/redir/downloads/Percona-Server-5.6/LATEST/source/Percona-Server-%{version}-rel%{percona_rel}.tar.gz
+# Source0-md5: 25a6d313e98ce3f759aa08288941e748
+Source100:     http://www.sphinxsearch.com/files/sphinx-2.1.2-release.tar.gz
+# Source100-md5:       3e828fa58e2e6049f02aa6aef3009d48
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}.logrotate
This page took 0.047522 seconds and 4 git commands to generate.