]> git.pld-linux.org Git - packages/mysql.git/commitdiff
- update to 5.0.56
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 7 Apr 2008 09:42:36 +0000 (09:42 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    mysql-align.patch -> 1.2.2.1
    mysql-libs.patch -> 1.14.2.6

mysql-align.patch
mysql-libs.patch

index 5feab48c0411f42ba214da8d63200a08c9d3292f..ac032a32036b5c05fa83f8c9b82cda0f721d1687 100644 (file)
                       opts->u_max_value : value);
  
      if (!result_pos)
-@@ -738,7 +738,7 @@
-     value             Pointer to variable
+@@ -864,7 +864,7 @@
+     value              Pointer to variable
  */
  
--static void init_one_value(const struct my_option *option, gptr *variable,
-+static void init_one_value(const struct my_option *option, gptr variable,
+-static void init_one_value(const struct my_option *optp, gptr *variable,
++static void init_one_value(const struct my_option *optp, gptr variable,
                           longlong value)
  {
-   switch ((option->var_type & GET_TYPE_MASK)) {
+   DBUG_ENTER("init_one_value");
 @@ -793,12 +793,12 @@
        set the value to default value.
      */
index d17635865ddccaee55889cef04d28c7d9024ba4e..ea6aa6c63e7026ac2e92fabbca9e4efa7ab12037 100644 (file)
@@ -1,6 +1,6 @@
---- mysql-5.0.41.org/configure.in      2007-05-02 16:39:58.000000000 +0200
-+++ mysql-5.0.41/configure.in  2007-05-10 15:02:12.075664162 +0200
-@@ -779,19 +779,20 @@
+--- mysql-5.0.56/configure.in~ 2008-04-07 09:44:34.000000000 +0300
++++ mysql-5.0.56/configure.in  2008-04-07 12:23:29.657592515 +0300
+@@ -826,9 +826,9 @@
  
  AC_CHECK_LIB(m, floor, [], AC_CHECK_LIB(m, __infinity))
  
 +              [AC_CHECK_LIB(nsl, gethostbyname_r)])])
  
  AC_CHECK_FUNC(setsockopt, , AC_CHECK_LIB(socket, setsockopt))
--AC_CHECK_FUNC(yp_get_default_domain, ,
--  AC_CHECK_LIB(nsl, yp_get_default_domain))
- AC_CHECK_FUNC(p2open, , AC_CHECK_LIB(gen, p2open))
+ AC_CHECK_FUNC(yp_get_default_domain, ,
+@@ -837,7 +837,11 @@
  # This may get things to compile even if bind-8 is installed
  AC_CHECK_FUNC(bind, , AC_CHECK_LIB(bind, bind))
  # Check if crypt() exists in libc or libcrypt, sets LIBS if needed
 -AC_SEARCH_LIBS(crypt, crypt, AC_DEFINE(HAVE_CRYPT, 1, [crypt]))
--AC_SEARCH_LIBS(inet_aton, [socket nsl resolv])
 +save_LIBS="$LIBS"
 +AC_CHECK_LIB(crypt, crypt, [LIBS="-lcrypt $LIBS"; LIBCRYPT="-lcrypt"])
 +AC_SUBST(LIBCRYPT)
 +AC_CHECK_FUNC(crypt, AC_DEFINE([HAVE_CRYPT], [1], [crypt]))
 +LIBS="$save_LIBS"
+ # See if we need a library for address lookup.
+ AC_SEARCH_LIBS(inet_aton, [socket nsl resolv])
  
- # For the sched_yield() function on Solaris
- AC_CHECK_FUNC(sched_yield, , AC_CHECK_LIB(posix4, sched_yield))
 --- mysql-5.0.51/sql/Makefile.am~      2007-12-06 22:13:15.000000000 +0200
 +++ mysql-5.0.51/sql/Makefile.am       2007-12-06 22:14:55.492574255 +0200
 @@ -43,7 +43,7 @@
This page took 0.044778 seconds and 4 git commands to generate.