]> git.pld-linux.org Git - packages/mysql.git/commitdiff
- rel 2; patches updated auto/th/mysql-5_5_21-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 27 Apr 2012 13:00:48 +0000 (13:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    memory_dynamic_rows.patch -> 1.6
    mysql.spec -> 1.571

memory_dynamic_rows.patch
mysql.spec

index 3026815470758991b9538c194d203766b4e66f11..2b86c8476fbcefaf8a3f8ed2a215e71ad3df3f51 100644 (file)
  } /* heap_update */
 --- /dev/null
 +++ b/mysql-test/r/percona_heap_blob.result
-@@ -0,0 +1,952 @@
+@@ -0,0 +1,956 @@
 +SET @old_default_storage_engine=@@default_storage_engine;
 +SET default_storage_engine=MEMORY;
 +drop table if exists t1,t2,t3,t4,t5,t6,t7;
 +a
 +Where
 +drop table t1;
-+create table t1 (t text,c char(10),b blob, d varbinary(10));
++create table t1 (t text,c char(10),b blob, d varbinary(10)) collate latin1_general_cs;
 +insert into t1 values (NULL,NULL,NULL,NULL);
 +insert into t1 values ("","","","");
 +insert into t1 values ("hello","hello","hello","hello");
 +lock tables t1 READ;
 +show full fields from t1;
 +Field Type    Collation       Null    Key     Default Extra   Privileges      Comment
-+t     text    latin1_swedish_ci       YES             NULL            #       
-+c     char(10)        latin1_swedish_ci       YES             NULL            #       
++t     text    latin1_general_cs       YES             NULL            #       
++c     char(10)        latin1_general_cs       YES             NULL            #       
 +b     blob    NULL    YES             NULL            #       
 +d     varbinary(10)   NULL    YES             NULL            #       
 +lock tables t1 WRITE;
 +show full fields from t1;
 +Field Type    Collation       Null    Key     Default Extra   Privileges      Comment
-+t     text    latin1_swedish_ci       YES             NULL            #       
-+c     char(10)        latin1_swedish_ci       YES             NULL            #       
++t     text    latin1_general_cs       YES             NULL            #       
++c     char(10)        latin1_general_cs       YES             NULL            #       
 +b     blob    NULL    YES             NULL            #       
 +d     varbinary(10)   NULL    YES             NULL            #       
 +unlock tables;
 +select t from t1 where t like "hello";
 +t
 +hello
-+HELLO
 +select c from t1 where c like "hello";
 +c
 +hello
-+HELLO
 +select b from t1 where b like "hello";
 +b
 +hello
 +select c from t1 having c like "hello";
 +c
 +hello
-+HELLO
 +select d from t1 having d like "hello";
 +d
 +hello
 +select t from t1 where t like "%HELLO%";
 +t
-+hello
 +HELLO
 +HELLO MY
 +select c from t1 where c like "%HELLO%";
 +c
-+hello
 +HELLO
 +HELLO MY
 +select b from t1 where b like "%HELLO%";
 +HELLO MY
 +select c from t1 having c like "%HELLO%";
 +c
-+hello
 +HELLO
 +HELLO MY
 +select d from t1 having d like "%HELLO%";
 +
 +1
 +a
-+hello
 +HELLO
 +HELLO MY
++hello
 +select c from t1 order by c;
 +c
 +NULL
 +
 +
 +a
-+hello
 +HELLO
 +HELLO MY
++hello
 +select b from t1 order by b;
 +b
 +NULL
 +NULL
 +
 +hello
++HELLO
 +HELLO MY
 +a
 +1
 +
 +1
 +a
-+hello
++HELLO
 +HELLO MY
++hello
 +select distinct b from t1 order by b;
 +b
 +NULL
 +
 +1
 +a
-+hello
++HELLO
 +HELLO MY
++hello
 +select b from t1 group by b;
 +b
 +NULL
 +NULL
 +
 +hello
++HELLO
 +HELLO MY
 +a
 +1
 +
 +1
 +a
-+hello
++HELLO
 +HELLO MY
++hello
 +select distinct b from t1 order by b;
 +b
 +NULL
 +NULL
 +
 +hello
++HELLO
 +HELLO MY
 +a
 +select distinct d from t1;
 +NULL
 +
 +a
-+hello
++HELLO
 +HELLO MY
++hello
 +select distinct d from t1 order by d;
 +d
 +NULL
 +NULL
 +
 +a
-+hello
++HELLO
 +HELLO MY
++hello
 +select d from t1 group by d;
 +d
 +NULL
 +      1
 +1     1
 +a     1
-+hello 2
++HELLO 1
 +HELLO MY      1
++hello 1
 +select b,count(*) from t1 group by b;
 +b     count(*)
 +NULL  3
 +NULL  2
 +      2
 +a     1
-+hello 2
++HELLO 1
 +HELLO MY      1
++hello 1
 +select d,count(*) from t1 group by d;
 +d     count(*)
 +NULL  2
 +#
 +# test of blob, text, char and varbinary
 +#
-+create table t1 (t text,c char(10),b blob, d varbinary(10));
++create table t1 (t text,c char(10),b blob, d varbinary(10)) collate latin1_general_cs;
 +insert into t1 values (NULL,NULL,NULL,NULL);
 +insert into t1 values ("","","","");
 +insert into t1 values ("hello","hello","hello","hello");
index 059a91387b02c074ca688b7215821844d137433a..b0c36d7f5f444384b4d3d3d513dfc5ee22734566 100644 (file)
@@ -36,7 +36,7 @@ Summary(uk.UTF-8):    MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
 Version:       5.5.21
-Release:       1
+Release:       2
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
 # Source0Download: http://dev.mysql.com/downloads/mysql/5.5.html#downloads
This page took 0.182993 seconds and 4 git commands to generate.