]> git.pld-linux.org Git - packages/mysql.git/commitdiff
- up to 5.5.31 auto/th/mysql-5.5.31-1 auto/ti/mysql-5.5.31-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 7 Jun 2013 17:57:57 +0000 (19:57 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 7 Jun 2013 17:57:57 +0000 (19:57 +0200)
mysql-dubious-exports.patch
mysql-system-users.patch
mysql-versioning.patch [deleted file]
mysql.spec

index cc37c6f8dca5e13f10fdf674a089c896a96c2365..8874fce45a6e89b4d421f1e4ab44b121ca4dde0b 100644 (file)
@@ -3,17 +3,6 @@ from libmysqlclient because mysql-connector-odbc and/or PHP depend on them.
 This limits the intrusion on application namespace.
 
 
-diff -Naur mysql-5.5.8.orig/include/errmsg.h mysql-5.5.8/include/errmsg.h
---- mysql-5.5.8.orig/include/errmsg.h  2010-12-03 12:58:24.000000000 -0500
-+++ mysql-5.5.8/include/errmsg.h       2010-12-27 14:29:59.184552374 -0500
-@@ -24,6 +24,7 @@
- #endif
- void  init_client_errs(void);
- void  finish_client_errs(void);
-+#define client_errors mysql_client_errors             /* namespace sanity */
- extern const char *client_errors[];   /* Error messages */
- #ifdef        __cplusplus
- }
 diff -Naur mysql-5.5.8.orig/include/my_sys.h mysql-5.5.8/include/my_sys.h
 --- mysql-5.5.8.orig/include/my_sys.h  2010-12-03 12:58:24.000000000 -0500
 +++ mysql-5.5.8/include/my_sys.h       2010-12-27 14:27:23.956926896 -0500
index b4f38e3a6a6007150af3999466b806b04c490e4f..cb0d7f522d1829a0af7b546aae7ef7cf1ac63892 100644 (file)
@@ -1,9 +1,10 @@
 --- mysql-5.5.8/scripts/mysql_system_tables_data.sql.org       2010-12-16 00:09:23.662631925 +0100
 +++ mysql-5.5.8/scripts/mysql_system_tables_data.sql   2010-12-16 00:10:17.763454969 +0100
-@@ -8,23 +8,18 @@
set @current_hostname= @@hostname;
+@@ -27,23 +27,17 @@
SET @get_hostname= @@hostname;
+ SELECT REPLACE((SELECT REPLACE(@get_hostname,'_','\_')),'%','\%') INTO @current_hostname;
  
+-
 --- Fill "db" table with default grants for anyone to
 --- access database 'test' and 'test_%' if "db" table didn't exist
 -CREATE TEMPORARY TABLE tmp_db LIKE db;
 -DROP TABLE tmp_db;
 -
 -
- -- Fill "users" table with default users allowing root access
- -- from local machine if "users" table didn't exist before
+ -- Fill "user" table with default users allowing root access
+ -- from local machine if "user" table didn't exist before
  CREATE TEMPORARY TABLE tmp_user LIKE user;
- set @current_hostname= @@hostname;
 -INSERT INTO tmp_user VALUES ('localhost','root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','');
 -REPLACE INTO tmp_user SELECT @current_hostname,'root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','' FROM dual WHERE LOWER( @current_hostname) != 'localhost';
 -REPLACE INTO tmp_user VALUES ('127.0.0.1','root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','');
 -REPLACE INTO tmp_user VALUES ('::1','root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','');
-+INSERT INTO tmp_user VALUES ('localhost','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','');
-+REPLACE INTO tmp_user SELECT @current_hostname,'mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','' FROM dual WHERE LOWER( @current_hostname) != 'localhost';
-+REPLACE INTO tmp_user VALUES ('127.0.0.1','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','');
-+REPLACE INTO tmp_user VALUES ('::1','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','');
-+INSERT INTO tmp_user VALUES ('localhost','mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','');
-+REPLACE INTO tmp_user SELECT @current_hostname,'mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','' FROM dual WHERE LOWER( @current_hostname) != 'localhost';
-+REPLACE INTO tmp_user VALUES ('127.0.0.1','mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','');
-+REPLACE INTO tmp_user VALUES ('::1','mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','');
++-INSERT INTO tmp_user VALUES ('localhost','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','');
++-REPLACE INTO tmp_user SELECT @current_hostname,'mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','' FROM dual WHERE LOWER( @current_hostname) != 'localhost';
++-REPLACE INTO tmp_user VALUES ('127.0.0.1','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','');
++-REPLACE INTO tmp_user VALUES ('::1','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','');
+++INSERT INTO tmp_user VALUES ('localhost','mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','');
+++REPLACE INTO tmp_user SELECT @current_hostname,'mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','' FROM dual WHERE LOWER( @current_hostname) != 'localhost';
+++REPLACE INTO tmp_user VALUES ('127.0.0.1','mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','');
+++REPLACE INTO tmp_user VALUES ('::1','mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','');
  INSERT INTO tmp_user (host,user) VALUES ('localhost','');
  INSERT INTO tmp_user (host,user) SELECT @current_hostname,'' FROM dual WHERE LOWER(@current_hostname ) != 'localhost';
  INSERT INTO user SELECT * FROM tmp_user WHERE @had_user_table=0;
diff --git a/mysql-versioning.patch b/mysql-versioning.patch
deleted file mode 100644 (file)
index aaaa828..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-The symbol versioning solution for libmysqlclient in mysql 5.1 was pretty
-awful (export everything) and as of 5.5.8 the cmake build scripts have
-forgotten the issue entirely.  So we now maintain our own list of exported
-symbols and jam it into the build with this hack.
-
-
-diff -Naur mysql-5.5.8.orig/libmysql/CMakeLists.txt mysql-5.5.8/libmysql/CMakeLists.txt
---- mysql-5.5.8.orig/libmysql/CMakeLists.txt   2010-12-03 12:58:26.000000000 -0500
-+++ mysql-5.5.8/libmysql/CMakeLists.txt        2010-12-21 21:00:07.135311386 -0500
-@@ -197,7 +197,7 @@
-         SET(libmysql_link_flags)
-       ENDIF()
-       SET_TARGET_PROPERTIES(libmysql PROPERTIES LINK_FLAGS 
--        "${libmysql_link_flags} ${LINK_FLAG_NO_UNDEFINED}")
-+        "${libmysql_link_flags} -Wl,--version-script=libmysql.version ${LINK_FLAG_NO_UNDEFINED}")
-     ENDIF() 
-     # clean direct output needs to be set several targets have the same name
-     #(mysqlclient in this case)
index 0794cd330037e44e6999bda2b01a497135d46c60..6742a2da65c5fd8d69d16cb4c102893a9e20f6c8 100644 (file)
@@ -23,7 +23,7 @@
 %bcond_with    tests           # FIXME: don't run correctly
 %bcond_with    ndb             # NDB is now a separate product, this here is broken, so disable it
 
-%define        percona_rel     30.2
+%define        percona_rel     30.3
 %include       /usr/lib/rpm/macros.perl
 Summary:       MySQL: a very fast and reliable SQL database engine
 Summary(de.UTF-8):     MySQL: ist eine SQL-Datenbank
@@ -34,16 +34,16 @@ Summary(ru.UTF-8):  MySQL - быстрый SQL-сервер
 Summary(uk.UTF-8):     MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
-Version:       5.5.30
-Release:       3
+Version:       5.5.31
+Release:       1
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
 # Source0Download: http://dev.mysql.com/downloads/mysql/5.5.html#downloads
 # Source0:     http://vesta.informatik.rwth-aachen.de/mysql/Downloads/MySQL-5.5/%{name}-%{version}.tar.gz
 Source0:       http://www.percona.com/redir/downloads/Percona-Server-5.5/LATEST/source/Percona-Server-%{version}-rel%{percona_rel}.tar.gz
-# Source0-md5: 82604d750e9d858e927c3abcda784431
-Source100:     http://sphinxsearch.com/files/sphinx-2.0.6-release.tar.gz
-# Source100-md5:       de6be5ee20b1bfafa2a0cea7155a8331
+# Source0-md5: 702f4869b97cec5de8531954291a6b74
+Source100:     http://www.sphinxsearch.com/files/sphinx-2.0.8-release.tar.gz
+# Source100-md5:       bcaf0af0ba403a43b9ef3af6f9599cb4
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}.logrotate
@@ -63,7 +63,6 @@ Source15:     lib%{name}.version
 Patch2:                mysqlhotcopy-5.0-5.5.patch
 Patch3:                bug-67402.patch
 # from fedora
-Patch5:                %{name}-versioning.patch
 Patch6:                %{name}-system-users.patch
 
 Patch8:                %{name}-client-config.patch
@@ -495,7 +494,6 @@ mv sphinx-*/mysqlse storage/sphinx
 %patch2 -p1
 %patch3 -p1
 
-%patch5 -p1
 %patch6 -p1
 
 %patch8 -p1
This page took 0.05952 seconds and 4 git commands to generate.