]> git.pld-linux.org Git - packages/mysql.git/commitdiff
- rel 1; works for me; build some libs statically; use our versioning script auto/th/mysql-5.6.13-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 15 Oct 2013 18:46:13 +0000 (20:46 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 15 Oct 2013 18:46:13 +0000 (20:46 +0200)
mysql-build.patch
mysql.spec

index 4282730e93da31c8fe96e0c094a6ac251245b5a8..42014ac8e375a67d8ab8d2e2b1734f551f704efb 100644 (file)
@@ -41,3 +41,30 @@ diff -urNbB mysql-5.0.13-rc.org/sql/mysqld.cc mysql-5.0.13-rc/sql/mysqld.cc
        {
          struct request_info req;
          signal(SIGCHLD, SIG_DFL);
+--- Percona-Server-5.6.13-rel61.0/sql/CMakeLists.txt~  2013-10-07 12:25:25.000000000 +0200
++++ Percona-Server-5.6.13-rel61.0/sql/CMakeLists.txt   2013-10-15 20:37:28.259765844 +0200
+@@ -237,20 +237,20 @@
+                    log_event.cc log_event_old.cc binlog.cc sql_binlog.cc
+                  rpl_filter.cc rpl_record.cc rpl_record_old.cc rpl_utility.cc
+                  rpl_injector.cc)
+-ADD_LIBRARY(binlog ${BINLOG_SOURCE})
++ADD_LIBRARY(binlog STATIC ${BINLOG_SOURCE})
+ SET (RPL_SOURCE rpl_handler.cc rpl_tblmap.cc)
+ ADD_DEPENDENCIES(binlog GenError)
+-ADD_LIBRARY(rpl ${RPL_SOURCE})
++ADD_LIBRARY(rpl STATIC ${RPL_SOURCE})
+ SET (MASTER_SOURCE rpl_master.cc)
+ ADD_DEPENDENCIES(rpl GenError)
+-ADD_LIBRARY(master ${MASTER_SOURCE})
++ADD_LIBRARY(master STATIC ${MASTER_SOURCE})
+ ADD_DEPENDENCIES(master GenError)
+ SET (SLAVE_SOURCE rpl_slave.cc rpl_reporting.cc rpl_mi.cc rpl_rli.cc
+                 rpl_info_handler.cc rpl_info_file.cc rpl_info_table.cc
+                 rpl_info_values.cc rpl_info.cc rpl_info_factory.cc
+                 rpl_info_table_access.cc dynamic_ids.cc rpl_rli_pdb.cc
+                 rpl_info_dummy.cc)
+-ADD_LIBRARY(slave ${SLAVE_SOURCE})
++ADD_LIBRARY(slave STATIC ${SLAVE_SOURCE})
+ ADD_DEPENDENCIES(slave GenError)
+ ADD_LIBRARY(sqlgunitlib
+   filesort_utils.cc mdl.cc sql_list.cc sql_string.cc thr_malloc.cc
index 9e5146326fc18263b8167235f617e120495699af..9b1e0d824d0f4092c34a6d8811be5d8177ac906a 100644 (file)
@@ -35,7 +35,7 @@ Summary(uk.UTF-8):    MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
 Version:       5.6.13
-Release:       0.1
+Release:       1
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
 # Source0Download: http://dev.mysql.com/downloads/mysql/5.5.html#downloads
@@ -511,6 +511,9 @@ mv sphinx-*/mysqlse storage/sphinx
 [ -f sql/sql_yacc.cc ] && rm sql/sql_yacc.cc
 [ -f sql/sql_yacc.h ] && rm sql/sql_yacc.h
 
+# upstream has fallen down badly on symbol versioning, do it ourselves
+install %{SOURCE15} libmysql/libmysql.ver.in
+
 %build
 install -d build
 cd build
@@ -525,10 +528,6 @@ cd build
 %{expand:%%define      __cpp   %(echo '%__cpp' | sed -e 's,-gcc,-gcc4,')}
 %endif
 
-# upstream has fallen down badly on symbol versioning, do it ourselves
-install -d libmysql
-cp -a %{SOURCE15} libmysql/libmysql.version
-
 %cmake \
        -DCMAKE_BUILD_TYPE=%{!?debug:RelWithDebInfo}%{?debug:Debug} \
        -DCMAKE_C_FLAGS_RELEASE="%{rpmcflags} -DNDEBUG -fno-omit-frame-pointer -fno-strict-aliasing" \
This page took 0.041697 seconds and 4 git commands to generate.