]> git.pld-linux.org Git - packages/mysql.git/blobdiff - mysql-build.patch
- up to 5.6.51; 43594 seems to be fixed
[packages/mysql.git] / mysql-build.patch
index ea45a7bbb9a1526a4c8986452fa36cc2721b97fb..ae10f266878d9391f06502f9568f55ce5c36f1b8 100644 (file)
@@ -1,35 +1,3 @@
-diff -urNbB mysql-5.0.13-rc.org/sql/mysqld.cc mysql-5.0.13-rc/sql/mysqld.cc
---- mysql-5.0.13-rc.org/sql/mysqld.cc  2005-09-22 21:39:56.000000000 +0200
-+++ mysql-5.0.13-rc/sql/mysqld.cc      2005-09-29 19:29:59.991454000 +0200
-@@ -3183,7 +3183,7 @@
-   init_ssl();
- #ifdef HAVE_LIBWRAP
--  libwrapName= my_progname+dirname_length(my_progname);
-+  libwrapName= (char *)my_progname+dirname_length(my_progname);
-   openlog(libwrapName, LOG_PID, LOG_AUTH);
- #endif
---- Percona-Server-5.6.13-rel61.0/storage/innobase/row/row0log.cc~     2013-10-07 12:25:25.000000000 +0200
-+++ Percona-Server-5.6.13-rel61.0/storage/innobase/row/row0log.cc      2013-10-15 18:28:42.453836505 +0200
-@@ -2364,7 +2364,7 @@
-               and be ignored when the operation is unsupported. */
-               fallocate(index->online_log->fd,
-                         FALLOC_FL_PUNCH_HOLE | FALLOC_FL_KEEP_SIZE,
--                        ofs, srv_buf_size);
-+                        ofs, srv_sort_buf_size);
- #endif /* FALLOC_FL_PUNCH_HOLE */
-               next_mrec = index->online_log->head.block;
-@@ -3153,7 +3153,7 @@
-               and be ignored when the operation is unsupported. */
-               fallocate(index->online_log->fd,
-                         FALLOC_FL_PUNCH_HOLE | FALLOC_FL_KEEP_SIZE,
--                        ofs, srv_buf_size);
-+                        ofs, srv_sort_buf_size);
- #endif /* FALLOC_FL_PUNCH_HOLE */
-               next_mrec = index->online_log->head.block;
 --- Percona-Server-5.6.13-rel61.0/sql/CMakeLists.txt~  2013-10-07 12:25:25.000000000 +0200
 +++ Percona-Server-5.6.13-rel61.0/sql/CMakeLists.txt   2013-10-15 20:37:28.259765844 +0200
 @@ -237,20 +237,20 @@
@@ -57,3 +25,38 @@ diff -urNbB mysql-5.0.13-rc.org/sql/mysqld.cc mysql-5.0.13-rc/sql/mysqld.cc
  ADD_DEPENDENCIES(slave GenError)
  ADD_LIBRARY(sqlgunitlib
    filesort_utils.cc mdl.cc sql_list.cc sql_string.cc thr_malloc.cc
+--- percona-server-5.6.28-76.1/storage/tokudb/CMakeLists.txt~  2016-01-27 21:17:38.000000000 +0100
++++ percona-server-5.6.28-76.1/storage/tokudb/CMakeLists.txt   2016-01-28 07:23:41.844001444 +0100
+@@ -1,6 +1,7 @@
+ SET(TOKUDB_VERSION )
+ # PerconaFT only supports x86-64 and cmake-2.8.9+
+ IF(CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND
++    "${CMAKE_SIZEOF_VOID_P}" EQUAL "8" AND
+     NOT CMAKE_VERSION VERSION_LESS "2.8.9")
+ CHECK_CXX_SOURCE_COMPILES(
+ "
+--- percona-server-5.6.37-82.2/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCompiler.cmake~ 2017-08-24 13:36:46.000000000 +0200
++++ percona-server-5.6.37-82.2/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCompiler.cmake  2017-10-09 20:12:03.039109021 +0200
+@@ -197,8 +197,8 @@ if (NOT CMAKE_CXX_COMPILER_ID STREQUAL C
+ endif ()
+ ## always want these
+-set(CMAKE_C_FLAGS "-Wall -Werror ${CMAKE_C_FLAGS}")
+-set(CMAKE_CXX_FLAGS "-Wall -Werror ${CMAKE_CXX_FLAGS}")
++set(CMAKE_C_FLAGS "-Wall ${CMAKE_C_FLAGS}")
++set(CMAKE_CXX_FLAGS "-Wall ${CMAKE_CXX_FLAGS}")
+ # pick language dialect
+ set(CMAKE_C_FLAGS "-std=c99 ${CMAKE_C_FLAGS}")
+--- percona-server-5.6.37-82.2/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/CMakeLists.txt~   2017-10-09 20:37:05.000000000 +0200
++++ percona-server-5.6.37-82.2/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/CMakeLists.txt    2017-10-09 20:42:02.664375729 +0200
+@@ -18,7 +18,7 @@ set_property(DIRECTORY APPEND PROPERTY C
+   _FILE_OFFSET_BITS=64 
+   _LARGEFILE64_SOURCE)
+-set(CMAKE_CXX_FLAGS "-Werror -W -Wall -Wshadow ${CMAKE_CXX_FLAGS}")
++set(CMAKE_CXX_FLAGS "-W -Wall -Wshadow ${CMAKE_CXX_FLAGS}")
+ set(USE_VALGRIND OFF CACHE BOOL "whether to use valgrind headers")
+ if (USE_VALGRIND)
+
This page took 0.095316 seconds and 4 git commands to generate.