]> git.pld-linux.org Git - packages/mutt.git/commitdiff
- patches merged from RH. mutt-1_2_5i-5
authorkloczek <kloczek@pld-linux.org>
Thu, 14 Dec 2000 21:37:10 +0000 (21:37 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    mutt-imap.patch -> 1.1
    mutt-md5.patch -> 1.1
    mutt-nosetgid.patch -> 1.1

mutt-imap.patch [new file with mode: 0644]
mutt-md5.patch [new file with mode: 0644]
mutt-nosetgid.patch [new file with mode: 0644]

diff --git a/mutt-imap.patch b/mutt-imap.patch
new file mode 100644 (file)
index 0000000..f73c1bb
--- /dev/null
@@ -0,0 +1,29 @@
+It looks like the 1.3 branch already has a more correct fix for this problem
+(which has potential to crop up elsewhere in the source tree), but this fixes
+the most obvious one.
+
+--- mutt-1.2.5/imap/auth_gss.c Wed Jun 21 15:21:56 2000
++++ mutt-1.2.5/imap/auth_gss.c Mon Nov  6 13:24:27 2000
+@@ -226,13 +226,15 @@
+   mutt_socket_write (idata->conn, buf1);
+   /* Joy of victory or agony of defeat? */
+-  if (mutt_socket_read_line_d (buf1, GSS_BUFSIZE, idata->conn) < 0)
+-  {
+-    dprint (1, (debugfile, "Error receiving server response.\n"));
+-
+-    mutt_socket_write(idata->conn, "*\r\n");
+-    return -1;
+-  }
++  do {
++    if (mutt_socket_read_line_d (buf1, GSS_BUFSIZE, idata->conn) < 0)
++    {
++      dprint (1, (debugfile, "Error receiving server response.\n"));
++      mutt_socket_write(idata->conn, "*\r\n");
++      return -1;
++    }
++  } while ((mutt_strncmp (buf1, seq, SEQLEN) != 0));
++ 
+   if (imap_code (buf1))
+   {
+     /* flush the security context */
diff --git a/mutt-md5.patch b/mutt-md5.patch
new file mode 100644 (file)
index 0000000..916e2e2
--- /dev/null
@@ -0,0 +1,21 @@
+--- mutt-1.2/imap/md5.h.how-many-times-do-i-have-to-fix-friggin-md5-code       Thu Jun 22 08:20:24 2000
++++ mutt-1.2/imap/md5.h        Thu Jun 22 08:20:56 2000
+@@ -26,14 +26,16 @@
+ #ifndef MD5_H
+ #define MD5_H 1
++#include <sys/types.h>
++
+ /* POINTER defines a generic pointer type */
+ typedef unsigned char *POINTER;
+ /* UINT2 defines a two byte word */
+-typedef unsigned short int UINT2;
++typedef u_int16_t UINT2;
+ /* UINT4 defines a four byte word */
+-typedef unsigned long int UINT4;
++typedef u_int32_t UINT4;
+ /* MD5 context. */
+ typedef struct {
diff --git a/mutt-nosetgid.patch b/mutt-nosetgid.patch
new file mode 100644 (file)
index 0000000..84bb7bc
--- /dev/null
@@ -0,0 +1,28 @@
+--- mutt-0.95-us/configure.in.nosetgid Sat Dec 12 04:22:04 1998
++++ mutt-0.95-us/configure.in  Sat Dec 12 22:31:34 1998
+@@ -302,25 +302,6 @@
+       mutt_cv_setgid=no
+       if test $mutt_cv_worldwrite = yes; then
+               AC_DEFINE(USE_DOTLOCK)
+-      else
+-
+-              AC_CACHE_CHECK(if $mutt_cv_mailpath is group writable, mutt_cv_groupwrite, [AC_TRY_RUN([#include <sys/types.h>
+-#include <sys/stat.h>
+-
+-int main (int argc, char **argv)
+-{
+-      struct stat s;
+-
+-      stat ("$mutt_cv_mailpath", &s);
+-      if (s.st_mode & S_IWGRP) exit (0);
+-      exit (1);
+-}], mutt_cv_groupwrite=yes, mutt_cv_groupwrite=no, mutt_cv_groupwrite=no)])
+-
+-              if test $mutt_cv_groupwrite = yes; then
+-                      AC_DEFINE(USE_DOTLOCK)
+-                      AC_DEFINE(USE_SETGID)
+-                      mutt_cv_setgid=yes
+-              fi
+       fi
+ fi
This page took 0.043628 seconds and 4 git commands to generate.