]> git.pld-linux.org Git - packages/musescore.git/blob - musescore.spec
- release 1
[packages/musescore.git] / musescore.spec
1 #
2
3 %define min_qt_version 5.15.8
4
5 Summary:        MuseScore - music notation software
6 Summary(pl.UTF-8):      MuseScore - oprogramowanie do notacji muzycznej
7 Name:           musescore
8 Version:        4.0.2
9 Release:        1
10 License:        GPL v2
11 Group:          Applications
12 Source0:        https://github.com/musescore/MuseScore/archive/v%{version}.tar.gz
13 # Source0-md5:  e1a5b52bd2cede8f6f332f0f6e315b73
14 Patch0:         no-crashpad.patch
15 Patch1:         desktop.patch
16 Patch2:         use-qtmake-qt5.patch
17 Patch3:         set_as_stable.patch
18 Patch4:         %{name}-4.0.2-return.patch
19 URL:            https://musescore.org/
20 BuildRequires:  Qt5Concurrent-devel >= %{min_qt_version}
21 BuildRequires:  Qt5Core-devel >= %{min_qt_version}
22 BuildRequires:  Qt5Designer-devel >= %{min_qt_version}
23 BuildRequires:  Qt5Gui-devel >= %{min_qt_version}
24 BuildRequires:  Qt5Help-devel >= %{min_qt_version}
25 BuildRequires:  Qt5Network-devel >= %{min_qt_version}
26 BuildRequires:  Qt5NetworkAuth-devel >= %{min_qt_version}
27 BuildRequires:  Qt5OpenGL-devel >= %{min_qt_version}
28 BuildRequires:  Qt5PrintSupport-devel >= %{min_qt_version}
29 BuildRequires:  Qt5Qml-devel >= %{min_qt_version}
30 BuildRequires:  Qt5Quick-controls2-devel
31 BuildRequires:  Qt5Quick-devel >= %{min_qt_version}
32 BuildRequires:  Qt5Sql-devel >= %{min_qt_version}
33 BuildRequires:  Qt5Svg-devel >= %{min_qt_version}
34 BuildRequires:  Qt5Test-devel >= %{min_qt_version}
35 BuildRequires:  Qt5UiTools-devel >= %{min_qt_version}
36 BuildRequires:  Qt5Widgets-devel >= %{min_qt_version}
37 BuildRequires:  Qt5Xml-devel >= %{min_qt_version}
38 BuildRequires:  Qt5XmlPatterns-devel >= %{min_qt_version}
39 BuildRequires:  alsa-lib-devel
40 BuildRequires:  cmake >= 3.3.0
41 BuildRequires:  doxygen
42 BuildRequires:  freetype-devel >= 2.5.2
43 BuildRequires:  jack-audio-connection-kit-devel >= 0.98
44 BuildRequires:  lame-libs-devel
45 BuildRequires:  pkgconfig
46 BuildRequires:  portaudio-devel
47 BuildRequires:  pulseaudio-devel
48 BuildRequires:  qt5-assistant
49 BuildRequires:  qt5-build
50 BuildRequires:  qt5-linguist
51 BuildRequires:  qt5-qmake
52 BuildRequires:  texlive-latex
53 Requires:       Qt5Quick-graphicaleffects
54 Suggests:       %{name}-fonts
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 MuseScore is an open source and free music notation software.
59
60 Features:
61 - WYSIWYG design, notes are entered on a "virtual notepaper"
62 - TrueType font(s) for printing & display allows for high quality
63   scaling to all sizes
64 - easy & fast note entry
65 - many editing functions
66 - MusicXML import/export
67 - Midi (SMF) import/export
68 - MuseData import
69 - Midi input for note entry
70 - integrated sequencer and software synthesizer to play the score
71 - print or create pdf files
72
73 %description -l pl.UTF-8
74 MuseScore to otwarte i darmowe oprogramowanie do notacji muzycznej.
75
76 Cechy:
77 - edytor WYSIWYG, nuty są wprowadzane na "wirtualny papier nutowy"
78 - czcionki TrueType do drukowania i wyświetlania umożliwiają wysokiej
79   jakości skalowanie do wszystkich rozmiarów
80 - łatwe i szybkie wprowadzanie nut
81 - wiele funkcji edycyjnych
82 - import/eksport MusicXML
83 - import/eksport Midi (SMF).
84 - import MuseData
85 - wejście Midi do wprowadzania nut
86 - zintegrowany sekwencer i syntezator programowy do odtwarzania
87   partytury
88 - możliwość tworzenia i drukowania plików pdf
89
90 %package fonts
91 Summary:        MuseScore fonts
92 Summary(pl.UTF-8):      Czcionki MuseScore
93 License:        GPL-3.0-or-later WITH Font-exception-2.0 AND OFL-1.1
94 Group:          Fonts
95 BuildArch:      noarch
96
97 %description fonts
98 Additional fonts for use by the MuseScore music notation program.
99
100 %description fonts -l pl.UTF-8
101 Dodatkowe czcionki do użytku w oprogramowaniu do notacji muzycznej
102 MuseScore.
103
104 %prep
105 %setup -q -n MuseScore-%{version}
106 %patch0 -p1
107 %patch1 -p1
108 %patch2 -p1
109 %patch3 -p1
110 %patch4 -p1
111
112 # fix EOL encoding
113 sed 's/\r$//' fonts/bravura/OFL-FAQ.txt > tmpfile
114 touch -r fonts/bravura/OFL-FAQ.txt tmpfile
115 mv -f tmpfile fonts/bravura/OFL-FAQ.txt
116
117 sed 's/\r$//' thirdparty/rtf2html/README > tmpfile
118 touch -r thirdparty/rtf2html/README tmpfile
119 mv -f tmpfile thirdparty/rtf2html/README
120
121 sed 's/\r$//' thirdparty/rtf2html/README.ru > tmpfile
122 touch -r thirdparty/rtf2html/README.ru tmpfile
123 mv -f tmpfile thirdparty/rtf2html/README.ru
124
125 %build
126
127 # note: 'build' directory is already there, for something else
128 install -d build.release
129 cd build.release
130
131 %cmake  \
132         -DCMAKE_BUILD_TYPE=RelWithDebInfo \
133         -DMUSESCORE_BUILD_CONFIG=release \
134         -DMSCORE_INSTALL_SUFFIX="" \
135         -DMUSESCORE_LABEL="" \
136         -DBUILD_UNIT_TESTS=OFF \
137         -DCMAKE_SKIP_RPATH="FALSE" \
138         -DDOWNLOAD_SOUNDFONT="OFF" \
139         -DUSE_SYSTEM_FREETYPE="ON" \
140         -DBUILD_CRASHPAD_CLIENT=OFF \
141 %ifarch x32
142         -DBUILD_WEBENGINE="OFF" \
143 %endif
144         ..
145
146 %{__make} lrelease
147 %{__make}
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151
152 cd build.release
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 # don't package kddockwidgets. It should not be installed
157 rm $RPM_BUILD_ROOT%{_libdir}/*.a
158 rm -r $RPM_BUILD_ROOT%{_includedir}/kddockwidgets
159 rm -r $RPM_BUILD_ROOT%{_libdir}/cmake/KDDockWidgets
160
161 # Remove opus devel files, they are provided by system
162 rm -r $RPM_BUILD_ROOT%{_includedir}/opus
163
164 rm $RPM_BUILD_ROOT%{_mandir}/man1/musescore.1.gz
165 echo ".so mscore.1" > $RPM_BUILD_ROOT%{_mandir}/man1/musescore.1
166
167 cd ..
168 # install fonts
169 install -d $RPM_BUILD_ROOT%{_datadir}/fonts/{OTF,TTF}
170 install -p fonts/*.ttf $RPM_BUILD_ROOT%{_datadir}/fonts/TTF
171 install -p fonts/*/*.ttf $RPM_BUILD_ROOT%{_datadir}/fonts/TTF
172 install -p fonts/bravura/BravuraText.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
173 install -p fonts/campania/Campania.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
174 install -p fonts/edwin/*.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
175 install -p fonts/gootville/GootvilleText.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
176 install -p fonts/leland/LelandText.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
177 install -p fonts/musejazz/MuseJazzText.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
178 install -p fonts/petaluma/PetalumaText.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
179
180 # unique names for font docs
181 mv fonts/edwin/README.md         fonts/edwin/README.md.edwin
182 mv fonts/edwin/LICENSE.txt       fonts/edwin/LICENSE.txt.edwin
183 mv fonts/leland/README.md        fonts/leland/README.md.leland
184 mv fonts/leland/LICENSE.txt      fonts/leland/LICENSE.txt.leland
185
186 # collect doc files
187 mkdir tmp_doc
188 install -p thirdparty/beatroot/COPYING         tmp_doc/COPYING.beatroot
189 install -p thirdparty/beatroot/README.txt      tmp_doc/README.txt.beatroot
190 install -p thirdparty/dtl/COPYING              tmp_doc/COPYING.BSD.dtl
191 install -p thirdparty/freetype/README          tmp_doc/README.freetype
192 install -p thirdparty/intervaltree/README      tmp_doc/README.intervaltree
193 install -p thirdparty/rtf2html/ChangeLog       tmp_doc/ChangeLog.rtf2html
194 install -p thirdparty/rtf2html/COPYING.LESSER  tmp_doc/COPYING.LESSER.rtf2html
195 install -p thirdparty/rtf2html/README          tmp_doc/README.rtf2html
196 install -p thirdparty/rtf2html/README.mscore   tmp_doc/README.mscore.rtf2html
197 install -p thirdparty/rtf2html/README.ru       tmp_doc/README.ru.rtf2html
198 install -p thirdparty/singleapp/LGPL_EXCEPTION.txt tmp_doc/LGPL_EXCEPTION.txt.singleapp
199 install -p thirdparty/singleapp/LICENSE.GPL3   tmp_doc/LICENSE.GPL3.singleapp
200 install -p thirdparty/singleapp/LICENSE.LGPL   tmp_doc/LICENSE.LGPL.singleapp
201 install -p thirdparty/singleapp/README.TXT     tmp_doc/README.TXT.singleapp
202 install -p tools/bww2mxml/COPYING              tmp_doc/COPYING.bww2mxml
203 install -p tools/bww2mxml/README               tmp_doc/README.bww2mxml
204 install -p share/sound/README.md               tmp_doc/README.md.sound
205 install -p share/instruments/README.md         tmp_doc/README.md.instruments
206 install -p share/wallpapers/COPYRIGHT          tmp_doc/COPYING.wallpaper
207
208 %post
209 %update_desktop_database
210 %update_icon_cache hicolor
211 %update_mime_database
212
213 %postun
214 %update_desktop_database
215 %update_icon_cache hicolor
216 %update_mime_database
217
218 %post fonts
219 fontpostinst OTF
220 fontpostinst TTF
221
222 %postun fonts
223 fontpostinst OTF
224 fontpostinst TTF
225
226 %clean
227 rm -rf $RPM_BUILD_ROOT
228
229 %files
230 %defattr(644,root,root,755)
231 %doc README.md Compatibility LICENSE.GPL tmp_doc/*
232 %attr(755,root,root) %{_bindir}/mscore
233 %{_datadir}/mscore-4.0
234 %{_desktopdir}/org.musescore.MuseScore.desktop
235 %{_iconsdir}/*/*/apps/*
236 %{_iconsdir}/*/*/mimetypes/*
237 %{_mandir}/man1/mscore.1*
238 %{_mandir}/man1/musescore.1*
239 %{_datadir}/mime/packages/musescore.xml
240 %{_datadir}/metainfo/org.musescore.MuseScore.appdata.xml
241
242 %files fonts
243 %defattr(644,root,root,755)
244 %{_datadir}/fonts/TTF/*.ttf
245 %{_datadir}/fonts/OTF/*.otf
246 %doc fonts/README.md
247 %doc fonts/bravura/bravura-text.md
248 %doc fonts/bravura/OFL-FAQ.txt
249 %doc fonts/bravura/OFL.txt
250 %doc fonts/gootville/readme.txt fonts/campania/LICENSE
251 # see section 'unique names for font docs' above
252 %doc fonts/edwin/README.md.edwin fonts/edwin/LICENSE.txt.edwin
253 %doc fonts/leland/README.md.leland fonts/leland/LICENSE.txt.leland
This page took 0.145572 seconds and 3 git commands to generate.