]> git.pld-linux.org Git - packages/muparser.git/blob - muparser.spec
- updated to 2.3.4 (includes security fixes); license is 2-clause BSD; fixed dirs...
[packages/muparser.git] / muparser.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4 %bcond_without  openmp  # OpenMP support
5 #
6 Summary:        A fast math parser library
7 Summary(pl.UTF-8):      Biblioteka szybkiego analizatora matematycznego
8 Name:           muparser
9 Version:        2.3.4
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 #Source0Download: https://github.com/beltoforion/muparser/releases
14 Source0:        https://github.com/beltoforion/muparser/archive/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  b92180a648be88238008ea01a597ccb9
16 URL:            https://github.com/beltoforion/muparser
17 BuildRequires:  cmake >= 3.1.0
18 %{?with_apidocs:BuildRequires:  doxygen}
19 %{?with_openmp:BuildRequires:   libgomp-devel}
20 BuildRequires:  libstdc++-devel >= 6:4.7
21 BuildRequires:  rpm-build >= 4.6
22 BuildRequires:  rpmbuild(macros) >= 1.752
23 BuildRequires:  sed >= 4.0
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Many applications require the parsing of mathematical expressions. The
28 main objective of this project is to provide a fast and easy way of
29 doing this. muParser is an extensible high performance math parser
30 library. It is based on transforming an expression into a bytecode and
31 precalculating constant parts of it.
32
33 %description -l pl.UTF-8
34 Wiele aplikacji wymaga analizowania wyrażeń matematycznych. Głównym
35 celem tego projektu jest zapewnienie szybkiego i wygodnego sposobu
36 wykonywania tego zadania. muParser to bardzo wydajna, rozszerzalna
37 biblioteka analizatora matematycznego. Opiera się na przekształcaniu
38 wyrażenia na bajtkod oraz wstępnym obliczaniu jego stałych części.
39
40 %package devel
41 Summary:        Development and doc files for muParser library
42 Summary(pl.UTF-8):      Pliki programistyczne i dokumentacja do biblioteki muParser
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       libstdc++-devel
46
47 %description devel
48 Development and doc files for muParser library.
49
50 %description devel -l pl.UTF-8
51 Pliki programistyczne i dokumentacja do biblioteki muParser.
52
53 %package apidocs
54 Summary:        API documentation for muParser library
55 Summary(pl.UTF-8):      Dokumentacja API biblioteki muParser
56 Group:          Documentation
57 BuildArch:      noarch
58
59 %description apidocs
60 API documentation for muParser library.
61
62 %description apidocs -l pl.UTF-8
63 Dokumentacja API biblioteki muParser.
64
65 %prep
66 %setup -q
67
68 # html/misc/footer.html not present (even in git)
69 %{__sed} -i -e '/^HTML_FOOTER .*/s/.*/HTML_FOOTER = /' docs/Doxyfile
70
71 %build
72 install -d build
73 cd build
74 %cmake .. \
75         -DCMAKE_INSTALL_INCLUDEDIR=include \
76         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
77         %{!?with_openmp:-DENABLE_OPENMP=OFF} \
78         -DENABLE_SAMPLES=OFF
79
80 %{__make}
81
82 %if %{with apidocs}
83 cd ../docs
84 doxygen
85 %endif
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} -C build install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc CHANGELOG LICENSE README.rst docs/muparser_doc.html
102 %attr(755,root,root) %{_libdir}/libmuparser.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libmuparser.so.2
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libmuparser.so
108 %{_includedir}/muParser*.h
109 %{_pkgconfigdir}/muparser.pc
110 %{_libdir}/cmake/muparser
111
112 %if %{with apidocs}
113 %files apidocs
114 %defattr(644,root,root,755)
115 %doc docs/html/classdocu/{d?,search,*.css,*.html,*.jpg,*.js,*.png}
116 %endif
This page took 0.260653 seconds and 4 git commands to generate.