]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- up to 20171221
[packages/mplayer.git] / mplayer.spec
1 #
2 # Conditional build:
3 # - CPU optimization:
4 %bcond_without  altivec         # PPC altivec support
5 %bcond_without  ssse3           # SSSE3 optimizations (needs binutils >= 2.16.92)
6 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
7                                 #  in compile time (advertised by mplayer authors as working faster); in this case
8                                 #  mplayer may not work on machine other then where it was compiled
9 %bcond_without  hidden_visibility       # no gcc hidden visibility
10 %bcond_without  verbose         # disable verbose build
11 # - general features:
12 %bcond_without  bluray          # Blu-ray support
13 %bcond_without  cdio            # libcdio support
14 %bcond_without  cdparanoia      # cdparanoia support (when libcdio not enabled)
15 %bcond_without  doc             # don't build docs (slow)
16 %bcond_without  dvdnav          # dvdnav support
17 %bcond_without  system_dvdcss   # system libdvdcss library (instead of internal copy)
18 %bcond_without  system_dvdread  # system libdvdread library (instead of internal copy)
19 %bcond_without  enca            # disable using ENCA charset oracle library
20 %bcond_without  gui             # without GTK+ GUI
21 %bcond_without  joystick        # joystick support
22 %bcond_without  lirc            # lirc support
23 %bcond_without  live            # LIVE555 Streaming Media support
24 %bcond_without  mencoder        # mencoder (a/v encoder) compilation
25 %bcond_without  nemesi          # NeMeSi Streaming Media support
26 %bcond_without  osd             # osd menu support
27 %bcond_without  rtmp            # RTMPDump Streaming Media support
28 %bcond_with     shared          # experimental libmplayer.so support
29 %bcond_without  smb             # Samba (SMB) input support
30 %bcond_without  vstream         # TiVo vstream client support
31 # - codecs:
32 %bcond_without  amr             # Adaptive Multi Rate (AMR) speech codec support
33 %bcond_without  bs2b            # BS2B audio filter support
34 %bcond_without  crystalhd       # CrystalHD support
35 %bcond_without  faad            # FAAD2 (AAC) support
36 %bcond_without  gif             # GIF support
37 %bcond_without  ladspa          # LADSPA plugin support
38 %bcond_without  libdts          # libdts support
39 %bcond_without  libdv           # libdv en/decoding support
40 %bcond_without  lzo             # LZO support (requires lzo 2.x)
41 %bcond_without  mad             # mad (audio MPEG) support
42 %bcond_without  mpg123          # libmpg123 MP3 decoding support
43 %bcond_with     musepack        # libmpcdec support (deprecated in favour of libavcodec)
44 %bcond_without  openjpeg        # OpenJPEG (JPEG2000) input/output support
45 %bcond_without  quicktime       # binary quicktime dll support
46 %bcond_without  real            # Real* 8/9 codecs support
47 %bcond_without  vorbis          # Ogg Vorbis audio support (both tremor and libvorbis)
48 %bcond_with     tremor          # use tremor instead of libvorbis
49 %bcond_without  theora          # Ogg Theora video support
50 %bcond_without  win32           # Win32 codecs support
51 %bcond_without  x264            # x264 support
52 %bcond_with     xmms            # XMMS inputplugin support
53 %bcond_without  xvid            # XviD codec
54 %bcond_with     system_libmpeg2 # system libmpeg2 library (instead of internal copy with some quantizer modifications)
55 %bcond_with     system_ffmpeg   # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
56 # - video output:
57 %bcond_without  aalib           # aalib video output
58 %bcond_without  caca            # libcaca video output
59 %bcond_with     directfb        # DirectFB video output
60 %bcond_with     dxr2            # DXR2 (hardware MPEG decoder) video output
61 %bcond_with     dxr3            # DXR3/H+ (hardware MPEG decoder) video output
62 %bcond_with     ggi             # GGI video output
63 %bcond_without  sdl             # SDL video output
64 %bcond_with     svga            # svgalib video output
65 %bcond_without  vdpau           # VDPAU acceleration
66 %bcond_without  vidix           # VIDIX video drivers
67 %bcond_with     zr              # ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
68 %bcond_with     gnomess         # controling gnome screensaver [patch not updated]
69 # - audio output:
70 %bcond_without  alsa            # ALSA audio output
71 %bcond_with     arts            # aRts audio output
72 %bcond_with     esd             # EsounD sound support
73 %bcond_without  jack            # JACKD support
74 %bcond_with     nas             # NAS audio output
75 %bcond_without  pulseaudio      # pulseaudio output
76 %bcond_without  select          # audio select() support (required e.g. for ALSA or Vortex2 driver)
77
78 %if %{with alsa}
79 %undefine       with_select
80 %endif
81 %if %{without vorbis}
82 %undefine       with_tremor
83 %endif
84
85 %ifnarch %{ix86}
86 %undefine       with_win32
87 %undefine       with_quicktime
88 %undefine       with_vidix
89 %endif
90 %ifnarch %{ix86} %{x8664} ppc ppc64
91 %undefine       with_runtime
92 %endif
93 %ifnarch %{ix86} %{x8664}
94 %undefine       with_vdpau
95 %endif
96 %ifnarch ppc
97 %undefine       with_altivec
98 %endif
99 %ifnarch i686 pentium4 athlon %{x8664}
100 %undefine       with_crystalhd
101 %endif
102
103 %if %{_lib} != "lib"
104 %define         binsuf  %(lib=%{_lib} ; echo ${lib#lib})
105 %else
106 %ifarch %{ix86} ppc sparc sparcv9 s390
107 %define         binsuf  32
108 %else
109 %define         binsuf  %{nil}
110 %endif
111 %endif
112
113 # date from directory inside of tarball (like mplayer-export-2014-04-29)
114 %define snap    2017-12-21
115 %define ssnap   %(echo %{snap} | tr -d -)
116 %define rel     1
117 Summary:        MPlayer - THE Movie Player for UN*X
118 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
119 Summary(es.UTF-8):      Otro reproductor de películas
120 Summary(ko.UTF-8):      리눅스용 미디어플레이어
121 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
122 Summary(pt_BR.UTF-8):   Reprodutor de filmes
123 Name:           mplayer
124 Version:        1.3
125 Release:        1.%{ssnap}.%{rel}
126 # DO NOT increase epoch unless it's really neccessary!
127 # especially such changes like pre7->pre7try2, increase Release instead!
128 # PS: $ rpmvercmp pre7try2 pre7
129 # pre7try2 > pre7
130 Epoch:          3
131 License:        GPL
132 Group:          Applications/Multimedia
133 # Source0:        http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
134 Source0:        ftp://ftp.mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
135 # Source0-md5:  19002ff25bbb7efc7329d64ba7c8392a
136 Source1:        http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
137 # Source1-md5:  6f543d16f2c61e5f41d8e754c5ddbda8
138 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
139 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
140 Source5:        g%{name}.desktop
141 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
142 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
143 Source7:        %{name}.png
144 Source8:        %{name}.desktop
145
146 # build (configure / Makefile) related:
147 Patch10:        %{name}-ldflags.patch
148 Patch11:        %{name}-altivec.patch
149 Patch12:        %{name}-check-byteswap.patch
150 Patch13:        %{name}-visibility-hidden-fix.patch
151
152 Patch15:        %{name}-live555-async.patch
153
154 Patch17:        %{name}-gsm.patch
155
156 Patch19:        %{name}-shared.patch
157 Patch20:        %{name}-vstream.patch
158
159 # codecs, outputs, demuxers:
160 Patch21:        %{name}-auto-expand.patch
161 Patch22:        %{name}-release_directfb.patch
162
163 # goodies:
164 Patch30:        %{name}-cp1250-fontdesc.patch
165 Patch31:        %{name}-350.patch
166 # update, hard to fix right now because of gnome bug 579430:
167 # https://bugzilla.gnome.org/show_bug.cgi?id=579430
168 #Patch32:       %{name}-gnome-screensaver.patch
169
170 Patch101:       %{name}-link.patch
171
172 URL:            http://www.mplayerhq.hu/
173 %{?with_directfb:BuildRequires: DirectFB-devel >= 0.9.22}
174 BuildRequires:  EGL-devel
175 BuildRequires:  OpenAL-devel
176 BuildRequires:  OpenGL-GLX-devel
177 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
178 # checked, but seems actually not used
179 #%{?with_sdl:BuildRequires:     SDL_image-devel}
180 BuildRequires:  a52dec-libs-devel
181 %{?with_aalib:BuildRequires:    aalib-devel}
182 %{?with_alsa:BuildRequires:     alsa-lib-devel}
183 %{?with_arts:BuildRequires:     artsc-devel}
184 BuildRequires:  binutils >= 2.10.1
185 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
186 BuildRequires:  bzip2-devel
187 #%{?with_cdparanoia:BuildRequires:      cdparanoia-III-devel}
188 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
189 BuildRequires:  dirac-devel
190 %{?with_doc:BuildRequires:      docbook-dtd45-xml}
191 %{?with_doc:BuildRequires:      docbook-style-xsl}
192 %{?with_dxr2:BuildRequires:     dxr2-driver-devel}
193 %{?with_dxr3:BuildRequires:     em8300-devel}
194 %{?with_enca:BuildRequires:     enca-devel}
195 %{?with_esd:BuildRequires:      esound-devel}
196 BuildRequires:  faac-devel
197 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
198 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 0.4.9-4.20081024.3}
199 BuildRequires:  fontconfig-devel >= 1:2.4.2
200 BuildRequires:  freetype-devel >= 1:2.2.1
201 BuildRequires:  fribidi-devel
202 %{?with_altivec:BuildRequires:  gcc >= 5:4.1}
203 %{?with_gif:BuildRequires:      giflib-devel}
204 %{?with_gui:BuildRequires:      glib2-devel >= 1:2.6.0}
205 BuildRequires:  gnutls-devel
206 %{?with_gui:BuildRequires:      gtk+2-devel >= 2:2.4.0}
207 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
208 %{?with_ladspa:BuildRequires:   ladspa-devel}
209 BuildRequires:  lame-libs-devel
210 BuildRequires:  libass-devel >= 0.9.10
211 %{?with_bluray:BuildRequires:   libbluray-devel}
212 %{?with_bs2b:BuildRequires:     libbs2b-devel >= 3.0.0}
213 %{?with_caca:BuildRequires:     libcaca-devel}
214 %{?with_cdio:BuildRequires:     libcdio-paranoia-devel}
215 %{?with_crystalhd:BuildRequires:        libcrystalhd-devel}
216 %{?with_libdts:BuildRequires:   libdts-devel}
217 %{?with_libdv:BuildRequires:    libdv-devel > 0.9.5}
218 #%{?with_system_dvdcss:BuildRequires:   libdvdcss-devel}
219 %{?with_dvdnav:BuildRequires:   libdvdnav-devel >= 4.1.3}
220 %{?with_system_dvdread:BuildRequires:   libdvdread-devel >= 4.1}
221 %{?with_ggi:BuildRequires:      libggi-devel}
222 %{?with_ggi:BuildRequires:      libggiwmh-devel}
223 BuildRequires:  libgsm-devel
224 BuildRequires:  libjpeg-devel
225 %{?with_mad:BuildRequires:      libmad-devel}
226 BuildRequires:  libmng-devel
227 %{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2.1}
228 %{?with_system_libmpeg2:BuildRequires:  libmpeg2-devel}
229 %{?with_mpg123:BuildRequires:   libmpg123-devel >= 1.14}
230 %{?with_nemesi:BuildRequires:   libnemesi-devel >= 0.6.3}
231 BuildRequires:  libnut-devel
232 BuildRequires:  libpng-devel
233 %{?with_rtmp:BuildRequires:     librtmp-devel}
234 %{?with_smb:BuildRequires:      libsmbclient-devel}
235 %{?with_theora:BuildRequires:   libtheora-devel}
236 %{?with_vdpau:BuildRequires:    libvdpau-devel}
237 %if %{with vorbis} && %{without tremor}
238 BuildRequires:  libvorbis-devel
239 %endif
240 BuildRequires:  libvpx-devel
241 # build >= 118
242 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3}
243 BuildRequires:  libxslt-progs
244 # with v4l2 headers
245 BuildRequires:  linux-libc-headers >= 7:2.6.22
246 %{?with_lirc:BuildRequires:     lirc-devel}
247 %{?with_live:BuildRequires:     live-devel >= 2:2011.01.10}
248 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
249 %{?with_nas:BuildRequires:      nas-devel}
250 BuildRequires:  ncurses-devel
251 %{?with_amr:BuildRequires:      opencore-amr-devel}
252 %{?with_openjpeg:BuildRequires: openjpeg2-devel}
253 BuildRequires:  opus-devel
254 BuildRequires:  pkgconfig
255 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
256 BuildRequires:  rpm >= 4.4.9-56
257 BuildRequires:  rpmbuild(macros) >= 1.527
258 BuildRequires:  schroedinger-devel
259 BuildRequires:  speex-devel >= 1.1
260 %{?with_svga:BuildRequires:     svgalib-devel}
261 BuildRequires:  tar >= 1:1.22
262 %{?with_tremor:BuildRequires:   tremor-devel}
263 BuildRequires:  twolame-devel
264 %{?with_vidix:BuildRequires:    vidix-devel}
265 %{?with_vstream:BuildRequires:  vstream-client-devel}
266 BuildRequires:  webrtc-libilbc-devel
267 %{?with_xmms:BuildRequires:     xmms-devel}
268 BuildRequires:  xorg-lib-libX11-devel
269 BuildRequires:  xorg-lib-libXScrnSaver-devel
270 BuildRequires:  xorg-lib-libXext-devel
271 BuildRequires:  xorg-lib-libXinerama-devel
272 BuildRequires:  xorg-lib-libXv-devel
273 BuildRequires:  xorg-lib-libXvMC-devel
274 BuildRequires:  xorg-lib-libXxf86dga-devel
275 BuildRequires:  xorg-lib-libXxf86vm-devel
276 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
277 BuildRequires:  xz
278 %ifarch %{ix86} %{x8664}
279 BuildRequires:  yasm
280 %endif
281 BuildRequires:  zlib-devel
282 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
283 Requires:       OpenGL
284 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
285
286 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
287 %define         specflags_ia32  -fomit-frame-pointer
288 %if %{with altivec}
289 %define         specflags_ppc   -maltivec
290 %endif
291
292 %description
293 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
294 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
295 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
296 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
297 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
298 optionally with SHM extension, X11 using overlays with the Xvideo
299 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
300 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
301
302 If you want to use win32 codecs install w32codec package.
303
304 %description -l de.UTF-8
305 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
306 Kennzeichnend ist die herausragende Format- und
307 Plattform-Kompatibilität.
308
309 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
310 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
311 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
312 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
313 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
314 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
315 installierte Codecs nicht mit MPlayer kollidieren können.
316
317 %description -l es.UTF-8
318 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
319 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
320 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
321 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
322 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
323 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
324 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
325 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
326 v1.1.7 etc.
327
328 Si quiere usar codecs Win32, instale el paquete w32codec.
329
330 %description -l ko.UTF-8
331 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
332 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
333 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
334 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
335 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
336 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
337 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
338 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
339 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
340
341 %description -l pl.UTF-8
342 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
343 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
344 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
345 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
346 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
347 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
348 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
349
350 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
351
352 %description -l pt_BR.UTF-8
353 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
354 áudio. Diferentes mecanismos de reprodução podem também ser
355 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
356
357 %package -n gmplayer
358 Summary:        MPlayer with GTK+ GUI interface
359 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
360 Group:          X11/Applications/Multimedia
361 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
362 Requires:       %{name}-skin
363
364 %description -n gmplayer
365 MPlayer with GUI GTK+ interface.
366
367 %description -n gmplayer -l pl.UTF-8
368 MPlayer z graficznym interfejsem GTK+.
369
370 %package common
371 Summary:        Configuration files and documentation for MPlayer
372 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
373 Group:          Applications/Multimedia
374 Suggests:       unrar
375 Obsoletes:      mplayer-vidix
376
377 %description common
378 Configuration files, man page and HTML documentation for MPlayer.
379
380 %description common -l pl.UTF-8
381 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
382
383 %package doc
384 Summary:        HTML documentation for MPlayer
385 Summary(pl.UTF-8):      Dokumentacja do MPlayera w formacie HTML
386 Group:          Documentation
387
388 %description doc
389 HTML Documentation for MPlayer.
390
391 %description doc -l pl.UTF-8
392 Dokumentacja do MPlayera w formacie HTML.
393
394 %package -n mencoder
395 Summary:        MEncoder - a movie encoder for Linux
396 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
397 Group:          Applications/Multimedia
398 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
399
400 %description -n mencoder
401 MEncoder is a movie encoder for Linux and is a part of the MPlayer
402 package.
403
404 %description -n mencoder -l pl.UTF-8
405 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
406
407 %prep
408 %setup -q -n %{name}-export-%{snap} -a1 -a3 -a6
409 cp -f etc/codecs.conf etc/codecs.win32.conf
410
411 # build (configure / Makefile) related:
412 %patch10 -p1
413 %patch11 -p1
414 %patch12 -p1
415 %patch13 -p1
416
417 %patch15 -p1
418
419 %patch17 -p1
420
421 %{?with_shared:%patch19 -p1}
422 %patch20 -p1
423
424 # codecs, outputs, demuxers:
425 %patch21 -p1
426 %patch22 -p1
427
428 # goodies:
429 %patch30 -p0
430 %patch31 -p1
431 #%{with_gnomess:%patch32 -p1}
432
433 %patch101 -p1
434
435 cat etc/example.conf > etc/mplayer.conf
436 cat <<'CONFIGADD' >> etc/mplayer.conf
437
438 ######################
439 # PLD Linux Defaults #
440 ######################
441 [default]
442
443 # alternate solution for CP1250-encoded subtitles
444 fontconfig = yes
445 subcp = cp1250
446
447 # ...or if you prefer native bitmap fonts shipped with mplayer
448 #fontconfig = no
449 #subcp = iso-8859-1
450
451 # Standard location
452 unrarexec = "%{_bindir}/unrar"
453
454 # Joystick input is disabled because of issues on some laptops (thinkpad, macbook pro).
455 joystick=no
456
457 CONFIGADD
458
459 %if %{with system_ffmpeg}
460 # using external ffmpeg, but mplayer adds these to includepath
461 %{__rm} -rf ffmpeg
462 %endif
463
464 %build
465 CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
466 CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb} -DHAVE_GSM_H=1"
467
468 # NOTE:
469 # - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
470 # - toolame is obsolete predecessor of twolame
471 # - libcdio-paranoia is preferred over cdparanoia-III libs
472 build() {
473         set -x
474
475         ./configure \
476         %{?debug:--enable-debug=3} \
477         --prefix=%{_prefix} \
478         --codecsdir=%{_libdir}/codecs \
479         --confdir=%{_sysconfdir}/mplayer \
480         --cc="%{__cc}" \
481         --extra-cflags="$CFLAGS" \
482         --real-ldflags="%{rpmldflags}" \
483         --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
484         --language=all \
485 %if %{with system_ffmpeg}
486         --disable-ffmpeg_a \
487 %endif
488 %ifnarch %{ix86} %{x8664}
489         --disable-3dnow \
490         --disable-3dnowext \
491         --disable-fastmemcpy \
492         --disable-mmx \
493         --disable-mmxext \
494         --disable-sse \
495         --disable-sse2 \
496 %endif
497         %{__disable ssse3} \
498 %ifarch ppc
499         %{__disable altivec} \
500 %endif
501         %{__disable aalib aa} \
502         %{__enable_disable alsa} \
503         %{__disable arts} \
504         %{__disable bluray} \
505         %{__disable caca} \
506         %{__disable cdparanoia} \
507         --enable-dga1 \
508         --enable-dga2 \
509         %{__enable_disable directfb} \
510         %{__enable_disable dvdnav} \
511         %{__disable system_dvdread dvdread-internal} \
512         %{__disable dxr2} \
513         %{__disable dxr3} \
514         --enable-dynamic-plugins \
515         %{__disable enca} \
516         %{__disable esd} \
517         %{__disable faad} \
518         --enable-fbdev \
519         %{__disable gif} \
520         --enable-gl \
521         %{__disable ggi} \
522         %{__disable jack} \
523         %{__enable joystick} \
524         %{__disable cdio libcdio} \
525         %{__disable ladspa} \
526         %{__disable bs2b libbs2b} \
527         %{__disable libdts libdca} \
528         %{__disable libdv} \
529         %{__disable system_dvdcss libdvdcss-internal} \
530         %{__disable lzo liblzo} \
531         %{__disable system_libmpeg2 libmpeg2-internal} \
532         %{__disable nemesi} \
533         %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
534         %{__disable openjpeg} \
535         %{__disable rtmp librtmp} \
536         %{__disable vorbis libvorbis} \
537         %{__enable_disable lirc} \
538         --disable-lircc \
539         %{__disable live} \
540         %{__disable mad} \
541         %{__disable mencoder} \
542         %{__enable osd menu} \
543         --enable-mga \
544         %{__disable mpg123} \
545         %{__enable musepack} \
546         %{__disable nas} \
547         %{__disable pulseaudio pulse} \
548         %{__disable quicktime qtx} \
549         --enable-radio \
550         --enable-radio-capture \
551         %{__disable real} \
552         %{__enable_disable runtime runtime-cpudetection} \
553         %{__enable_disable sdl} \
554         %{__disable select} \
555         --enable-s3fb \
556         %{__disable smb} \
557         %{__disable svga} \
558         --enable-tdfxfb \
559         --enable-tdfxvid \
560         %{__disable theora} \
561         --disable-toolame \
562         %{!?with_tremor:--disable-tremor} \
563         --enable-unrarexec \
564         %{__disable vdpau} \
565         %{__disable vidix} \
566         %{__disable vstream} \
567         --enable-vm \
568 %ifarch ppc
569         --enable-wii \
570 %endif
571         %{__disable win32 win32dll} \
572         --enable-x11 \
573         %{__disable x264} \
574         --enable-xmga \
575         %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
576         --enable-xv \
577         %{__disable xvid} \
578         --enable-xvmc --with-xvmclib=XvMCW \
579         %{__enable_disable zr} \
580         "$@"
581
582         %{__make} %{?with_verbose:V=1}
583 }
584
585 %if %{with gui}
586 # build GUI version
587 build --enable-gui --disable-mencoder
588 %{__mv} mplayer gmplayer
589 %{__make} distclean
590 %endif
591
592 # now build regular version
593 build --disable-gui
594
595 %if %{with doc}
596 %{__make} -j1 doc
597 %endif
598
599 %install
600 rm -rf $RPM_BUILD_ROOT
601 install -d \
602         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
603         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,ru,sv,zh_CN,}/man1 \
604         $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
605         $RPM_BUILD_ROOT%{_desktopdir}
606
607 # default config files
608 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
609
610 # executables
611 for prog in mplayer %{?with_mencoder:mencoder} %{?with_gui:gmplayer} ; do
612 install $prog $RPM_BUILD_ROOT%{_bindir}/${prog}%{binsuf}
613 %if "%{binsuf}" != ""
614 ln -sf ${prog}%{binsuf} $RPM_BUILD_ROOT%{_bindir}/$prog
615 %endif
616 done
617
618 %if %{with shared}
619 install -d $RPM_BUILD_ROOT%{_libdir}
620 install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
621 %endif
622
623 # fonts
624 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
625 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
626
627 %if %{with gui}
628 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
629 %endif
630 touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
631 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
632 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
633
634 # man pages
635 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
636 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
637 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
638 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
639 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
640 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
641 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
642 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
643 install DOCS/man/ru/*.1 $RPM_BUILD_ROOT%{_mandir}/ru/man1
644 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
645 install DOCS/man/zh_CN/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
646
647 %clean
648 rm -rf $RPM_BUILD_ROOT
649
650 %post -n gmplayer
651 umask 022
652 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
653
654 %postun -n gmplayer
655 umask 022
656 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
657
658 %files
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_bindir}/mplayer*
661
662 %if %{with gui}
663 %files -n gmplayer
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{_bindir}/gmplayer*
666 %{_desktopdir}/gmplayer.desktop
667 %endif
668
669 %if %{with mencoder}
670 %files -n mencoder
671 %defattr(644,root,root,755)
672 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
673 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
674 %doc DOCS/tech/colorspaces.txt
675 %attr(755,root,root) %{_bindir}/mencoder*
676 %endif
677
678 %if %{with doc}
679 %files doc
680 %defattr(644,root,root,755)
681 %doc DOCS/tech
682 # HTML and XML-generated docs
683 %doc DOCS/HTML/en
684 %lang(cs) %doc DOCS/HTML/cs
685 %lang(de) %doc DOCS/HTML/de
686 %lang(es) %doc DOCS/HTML/es
687 %lang(fr) %doc DOCS/HTML/fr
688 %lang(hu) %doc DOCS/HTML/hu
689 %lang(it) %doc DOCS/HTML/it
690 %lang(pl) %doc DOCS/HTML/pl
691 %lang(ru) %doc DOCS/HTML/ru
692 %lang(zh_CN) %doc DOCS/HTML/zh_CN
693 %endif
694
695 %files common
696 %defattr(644,root,root,755)
697 %doc AUTHORS README
698 %{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
699 %if %{with win32}
700 %doc etc/codecs.win32.conf
701 %endif
702
703 %dir %{_sysconfdir}/%{name}
704 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
705 %{_mandir}/man1/mplayer.1*
706 %lang(cs) %{_mandir}/cs/man1/mplayer.1*
707 %lang(de) %{_mandir}/de/man1/mplayer.1*
708 %lang(es) %{_mandir}/es/man1/mplayer.1*
709 %lang(fr) %{_mandir}/fr/man1/mplayer.1*
710 %lang(hu) %{_mandir}/hu/man1/mplayer.1*
711 %lang(it) %{_mandir}/it/man1/mplayer.1*
712 %lang(pl) %{_mandir}/pl/man1/mplayer.1*
713 %lang(ru) %{_mandir}/ru/man1/mplayer.1*
714 #%lang(sv) %{_mandir}/sv/man1/mplayer.1*
715 %lang(zh_CN) %{_mandir}/zh_CN/man1/mplayer.1*
716 %{_desktopdir}/mplayer.desktop
717 %{_pixmapsdir}/mplayer.png
718 %dir %{_datadir}/%{name}
719 %{_datadir}/%{name}/font*
720 %dir %{_datadir}/%{name}/skins
721 %ghost %{_datadir}/%{name}/skins/default
This page took 0.100773 seconds and 4 git commands to generate.