]> git.pld-linux.org Git - packages/mpfr.git/blob - mpfr.spec
- updated to 2.3.0, bcond fixed.
[packages/mpfr.git] / mpfr.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make check
4 #
5 Summary:        Multiple-precision floating-point computations library
6 Summary(pl.UTF-8):      Biblioteka obliczeń zmiennoprzecinkowych wielokrotnej precyzji
7 Name:           mpfr
8 Version:        2.3.0
9 Release:        1
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://www.mpfr.org/mpfr-current/%{name}-%{version}.tar.bz2
13 # Source0-md5:  cf7c743e4be122e63eb6f372fc58b657
14 Patch0:         %{name}-info.patch
15 URL:            http://www.mpfr.org/
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake >= 1.6
18 BuildRequires:  gmp-devel >= 4.1.0
19 BuildRequires:  libtool
20 BuildRequires:  texinfo
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The MPFR library is a C library for multiple-precision floating-point
25 computations with exact rounding (also called correct rounding). It is
26 based on the GMP multiple-precision library. The main goal of MPFR is
27 to provide a library for multiple-precision floating-point computation
28 which is both efficient and has a well-defined semantics. It copies
29 the good ideas from the ANSI/IEEE-754 standard for double-precision
30 floating-point arithmetic (53-bit mantissa).
31
32 %description -l pl.UTF-8
33 Biblioteka MPFR to biblioteka C do obliczeń zmiennoprzecinkowych z
34 wielokrotną precyzją i dokładnym zaokrąglaniem (zwanym także poprawnym
35 zaokrąglaniem). Jest oparta na bibliotece GMP wielokrotnej precyzji.
36 Głównym celem MPFR jest dostarczenie biblioteki do obliczeń
37 zmiennoprzecinkowych wielokrotnej precyzji, która jest wydajna i ma
38 dobrze zdefiniowaną semantykę. Powiela dobre idee ze standardu
39 ANSI/IEEE-754 dla arytmetyki zmiennoprzecinkowej podwójnej precyzji (z
40 53-bitową mantysą).
41
42 %package devel
43 Summary:        Header files for MPFR library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki MPFR
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       gmp-devel >= 4.1.0
48 Obsoletes:      libmpfr-devel
49
50 %description devel
51 Header files for MPFR library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki MPFR.
55
56 %package static
57 Summary:        Static MPFR library
58 Summary(pl.UTF-8):      Statyczna biblioteka MPFR
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static MPFR library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka MPFR.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71
72 %build
73 %{__libtoolize}
74 %{__aclocal}
75 %{__autoconf}
76 %{__automake}
77 %configure \
78         --enable-shared
79
80 # make -j4 creates truncated .lo files
81 %{__make} -j1 all
82
83 %if %{with tests}
84 %{__make} check
85 %endif
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %post devel
102 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
103
104 %postun devel
105 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
106
107 %files
108 %defattr(644,root,root,755)
109 %doc AUTHORS BUGS ChangeLog FAQ.html NEWS README TODO
110 %attr(755,root,root) %{_libdir}/libmpfr.so.*.*.*
111
112 %files devel
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_libdir}/libmpfr.so
115 %{_libdir}/libmpfr.la
116 %{_includedir}/mpfr.h
117 %{_includedir}/mpf2mpfr.h
118 %{_infodir}/mpfr.info*
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libmpfr.a
This page took 0.078258 seconds and 3 git commands to generate.