]> git.pld-linux.org Git - packages/mozldap.git/blob - mozldap.spec
- add todo
[packages/mozldap.git] / mozldap.spec
1 # TODO
2 # - ./config.status creation broken (libtool2 problem likely) on th/ti
3 %define nspr_version    4.6
4 %define nspr_evr        1:%{nspr_version}
5 %define nss_version     3.11
6 %define nss_evr         1:%{nss_version}
7 %define svrcore_version 4.0.3
8 Summary:        Mozilla LDAP C SDK
9 Summary(pl.UTF-8):      Biblioteki Mozilla LDAP C SDK
10 Name:           mozldap
11 Version:        6.0.5
12 Release:        1
13 License:        MPL v1.1 or GPL v2+ or LGPL v2.1+
14 Group:          Libraries
15 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/directory/c-sdk/releases/v%{version}/src/%{name}-%{version}.tar.gz
16 # Source0-md5:  9719bd5b9efc13f810c85a47fb8c6412
17 Patch0:         %{name}-link.patch
18 URL:            http://wiki.mozilla.org/LDAP_C_SDK
19 BuildRequires:  autoconf >= 2.13
20 BuildRequires:  cyrus-sasl-devel >= 2.0
21 BuildRequires:  gawk
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  nspr-devel >= %{nspr_evr}
24 BuildRequires:  nss-devel >= %{nss_evr}
25 BuildRequires:  perl-base
26 BuildRequires:  pkgconfig
27 BuildRequires:  svrcore-devel >= %{svrcore_version}
28 Requires:       nspr >= %{nspr_evr}
29 Requires:       nss >= %{nss_evr}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _noautoreqdep   libldap60.so libprldap60.so libssldap60.so libldif60.so
33
34 %description
35 The Mozilla LDAP C SDK is a set of libraries that allow applications
36 to communicate with LDAP directory servers. These libraries are
37 derived from the University of Michigan and Netscape LDAP libraries.
38 They use Mozilla NSPR and NSS for crypto.
39
40 %description -l pl.UTF-8
41 Mozilla LDAP C SDK to zestaw bibliotek pozwalających aplikacjom
42 komunikować się z serwerami usług katalogowych LDAP. Biblioteki te
43 wywodzą się z bibliotek LDAP University of Michigan i Netscape.
44 Wykorzystują biblioteki Mozilla NSPR i NSS do kryptografii.
45
46 %package devel
47 Summary:        Development files and examples for Mozilla LDAP C SDK
48 Summary(pl.UTF-8):      Pliki programistyczne i przykłady dla bibliotek Mozilla LDAP C SDK
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       nspr-devel >= %{nspr_evr}
52 Requires:       nss-devel >= %{nss_evr}
53
54 %description devel
55 Header and other files for doing development with the Mozilla LDAP C
56 SDK.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe i inne do tworzenia oprogramowania z użyciem
60 bibliotek Mozilla LDAP C SDK
61
62 %package static
63 Summary:        Static Mozilla LDAP C SDK libraries
64 Summary(pl.UTF-8):      Statyczne biblioteki Mozilla LDAP C SDK
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static Mozilla LDAP C SDK libraries.
70
71 %description static -l pl.UTF-8
72 Statyczne biblioteki Mozilla LDAP C SDK.
73
74 %package tools
75 Summary:        Tools for the Mozilla LDAP C SDK
76 Summary(pl.UTF-8):      Narzędzia dla bibliotek Mozilla LDAP C SDK
77 Group:          Applications/System
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       svrcore >= %{svrcore_version}
80
81 %description tools
82 The mozldap-tools package provides the ldapsearch, ldapmodify, and
83 ldapdelete tools that use the Mozilla LDAP C SDK libraries.
84
85 %description tools -l pl.UTF-8
86 Ten pakiet dostarcza narzędzia ldapsearch, ldapmodify i ldapdelete
87 wykorzystujące biblioteki Mozilla LDAP C SDK.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92
93 %build
94 cd mozilla/directory/c-sdk
95 %{__autoconf}
96 %configure \
97 %ifarch %{x8664} ia64 ppc64 s390x
98         --enable-64bit \
99 %endif
100         --disable-debug \
101         --enable-clu \
102         --enable-optimize \
103         --with-sasl \
104         --with-system-nspr \
105         --with-system-nss \
106         --with-system-svrcore
107
108 %ifarch %{x8664} ppc64 ia64 s390x
109 USE_64=1
110 export USE_64
111 %endif
112
113 %{__make} \
114         XCFLAGS="%{rpmcflags}"
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT{{%{_includedir},%{_libdir}}/mozldap,%{_bindir},%{_sysconfdir}/%{name}}
119
120 cd mozilla
121 install dist/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
122 install dist/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
123 install dist/public/ldap/*.h $RPM_BUILD_ROOT%{_includedir}/mozldap
124 install dist/bin/ldap* $RPM_BUILD_ROOT%{_bindir}
125 # what really uses these and proper install dir?
126 install dist/etc/* $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
127
128 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
129 cd directory/c-sdk/ldap
130 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
131 rm -f $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/Makefile
132 cd -
133
134 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
135 sed directory/c-sdk/mozldap.pc.in -e "
136         s,%%libdir%%,%{_libdir},g
137         s,%%prefix%%,%{_prefix},g
138         s,%%exec_prefix%%,%{_prefix},g
139         s,%%includedir%%,%{_includedir}/mozldap,g
140         s,%%NSPR_VERSION%%,%{nspr_version},g
141         s,%%NSS_VERSION%%,%{nss_version},g
142         s,%%MOZLDAP_VERSION%%,%{version},g
143 " > $RPM_BUILD_ROOT%{_pkgconfigdir}/mozldap.pc
144
145 cd $RPM_BUILD_ROOT%{_libdir}
146 for file in lib*.so; do
147         mv $file $file.%{version}
148         ln -s $file.%{version} $file
149 done
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post   -p /sbin/ldconfig
155 %postun -p /sbin/ldconfig
156
157 %files
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libldap60.so.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libldap60.so
161 %attr(755,root,root) %{_libdir}/libprldap60.so.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libprldap60.so
163 %attr(755,root,root) %{_libdir}/libssldap60.so.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libssldap60.so
165 %attr(755,root,root) %{_libdir}/libldif60.so.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libldif60.so
167
168 %files devel
169 %defattr(644,root,root,755)
170 %{_includedir}/mozldap
171 %{_pkgconfigdir}/mozldap.pc
172 %{_examplesdir}/%{name}-%{version}
173
174 %files static
175 %defattr(644,root,root,755)
176 %{_libdir}/libiutil60.a
177 %{_libdir}/liblber60.a
178 %{_libdir}/libldap60.a
179 %{_libdir}/libldif60.a
180
181 %files tools
182 %defattr(644,root,root,755)
183 %dir %{_sysconfdir}/%{name}
184 %{_sysconfdir}/%{name}/ldapfilter.conf
185 %{_sysconfdir}/%{name}/ldapfriendly
186 %{_sysconfdir}/%{name}/ldapsearchprefs.conf
187 %{_sysconfdir}/%{name}/ldaptemplates.conf
188 # NOTE: these probably collide with openldap
189 %attr(755,root,root) %{_bindir}/ldapcmp
190 %attr(755,root,root) %{_bindir}/ldapcompare
191 %attr(755,root,root) %{_bindir}/ldapdelete
192 %attr(755,root,root) %{_bindir}/ldapmodify
193 %attr(755,root,root) %{_bindir}/ldappasswd
194 %attr(755,root,root) %{_bindir}/ldapsearch
This page took 0.086036 seconds and 3 git commands to generate.