]> git.pld-linux.org Git - packages/mono.git/commitdiff
- fix concurrent sweep thread start code to actually work. auto/th/mono-2_11_1-1
authorPaweł Sikora <pluto@pld-linux.org>
Mon, 23 Apr 2012 08:56:16 +0000 (08:56 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- release 1.

Changed files:
    mono-concurrent-sweep.patch -> 1.1
    mono.spec -> 1.291

mono-concurrent-sweep.patch [new file with mode: 0644]
mono.spec

diff --git a/mono-concurrent-sweep.patch b/mono-concurrent-sweep.patch
new file mode 100644 (file)
index 0000000..abce7b6
--- /dev/null
@@ -0,0 +1,19 @@
+commit 5b3f143191d599c1fcca89125793405150c79424
+Author: Rodrigo Kumpera <kumpera@gmail.com>
+Date:   Sun Apr 22 21:02:59 2012 -0300
+
+    Fix concurrent sweep thread start code to actually work.
+
+diff --git a/mono/metadata/sgen-marksweep.c b/mono/metadata/sgen-marksweep.c
+index 15e2767..78bc368 100644
+--- a/mono/metadata/sgen-marksweep.c
++++ b/mono/metadata/sgen-marksweep.c
+@@ -1960,7 +1960,7 @@ static void
+ post_param_init (void)
+ {
+       if (concurrent_sweep) {
+-              if (mono_native_thread_create (&ms_sweep_thread, ms_sweep_thread_func, NULL)) {
++              if (!mono_native_thread_create (&ms_sweep_thread, ms_sweep_thread_func, NULL)) {
+                       fprintf (stderr, "Error: Could not create sweep thread.\n");
+                       exit (1);
+               }
index c58f9380779cd203284e5e5bff085eac73be7c74..20b4fc10950b8f5a6685bfc5d2591c5b03a72667 100644 (file)
--- a/mono.spec
+++ b/mono.spec
@@ -18,7 +18,7 @@ Summary:      Common Language Infrastructure implementation
 Summary(pl.UTF-8):     Implementacja Common Language Infrastructure
 Name:          mono
 Version:       2.11.1
-Release:       0.1
+Release:       1
 License:       LGPL v2 (VM), MIT X11/GPL v2 (C# compilers), MIT X11 (classes, tools), GPL v2 (tools)
 Group:         Development/Languages
 # latest downloads summary at http://download.mono-project.com/sources-stable/
@@ -31,6 +31,7 @@ Patch3:               %{name}-awk.patch
 Patch4:                %{name}-console-no-utf8-bom.patch
 Patch5:                %{name}-pc.patch
 Patch6:                %{name}-ARG_MAX.patch
+Patch7:                %{name}-concurrent-sweep.patch
 URL:           http://www.mono-project.com/
 %if %(test -r /dev/random; echo $?)
 BuildRequires: ACCESSIBLE_/dev/random
@@ -221,6 +222,7 @@ oraz dotGNU.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 
 # for jay
 cat >> mcs/build/config-default.make <<'EOF'
This page took 0.02722 seconds and 4 git commands to generate.