]> git.pld-linux.org Git - packages/moc.git/blob - moc.spec
- move decoders to subpackages
[packages/moc.git] / moc.spec
1 # FIX:
2 # - ffmpeg decoder don't want to install
3 #
4 # bconds:
5 %bcond_without  home_etc    # disable HOME_ETC support
6 #
7
8 %define _status beta1
9 Summary:        Console audio player with simple ncurses interface
10 Summary(pl):    Konsolowy odtwarzacz audio z prostym interfejsem ncurses
11 Name:           moc
12 Version:        2.4.0
13 Release:        0.%{_status}.1
14 License:        GPL
15 Group:          Applications/Sound
16 Source0:        ftp://ftp.daper.net/pub/soft/moc/unstable/%{name}-%{version}-%{_status}.tar.bz2
17 # Source0-md5:  c5f534e5ee0cc080f0c0c89f5a8c53cd
18 Patch0:         %{name}-home_etc.patch
19 URL:            http://moc.daper.net/
20 BuildRequires:  alsa-lib-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  curl-devel
24 BuildRequires:  flac-devel
25 BuildRequires:  libao-devel
26 BuildRequires:  libid3tag-devel
27 BuildRequires:  libltdl-devel
28 BuildRequires:  libmad-devel
29 BuildRequires:  libmpcdec-devel >= 1.2
30 BuildRequires:  libsamplerate-devel
31 BuildRequires:  libsndfile-devel
32 BuildRequires:  libtool
33 BuildRequires:  libvorbis-devel
34 BuildRequires:  ncurses-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  taglib-devel >= 1.3.1
37 BuildRequires:  zlib-devel
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39 %define _decoder_plugins        %{_libdir}/%{name}/decoder_plugins
40
41 %description
42 MOC is a console audio player with simple ncurses interface in
43 playmp3list style. It supports MP3, Ogg, FLAC, Musepack, Speex, WAV
44 and other less popular formats supported by libsndfile. It has 
45 all functions one may expect from simple audio player. Now it supports
46 net streams (shoutcast, icecast, regular HTTP, FTP) also.
47
48 %description -l pl
49 MOC to konsolowy odtwarzacz audio z prostym interfejsem budz±cym
50 skojarzenia z playmp3list. Obs³uguje formaty MP3, Ogg, FLAC, 
51 Musepack, Speex, WAV oraz inne mniej popularne formaty wspierane przez
52 bibliotekê libsndfile. Ma wszystkie funkcje, których mo¿na spodziewaæ
53 siê w prostym odtwarzaczu audio. Teraz tak¿e obs³uguje strumienie
54 sieciowe (shoutcast, icecast, HTTP, FTP).
55
56 %package mp3
57 Summary:        MP3 decoder for MoC - Music on Console
58 Summary(pl):    Dekoder MP3 dla MOC
59 Group:          Applications/Sound
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       libmad 
62 Requires:       libid3tag
63 Provides:       %{name}-input = %{version}-%{release}
64
65 %description mp3
66 This package contains the MP3 decoder.
67 After install you should reload MOC player.
68
69 %description -l pl
70 Ten pakiet zawiera dekodowanie formatu MP3
71 Po zainstalowaniu nale¿y uruchomiæ ponownie MOC
72
73 %package musepack
74 Summary:        Musepack (MPC) decoder for MoC - Music on Console
75 Summary(pl):    Dekoder Musepack (MPC) dla MOC
76 Group:          Applications/Sound
77 Requires:       libmpcdec 
78 Requires:       taglib
79 Requires:       %{name} = %{version}-%{release}
80 Provides:       %{name}-input = %{version}-%{release}
81
82 %description musepack
83 This package contains the Musepack (MPC) decoder
84 After install you should reload MOC player.
85
86 %description musepack -l pl
87 Ten pakiet zawiera dekodowanie formatu Musepack (MPC)
88 Po zainstalowaniu nale¿y uruchomiæ ponownie MOC
89
90 %package ogg
91 Summary:        Ogg decoder for MoC - Music on Console
92 Summary(pl):    Dekoder Ogg dla MOC
93 Group:          Applications/Sound
94 Requires:       libogg 
95 Requires:       libvorbis
96 Requires:       %{name} = %{version}-%{release}
97 Provides:       %{name}-input = %{version}-%{release}
98
99 %description ogg
100 This package contains the ogg decoder
101 After install you should reload MOC player.
102
103 %description ogg -l pl
104 Ten pakiet zawiera dekodowanie formatu Ogg
105 Po zainstalowaniu nale¿y uruchomiæ ponownie MOC
106
107 %package flac
108 Summary:        FLAC decoder for MoC - Music on Console
109 Summary(pl):    Dekoder FLAC dla MOC
110 Group:          Applications/Sound
111 Requires:       flac
112 Requires:       %{name} = %{version}-%{release}
113 Provides:       %{name}-input = %{version}-%{release}
114
115 %description flac
116 This package contains the FLAC decoder
117 After install you should reload MOC player.
118
119 %description flac -l pl
120 Ten pakiet zawiera dekodowanie formatu FLAC
121 Po zainstalowaniu nale¿y uruchomiæ ponownie MOC
122
123 %package sndfile
124 Summary:        Decoder of the sndfile formats for MoC - Music on Console
125 Summary(pl):    Dekoder plików WAV/AIFF
126 Group:          Applications/Sound
127 Requires:       libsndfile
128 Requires:       %{name} = %{version}-%{release}
129 Provides:       %{name}-input = %{version}-%{release}
130
131 %description sndfile
132 This package contains the decoders of sndfile
133 After install you should reload MOC player.
134
135 %description sndfile -l pl
136 Ten pakiet zapewnia dekodowanie plików WAV/AIFF
137 Po zainstalowaniu nale¿y uruchomiæ ponownie MOC
138
139 %package speex
140 Summary:        Speex decoder for MoC - Music on Console
141 Summary(pl):    Dekoder formatu Speex dla MOC
142 Group:          Applications/Sound
143 Requires:       speex
144 Requires:       %{name} = %{version}-%{release}
145 Provides:       %{name}-input = %{version}-%{release}
146
147 %description speex
148 This package contains the Speex decoder
149 After install you should reload MOC player.
150
151 %description speex -l pl
152 Ten pakiet zapewnia dekodowanie formatu Speex
153 Po zainstalowaniu nale¿y uruchomiæ ponownie MOC
154
155
156 %prep
157 %setup -q -n %{name}-%{version}-%{_status}
158 %{?with_home_etc:%patch0 -p1}
159
160 %build
161 CFLAGS="-I/usr/include/ncurses %{rpmcflags}"
162
163 %{__aclocal} -I m4
164 %{__autoconf}
165 %{__automake}
166 %configure \
167         --disable-debug 
168
169 %{__make}
170
171 %install
172 rm -rf $RPM_BUILD_ROOT
173 install -d $RPM_BUILD_ROOT
174
175 %{__make} install \
176         DESTDIR=$RPM_BUILD_ROOT
177
178 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
179 rm -f $RPM_BUILD_ROOT%{_decoder_plugins}/lib*.la
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %files
185 %defattr(644,root,root,755)
186 %doc AUTHORS NEWS README THANKS TODO *.example
187 %attr(755,root,root) %{_bindir}/*
188 %dir %{_libdir}/moc
189 #%dir %{_libdir}/moc/decoder_plugins
190 #%attr(755,root,root) %{_libdir}/moc/decoder_plugins/lib*.so
191 %{_datadir}/%{name}
192 %{_mandir}/man1/mocp*
193
194 %files musepack
195 %defattr(-, root, root)
196 %{_decoder_plugins}/libmusepack_decoder.*
197
198 %files flac
199 %defattr(-, root, root)
200 %{_decoder_plugins}/libflac_decoder.*
201
202 %files mp3
203 %defattr(-, root, root)
204 %{_decoder_plugins}/libmp3_decoder.*
205
206 %files ogg
207 %defattr(-, root, root)
208 %{_decoder_plugins}/libvorbis_decoder.*
209
210 %files sndfile
211 %defattr(-, root, root)
212 %{_decoder_plugins}/libsndfile_formats_decoder.*
213
214 %files speex
215 %defattr(-, root, root)
216 %{_decoder_plugins}/libspeex_decoder.*
This page took 0.050874 seconds and 3 git commands to generate.